summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2020-02-25 00:44:48 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2020-02-25 00:44:48 +0000
commit6e65d53c8fdeae4573f0395c5009a69e45fadc70 (patch)
treea692888ff161b07228f46998e472d17399151251 /user
parent09752ec51ab04a72d6880fde1d925e42cd5fb8fe (diff)
parent8692497bfa258922262fb5dea99dbc85f7137558 (diff)
downloadpackages-6e65d53c8fdeae4573f0395c5009a69e45fadc70.tar.gz
packages-6e65d53c8fdeae4573f0395c5009a69e45fadc70.tar.bz2
packages-6e65d53c8fdeae4573f0395c5009a69e45fadc70.tar.xz
packages-6e65d53c8fdeae4573f0395c5009a69e45fadc70.zip
Merge branch 'hexchat' into 'master'
Hexchat See merge request adelie/packages!401
Diffstat (limited to 'user')
-rw-r--r--user/hexchat/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/user/hexchat/APKBUILD b/user/hexchat/APKBUILD
new file mode 100644
index 000000000..8ba05d268
--- /dev/null
+++ b/user/hexchat/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+pkgname=hexchat
+pkgver=2.14.3
+pkgrel=0
+pkgdesc="GTK-based IRC client"
+url="https://hexchat.org"
+arch="all"
+options="!check" # no tests
+license="GPL-2.0+ AND Custom:Expat AND LGPL-2.0+ AND LGPL-2.1+"
+depends=""
+makedepends="meson ninja
+ openssl-dev libproxy-dev libcanberra-dev dbus-glib-dev libnotify-dev
+ iso-codes-dev
+ lua5.3-dev perl-dev python3-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://dl.hexchat.net/hexchat/hexchat-$pkgver.tar.xz"
+builddir="$srcdir/hexchat-$pkgver"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ -Dwith-lua=lua \
+ . output
+ ninja -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="c265921f2cb02c5d273bcdbb20a44a5c9f38b0f8cbba4fd56b177b676fc5d1dfd05bf80fcfa3706c7981f712f2f6c9aaaf80bccf3be0f6d96068dd393f3a7cb5 hexchat-2.14.3.tar.xz"