summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-09-04 19:03:22 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-09-04 19:03:22 +0000
commit73e99a6a7bb80a41d51bc25ee6e18ba41559c319 (patch)
tree67610dac0dbb68306b4c3e9cc8ff1af65ad2fe5e /user
parent6c70fdf2b706dd398f4b77613a43d57fa9e7916d (diff)
parent22449e780e90c4f1503fceb45b787637d82816e4 (diff)
downloadpackages-73e99a6a7bb80a41d51bc25ee6e18ba41559c319.tar.gz
packages-73e99a6a7bb80a41d51bc25ee6e18ba41559c319.tar.bz2
packages-73e99a6a7bb80a41d51bc25ee6e18ba41559c319.tar.xz
packages-73e99a6a7bb80a41d51bc25ee6e18ba41559c319.zip
Merge branch 'clucene-tmp' into 'master'
user/clucene: tell check to use $builddir/tmp instead of tmp If we use /tmp (the default), successive runs of check will usually fail because /tmp is not cleared on each run, and clucene is not smart enough to delete its test files on its own, so a whole bunch of tests will fail. Instead, tell it to use $builddir/tmp, which we can safely clear each time we run check. See merge request !49
Diffstat (limited to 'user')
-rw-r--r--user/clucene/APKBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/user/clucene/APKBUILD b/user/clucene/APKBUILD
index 90f7a8eb7..2c5e047e4 100644
--- a/user/clucene/APKBUILD
+++ b/user/clucene/APKBUILD
@@ -40,11 +40,19 @@ build() {
check() {
cd "$builddir"
+
+ # clucene is not smart enough to delete files between successive checks,
+ # so let's remove them for it. Otherwise, if check is run a second time
+ # without clearing the files beforehand, a lot of tests will fail.
+ rm -rf "$builddir/tmp"
+ mkdir "$builddir/tmp"
+
# Need to force cmake to update - some sort of race condition
touch CMakeCache.txt
make cl_test
+
cd bin
- ./cl_test
+ TMP="$builddir/tmp" ./cl_test
}
package() {