summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorSíle Ekaterin Liszka <sheila@vulpine.house>2023-11-01 09:53:29 -0700
committerZach van Rijn <me@zv.io>2023-11-05 14:57:19 +0000
commitaa77453a8a09c4d4055afea3b6c480934bc1d26f (patch)
tree63fefac08f414c106bc74026387c6d627c61088b /user
parent39d9d4a84fb8780da4228289daf423aaf28d739f (diff)
downloadpackages-aa77453a8a09c4d4055afea3b6c480934bc1d26f.tar.gz
packages-aa77453a8a09c4d4055afea3b6c480934bc1d26f.tar.bz2
packages-aa77453a8a09c4d4055afea3b6c480934bc1d26f.tar.xz
packages-aa77453a8a09c4d4055afea3b6c480934bc1d26f.zip
user/meson: upgrade to 1.2.3
Diffstat (limited to 'user')
-rw-r--r--user/meson/APKBUILD8
-rw-r--r--user/meson/meson-0.62.1-gettext-tiny.patch92
2 files changed, 3 insertions, 97 deletions
diff --git a/user/meson/APKBUILD b/user/meson/APKBUILD
index 725c42f0a..60146659f 100644
--- a/user/meson/APKBUILD
+++ b/user/meson/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
pkgname=meson
-pkgver=0.62.2
+pkgver=1.2.3
pkgrel=0
pkgdesc="Fast, user-friendly build system"
url="https://mesonbuild.com/"
@@ -10,8 +10,7 @@ license="Apache-2.0"
depends="python3 ninja"
makedepends="python3-dev"
subpackages="$pkgname-doc"
-source="https://github.com/mesonbuild/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz
- meson-0.62.1-gettext-tiny.patch"
+source="https://github.com/mesonbuild/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
build() {
python3 setup.py build
@@ -25,5 +24,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="4089588701f0f702eb3b794e0ede78b99f13ec7545d1a7470c7bfd6a857de59673684a543928dd578402578c53f38365a3a59e3e29022fd30a525353818a4195 meson-0.62.2.tar.gz
-c6b65c88e7403ef2f892840575021f78082b683b7e3b879cd5fef7d639f571920dfd264c60c9085d68f8cfc649c7db401fe2375f409e5038864e74896f22b18a meson-0.62.1-gettext-tiny.patch"
+sha512sums="cdcadc731effc1ffb2de98b795ba37955f934ed9b54b9f7f3ac5fe96ab33268d4de4fce734a4c2ef7d2ecc5051616df127e1f8665e197ff954310bf1483b81fc meson-1.2.3.tar.gz"
diff --git a/user/meson/meson-0.62.1-gettext-tiny.patch b/user/meson/meson-0.62.1-gettext-tiny.patch
deleted file mode 100644
index 4413a32dc..000000000
--- a/user/meson/meson-0.62.1-gettext-tiny.patch
+++ /dev/null
@@ -1,92 +0,0 @@
-Upstream-URL: https://github.com/mesonbuild/meson/pull/10365
-
-From 7606b19f8981f75b7076a765cec1ecf7b04220fb Mon Sep 17 00:00:00 2001
-From: Eli Schwartz <eschwartz@archlinux.org>
-Date: Sat, 7 May 2022 23:03:01 -0400
-Subject: [PATCH 1/3] gettext: explicitly pass source root / subdir as cli args
-
-Because this is a wrapper script and we could/should do this, we even
-have half the infra for it.
----
- mesonbuild/modules/i18n.py | 6 ++++++
- mesonbuild/scripts/gettext.py | 15 +++++++--------
- 2 files changed, 13 insertions(+), 8 deletions(-)
-
-diff --git a/mesonbuild/modules/i18n.py b/mesonbuild/modules/i18n.py
-index 2bdf9d30b97..4bbc69abfb1 100644
---- a/mesonbuild/modules/i18n.py
-+++ b/mesonbuild/modules/i18n.py
-@@ -251,6 +251,9 @@ def gettext(self, state: 'ModuleState', args: T.Tuple[str], kwargs: 'Gettext') -
- extra_arg = '--extra-args=' + '@@'.join(extra_args) if extra_args else None
-
- potargs = state.environment.get_build_command() + ['--internal', 'gettext', 'pot', pkg_arg]
-+ potargs.append(f'--source-root={state.source_root}')
-+ if state.subdir:
-+ potargs.append(f'--subdir={state.subdir}')
- if datadirs:
- potargs.append(datadirs)
- if extra_arg:
-@@ -292,6 +295,9 @@ def gettext(self, state: 'ModuleState', args: T.Tuple[str], kwargs: 'Gettext') -
- targets.append(allgmotarget)
-
- updatepoargs = state.environment.get_build_command() + ['--internal', 'gettext', 'update_po', pkg_arg]
-+ updatepoargs.append(f'--source-root={state.source_root}')
-+ if state.subdir:
-+ updatepoargs.append(f'--subdir={state.subdir}')
- if lang_arg:
- updatepoargs.append(lang_arg)
- if datadirs:
-diff --git a/mesonbuild/scripts/gettext.py b/mesonbuild/scripts/gettext.py
-index c3298926ef8..c31657a71d3 100644
---- a/mesonbuild/scripts/gettext.py
-+++ b/mesonbuild/scripts/gettext.py
-@@ -23,6 +23,7 @@
- parser.add_argument('--datadirs', default='')
- parser.add_argument('--langs', default='')
- parser.add_argument('--localedir', default='')
-+parser.add_argument('--source-root', default='')
- parser.add_argument('--subdir', default='')
- parser.add_argument('--xgettext', default='xgettext')
- parser.add_argument('--msgmerge', default='msgmerge')
-@@ -45,7 +46,7 @@ def read_linguas(src_sub: str) -> T.List[str]:
- print(f'Could not find file LINGUAS in {src_sub}')
- return []
-
--def run_potgen(src_sub: str, xgettext: str, pkgname: str, datadirs: str, args: T.List[str]) -> int:
-+def run_potgen(src_sub: str, xgettext: str, pkgname: str, datadirs: str, args: T.List[str], source_root: str) -> int:
- listfile = os.path.join(src_sub, 'POTFILES.in')
- if not os.path.exists(listfile):
- listfile = os.path.join(src_sub, 'POTFILES')
-@@ -59,7 +60,7 @@ def run_potgen(src_sub: str, xgettext: str, pkgname: str, datadirs: str, args: T
-
- ofile = os.path.join(src_sub, pkgname + '.pot')
- return subprocess.call([xgettext, '--package-name=' + pkgname, '-p', src_sub, '-f', listfile,
-- '-D', os.environ['MESON_SOURCE_ROOT'], '-k_', '-o', ofile] + args,
-+ '-D', source_root, '-k_', '-o', ofile] + args,
- env=child_env)
-
- def update_po(src_sub: str, msgmerge: str, msginit: str, pkgname: str, langs: T.List[str]) -> int:
-@@ -77,18 +78,16 @@ def run(args: T.List[str]) -> int:
- subcmd = options.command
- langs = options.langs.split('@@') if options.langs else None
- extra_args = options.extra_args.split('@@') if options.extra_args else []
-- subdir = os.environ.get('MESON_SUBDIR', '')
-- if options.subdir:
-- subdir = options.subdir
-- src_sub = os.path.join(os.environ['MESON_SOURCE_ROOT'], subdir)
-+ subdir = options.subdir
-+ src_sub = os.path.join(options.source_root, subdir)
-
- if not langs:
- langs = read_linguas(src_sub)
-
- if subcmd == 'pot':
-- return run_potgen(src_sub, options.xgettext, options.pkgname, options.datadirs, extra_args)
-+ return run_potgen(src_sub, options.xgettext, options.pkgname, options.datadirs, extra_args, options.source_root)
- elif subcmd == 'update_po':
-- if run_potgen(src_sub, options.xgettext, options.pkgname, options.datadirs, extra_args) != 0:
-+ if run_potgen(src_sub, options.xgettext, options.pkgname, options.datadirs, extra_args, options.source_root) != 0:
- return 1
- return update_po(src_sub, options.msgmerge, options.msginit, options.pkgname, langs)
- else:
-