summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-02-03 19:15:43 +0000
committerZach van Rijn <me@zv.io>2022-06-12 23:51:57 +0000
commitf58ce0295f3e15ba019219b585a4b4c367a2feca (patch)
tree41c38e9950c96803c66a8b3ad209bd20bfd6e1a3 /user
parent25c5bf2ad06f0e74f8943c0f63b5515bc0ab693e (diff)
downloadpackages-f58ce0295f3e15ba019219b585a4b4c367a2feca.tar.gz
packages-f58ce0295f3e15ba019219b585a4b4c367a2feca.tar.bz2
packages-f58ce0295f3e15ba019219b585a4b4c367a2feca.tar.xz
packages-f58ce0295f3e15ba019219b585a4b4c367a2feca.zip
user/qt5-qtcharts: new package.
Diffstat (limited to 'user')
-rw-r--r--user/qt5-qtcharts/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/user/qt5-qtcharts/APKBUILD b/user/qt5-qtcharts/APKBUILD
new file mode 100644
index 000000000..908528dd1
--- /dev/null
+++ b/user/qt5-qtcharts/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Zach van Rijn <me@zv.io>
+pkgname=qt5-qtcharts
+_pkgname=${pkgname#*-}-everywhere-src
+pkgver=5.15.3_git20201027
+pkgrel=0
+_commit=130463160b4923069eb98da49edaf7d93180f4f8
+pkgdesc="Qt5 QML Applications and Manipulating Qt Charts graphs with QML Designer"
+url="https://www.qt.io/"
+arch="all"
+license="LGPL-3.0-only WITH Qt-LGPL-exception-1.1 OR GPL-3.0-only WITH Qt-GPL-exception-1.0"
+depends=""
+makedepends="qt5-qtbase-dev"
+subpackages="$pkgname-dev"
+source="https://invent.kde.org/qt/qt/${pkgname#*-}/-/archive/$_commit/${pkgname#*-}-$_commit.tar.gz"
+builddir="$srcdir"/${pkgname#*-}-$_commit
+
+prepare() {
+ default_prepare
+
+ # Make configure think we are running in a git directory
+ # This makes it symlink the include files to the right directory
+ mkdir .git
+}
+
+build() {
+ qmake
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make install INSTALL_ROOT="$pkgdir"
+}
+
+sha512sums="d0513e84bfb50675e83c3343f77593f44077d1a1c06ed53a1d9cc56371694aafd677f94d49306e60cfc51f7791f44ce9aa9e8c998a40fdea6b982d2a8aed6807 qtcharts-130463160b4923069eb98da49edaf7d93180f4f8.tar.gz"