summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-02-03 19:17:52 +0000
committerZach van Rijn <me@zv.io>2022-06-12 23:51:57 +0000
commit4d2e8660403fc2043e024822806caa7e823dfe58 (patch)
tree0f4b0845c522407effb39777da83ed5e01b1b690 /user
parentf58ce0295f3e15ba019219b585a4b4c367a2feca (diff)
downloadpackages-4d2e8660403fc2043e024822806caa7e823dfe58.tar.gz
packages-4d2e8660403fc2043e024822806caa7e823dfe58.tar.bz2
packages-4d2e8660403fc2043e024822806caa7e823dfe58.tar.xz
packages-4d2e8660403fc2043e024822806caa7e823dfe58.zip
user/qt5-qtconnectivity: new package.
Diffstat (limited to 'user')
-rw-r--r--user/qt5-qtconnectivity/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/user/qt5-qtconnectivity/APKBUILD b/user/qt5-qtconnectivity/APKBUILD
new file mode 100644
index 000000000..30baf105f
--- /dev/null
+++ b/user/qt5-qtconnectivity/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Zach van Rijn <me@zv.io>
+pkgname=qt5-qtconnectivity
+_pkgname=${pkgname#*-}-everywhere-src
+pkgver=5.15.3_git20210322
+pkgrel=0
+_commit=5e9ca5d36d65dadb98ef90013a1dcf15fbd7ae26
+pkgdesc="Qt5 Connectivity module offers support for features such as Dial-up, (W)LAN, USB and VPN"
+url="https://www.qt.io/"
+arch="all"
+license="LGPL-3.0-only WITH Qt-LGPL-exception-1.1 OR GPL-3.0-only WITH Qt-GPL-exception-1.0"
+depends=""
+makedepends="qt5-qtbase-dev"
+subpackages="$pkgname-dev"
+source="https://invent.kde.org/qt/qt/${pkgname#*-}/-/archive/$_commit/${pkgname#*-}-$_commit.tar.gz"
+builddir="$srcdir"/${pkgname#*-}-$_commit
+
+prepare() {
+ default_prepare
+
+ # Make configure think we are running in a git directory
+ # This makes it symlink the include files to the right directory
+ mkdir .git
+}
+
+build() {
+ qmake
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make install INSTALL_ROOT="$pkgdir"
+}
+
+sha512sums="6be16baa0f63d6b36836adac50df4b9db79ca65b3bb4c92be13f748cec9384c42e57833bc1d06a8f50575f13623965cf40d1497e5fa51f44cb51b15760fb198f qtconnectivity-5e9ca5d36d65dadb98ef90013a1dcf15fbd7ae26.tar.gz"