summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-02-03 19:28:40 +0000
committerZach van Rijn <me@zv.io>2022-06-12 23:51:58 +0000
commitaec07048439bd2696e5a817b3732af9b6655be94 (patch)
treef3303755983f4c0360e3296abc4735b4c01c66ee /user
parentbf44c6cf326281ae4d4df760b97280b6c39c7502 (diff)
downloadpackages-aec07048439bd2696e5a817b3732af9b6655be94.tar.gz
packages-aec07048439bd2696e5a817b3732af9b6655be94.tar.bz2
packages-aec07048439bd2696e5a817b3732af9b6655be94.tar.xz
packages-aec07048439bd2696e5a817b3732af9b6655be94.zip
user/qt5-qtlocation: new package.
Diffstat (limited to 'user')
-rw-r--r--user/qt5-qtlocation/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/user/qt5-qtlocation/APKBUILD b/user/qt5-qtlocation/APKBUILD
new file mode 100644
index 000000000..b48a6a0a2
--- /dev/null
+++ b/user/qt5-qtlocation/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Zach van Rijn <me@zv.io>
+pkgname=qt5-qtlocation
+_pkgname=${pkgname#*-}-everywhere-src
+pkgver=5.15.3_git20201103
+pkgrel=0
+_commit=861e372b6ad81570d4f496e42fb25a6699b72f2f
+pkgdesc="Qt5 Location API provides the developer with a set of functions to interact with maps, navigational data and places of interest"
+url="https://www.qt.io/"
+arch="all"
+license="LGPL-3.0-only WITH Qt-LGPL-exception-1.1 OR GPL-3.0-only WITH Qt-GPL-exception-1.0"
+depends=""
+makedepends="qt5-qtbase-dev"
+subpackages="$pkgname-dev"
+source="https://invent.kde.org/qt/qt/${pkgname#*-}/-/archive/$_commit/${pkgname#*-}-$_commit.tar.gz"
+builddir="$srcdir"/${pkgname#*-}-$_commit
+
+prepare() {
+ default_prepare
+
+ # Make configure think we are running in a git directory
+ # This makes it symlink the include files to the right directory
+ mkdir .git
+}
+
+build() {
+ qmake
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make install INSTALL_ROOT="$pkgdir"
+}
+
+sha512sums="b7cac8cd42185504c6140f1dcd4e8c0c749e3d8f22bf9977e97268e0ad6fbd3733e571a255ab7824eba31e30e707e804b07317f2ec9b7be15a4a5756c78c9e41 qtlocation-861e372b6ad81570d4f496e42fb25a6699b72f2f.tar.gz"