summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorErmine <mustela@erminea.space>2024-08-28 09:41:18 +0000
committerErmine <mustela@erminea.space>2024-09-01 12:53:53 +0000
commitc2f70c8cb192f9ca6d524be494b27f7c2b8389c8 (patch)
treea9c723e087274073bf3e584d17ecee75cf842cd0 /user
parent210937ec833065e215733fd0f1a6583a93ac699f (diff)
downloadpackages-c2f70c8cb192f9ca6d524be494b27f7c2b8389c8.tar.gz
packages-c2f70c8cb192f9ca6d524be494b27f7c2b8389c8.tar.bz2
packages-c2f70c8cb192f9ca6d524be494b27f7c2b8389c8.tar.xz
packages-c2f70c8cb192f9ca6d524be494b27f7c2b8389c8.zip
user/libxcvt: new package
Previously this was part of xorg-xserver package
Diffstat (limited to 'user')
-rw-r--r--user/libxcvt/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/user/libxcvt/APKBUILD b/user/libxcvt/APKBUILD
new file mode 100644
index 000000000..9efeb5b24
--- /dev/null
+++ b/user/libxcvt/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Milan P. Stanić <mps@arvanta.net>
+# Maintainer: Ermine <mustela@arvanta.net>
+pkgname=libxcvt
+pkgver=0.1.2
+pkgrel=0
+pkgdesc="VESA CVT standard timing modelines generator"
+url="https://www.X.Org/"
+arch="all"
+license="MIT AND X11"
+# older xorg-server versions included this package but it has since been split out
+# make sure we can upgrade properly to xorg-server 21.1.1 and later
+depends=""
+makedepends="meson"
+replaces="xorg-server<21.1.1"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://xorg.freedesktop.org/releases/individual/lib/libxcvt-$pkgver.tar.xz"
+
+build() {
+ meson setup --prefix=/usr output
+ meson compile -C output
+}
+
+check() {
+ meson test --no-rebuild --print-errorlogs -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+doc() {
+ default_doc
+
+ replaces="xorg-server-doc<21.1.1"
+}
+
+sha512sums="
+3f6b2baca712a4608780686932f8881255c07bb74b1a788f9b07d4e22975c038d75111cd6b452257882a0b2bad57eebb2002f80a3e435d2e2d16936597f039b0 libxcvt-0.1.2.tar.xz
+"
+sha512sums="3f6b2baca712a4608780686932f8881255c07bb74b1a788f9b07d4e22975c038d75111cd6b452257882a0b2bad57eebb2002f80a3e435d2e2d16936597f039b0 libxcvt-0.1.2.tar.xz"