summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-05-27 15:18:24 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-06-11 14:03:58 -0500
commitbbf380a20afcaf169c63fb6877b99a2aecb2a537 (patch)
treeb2810986ad48c44973e018bcb80d6f4df00db136 /user
parent5843ac4c228e7423b9aa424e0d5c35b5e4f94b3c (diff)
downloadpackages-bbf380a20afcaf169c63fb6877b99a2aecb2a537.tar.gz
packages-bbf380a20afcaf169c63fb6877b99a2aecb2a537.tar.bz2
packages-bbf380a20afcaf169c63fb6877b99a2aecb2a537.tar.xz
packages-bbf380a20afcaf169c63fb6877b99a2aecb2a537.zip
user/volume_key: Fix build against Python 3
If the build environment has a /usr/bin/python, the build system believes it is Python 2. Ensure that does not happen.
Diffstat (limited to 'user')
-rw-r--r--user/volume_key/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/user/volume_key/APKBUILD b/user/volume_key/APKBUILD
index d6d22c271..69da50792 100644
--- a/user/volume_key/APKBUILD
+++ b/user/volume_key/APKBUILD
@@ -21,13 +21,15 @@ prepare() {
}
build() {
- ./configure \
+ PYTHON3=python3.11 ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var
+ --localstatedir=/var \
+ --with-python=no \
+ --with-python3
make
}