summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-07-26 23:47:02 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-08-07 10:08:26 -0500
commitbae0638aa756a582ae5e30c74475b46f7ec793cd (patch)
treecea2ebb554948393af305195a2c3a972351f2196 /user
parent0f14b4e069398b3c444810467299fdc2f80bd573 (diff)
downloadpackages-bae0638aa756a582ae5e30c74475b46f7ec793cd.tar.gz
packages-bae0638aa756a582ae5e30c74475b46f7ec793cd.tar.bz2
packages-bae0638aa756a582ae5e30c74475b46f7ec793cd.tar.xz
packages-bae0638aa756a582ae5e30c74475b46f7ec793cd.zip
user/clazy: Specify the LLVM root path
The LLVM version is now a variable that can be easily changed, as well. Closes: #1225
Diffstat (limited to 'user')
-rw-r--r--user/clazy/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/user/clazy/APKBUILD b/user/clazy/APKBUILD
index d8e20a742..114cd4556 100644
--- a/user/clazy/APKBUILD
+++ b/user/clazy/APKBUILD
@@ -2,6 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=clazy
pkgver=1.11
+_llvmver=14
pkgrel=0
pkgdesc="Clang compiler plugin to warn about Qt best practices"
url="https://kde.org/applications/development/org.kde.clazy"
@@ -9,7 +10,7 @@ arch="all"
license="LGPL-2.1+"
options="!check" # need 'clang-tools-extra'
depends=""
-makedepends="cmake clang-dev llvm14-dev"
+makedepends="cmake clang-dev llvm$_llvmver-dev"
subpackages="$pkgname-doc"
source="https://download.kde.org/stable/clazy/$pkgver/src/clazy-$pkgver.tar.xz
fix-link-fs-lib.patch
@@ -26,6 +27,7 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
+ -DLLVM_ROOT="/usr/lib/llvm$_llvmver" \
${CMAKE_CROSSOPTS} \
.
make