summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorLuis Ressel <aranea@aixah.de>2019-12-05 07:14:40 +0100
committerLuis Ressel <aranea@aixah.de>2019-12-05 07:14:40 +0100
commitc9ebcd066086dfb80da7847c22a1cec8be81c8c2 (patch)
tree004164f6009b76bdf4178840531b73a15ccbe14b /user
parent0e7e7a2713a7925c4ac579460508ce593899dd9d (diff)
downloadpackages-c9ebcd066086dfb80da7847c22a1cec8be81c8c2.tar.gz
packages-c9ebcd066086dfb80da7847c22a1cec8be81c8c2.tar.bz2
packages-c9ebcd066086dfb80da7847c22a1cec8be81c8c2.tar.xz
packages-c9ebcd066086dfb80da7847c22a1cec8be81c8c2.zip
user/notmuch: Move to legacy
It needs a bump, but newer versions have an extremly painful to debug corruption bug (that may only occur on musl?), and noone besides me used it anyway.
Diffstat (limited to 'user')
-rw-r--r--user/notmuch/0.28.2-disable-rpath.patch48
-rw-r--r--user/notmuch/APKBUILD96
2 files changed, 0 insertions, 144 deletions
diff --git a/user/notmuch/0.28.2-disable-rpath.patch b/user/notmuch/0.28.2-disable-rpath.patch
deleted file mode 100644
index cc5102614..000000000
--- a/user/notmuch/0.28.2-disable-rpath.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From ed15cac16414418c11896071d6ca9238d033f23d Mon Sep 17 00:00:00 2001
-From: Luis Ressel <aranea@aixah.de>
-Date: Mon, 25 Feb 2019 08:18:24 +0100
-Subject: [PATCH] Add a configure flag to disable rpaths
-
----
- configure | 11 ++++++++++-
- 1 file changed, 10 insertions(+), 1 deletion(-)
-
-diff --git a/configure b/configure
-index a6f5dfa2..5e7e5aa9 100755
---- a/configure
-+++ b/configure
-@@ -82,6 +82,7 @@ WITH_API_DOCS=1
- WITH_EMACS=1
- WITH_DESKTOP=1
- WITH_BASH=1
-+WITH_RPATH=1
- WITH_RUBY=1
- WITH_ZSH=1
- WITH_RETRY_LOCK=1
-@@ -241,6 +242,14 @@ for option; do
- fi
- elif [ "${option}" = '--without-bash-completion' ] ; then
- WITH_BASH=0
-+ elif [ "${option%%=*}" = '--with-rpath' ]; then
-+ if [ "${option#*=}" = 'no' ]; then
-+ WITH_RPATH=0
-+ else
-+ WITH_RPATH=1
-+ fi
-+ elif [ "${option}" = '--without-rpath' ] ; then
-+ WITH_RPATH=0
- elif [ "${option%%=*}" = '--with-ruby' ]; then
- if [ "${option#*=}" = 'no' ]; then
- WITH_RUBY=0
-@@ -928,7 +937,7 @@ fi
- rm -f compat/check_asctime
-
- printf "Checking for rpath support... "
--if ${CC} -Wl,--enable-new-dtags -Wl,-rpath,/tmp/ -o minimal minimal.c >/dev/null 2>&1
-+if [ $WITH_RPATH = "1" ] && ${CC} -Wl,--enable-new-dtags -Wl,-rpath,/tmp/ -o minimal minimal.c >/dev/null 2>&1
- then
- printf "Yes.\n"
- rpath_ldflags="-Wl,--enable-new-dtags -Wl,-rpath,\$(libdir)"
---
-2.19.2
-
diff --git a/user/notmuch/APKBUILD b/user/notmuch/APKBUILD
deleted file mode 100644
index b204ef4d9..000000000
--- a/user/notmuch/APKBUILD
+++ /dev/null
@@ -1,96 +0,0 @@
-# Contributor: Luis Ressel <aranea@aixah.de>
-# Maintainer:
-pkgname=notmuch
-pkgver=0.28.4
-pkgrel=0
-pkgdesc="Thread-based email index, search and tagging"
-url="https://notmuchmail.org/"
-arch="all"
-license="GPL-3.0+"
-depends=""
-depends_dev="gmime-dev talloc-dev xapian-core-dev zlib-dev"
-makedepends="$depends_dev doxygen emacs python3-dev ruby-dev"
-checkdepends="bash dtach gnupg"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-emacs py3-$pkgname:_py ruby-$pkgname:_rb $pkgname-bash-completion:bashcomp:noarch $pkgname-zsh-completion:zshcomp:noarch"
-source="https://notmuchmail.org/releases/notmuch-$pkgver.tar.gz
- 0.28.2-disable-rpath.patch"
-
-build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --without-bash-completion \
- --without-desktop \
- --without-rpath
- make
-
- cd bindings/python
- python3 setup.py build
-}
-
-check() {
- cd "$builddir"
- # config, regexp-query: musl issues, TODO: Fixed in master
- # atomicity, count, new, insert: gdb-based tests which fail randomly on some arches, with some CFLAGS, or during some moon phases
- NOTMUCH_SKIP_TESTS="config regexp-query atomicity count new insert" make check
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
-}
-
-doc() {
- default_doc
- # TODO: We'd need sphinx to generate the man pages, but the raw *.rst's are still better than no docs at all.
- mkdir -p "$subpkgdir/usr/share/doc/$pkgname" "$builddir/doc/man"*
- cp -r "$builddir/doc/man"* "$subpkgdir/usr/share/doc/$pkgname/"
-}
-
-emacs() {
- mkdir -p "$subpkgdir/usr/bin" "$subpkgdir/usr/share"
- mv "$pkgdir/usr/bin/notmuch-emacs-mua" "$subpkgdir/usr/bin"
- mv "$pkgdir/usr/share/emacs" "$subpkgdir/usr/share"
-}
-
-_py() {
- pkgdesc="$pkgdesc (Python bindings)"
- depends="$pkgname=$pkgver-r$pkgrel python3"
-
- cd "$builddir/bindings/python"
- python3 setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-_rb() {
- pkgdesc="$pkgdesc (Ruby bindings)"
- depends="$pkgname=$pkgver-r$pkgrel ruby"
-
- cd "$builddir/bindings/ruby"
- make DESTDIR="$subpkgdir" install
-}
-
-
-bashcomp() {
- pkgdesc="$pkgdesc (Bash completion)"
- depends=""
- install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
-
- install -Dt "$subpkgdir/usr/share/bash-completion" "$builddir/completion/notmuch-completion.bash"
-}
-
-zshcomp() {
- pkgdesc="$pkgdesc (Zsh completion)"
- depends=""
- install_if="$pkgname=$pkgver-r$pkgrel zsh"
-
- mkdir -p "$subpkgdir/usr/share"
- mv "$pkgdir/usr/share/zsh" "$subpkgdir/usr/share"
-}
-
-sha512sums="77d7ad81e1f7dc93ae6392346da434f6dc74c21d19be728c2a6ca283c429f36e7081387d223af58eb5f63f5d2a8ad8367f0103f0bb9d052890c07fe419abbee7 notmuch-0.28.4.tar.gz
-b2991ee5edf927f04d904d99888dbce17a98e9d4d7d809bc2248f45d214025f4a1632b19e4fbca2b08e99721ec8a7eea82384c5c718206884801c7bfa5a8c540 0.28.2-disable-rpath.patch"