summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/py3-py/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/user/py3-py/APKBUILD b/user/py3-py/APKBUILD
index 171ac8245..ad05e041e 100644
--- a/user/py3-py/APKBUILD
+++ b/user/py3-py/APKBUILD
@@ -2,10 +2,10 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-py
_pkgname=py
-pkgver=1.4.34
+pkgver=1.5.3
pkgrel=0
pkgdesc="A python library with cross-python path, ini-parsing, io, code, log facilities"
-url="https://pypi.python.org/py/$pkgver"
+url="https://pypi.python.org/project/py"
arch="noarch"
license="MIT"
depends="python3"
@@ -21,10 +21,10 @@ build() {
}
check() {
- # This test suite seems to be incurring the wrath of
- # https://bugs.python.org/issue28627 on 1.5.2
+ # Can't use py3-pytest > 3.0 as of py3-py==1.5.3-r0 because some tests
+ # haven't been updated yet
cd "$builddir"
- tox -e py36
+ tox -e py36-pytest30
}
package() {
@@ -32,4 +32,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="2e19c82c8315274bffe0ba2c7e20ae3af95f942c40c16121ec953af186f8ff33e8f427c070e137bb04b7cc6dcc6779e35df3911c08595fd3294b5ec9897706e1 py3-py-1.4.34.tar.gz"
+sha512sums="243c0da94c439163257c525ef00b30fd6d8add5897121ee0b1f19476b50f18823ce2b99a5ab27a9cf47598b538758d0534060123dce0820d2a65d98046548c96 py3-py-1.5.3.tar.gz"