summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libfetch/libfetch-2.33-r1.ebuild25
-rw-r--r--profiles/base/eapi2
-rw-r--r--profiles/eapi2
3 files changed, 27 insertions, 2 deletions
diff --git a/dev-libs/libfetch/libfetch-2.33-r1.ebuild b/dev-libs/libfetch/libfetch-2.33-r1.ebuild
new file mode 100644
index 000000000..8598d4c85
--- /dev/null
+++ b/dev-libs/libfetch/libfetch-2.33-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2015-2016 Adélie Linux Team
+# Distributed under the terms of the NCSA License
+
+EAPI=6
+
+DESCRIPTION="High-level retrieval and download library for FTP and HTTP(S)"
+HOMEPAGE="http://cvsweb.netbsd.org/bsdweb.cgi/pkgsrc/net/libfetch/"
+SRC_URI="http://distfiles.foxkit.us/source/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="arm mips ppc x86 x86_64 ~alpha ~arm64 ~hppa ~ppc64 ~sparc64"
+IUSE="+ipv6 +ssl"
+
+DEPEND="ssl? ( dev-libs/openssl:0 )"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-remove-hardcoded-compiler.patch )
+
+src_compile() {
+ use ssl || export FETCH_WITH_OPENSSL=false
+ use ipv6 || export FETCH_WITH_INET6=false
+
+ emake
+}
diff --git a/profiles/base/eapi b/profiles/base/eapi
index 7ed6ff82d..1e8b31496 100644
--- a/profiles/base/eapi
+++ b/profiles/base/eapi
@@ -1 +1 @@
-5
+6
diff --git a/profiles/eapi b/profiles/eapi
index 7ed6ff82d..1e8b31496 100644
--- a/profiles/eapi
+++ b/profiles/eapi
@@ -1 +1 @@
-5
+6