summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/qt5-qtwebchannel/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/user/qt5-qtwebchannel/APKBUILD b/user/qt5-qtwebchannel/APKBUILD
new file mode 100644
index 000000000..d2a4e7c10
--- /dev/null
+++ b/user/qt5-qtwebchannel/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=qt5-qtwebchannel
+_pkgname=qtwebchannel-opensource-src
+pkgver=5.9.6
+pkgrel=0
+pkgdesc="Qt 5 - Connect Qt applications to WebSockets"
+url="https://qt.io/"
+arch="all"
+options="!check"
+license="LGPLv2 with exceptions OR GPLv3 with exceptions"
+depends=""
+makedepends="qt5-qtbase-dev"
+subpackages="$pkgname-dev"
+source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ qmake
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install INSTALL_ROOT="$pkgdir"
+}
+
+sha512sums="f2c4ceb7efba18ffbb2b3bf11b04c158c601ce82eadfcadeccbb81405db0ff2275fe4a5706872adaa6faa6ab2c1f1f6b6fdeeeb09e127e3b9dbfeac5a4eb7ab5 qtwebchannel-opensource-src-5.9.6.tar.xz"