summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitattributes1
-rwxr-xr-xscripts/bootstrap.sh25
-rw-r--r--system/docbook-xsl/APKBUILD8
-rw-r--r--system/docbook-xsl/docbook-xsl-ns.post-deinstall8
-rw-r--r--system/docbook-xsl/docbook-xsl-ns.post-install29
-rw-r--r--system/docbook-xsl/docbook-xsl-ns.post-upgrade32
-rw-r--r--system/docbook-xsl/docbook-xsl.install47
-rw-r--r--system/docbook-xsl/docbook-xsl.post-deinstall3
-rw-r--r--system/docbook-xsl/docbook-xsl.post-install8
-rw-r--r--system/docbook-xsl/docbook-xsl.post-upgrade12
-rw-r--r--user/iputils/APKBUILD16
-rw-r--r--user/iputils/docbook-man.patch33
-rw-r--r--user/kdoctools/APKBUILD2
-rw-r--r--user/kpmcore/APKBUILD2
-rw-r--r--user/kwalletmanager/APKBUILD2
-rw-r--r--user/labplot/APKBUILD4
-rw-r--r--user/partitionmanager/APKBUILD2
17 files changed, 112 insertions, 122 deletions
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 000000000..7d332a128
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1 @@
+**/APKBUILD gitlab-language=sh
diff --git a/scripts/bootstrap.sh b/scripts/bootstrap.sh
index 5d870f436..87d7b1d48 100755
--- a/scripts/bootstrap.sh
+++ b/scripts/bootstrap.sh
@@ -5,9 +5,6 @@ set -e
TARGET_ARCH="$1"
SUDO_APK=abuild-apk
-# optional cross build packages
-KERNEL_PKG="linux-firmware linux-vanilla"
-
# get abuild configurables
[ -e /usr/share/abuild/functions.sh ] || (echo "abuild not found" ; exit 1)
CBUILDROOT="$(CTARGET=$TARGET_ARCH . /usr/share/abuild/functions.sh ; echo $CBUILDROOT)"
@@ -17,7 +14,7 @@ CBUILDROOT="$(CTARGET=$TARGET_ARCH . /usr/share/abuild/functions.sh ; echo $CBUI
# deduce aports directory
[ -z "$APORTS" ] && APORTS=$(realpath $(dirname $0)/../)
-[ -e "$APORTS/system/build-tools" ] || die "Unable to deduce aports base checkout"
+[ -e "$APORTS/system/build-tools" ] || die "Unable to deduce packages directory"
apkbuildname() {
local repo="${1%%/*}"
@@ -39,14 +36,14 @@ if [ -z "$TARGET_ARCH" ]; then
usage: $program TARGET_ARCH
This script creates a local cross-compiler, and uses it to
-cross-compile an Alpine Linux base system for new architecture.
+cross-compile an Adélie Linux base system for new architecture.
Steps for introducing new architecture include:
- adding the compiler tripler and arch type to abuild
- adding the arch type detection to apk-tools
- adjusting build rules for packages that are arch aware:
- gcc, libressl, linux-headers
-- create new kernel config for linux-vanilla
+ gcc, musl, binutils, easy-kernel
+- create new kernel config for easy-kernel
After these steps the initial cross-build can be completed
by running this with the target arch as parameter, e.g.:
@@ -68,7 +65,7 @@ msg "Building cross-compiler"
# Build and install cross binutils (--with-sysroot)
CTARGET=$TARGET_ARCH BOOTSTRAP=nobase APKBUILD=$(apkbuildname binutils) abuild -r
-if ! CHOST=$TARGET_ARCH BOOTSTRAP=nolibc APKBUILD=$(apkbuildname musl) abuild up2date 2>/dev/null; then
+#if ! CHOST=$TARGET_ARCH BOOTSTRAP=nolibc APKBUILD=$(apkbuildname musl) abuild up2date 2>/dev/null; then
# C-library headers for target
CHOST=$TARGET_ARCH BOOTSTRAP=nocc APKBUILD=$(apkbuildname musl) abuild -r
@@ -79,7 +76,7 @@ if ! CHOST=$TARGET_ARCH BOOTSTRAP=nolibc APKBUILD=$(apkbuildname musl) abuild up
# Cross build bootstrap C-library for the target
EXTRADEPENDS_BUILD="gcc-pass2-$TARGET_ARCH" \
CHOST=$TARGET_ARCH BOOTSTRAP=nolibc APKBUILD=$(apkbuildname musl) abuild -r
-fi
+#fi
# Full cross GCC
EXTRADEPENDS_TARGET="musl musl-dev" \
@@ -97,10 +94,10 @@ apk info --quiet --installed --root "$CBUILDROOT" libgcc libstdc++ musl-dev || \
${SUDO_APK} --root "$CBUILDROOT" add --repository "$REPODEST/system" libgcc libstdc++ musl-dev
# ordered cross-build
-for PKG in fortify-headers linux-headers musl libc-dev pkgconf zlib \
- gettext-tiny ncurses readline bash binutils make bison flex m4 \
- openssl libfetch apk-tools linux-pam shadow \
- gmp mpfr3 mpc1 isl cloog gcc ca-certificates \
+for PKG in musl pkgconf zlib \
+ gettext-tiny ncurses bash binutils make bison flex m4 \
+ openssl apk-tools linux-pam shadow \
+ gmp mpfr3 mpc1 isl gcc ca-certificates \
openrc libcap-ng coreutils sed gzip bzip2 diffutils \
attr libcap patch sudo acl fakeroot libarchive mawk \
pax-utils abuild grep findutils patch lzip unzip autoconf automake libtool \
@@ -115,7 +112,7 @@ for PKG in fortify-headers linux-headers musl libc-dev pkgconf zlib \
fortify-headers | libc-dev | build-base)
# headers packages which are implicit but mandatory dependency
apk info --quiet --installed --root "$CBUILDROOT" $PKG || \
- ${SUDO_APK} --update --root "$CBUILDROOT" --repository "$REPODEST/main" add $PKG
+ ${SUDO_APK} --update --root "$CBUILDROOT" --repository "$REPODEST/system" add $PKG
;;
musl | gcc)
# target libraries rebuilt, force upgrade
diff --git a/system/docbook-xsl/APKBUILD b/system/docbook-xsl/APKBUILD
index ebfbf4dee..11a858afa 100644
--- a/system/docbook-xsl/APKBUILD
+++ b/system/docbook-xsl/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=docbook-xsl
pkgver=1.79.1
-pkgrel=3
-pkgdesc="XML stylesheets for Docbook-xml transformations."
+pkgrel=4
+pkgdesc="XML stylesheets for DocBook transformations"
url="http://docbook.sourceforge.net/"
arch="noarch"
options="!check" # Just XML files
@@ -11,7 +11,9 @@ license="MIT"
depends="libxml2-utils libxslt docbook-xml"
subpackages="$pkgname-ns"
makedepends=""
-install="$pkgname.post-install $pkgname.post-upgrade $pkgname.post-deinstall"
+install="$pkgname.post-install $pkgname.post-upgrade $pkgname.post-deinstall
+ $pkgname-ns.post-install $pkgname-ns.post-upgrade
+ $pkgname-ns.post-deinstall"
source="http://downloads.sourceforge.net/sourceforge/docbook/$pkgname-$pkgver.tar.bz2
https://downloads.sourceforge.net/project/docbook/docbook-xsl-ns/$pkgver/$pkgname-ns-$pkgver.tar.bz2
765567_non-recursive_string_subst.patch
diff --git a/system/docbook-xsl/docbook-xsl-ns.post-deinstall b/system/docbook-xsl/docbook-xsl-ns.post-deinstall
new file mode 100644
index 000000000..fdd4d3652
--- /dev/null
+++ b/system/docbook-xsl/docbook-xsl-ns.post-deinstall
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+if command -v xmlcatalog > /dev/null; then
+ xmlcatalog --noout --del \
+ "/usr/share/xml/docbook/xsl-stylesheets-ns" \
+ etc/xml/catalog
+fi
+
diff --git a/system/docbook-xsl/docbook-xsl-ns.post-install b/system/docbook-xsl/docbook-xsl-ns.post-install
new file mode 100644
index 000000000..aa708e534
--- /dev/null
+++ b/system/docbook-xsl/docbook-xsl-ns.post-install
@@ -0,0 +1,29 @@
+#!/bin/sh
+
+if [ ! -f /etc/xml/catalog ]; then
+ xmlcatalog --noout --create /etc/xml/catalog
+fi
+
+
+_NEW=${1%-r[0-9]*}
+
+xmlcatalog --noout --add "rewriteSystem" \
+ "http://docbook.sourceforge.net/release/xsl-ns/${_NEW}" \
+ "/usr/share/xml/docbook/xsl-stylesheets-ns" \
+ etc/xml/catalog
+
+xmlcatalog --noout --add "rewriteURI" \
+ "http://docbook.sourceforge.net/release/xsl-ns/${_NEW}" \
+ "/usr/share/xml/docbook/xsl-stylesheets-ns" \
+ etc/xml/catalog &&
+
+xmlcatalog --noout --add "rewriteSystem" \
+ "http://docbook.sourceforge.net/release/xsl-ns/current" \
+ "/usr/share/xml/docbook/xsl-stylesheets-ns" \
+ etc/xml/catalog &&
+
+xmlcatalog --noout --add "rewriteURI" \
+ "http://docbook.sourceforge.net/release/xsl-ns/current" \
+ "/usr/share/xml/docbook/xsl-stylesheets-ns" \
+ etc/xml/catalog
+
diff --git a/system/docbook-xsl/docbook-xsl-ns.post-upgrade b/system/docbook-xsl/docbook-xsl-ns.post-upgrade
new file mode 100644
index 000000000..92c32378f
--- /dev/null
+++ b/system/docbook-xsl/docbook-xsl-ns.post-upgrade
@@ -0,0 +1,32 @@
+#!/bin/sh
+
+if [ ! -f /etc/xml/catalog ]; then
+ xmlcatalog --noout --create /etc/xml/catalog
+fi
+
+_NEW=${1%-r[0-9]*}
+
+xmlcatalog --noout --del \
+ "/usr/share/xml/docbook/xsl-stylesheets-ns" \
+ etc/xml/catalog
+
+xmlcatalog --noout --add "rewriteSystem" \
+ "http://docbook.sourceforge.net/release/xsl-ns/${_NEW}" \
+ "/usr/share/xml/docbook/xsl-stylesheets-ns" \
+ etc/xml/catalog
+
+xmlcatalog --noout --add "rewriteURI" \
+ "http://docbook.sourceforge.net/release/xsl-ns/${_NEW}" \
+ "/usr/share/xml/docbook/xsl-stylesheets-ns" \
+ etc/xml/catalog
+
+xmlcatalog --noout --add "rewriteSystem" \
+ "http://docbook.sourceforge.net/release/xsl-ns/current" \
+ "/usr/share/xml/docbook/xsl-stylesheets-ns" \
+ etc/xml/catalog
+
+xmlcatalog --noout --add "rewriteURI" \
+ "http://docbook.sourceforge.net/release/xsl-ns/current" \
+ "/usr/share/xml/docbook/xsl-stylesheets-ns" \
+ etc/xml/catalog
+
diff --git a/system/docbook-xsl/docbook-xsl.install b/system/docbook-xsl/docbook-xsl.install
deleted file mode 100644
index a8ea3e72b..000000000
--- a/system/docbook-xsl/docbook-xsl.install
+++ /dev/null
@@ -1,47 +0,0 @@
-post_install() {
- if [ ! -f /etc/xml/catalog ]; then
- xmlcatalog --noout --create /etc/xml/catalog
- fi
- _NEW=`echo $1 | sed 's|\(.*\)\-.*|\1|'`
-
- xmlcatalog --noout --add "rewriteSystem" \
- "http://docbook.sourceforge.net/release/xsl/${_NEW}" \
- "/usr/share/xml/docbook/xsl-stylesheets-${_NEW}" \
- etc/xml/catalog
-
- xmlcatalog --noout --add "rewriteURI" \
- "http://docbook.sourceforge.net/release/xsl/${_NEW}" \
- "/usr/share/xml/docbook/xsl-stylesheets-${_NEW}" \
- etc/xml/catalog &&
-
- xmlcatalog --noout --add "rewriteSystem" \
- "http://docbook.sourceforge.net/release/xsl/current" \
- "/usr/share/xml/docbook/xsl-stylesheets-${_NEW}" \
- etc/xml/catalog &&
-
- xmlcatalog --noout --add "rewriteURI" \
- "http://docbook.sourceforge.net/release/xsl/current" \
- "/usr/share/xml/docbook/xsl-stylesheets-${_NEW}" \
- etc/xml/catalog
-}
-
-post_upgrade() {
- post_remove $2
- post_install $1
-}
-
-post_remove() {
- _OLD=`echo $1 | sed 's|\(.*\)\-.*|\1|'`
- xmlcatalog --noout --del "/usr/share/xml/docbook/xsl-stylesheets-${_OLD}" etc/xml/catalog
-
- if [ $(vercmp $1 1.72.0-3) -lt 0 ]; then
- xmlcatalog --noout --del "/usr/share/xml/docbook" etc/xml/catalog
- xmlcatalog --noout --del "file:///etc/xml/docbook" etc/xml/catalog
- fi
-}
-
-op=$1
-shift
-
-$op $*
-
diff --git a/system/docbook-xsl/docbook-xsl.post-deinstall b/system/docbook-xsl/docbook-xsl.post-deinstall
index 3faecd5a3..ffe2a0f23 100644
--- a/system/docbook-xsl/docbook-xsl.post-deinstall
+++ b/system/docbook-xsl/docbook-xsl.post-deinstall
@@ -6,5 +6,8 @@ if command -v xmlcatalog > /dev/null; then
xmlcatalog --noout --del \
"/usr/share/xml/docbook/xsl-stylesheets-${_OLD}" \
etc/xml/catalog
+ xmlcatalog --noout --del \
+ "/usr/share/xml/docbook/xsl-stylesheets" \
+ etc/xml/catalog
fi
diff --git a/system/docbook-xsl/docbook-xsl.post-install b/system/docbook-xsl/docbook-xsl.post-install
index 6afae6abe..250f7b986 100644
--- a/system/docbook-xsl/docbook-xsl.post-install
+++ b/system/docbook-xsl/docbook-xsl.post-install
@@ -9,21 +9,21 @@ _NEW=${1%-r[0-9]*}
xmlcatalog --noout --add "rewriteSystem" \
"http://docbook.sourceforge.net/release/xsl/${_NEW}" \
- "/usr/share/xml/docbook/xsl-stylesheets-${_NEW}" \
+ "/usr/share/xml/docbook/xsl-stylesheets" \
etc/xml/catalog
xmlcatalog --noout --add "rewriteURI" \
"http://docbook.sourceforge.net/release/xsl/${_NEW}" \
- "/usr/share/xml/docbook/xsl-stylesheets-${_NEW}" \
+ "/usr/share/xml/docbook/xsl-stylesheets" \
etc/xml/catalog &&
xmlcatalog --noout --add "rewriteSystem" \
"http://docbook.sourceforge.net/release/xsl/current" \
- "/usr/share/xml/docbook/xsl-stylesheets-${_NEW}" \
+ "/usr/share/xml/docbook/xsl-stylesheets" \
etc/xml/catalog &&
xmlcatalog --noout --add "rewriteURI" \
"http://docbook.sourceforge.net/release/xsl/current" \
- "/usr/share/xml/docbook/xsl-stylesheets-${_NEW}" \
+ "/usr/share/xml/docbook/xsl-stylesheets" \
etc/xml/catalog
diff --git a/system/docbook-xsl/docbook-xsl.post-upgrade b/system/docbook-xsl/docbook-xsl.post-upgrade
index d481480fc..5c82ae7d9 100644
--- a/system/docbook-xsl/docbook-xsl.post-upgrade
+++ b/system/docbook-xsl/docbook-xsl.post-upgrade
@@ -11,23 +11,27 @@ xmlcatalog --noout --del \
"/usr/share/xml/docbook/xsl-stylesheets-${_OLD}" \
etc/xml/catalog
+xmlcatalog --noout --del \
+ "/usr/share/xml/docbook/xsl-stylesheets" \
+ etc/xml/catalog
+
xmlcatalog --noout --add "rewriteSystem" \
"http://docbook.sourceforge.net/release/xsl/${_NEW}" \
- "/usr/share/xml/docbook/xsl-stylesheets-${_NEW}" \
+ "/usr/share/xml/docbook/xsl-stylesheets" \
etc/xml/catalog
xmlcatalog --noout --add "rewriteURI" \
"http://docbook.sourceforge.net/release/xsl/${_NEW}" \
- "/usr/share/xml/docbook/xsl-stylesheets-${_NEW}" \
+ "/usr/share/xml/docbook/xsl-stylesheets" \
etc/xml/catalog
xmlcatalog --noout --add "rewriteSystem" \
"http://docbook.sourceforge.net/release/xsl/current" \
- "/usr/share/xml/docbook/xsl-stylesheets-${_NEW}" \
+ "/usr/share/xml/docbook/xsl-stylesheets" \
etc/xml/catalog
xmlcatalog --noout --add "rewriteURI" \
"http://docbook.sourceforge.net/release/xsl/current" \
- "/usr/share/xml/docbook/xsl-stylesheets-${_NEW}" \
+ "/usr/share/xml/docbook/xsl-stylesheets" \
etc/xml/catalog
diff --git a/user/iputils/APKBUILD b/user/iputils/APKBUILD
index 4a35f931b..142a5ff2d 100644
--- a/user/iputils/APKBUILD
+++ b/user/iputils/APKBUILD
@@ -6,18 +6,16 @@ pkgrel=0
pkgdesc="IP Configuration Utilities (and Ping)"
url="https://github.com/iputils/iputils/"
arch="all"
+options="suid"
license="BSD-3-Clause AND GPL-2.0-or-later"
-makedepends="meson libcap-dev libxslt docbook-xsl-ns openssl-dev libgcrypt-dev"
+makedepends="docbook-xsl docbook-xsl-ns libcap-dev libgcrypt-dev libxslt meson
+ openssl-dev"
replaces="bbsuid"
subpackages="$pkgname-doc $pkgname-lang $pkgname-openrc"
-source="$pkgname-$pkgver.tgz::https://github.com/$pkgname/$pkgname/archive/s$pkgver.tar.gz
- docbook-man.patch
- "
-options="suid"
+source="$pkgname-$pkgver.tgz::https://github.com/$pkgname/$pkgname/archive/s$pkgver.tar.gz"
builddir="$srcdir/$pkgname-s$pkgver"
build() {
- cd "$builddir"
# we're waiting for idn support in musl so that we can enable it here
# https://wiki.musl-libc.org/functional-differences-from-glibc.html#Name-Resolver/DNS
meson --prefix /usr --buildtype=plain builddir -DUSE_IDN=false
@@ -25,18 +23,14 @@ build() {
}
check() {
- cd "$builddir"
ninja -C builddir test
}
package() {
- cd "$builddir"
-
DESTDIR=$pkgdir ninja -C builddir install
ln -s tracepath "$pkgdir"/usr/bin/tracepath6
ln -s ping "$pkgdir"/usr/bin/ping6
}
-sha512sums="adb8831ca3a567b9a5f3762227c631aefa62eedbaa7578c2bfea90b6d494b9e0cccf49b68713912611ec56c352d6c517df9e8409c9c9478cfc5732371c8cf250 iputils-20190515.tgz
-411f45a2d16c88b09f3547e3f04aa20e257f54650c7783123e4cb021bd8850cd96896480fbf9305d6df72abe32d8d5c2239ce4ac4ef9bfa821c205309451d6ff docbook-man.patch"
+sha512sums="adb8831ca3a567b9a5f3762227c631aefa62eedbaa7578c2bfea90b6d494b9e0cccf49b68713912611ec56c352d6c517df9e8409c9c9478cfc5732371c8cf250 iputils-20190515.tgz"
diff --git a/user/iputils/docbook-man.patch b/user/iputils/docbook-man.patch
deleted file mode 100644
index 1793858e4..000000000
--- a/user/iputils/docbook-man.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- iputils-s20190515/doc/custom-man.xsl.old 2019-06-25 11:48:48.790000000 +0000
-+++ iputils-s20190515/doc/custom-man.xsl 2019-06-25 11:49:06.250000000 +0000
-@@ -5,7 +5,7 @@
- extension-element-prefixes="exsl"
- version="1.0">
-
--<xsl:import href="http://docbook.sourceforge.net/release/xsl-ns/current/manpages/docbook.xsl"/>
-+<xsl:import href="file:///usr/share/xml/docbook/xsl-stylesheets-ns/manpages/docbook.xsl"/>
-
- <xsl:template name="top.comment" />
-
---- iputils-s20190515/doc/meson.build.old 2019-06-25 14:54:58.170000000 +0000
-+++ iputils-s20190515/doc/meson.build 2019-06-25 14:55:28.460000000 +0000
-@@ -48,7 +48,7 @@
- ]
-
- if xsltproc.found()
-- xsl = 'http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl'
-+ xsl = 'file:///usr/share/xml/docbook/xsl-stylesheets-ns/manpages/docbook.xsl'
- testrun = run_command([xsltproc, '--nonet', xsl])
- xsltproc_works = testrun.returncode() == 0
- if xsltproc_works == false
---- iputils-s20190515/doc/custom-html.xsl.old 2019-06-25 14:56:50.460000000 +0000
-+++ iputils-s20190515/doc/custom-html.xsl 2019-06-25 14:57:11.680000000 +0000
-@@ -2,7 +2,7 @@
-
- <xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0">
-
--<xsl:import href="http://docbook.sourceforge.net/release/xsl-ns/current/html/docbook.xsl"/>
-+<xsl:import href="file:///usr/share/xml/docbook/xsl-stylesheets-ns/html/docbook.xsl"/>
- <!--
- - The docbook stylesheet injects empty anchor tags into generated HTML, identified by an auto-generated ID.
- - Ask the docbook stylesheet to generate reproducible output when generating (these) ID values.
diff --git a/user/kdoctools/APKBUILD b/user/kdoctools/APKBUILD
index f11c59983..126b3eda5 100644
--- a/user/kdoctools/APKBUILD
+++ b/user/kdoctools/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kdoctools
pkgver=5.54.0
-pkgrel=0
+pkgrel=1
pkgdesc="Tools to generate user-readable documentation from DocBook XML"
url="https://www.kde.org/"
arch="all"
diff --git a/user/kpmcore/APKBUILD b/user/kpmcore/APKBUILD
index 102059e09..a6fef6476 100644
--- a/user/kpmcore/APKBUILD
+++ b/user/kpmcore/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kpmcore
pkgver=3.3.0
pkgrel=0
pkgdesc="Core routines for KDE Partition Manager"
-url="https://www.kde.org/applications/system/kdepartitionmanager"
+url="https://www.kde.org/applications/system/partitionmanager"
arch="all"
license="LGPL-2.1+"
depends=""
diff --git a/user/kwalletmanager/APKBUILD b/user/kwalletmanager/APKBUILD
index f4eae23bd..a512e4072 100644
--- a/user/kwalletmanager/APKBUILD
+++ b/user/kwalletmanager/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kwalletmanager
pkgver=19.04.2
pkgrel=0
pkgdesc="Manage KDE wallets"
-url="https://www.kde.org/applications/system/kwalletmanager/"
+url="https://www.kde.org/applications/system/kwalletmanager5"
arch="all"
license="GPL-2.0-only"
depends=""
diff --git a/user/labplot/APKBUILD b/user/labplot/APKBUILD
index caf9aa5df..d6ed5bf7e 100644
--- a/user/labplot/APKBUILD
+++ b/user/labplot/APKBUILD
@@ -4,7 +4,7 @@ pkgname=labplot
pkgver=2.6
pkgrel=0
pkgdesc="Interactive tool for graphing and analysis of scientific data"
-url="https://www.kde.org/applications/education/labplot/"
+url="https://www.kde.org/applications/education/labplot2"
arch="all"
license="GPL-2.0-only"
depends="shared-mime-info"
@@ -13,7 +13,7 @@ makedepends="cmake extra-cmake-modules qt5-qtbase-dev qt5-qtsvg-dev kconfig-dev
kdoctools-dev ki18n-dev kiconthemes-dev kdelibs4support-dev kxmlgui-dev
knewstuff-dev ktextwidgets-dev kwidgetsaddons-dev gsl-dev fftw-dev
qt5-qtserialport-dev syntax-highlighting-dev bison libexecinfo-dev
- cantor-dev"
+ cantor-dev docbook-xsl"
subpackages="$pkgname-doc $pkgname-lang"
source="https://download.kde.org/stable/labplot/$pkgver.0/labplot-$pkgver.0.tar.xz"
diff --git a/user/partitionmanager/APKBUILD b/user/partitionmanager/APKBUILD
index 33c6e3bdf..5e67e25af 100644
--- a/user/partitionmanager/APKBUILD
+++ b/user/partitionmanager/APKBUILD
@@ -4,7 +4,7 @@ pkgname=partitionmanager
pkgver=3.3.1
pkgrel=0
pkgdesc="Qt-based partition manager"
-url="https://www.kde.org/applications/system/kdepartitionmanager"
+url="https://www.kde.org/applications/system/partitionmanager"
arch="all"
license="GPL-3.0+"
depends=""