summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/mlt/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/user/mlt/APKBUILD b/user/mlt/APKBUILD
index 39f3fb299..0e2bda030 100644
--- a/user/mlt/APKBUILD
+++ b/user/mlt/APKBUILD
@@ -18,6 +18,12 @@ source="https://github.com/mltframework/mlt/releases/download/v$pkgver/mlt-$pkgv
build() {
cd "$builddir"
+ local _maybe_asm=""
+
+ case $CTARGET_ARCH in
+ pmmx) _maybe_asm="--disable-sse --target-arch=i586" ;;
+ esac
+
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -29,7 +35,8 @@ build() {
--enable-motion-est \
--enable-gpl \
--enable-gpl3 \
- --disable-rtaudio
+ --disable-rtaudio \
+ $_maybe_asm
make
}