summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/binutils/APKBUILD31
-rw-r--r--system/binutils/CVE-2019-12972.patch33
-rw-r--r--system/binutils/CVE-2019-14250.patch25
-rw-r--r--system/binutils/CVE-2019-9070-and-9071.patch128
-rw-r--r--system/binutils/CVE-2019-9073.patch31
-rw-r--r--system/binutils/CVE-2019-9074.patch49
-rw-r--r--system/binutils/CVE-2019-9075.patch96
-rw-r--r--system/binutils/CVE-2019-9077.patch33
-rw-r--r--system/iproute2/APKBUILD1
-rw-r--r--system/iproute2/iproute2.post-install6
-rw-r--r--system/lvm2/APKBUILD4
-rw-r--r--system/s6-linux-init/APKBUILD6
-rw-r--r--system/utmps/APKBUILD4
-rw-r--r--user/aspell/APKBUILD16
-rw-r--r--user/aspell/aspell-0.60.6.1-gcc7-fixes.patch34
-rw-r--r--user/gnutls/APKBUILD4
-rw-r--r--user/highlight/APKBUILD4
-rw-r--r--user/qt5-qtbase/APKBUILD6
-rw-r--r--user/qt5-qtbase/big-endian-scroll-wheel.patch43
-rw-r--r--user/qt5-qtbase/qt-musl-iconv-no-bom.patch2
20 files changed, 488 insertions, 68 deletions
diff --git a/system/binutils/APKBUILD b/system/binutils/APKBUILD
index 47b3609a2..c7924b43e 100644
--- a/system/binutils/APKBUILD
+++ b/system/binutils/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adelie Platform Group <adelie-devel@lists.adelielinux.org>
pkgname=binutils
pkgver=2.32
-pkgrel=1
+pkgrel=2
pkgdesc="Tools necessary to build programs"
url="https://www.gnu.org/software/binutils/"
depends=""
@@ -23,6 +23,13 @@ source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
remove-pr19719-test.patch
remove-pr19553c-test.patch
srec.patch
+ CVE-2019-9070-and-9071.patch
+ CVE-2019-9073.patch
+ CVE-2019-9074.patch
+ CVE-2019-9075.patch
+ CVE-2019-9077.patch
+ CVE-2019-12972.patch
+ CVE-2019-14250.patch
"
if [ "$CHOST" != "$CTARGET" ]; then
@@ -33,12 +40,23 @@ if [ "$CHOST" != "$CTARGET" ]; then
builddir="$srcdir"/binutils-$pkgver
fi
-# secfixes:
+# secfixes: binutils
# 2.28-r1:
# - CVE-2017-7614
# 2.31.1-r2:
# - CVE-2018-19931
# - CVE-2018-19932
+# 2.32-r0:
+# - CVE-2018-1000876
+# 2.32-r2:
+# - CVE-2019-9070
+# - CVE-2019-9071
+# - CVE-2019-9073
+# - CVE-2019-9074
+# - CVE-2019-9075
+# - CVE-2019-9077
+# - CVE-2019-12972
+# - CVE-2019-14250
build() {
local _sysroot=/
@@ -124,4 +142,11 @@ d378fdf1964f8f2bd0b1e62827ac5884bdf943aa435ec89c29fc84bb045d406b733fffaff8fdd8bd
32ab4215669c728648179c124632467573a3d4675e79f0f0d221c22eb2ec1ca5488b79910bd09142f90a1e0d0b81d99ca4846297f4f9561f158db63745facb66 remove-pr2404-tests.patch
a193d1fa7f42d91915960460a15e4d24e0df529d81e23014bcf45d283fae76bb7b300fdcb0d0a9d521cdb9137322efa1dc357112596d6ae7a7fd05988ac359b9 remove-pr19719-test.patch
39ef9c76dd5db6b15f11ffa8061f7ca844fb79c3fb9879c3b1466eef332a28b833597c87003ab9f260b1b85023fae264659088aee27cad7e5aa77b2d58b9a3f6 remove-pr19553c-test.patch
-f720b3356b88e366c52941da056e543e4b42bc77f012e5b0290f79e15b0a31d855989ad01920680507a9df0544e5b8e26d0cf8d6f22fbdeb874af31cff4c16d3 srec.patch"
+f720b3356b88e366c52941da056e543e4b42bc77f012e5b0290f79e15b0a31d855989ad01920680507a9df0544e5b8e26d0cf8d6f22fbdeb874af31cff4c16d3 srec.patch
+f52d21f194c2d7dbdc56e93636d3228034ee1718b457e5a5ce289bba2454155846d1ff6ea8530d11a901a85c9af945360bc17cda9e7370c36362aa6c762154c7 CVE-2019-9070-and-9071.patch
+032fed723b610fe06e210e2ebee8d24962ecad1dc69d98d38e95f768c9ed64cb991158758ef71e684d6d762a30e9a852287836be2bb8a2aba27fe31d2792c0a0 CVE-2019-9073.patch
+16b4cc094a6846399e47271da6fe8d8bd8b70246e12e872fcafb85f11809b5699eddba723fbac664c062c02f9b5658ea9770e14c522e151cdea1d39e69c851dd CVE-2019-9074.patch
+a46b9211608e2f35219b95363a5ba90506742dcb9e4bd4a43915af6c0b3e74bd8339a8318dc2923c0952ef579112412cb1cf619a5f090066769a852587b27d03 CVE-2019-9075.patch
+c0f50f1a843480f29b3895c8814df9801b9f90260edbaff1831aa5738fedd07a9e6b7a79f5b6f9be34df4954dbf02feb5232ebbecc596277fc2fe63673ed347c CVE-2019-9077.patch
+9109a6ff9c55f310f86a1561fe6b404534928d402672490059bbe358f77c0c2a7f73c8b67f0a4450f00ba1776452858b63fa60cf2ec0744104a6b077e8fa3e42 CVE-2019-12972.patch
+c277202272d9883741c2530a94c6d50d55dd9d0a9efaa43a1f8c9fc7529bd45e635255c0d90035dfc5920d5387010a4259612a4d711260a95d7b3d9fa6500e4f CVE-2019-14250.patch"
diff --git a/system/binutils/CVE-2019-12972.patch b/system/binutils/CVE-2019-12972.patch
new file mode 100644
index 000000000..82b41c014
--- /dev/null
+++ b/system/binutils/CVE-2019-12972.patch
@@ -0,0 +1,33 @@
+From 890f750a3b053532a4b839a2dd6243076de12031 Mon Sep 17 00:00:00 2001
+From: Alan Modra <amodra@gmail.com>
+Date: Fri, 21 Jun 2019 11:51:38 +0930
+Subject: [PATCH] PR24689, string table corruption
+
+The testcase in the PR had a e_shstrndx section of type SHT_GROUP.
+hdr->contents were initialized by setup_group rather than being read
+from the file, thus last byte was not zero and string dereference ran
+off the end of the buffer.
+
+ PR 24689
+ * elfcode.h (elf_object_p): Check type of e_shstrndx section.
+---
+ bfd/elfcode.h | 3 ++-
+ 2 files changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/bfd/elfcode.h b/bfd/elfcode.h
+index a0487b0..5180f79 100644
+--- a/bfd/elfcode.h
++++ b/bfd/elfcode.h
+@@ -754,7 +754,8 @@ elf_object_p (bfd *abfd)
+ /* A further sanity check. */
+ if (i_ehdrp->e_shnum != 0)
+ {
+- if (i_ehdrp->e_shstrndx >= elf_numsections (abfd))
++ if (i_ehdrp->e_shstrndx >= elf_numsections (abfd)
++ || i_shdrp[i_ehdrp->e_shstrndx].sh_type != SHT_STRTAB)
+ {
+ /* PR 2257:
+ We used to just goto got_wrong_format_error here
+--
+2.9.3
+
diff --git a/system/binutils/CVE-2019-14250.patch b/system/binutils/CVE-2019-14250.patch
new file mode 100644
index 000000000..fedc4fa7f
--- /dev/null
+++ b/system/binutils/CVE-2019-14250.patch
@@ -0,0 +1,25 @@
+Author: marxin
+Date: Tue Jul 23 07:33:32 2019 UTC
+https://gcc.gnu.org/viewcvs/gcc?view=revision&revision=273718
+
+libiberty: Check zero value shstrndx in simple-object-elf.c
+
+--- trunk/libiberty/simple-object-elf.c 2019/07/23 07:31:50 273717
++++ trunk/libiberty/simple-object-elf.c 2019/07/23 07:33:32 273718
+@@ -548,7 +548,15 @@
+ XDELETE (eor);
+ return NULL;
+ }
+-
++
++ if (eor->shstrndx == 0)
++ {
++ *errmsg = "invalid ELF shstrndx == 0";
++ *err = 0;
++ XDELETE (eor);
++ return NULL;
++ }
++
+ return (void *) eor;
+ }
+
diff --git a/system/binutils/CVE-2019-9070-and-9071.patch b/system/binutils/CVE-2019-9070-and-9071.patch
new file mode 100644
index 000000000..5f401d147
--- /dev/null
+++ b/system/binutils/CVE-2019-9070-and-9071.patch
@@ -0,0 +1,128 @@
+Author: nickc
+Date: Wed Apr 10 14:44:47 2019 UTC
+https://gcc.gnu.org/viewcvs/gcc?view=revision&revision=270258
+
+Fix a stack exhaustion bug in libiberty's demangler when decoding a
+pathalogically constructed mangled name.
+
+PR 89394
+* cp-demangle.c (cplus_demangle_fill_name): Reject negative
+lengths.
+(d_count_templates_scopes): Replace num_templates and num_scopes
+parameters with a struct d_print_info pointer parameter. Adjust
+body of the function accordingly. Add recursion counter and check
+that the recursion limit is not reached.
+(d_print_init): Pass dpi parameter to d_count_templates_scopes.
+Reset recursion counter afterwards, unless the recursion limit was
+reached.
+
+--- trunk/libiberty/cp-demangle.c 2019/04/10 14:39:59 270257
++++ trunk/libiberty/cp-demangle.c 2019/04/10 14:44:47 270258
+@@ -861,7 +861,7 @@
+ int
+ cplus_demangle_fill_name (struct demangle_component *p, const char *s, int len)
+ {
+- if (p == NULL || s == NULL || len == 0)
++ if (p == NULL || s == NULL || len <= 0)
+ return 0;
+ p->d_printing = 0;
+ p->type = DEMANGLE_COMPONENT_NAME;
+@@ -4061,7 +4061,7 @@
+ are larger than the actual numbers encountered. */
+
+ static void
+-d_count_templates_scopes (int *num_templates, int *num_scopes,
++d_count_templates_scopes (struct d_print_info *dpi,
+ const struct demangle_component *dc)
+ {
+ if (dc == NULL)
+@@ -4081,13 +4081,13 @@
+ break;
+
+ case DEMANGLE_COMPONENT_TEMPLATE:
+- (*num_templates)++;
++ dpi->num_copy_templates++;
+ goto recurse_left_right;
+
+ case DEMANGLE_COMPONENT_REFERENCE:
+ case DEMANGLE_COMPONENT_RVALUE_REFERENCE:
+ if (d_left (dc)->type == DEMANGLE_COMPONENT_TEMPLATE_PARAM)
+- (*num_scopes)++;
++ dpi->num_saved_scopes++;
+ goto recurse_left_right;
+
+ case DEMANGLE_COMPONENT_QUAL_NAME:
+@@ -4152,42 +4152,42 @@
+ case DEMANGLE_COMPONENT_TAGGED_NAME:
+ case DEMANGLE_COMPONENT_CLONE:
+ recurse_left_right:
+- d_count_templates_scopes (num_templates, num_scopes,
+- d_left (dc));
+- d_count_templates_scopes (num_templates, num_scopes,
+- d_right (dc));
++ /* PR 89394 - Check for too much recursion. */
++ if (dpi->recursion > DEMANGLE_RECURSION_LIMIT)
++ /* FIXME: There ought to be a way to report to the
++ user that the recursion limit has been reached. */
++ return;
++
++ ++ dpi->recursion;
++ d_count_templates_scopes (dpi, d_left (dc));
++ d_count_templates_scopes (dpi, d_right (dc));
++ -- dpi->recursion;
+ break;
+
+ case DEMANGLE_COMPONENT_CTOR:
+- d_count_templates_scopes (num_templates, num_scopes,
+- dc->u.s_ctor.name);
++ d_count_templates_scopes (dpi, dc->u.s_ctor.name);
+ break;
+
+ case DEMANGLE_COMPONENT_DTOR:
+- d_count_templates_scopes (num_templates, num_scopes,
+- dc->u.s_dtor.name);
++ d_count_templates_scopes (dpi, dc->u.s_dtor.name);
+ break;
+
+ case DEMANGLE_COMPONENT_EXTENDED_OPERATOR:
+- d_count_templates_scopes (num_templates, num_scopes,
+- dc->u.s_extended_operator.name);
++ d_count_templates_scopes (dpi, dc->u.s_extended_operator.name);
+ break;
+
+ case DEMANGLE_COMPONENT_FIXED_TYPE:
+- d_count_templates_scopes (num_templates, num_scopes,
+- dc->u.s_fixed.length);
++ d_count_templates_scopes (dpi, dc->u.s_fixed.length);
+ break;
+
+ case DEMANGLE_COMPONENT_GLOBAL_CONSTRUCTORS:
+ case DEMANGLE_COMPONENT_GLOBAL_DESTRUCTORS:
+- d_count_templates_scopes (num_templates, num_scopes,
+- d_left (dc));
++ d_count_templates_scopes (dpi, d_left (dc));
+ break;
+
+ case DEMANGLE_COMPONENT_LAMBDA:
+ case DEMANGLE_COMPONENT_DEFAULT_ARG:
+- d_count_templates_scopes (num_templates, num_scopes,
+- dc->u.s_unary_num.sub);
++ d_count_templates_scopes (dpi, dc->u.s_unary_num.sub);
+ break;
+ }
+ }
+@@ -4222,8 +4222,12 @@
+ dpi->next_copy_template = 0;
+ dpi->num_copy_templates = 0;
+
+- d_count_templates_scopes (&dpi->num_copy_templates,
+- &dpi->num_saved_scopes, dc);
++ d_count_templates_scopes (dpi, dc);
++ /* If we did not reach the recursion limit, then reset the
++ current recursion value back to 0, so that we can print
++ the templates. */
++ if (dpi->recursion < DEMANGLE_RECURSION_LIMIT)
++ dpi->recursion = 0;
+ dpi->num_copy_templates *= dpi->num_saved_scopes;
+
+ dpi->current_template = NULL;
diff --git a/system/binutils/CVE-2019-9073.patch b/system/binutils/CVE-2019-9073.patch
new file mode 100644
index 000000000..9ea45707b
--- /dev/null
+++ b/system/binutils/CVE-2019-9073.patch
@@ -0,0 +1,31 @@
+From 7d272a55caebfc26ab2e15d1e9439bac978b9bb7 Mon Sep 17 00:00:00 2001
+From: Alan Modra <amodra@gmail.com>
+Date: Wed, 20 Feb 2019 12:06:31 +1030
+Subject: [PATCH] PR24233, Out of memory
+
+ PR 24233
+ * objdump.c (dump_bfd_private_header): Print warning if
+ bfd_print_private_bfd_data returns false.
+---
+ binutils/ChangeLog | 6 ++++++
+ binutils/objdump.c | 4 +++-
+ 2 files changed, 9 insertions(+), 1 deletion(-)
+
+diff --git a/binutils/objdump.c b/binutils/objdump.c
+index 8725390..7d0c6a4 100644
+--- a/binutils/objdump.c
++++ b/binutils/objdump.c
+@@ -3178,7 +3178,9 @@ dump_bfd_header (bfd *abfd)
+ static void
+ dump_bfd_private_header (bfd *abfd)
+ {
+- bfd_print_private_bfd_data (abfd, stdout);
++ if (!bfd_print_private_bfd_data (abfd, stdout))
++ non_fatal (_("warning: private headers incomplete: %s"),
++ bfd_errmsg (bfd_get_error ()));
+ }
+
+ static void
+--
+2.9.3
+
diff --git a/system/binutils/CVE-2019-9074.patch b/system/binutils/CVE-2019-9074.patch
new file mode 100644
index 000000000..74b6c2040
--- /dev/null
+++ b/system/binutils/CVE-2019-9074.patch
@@ -0,0 +1,49 @@
+From 179f2db0d9c397d7dd8a59907b84208b79f7f48c Mon Sep 17 00:00:00 2001
+From: Alan Modra <amodra@gmail.com>
+Date: Tue, 19 Feb 2019 22:48:44 +1030
+Subject: [PATCH] PR24235, Read memory violation in pei-x86_64.c
+
+ PR 24235
+ * pei-x86_64.c (pex64_bfd_print_pdata_section): Correct checks
+ attempting to prevent read past end of section.
+---
+ bfd/pei-x86_64.c | 9 ++++-----
+ 2 files changed, 10 insertions(+), 5 deletions(-)
+
+diff --git a/bfd/pei-x86_64.c b/bfd/pei-x86_64.c
+index ff1093c..7e75104 100644
+--- a/bfd/pei-x86_64.c
++++ b/bfd/pei-x86_64.c
+@@ -541,7 +541,7 @@ pex64_bfd_print_pdata_section (bfd *abfd, void *vfile, asection *pdata_section)
+ /* virt_size might be zero for objects. */
+ if (stop == 0 && strcmp (abfd->xvec->name, "pe-x86-64") == 0)
+ {
+- stop = (datasize / onaline) * onaline;
++ stop = datasize;
+ virt_size_is_zero = TRUE;
+ }
+ else if (datasize < stop)
+@@ -551,8 +551,8 @@ pex64_bfd_print_pdata_section (bfd *abfd, void *vfile, asection *pdata_section)
+ _("Warning: %s section size (%ld) is smaller than virtual size (%ld)\n"),
+ pdata_section->name, (unsigned long) datasize,
+ (unsigned long) stop);
+- /* Be sure not to read passed datasize. */
+- stop = datasize / onaline;
++ /* Be sure not to read past datasize. */
++ stop = datasize;
+ }
+
+ /* Display functions table. */
+@@ -724,8 +724,7 @@ pex64_bfd_print_pdata_section (bfd *abfd, void *vfile, asection *pdata_section)
+ altent += imagebase;
+
+ if (altent >= pdata_vma
+- && (altent + PDATA_ROW_SIZE <= pdata_vma
+- + pei_section_data (abfd, pdata_section)->virt_size))
++ && altent - pdata_vma + PDATA_ROW_SIZE <= stop)
+ {
+ pex64_get_runtime_function
+ (abfd, &arf, &pdata[altent - pdata_vma]);
+--
+2.9.3
+
diff --git a/system/binutils/CVE-2019-9075.patch b/system/binutils/CVE-2019-9075.patch
new file mode 100644
index 000000000..0084d3368
--- /dev/null
+++ b/system/binutils/CVE-2019-9075.patch
@@ -0,0 +1,96 @@
+From 8abac8031ed369a2734b1cdb7df28a39a54b4b49 Mon Sep 17 00:00:00 2001
+From: Alan Modra <amodra@gmail.com>
+Date: Wed, 20 Feb 2019 08:21:24 +1030
+Subject: [PATCH] PR24236, Heap buffer overflow in
+ _bfd_archive_64_bit_slurp_armap
+
+ PR 24236
+ * archive64.c (_bfd_archive_64_bit_slurp_armap): Move code adding
+ sentinel NUL to string buffer nearer to loop where it is used.
+ Don't go past sentinel when scanning strings, and don't write
+ NUL again.
+ * archive.c (do_slurp_coff_armap): Simplify string handling to
+ archive64.c style.
+---
+ bfd/archive.c | 17 +++++++----------
+ bfd/archive64.c | 10 +++++-----
+ 3 files changed, 22 insertions(+), 15 deletions(-)
+
+diff --git a/bfd/archive.c b/bfd/archive.c
+index d2d9b72..68a92a3 100644
+--- a/bfd/archive.c
++++ b/bfd/archive.c
+@@ -1012,6 +1012,7 @@ do_slurp_coff_armap (bfd *abfd)
+ int *raw_armap, *rawptr;
+ struct artdata *ardata = bfd_ardata (abfd);
+ char *stringbase;
++ char *stringend;
+ bfd_size_type stringsize;
+ bfd_size_type parsed_size;
+ carsym *carsyms;
+@@ -1071,22 +1072,18 @@ do_slurp_coff_armap (bfd *abfd)
+ }
+
+ /* OK, build the carsyms. */
+- for (i = 0; i < nsymz && stringsize > 0; i++)
++ stringend = stringbase + stringsize;
++ *stringend = 0;
++ for (i = 0; i < nsymz; i++)
+ {
+- bfd_size_type len;
+-
+ rawptr = raw_armap + i;
+ carsyms->file_offset = swap ((bfd_byte *) rawptr);
+ carsyms->name = stringbase;
+- /* PR 17512: file: 4a1d50c1. */
+- len = strnlen (stringbase, stringsize);
+- if (len < stringsize)
+- len ++;
+- stringbase += len;
+- stringsize -= len;
++ stringbase += strlen (stringbase);
++ if (stringbase != stringend)
++ ++stringbase;
+ carsyms++;
+ }
+- *stringbase = 0;
+
+ ardata->symdef_count = nsymz;
+ ardata->first_file_filepos = bfd_tell (abfd);
+diff --git a/bfd/archive64.c b/bfd/archive64.c
+index 312bf82..42f6ed9 100644
+--- a/bfd/archive64.c
++++ b/bfd/archive64.c
+@@ -100,8 +100,6 @@ _bfd_archive_64_bit_slurp_armap (bfd *abfd)
+ return FALSE;
+ carsyms = ardata->symdefs;
+ stringbase = ((char *) ardata->symdefs) + carsym_size;
+- stringbase[stringsize] = 0;
+- stringend = stringbase + stringsize;
+
+ raw_armap = (bfd_byte *) bfd_alloc (abfd, ptrsize);
+ if (raw_armap == NULL)
+@@ -115,15 +113,17 @@ _bfd_archive_64_bit_slurp_armap (bfd *abfd)
+ goto release_raw_armap;
+ }
+
++ stringend = stringbase + stringsize;
++ *stringend = 0;
+ for (i = 0; i < nsymz; i++)
+ {
+ carsyms->file_offset = bfd_getb64 (raw_armap + i * 8);
+ carsyms->name = stringbase;
+- if (stringbase < stringend)
+- stringbase += strlen (stringbase) + 1;
++ stringbase += strlen (stringbase);
++ if (stringbase != stringend)
++ ++stringbase;
+ ++carsyms;
+ }
+- *stringbase = '\0';
+
+ ardata->symdef_count = nsymz;
+ ardata->first_file_filepos = bfd_tell (abfd);
+--
+2.9.3
+
diff --git a/system/binutils/CVE-2019-9077.patch b/system/binutils/CVE-2019-9077.patch
new file mode 100644
index 000000000..de044e387
--- /dev/null
+++ b/system/binutils/CVE-2019-9077.patch
@@ -0,0 +1,33 @@
+From 7fc0c668f2aceb8582d74db1ad2528e2bba8a921 Mon Sep 17 00:00:00 2001
+From: Nick Clifton <nickc@redhat.com>
+Date: Wed, 20 Feb 2019 17:03:47 +0000
+Subject: [PATCH] Fix a illegal memory access fault when parsing a corrupt MIPS
+ option section using readelf.
+
+ PR 24243
+ * readelf.c (process_mips_specific): Check for an options section
+ that is too small to even contain a single option.
+---
+ binutils/readelf.c | 6 ++++++
+ 2 files changed, 9 insertions(+)
+
+diff --git a/binutils/readelf.c b/binutils/readelf.c
+index 54d165e..20ebacc 100644
+--- a/binutils/readelf.c
++++ b/binutils/readelf.c
+@@ -16187,6 +16187,12 @@ process_mips_specific (Filedata * filedata)
+ error (_("No MIPS_OPTIONS header found\n"));
+ return FALSE;
+ }
++ /* PR 24243 */
++ if (sect->sh_size < sizeof (* eopt))
++ {
++ error (_("The MIPS options section is too small.\n"));
++ return FALSE;
++ }
+
+ eopt = (Elf_External_Options *) get_data (NULL, filedata, options_offset, 1,
+ sect->sh_size, _("options"));
+--
+2.9.3
+
diff --git a/system/iproute2/APKBUILD b/system/iproute2/APKBUILD
index 4b4b6060c..b4e32f6a8 100644
--- a/system/iproute2/APKBUILD
+++ b/system/iproute2/APKBUILD
@@ -11,7 +11,6 @@ options="!check"
license="GPL-2.0-only"
depends=""
makedepends="bison flex bash libelf-dev libmnl-dev libcap-dev bsd-compat-headers"
-install="$pkgname.post-install"
subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp:noarch"
source="https://kernel.org/pub/linux/utils/net/iproute2/iproute2-$pkgver.tar.xz
devlink-sysinfo.patch"
diff --git a/system/iproute2/iproute2.post-install b/system/iproute2/iproute2.post-install
deleted file mode 100644
index 36d567ea2..000000000
--- a/system/iproute2/iproute2.post-install
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-if [ "$(readlink /bin/ip)" = "/bin/busybox" ]; then
- rm -f /bin/ip
-fi
-exit 0
diff --git a/system/lvm2/APKBUILD b/system/lvm2/APKBUILD
index 842dee2fa..fc491a70a 100644
--- a/system/lvm2/APKBUILD
+++ b/system/lvm2/APKBUILD
@@ -51,6 +51,10 @@ build () {
--with-thin=internal \
--enable-dmeventd \
--enable-cmdlib \
+ --with-default-dm-run-dir=/run \
+ --with-default-locking-dir=/run/lock/lvm \
+ --with-default-pid-dir=/run \
+ --with-default-run-dir=/run/lvm \
--with-thin-check=/sbin/thin_check \
--with-thin-dump=/sbin/thin_dump \
--with-thin-repair=/sbin/thin_repair \
diff --git a/system/s6-linux-init/APKBUILD b/system/s6-linux-init/APKBUILD
index d1cead76d..9217a7d03 100644
--- a/system/s6-linux-init/APKBUILD
+++ b/system/s6-linux-init/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Laurent Bercot <ska-adelie@skarnet.org>
# Maintainer: Laurent Bercot <ska-adelie@skarnet.org>
pkgname=s6-linux-init
-pkgver=1.0.2.0
-pkgrel=1
+pkgver=1.0.2.1
+pkgrel=0
pkgdesc="A s6-based init system"
url="https://skarnet.org/software/$pkgname/"
arch="all"
@@ -120,7 +120,7 @@ doc() {
cp -a "$builddir/doc" "$subpkgdir/usr/share/doc/$pkgname"
}
-sha512sums="1140434b07bf85956382a43bc8f58fa32cbefc43e40a48825b9e938d7950d988585e872667b79ba1bd44f0befb69202bcb7347c0e722ab5d20dc9304cd1be843 s6-linux-init-1.0.2.0.tar.gz
+sha512sums="65ffd4c7a1457c6ad7397ccf7c4ee92dd04e546e21acf75bbfd49ace5b93eb22bac673185061ad9389449d324b6164577715258ab292825da8973140bc548d92 s6-linux-init-1.0.2.1.tar.gz
756b0cbbe5dabb4631380c3c7ea199cc213224b2e36e50a2d012a61948170078b78bf49b85d886319fecf59843087f937d3d804723b2553ac9f94d088a2f0fd8 rc.init
e73c3c32b118831074288d23fadace2158a2b15d5a13ffa73290b92a9e39c2a21c73d3b0eabea29bcbaa5f6381611fd8d0aaa6aa691ec7de91b8ef6ae404b6da runlevel
7bb050248a5c2ab6a56c50c35f87cde724f97ff9882f5e60b0f0f2f14bd93c1df7d99fedc3d81c8519cf1a1ed90e03f1cbb9bf891c7b3618aa9a5f5738d262f4 rc.shutdown
diff --git a/system/utmps/APKBUILD b/system/utmps/APKBUILD
index 78d3a176e..50bd13dba 100644
--- a/system/utmps/APKBUILD
+++ b/system/utmps/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Laurent Bercot <ska-adelie@skarnet.org>
# Maintainer: Laurent Bercot <ska-adelie@skarnet.org>
pkgname=utmps
-pkgver=0.0.2.1
+pkgver=0.0.2.2
pkgrel=1
pkgdesc="A secure utmp/wtmp implementation"
url="https://skarnet.org/software/$pkgname/"
@@ -76,6 +76,6 @@ doc() {
cp -a "$builddir/doc" "$subpkgdir/usr/share/doc/$pkgname"
}
-sha512sums="e0ead9dc4085ce778f22831eec0f79ad251c6f5cb83afa6e52a9ab47a4a0037695e70c2ff0624da8b406a8e3c79f0c8653600bc541fad90c4e21d241c53c27aa utmps-0.0.2.1.tar.gz
+sha512sums="1e7b53e7fcbd15a113aef8001ac77c3646ecd4723eaca77b36400c76ee96dafe919a993603a1fd441f1c9fff08c5924714910d43ae86fbf85971c39b950323c0 utmps-0.0.2.2.tar.gz
0ec30284c64c6ea9f25142c5f4a643bd48b137fe85781b650104f5137ffa4dfc35ca7be3e41e3acd3403ebe1d8c5378073afa4e2f3607d3d794fcd9f98ed51c4 utmpd.run
cba4f2ec3b8f5becf3ae57eecf584745d783046ee6cf5d116322421ad5ffd074d2955da22d31d2b5b1d05f906378aae92f221d2ac95ac21b54a361fbdc0566e7 wtmpd.run"
diff --git a/user/aspell/APKBUILD b/user/aspell/APKBUILD
index 88ab8a736..bce270974 100644
--- a/user/aspell/APKBUILD
+++ b/user/aspell/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer:
pkgname=aspell
-pkgver=0.60.6.1
-pkgrel=15
+pkgver=0.60.7
+pkgrel=0
pkgdesc="Libre spell checker software"
url="http://aspell.net/"
arch="all"
@@ -12,14 +12,7 @@ makedepends="ncurses-dev perl"
provides="aspell-utils"
subpackages="$pkgname-compat::noarch $pkgname-dev $pkgname-doc
$pkgname-lang"
-source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz
- aspell-0.60.6.1-gcc7-fixes.patch
- "
-
-prepare() {
- default_prepare
- update_config_sub
-}
+source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
build() {
LIBS="-ltinfo" ./configure \
@@ -49,5 +42,4 @@ compat() {
mv spell ispell "$subpkgdir"/usr/bin/
}
-sha512sums="f310c7590be98406589b5c26ca36a2ecfe4733f0b40fd6c176b96b7955ef2b5cd0ec9a3d770cf132146ae7a896042b4b698945112995ee1ae66adcfa5542247f aspell-0.60.6.1.tar.gz
-7acdd483fa218952775282f42c28998b4901b1c70aeeef307835a205d1cde3fb2912898d08799ee596d744dde55d04e5c4905fb66d8bfa3028d1f5d45bb66d1e aspell-0.60.6.1-gcc7-fixes.patch"
+sha512sums="6f5fcd1c29164ee18f205594b66f382b51d19b17686293a931ca92c1442d3f7228627ca7d604d860551d0d367ac34dfb2ae34170a844f51e84e390fb1edc4535 aspell-0.60.7.tar.gz"
diff --git a/user/aspell/aspell-0.60.6.1-gcc7-fixes.patch b/user/aspell/aspell-0.60.6.1-gcc7-fixes.patch
deleted file mode 100644
index 4eb825a24..000000000
--- a/user/aspell/aspell-0.60.6.1-gcc7-fixes.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-commit 8089fa02122fed0a6394eba14bbedcb1d18e2384
-Author: Kevin Atkinson <kevina@gnu.org>
-Date: Thu Dec 29 00:50:31 2016 -0500
-
- Compile Fixes for GCC 7.
-
- Closes #519.
-
-diff --git a/modules/filter/tex.cpp b/modules/filter/tex.cpp
-index a979539..19ab63c 100644
---- a/modules/filter/tex.cpp
-+++ b/modules/filter/tex.cpp
-@@ -174,7 +174,7 @@ namespace {
-
- if (c == '{') {
-
-- if (top.in_what == Parm || top.in_what == Opt || top.do_check == '\0')
-+ if (top.in_what == Parm || top.in_what == Opt || *top.do_check == '\0')
- push_command(Parm);
-
- top.in_what = Parm;
-diff --git a/prog/check_funs.cpp b/prog/check_funs.cpp
-index db54f3d..89ee09d 100644
---- a/prog/check_funs.cpp
-+++ b/prog/check_funs.cpp
-@@ -647,7 +647,7 @@ static void print_truncate(FILE * out, const char * word, int width) {
- }
- }
- if (i == width-1) {
-- if (word == '\0')
-+ if (*word == '\0')
- put(out,' ');
- else if (word[len] == '\0')
- put(out, word, len);
diff --git a/user/gnutls/APKBUILD b/user/gnutls/APKBUILD
index 627abf2ec..8578e002b 100644
--- a/user/gnutls/APKBUILD
+++ b/user/gnutls/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer:
pkgname=gnutls
-pkgver=3.6.8
+pkgver=3.6.9
pkgrel=0
pkgdesc="A TLS protocol implementation"
url="http://www.gnutls.org/"
@@ -80,5 +80,5 @@ xx() {
mv "$pkgdir"/usr/lib/lib*xx.so.* "$subpkgdir"/usr/lib/
}
-sha512sums="71f0899de0ffb2a39b25928042114e2bbfde7fbf2029d9f91f60bf60794916d13f544fc97337e4e3282e7faa17e79a8012b0e08f98805bee543c0ba4e5d5a905 gnutls-3.6.8.tar.xz
+sha512sums="a9fd0f4edae4c081d5c539ba2e5574a4d7294bc00c5c73ea25ce26cb7fd126299c2842a282d45ef5cf0544108f27066e587df28776bc7915143d190d7d5b9d07 gnutls-3.6.9.tar.xz
abc24ee59cc67805fe953535b0bae33080fc8b0bf788304377f6d10ec8c162c4cf203a69c98a4ba3483b4c60ed7a204433cc7db9b8190eddb0d68f6fb6dad52d gnulib-tests-dont-require-gpg-passphrase.patch"
diff --git a/user/highlight/APKBUILD b/user/highlight/APKBUILD
index d0289e95a..8ceb16c85 100644
--- a/user/highlight/APKBUILD
+++ b/user/highlight/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname=highlight
-pkgver=3.52
+pkgver=3.53
pkgrel=0
pkgdesc="Fast and flexible source code highlighter"
url="http://www.andre-simon.de/doku/highlight/highlight.html"
@@ -20,4 +20,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="4a44f6c4d29836c6f1af9db02c4e989c7ce155bcb387ca294170c361ae6c41b7441b03810ee27e7b7cdbd3ec73907fb5746ab545b7a44dfc482cc242a86681fe highlight-3.52.tar.bz2"
+sha512sums="b25340aa881e5188fb9862d4858fab17627a80329835723a75de95bbf523f2453f42fa4e6ed842345b5e2842d66a40f16b03c19fbbbea4a226e247a93130a5e3 highlight-3.53.tar.bz2"
diff --git a/user/qt5-qtbase/APKBUILD b/user/qt5-qtbase/APKBUILD
index 08e623af5..95f461d64 100644
--- a/user/qt5-qtbase/APKBUILD
+++ b/user/qt5-qtbase/APKBUILD
@@ -2,7 +2,7 @@
pkgname=qt5-qtbase
_pkgname=qtbase-opensource-src
pkgver=5.9.7
-pkgrel=0
+pkgrel=1
pkgdesc="Qt 5.9 base components"
url="https://www.qt.io/"
arch="all"
@@ -22,6 +22,7 @@ makedepends="$depends_dev
"
subpackages="$pkgname-dev $pkgname-doc $_sub"
source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz
+ big-endian-scroll-wheel.patch
link-to-execinfo.patch
qt-musl-iconv-no-bom.patch
"
@@ -173,5 +174,6 @@ x11() {
}
sha512sums="7121837501b810f31863fbb3a6ea7189d3e38789ff25eb49b639a69b73913761c8cba18b65046519693d2f5c8755c2197feff1df1ec3d88676d00c649a326e1e qtbase-opensource-src-5.9.7.tar.xz
+0f5b3d93bd1543f4e28e3dfe4a77db4759f2e3afbeb6f6b2c3aa76bf106ed585984ea228b2233bc53afeb3f51c557e3545b18a74096d2cf129364a1f6c4ef090 big-endian-scroll-wheel.patch
ee78a44e28ba5f728914bfc3d8d5b467896c7de11a02d54b0bce11e40a4338b1f776c1fcc30cbd436df4f548c1ab0b4fe801f01b162ddd5c0f892893e227acfd link-to-execinfo.patch
-7d68421a14f0259535c977d8a521c98918193c107b76ac664571b12f5b0d7588a0d0e1297af412a26753a393b21f3f44c3274fa8ab5bc87f03705a3a03acb444 qt-musl-iconv-no-bom.patch"
+dca65670df25a8e391d4c62b8967f4377cbd193a3053d8e8e288452ea197f418fe3f6d9d5e48dc333a44aeadec68e3d4380b3672a07ef6baf7aa3eed96ba96e3 qt-musl-iconv-no-bom.patch"
diff --git a/user/qt5-qtbase/big-endian-scroll-wheel.patch b/user/qt5-qtbase/big-endian-scroll-wheel.patch
new file mode 100644
index 000000000..3fbb8aec7
--- /dev/null
+++ b/user/qt5-qtbase/big-endian-scroll-wheel.patch
@@ -0,0 +1,43 @@
+--- qtbase-opensource-src-5.9.7/src/plugins/platforms/xcb/qxcbconnection_xi2.cpp.old 2018-10-16 08:37:05.000000000 +0000
++++ qtbase-opensource-src-5.9.7/src/plugins/platforms/xcb/qxcbconnection_xi2.cpp 2019-08-03 03:58:05.875790720 +0000
+@@ -43,6 +43,7 @@
+ #include "qxcbwindow.h"
+ #include "qtouchdevice.h"
+ #include "QtCore/qmetaobject.h"
++#include "QtCore/qendian.h"
+ #include <qpa/qwindowsysteminterface_p.h>
+ #include <QDebug>
+ #include <cmath>
+@@ -106,6 +107,7 @@
+ XIEventMask xiEventMask;
+ bitMask = XI_HierarchyChangedMask;
+ bitMask |= XI_DeviceChangedMask;
++ bitMask = qToLittleEndian(bitMask);
+ xiEventMask.deviceid = XIAllDevices;
+ xiEventMask.mask_len = sizeof(bitMask);
+ xiEventMask.mask = xiBitMask;
+@@ -327,7 +329,8 @@
+ }
+ XIEventMask mask;
+ mask.mask_len = sizeof(bitMask);
++ bitMask = qToLittleEndian(bitMask);
+ mask.mask = xiBitMask;
+ // When xi2MouseEvents() is true (the default), pointer emulation for touch and tablet
+ // events will get disabled. This is preferable, as Qt Quick handles touch events
+ // directly, while for other applications QtGui synthesizes mouse events.
+@@ -353,6 +356,7 @@
+ tabletBitMask = XI_PropertyEventMask;
+ if (!pointerSelected)
+ tabletBitMask |= XI_ButtonPressMask | XI_ButtonReleaseMask | XI_MotionMask;
++ tabletBitMask = qToLittleEndian(tabletBitMask);
+ for (int i = 0; i < m_tabletData.count(); ++i) {
+ int deviceId = m_tabletData.at(i).deviceId;
+ tabletDevices.insert(deviceId);
+@@ -374,6 +378,7 @@
+
+ scrollBitMask = XI_MotionMask;
+ scrollBitMask |= XI_ButtonReleaseMask;
++ scrollBitMask = qToLittleEndian(scrollBitMask);
+ int i=0;
+ for (const ScrollingDevice& scrollingDevice : qAsConst(m_scrollingDevices)) {
+ if (tabletDevices.contains(scrollingDevice.deviceId))
diff --git a/user/qt5-qtbase/qt-musl-iconv-no-bom.patch b/user/qt5-qtbase/qt-musl-iconv-no-bom.patch
index 8bf35ec1e..be2afc714 100644
--- a/user/qt5-qtbase/qt-musl-iconv-no-bom.patch
+++ b/user/qt5-qtbase/qt-musl-iconv-no-bom.patch
@@ -1,6 +1,6 @@
--- qtbase/src/corelib/codecs/qiconvcodec.cpp 2017-01-18 15:20:58.000000000 +0100
+++ qtbase/src/corelib/codecs/qiconvcodec.cpp 2017-02-21 14:33:32.423808603 +0100
-@@ -64,7 +64,7 @@
+@@ -63,7 +63,7 @@
#elif defined(Q_OS_AIX)
# define NO_BOM
# define UTF16 "UCS-2"