summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/py3-monotonic/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/user/py3-monotonic/APKBUILD b/user/py3-monotonic/APKBUILD
new file mode 100644
index 000000000..473c12f1e
--- /dev/null
+++ b/user/py3-monotonic/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=py3-monotonic
+_pkgname=monotonic
+_p="${_pkgname#?}"
+_p="${_pkgname%"$_p"}"
+pkgver=1.5
+pkgrel=0
+pkgdesc="Monotonic clock for Python"
+url="https://pypi.org/project/monotonic/"
+arch="noarch"
+license="Apache-2.0"
+depends="python3"
+makedepends=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/monotonic-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="05485e0baa51df95f9812d463306ce0bbe7228170b43aed8faa9d77d2b613ffede6b57b3dd273c352e0d1c04782043bec2f36be88cb1acde182a5aeb0538f970 monotonic-1.5.tar.gz"