summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/coreutils/APKBUILD4
-rw-r--r--system/coreutils/disable-csplit-io-err-test.patch11
2 files changed, 14 insertions, 1 deletions
diff --git a/system/coreutils/APKBUILD b/system/coreutils/APKBUILD
index 4adb181e3..f54e82463 100644
--- a/system/coreutils/APKBUILD
+++ b/system/coreutils/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=coreutils
pkgver=8.29
-pkgrel=1
+pkgrel=2
pkgdesc="Basic file, shell, and text manipulation utilities"
url="http://www.gnu.org/software/coreutils/"
arch="all"
@@ -16,6 +16,7 @@ subpackages="$pkgname-doc"
[ ${CBUILD} == ${CHOST} ] && subpackages="$subpackages $pkgname-lang"
install="$pkgname.post-deinstall"
source="http://ftp.gnu.org/gnu/coreutils/$pkgname-$pkgver.tar.xz
+ disable-csplit-io-err-test.patch
disable-mbrtowc-test.patch
localename-test-fix.patch
"
@@ -76,6 +77,7 @@ package() {
}
sha512sums="546bbcd5741beae7a68e7c4ca14d6d634f7c8be87feecdeddd00e226f4865bb89d503437c3a95622ba7bb0cb70addbb5bdf3767fa18d0b7410ab90ee53b29dfd coreutils-8.29.tar.xz
+bd8b5cecba59eba30458c8afa895877d39a987b989bc06b70cd6836e0ef684677aaadcb4949b58a713779fe1df1e15e3903e9be14e306671b86b69018b75de8b disable-csplit-io-err-test.patch
532ef8210261437855ba3e2fc72ec57b0e0252b2b0f7817990c9629613ece2cdd86cf30aa049f3cff6fbda12ed3bb9a0db3a3642475378ae44ce319bdf005d9b disable-mbrtowc-test.patch
a6cbe77d2fd3655e59ead9ec5cfcc80ae8c1a688f779219910d9370a0e5f86195e2d3a1ca427a374d8457c5ca04ebb72f8bac0b7a7415337bac3545a85d22e3d localename-test-fix.patch"
diff --git a/system/coreutils/disable-csplit-io-err-test.patch b/system/coreutils/disable-csplit-io-err-test.patch
new file mode 100644
index 000000000..035d84486
--- /dev/null
+++ b/system/coreutils/disable-csplit-io-err-test.patch
@@ -0,0 +1,11 @@
+--- a/tests/misc/csplit-io-err.sh 2017-09-20 01:17:21.000000000 +0000
++++ b/tests/misc/csplit-io-err.sh 2018-08-02 09:14:34.897772887 +0000
+@@ -20,6 +20,8 @@
+ print_ver_ csplit
+ require_gcc_shared_
+
++skip_ 'test relies on glibc-specific behavior'
++
+ if ! test -w /dev/full || ! test -c /dev/full; then
+ skip_ '/dev/full is required'
+ fi