summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/a52dec/APKBUILD7
-rw-r--r--user/faad2/APKBUILD2
-rw-r--r--user/libdvdcss/APKBUILD6
-rw-r--r--user/libdvdnav/APKBUILD3
-rw-r--r--user/libdvdread/APKBUILD4
5 files changed, 6 insertions, 16 deletions
diff --git a/user/a52dec/APKBUILD b/user/a52dec/APKBUILD
index 9296f3ad0..73419f6c7 100644
--- a/user/a52dec/APKBUILD
+++ b/user/a52dec/APKBUILD
@@ -6,15 +6,15 @@ pkgdesc="Library for decoding ATSC A/52 streams"
url="http://liba52.sourceforge.net/"
arch="all"
license="GPL-2.0+"
-subpackages="$pkgname-dev $pkgname-doc"
+depends=""
makedepends="autoconf automake libtool linux-headers"
+subpackages="$pkgname-dev $pkgname-doc"
source="http://liba52.sourceforge.net/files/$pkgname-$pkgver.tar.gz
automake.patch
$pkgname-$pkgver-build.patch
"
prepare() {
- cd "$builddir"
default_prepare
update_config_sub
libtoolize --force && \
@@ -22,7 +22,6 @@ prepare() {
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -32,12 +31,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -m644 liba52/a52_internal.h "$pkgdir"/usr/include/a52dec/
}
diff --git a/user/faad2/APKBUILD b/user/faad2/APKBUILD
index af7ffa905..679d7831e 100644
--- a/user/faad2/APKBUILD
+++ b/user/faad2/APKBUILD
@@ -8,9 +8,9 @@ url="https://www.audiocoding.com/"
arch="all"
options="!check" # No test suite.
license="GPL-2.0+"
-subpackages="$pkgname-dev $pkgname-doc"
depends=""
makedepends="autoconf automake libtool"
+subpackages="$pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/knik0/faad2/archive/$_pkgver.tar.gz"
builddir="$srcdir/$pkgname-$_pkgver"
diff --git a/user/libdvdcss/APKBUILD b/user/libdvdcss/APKBUILD
index 25e46df5e..27c8d14b1 100644
--- a/user/libdvdcss/APKBUILD
+++ b/user/libdvdcss/APKBUILD
@@ -5,13 +5,13 @@ pkgrel=0
pkgdesc="Library for accessing encrypted DVDs like a block device"
url="https://www.videolan.org/developers/libdvdcss.html"
arch="all"
-makedepends="file linux-headers"
license="GPL-2.0+"
+depends=""
+makedepends="file linux-headers"
subpackages="$pkgname-dev $pkgname-doc"
source="https://download.videolan.org/pub/libdvdcss/$pkgver/libdvdcss-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--prefix=/usr \
--sysconfdir=/etc \
@@ -21,12 +21,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/libdvdnav/APKBUILD b/user/libdvdnav/APKBUILD
index d9fb2d5e4..832270be3 100644
--- a/user/libdvdnav/APKBUILD
+++ b/user/libdvdnav/APKBUILD
@@ -14,7 +14,6 @@ subpackages="$pkgname-dev $pkgname-doc"
source="https://download.videolan.org/pub/videolan/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,12 +24,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/libdvdread/APKBUILD b/user/libdvdread/APKBUILD
index 879a36a29..295c93920 100644
--- a/user/libdvdread/APKBUILD
+++ b/user/libdvdread/APKBUILD
@@ -7,12 +7,12 @@ pkgdesc="Library for reading DVD video discs"
url="http://dvdnav.mplayerhq.hu/"
arch="all"
license="GPL-2.0+ AND LGPL-2.1+ AND GPL-2.0-only"
+depends=""
makedepends="libdvdcss-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="https://download.videolan.org/pub/videolan/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -24,12 +24,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}