summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/py3-six/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/user/py3-six/APKBUILD b/user/py3-six/APKBUILD
new file mode 100644
index 000000000..7c001b2a9
--- /dev/null
+++ b/user/py3-six/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=py3-six
+_pkgname=six
+pkgver=1.11.0
+pkgrel=1
+pkgdesc="Python 2 compatibility library"
+url="https://pypi.python.org/pypi/six"
+arch="noarch"
+license="MIT"
+depends=""
+makedepends="python3-dev"
+checkdepends="py3-pluggy py3-pytest"
+source="$pkgname-$pkgver.tar.gz::https://github.com/benjaminp/$_pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="f301c6e3c159fc87c121a6b860e4a24fa77ca2d23c3beb29201f7ba0ef71188d683d103fd3f44f50bc774a0682183256ac119e20463d389ebe0f481e2c4711f9 py3-six-1.11.0.tar.gz"