summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/hicolor-icon-theme/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/user/hicolor-icon-theme/APKBUILD b/user/hicolor-icon-theme/APKBUILD
new file mode 100644
index 000000000..ffcc38651
--- /dev/null
+++ b/user/hicolor-icon-theme/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=hicolor-icon-theme
+pkgver=0.17
+pkgrel=0
+pkgdesc="Freedesktop.org Hicolor icon theme"
+url="https://www.freedesktop.org/wiki/Software/icon-theme/"
+arch="noarch"
+options="!check" # Just icon set, no tests.
+license="GPL-2.0-only"
+source="https://icon-theme.freedesktop.org/releases/$pkgname-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="eca8655930aa7e234f42630041c0053fde067b970fad1f81c55fcd4c5046c03edfdf2ede72a3e78fba2908e7da53e9463d3c5ae12ab9f5ef261e29a49f9c7a8d hicolor-icon-theme-0.17.tar.xz"