summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/trigger-rally/APKBUILD29
-rw-r--r--user/trigger-rally/dont-strip.patch20
2 files changed, 49 insertions, 0 deletions
diff --git a/user/trigger-rally/APKBUILD b/user/trigger-rally/APKBUILD
new file mode 100644
index 000000000..adf5c2b40
--- /dev/null
+++ b/user/trigger-rally/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=trigger-rally
+pkgver=0.6.5
+pkgrel=0
+pkgdesc="Fast-paced rally racing game"
+url="http://trigger-rally.sourceforge.net/"
+arch="all"
+options="!check" # No test suite.
+license="GPL-2.0-only"
+depends=""
+makedepends="freealut-dev glew-dev glu-dev openal-soft-dev physfs-dev sdl2-dev
+ sdl2_image-dev"
+source="https://downloads.sourceforge.net/trigger-rally/trigger-rally-$pkgver.tar.gz
+ dont-strip.patch
+ "
+
+build() {
+ cd "$builddir"/src
+ make OPTIMS="$CXXFLAGS -Wno-deprecated-declarations" DESTDIR="$pkgdir" prefix=/usr build
+}
+
+package() {
+ cd "$builddir"/src
+ make OPTIMS="$CXXFLAGS" DESTDIR="$pkgdir" prefix=/usr install
+}
+
+sha512sums="59f48c116b20e47559b4c07107fa4055a9ad516e9c147763e4ba5d2ead3a4a5101f7d690483a1ef0df847ca647c0f750937512ee579f4ae06908157d9eabf184 trigger-rally-0.6.5.tar.gz
+a81781058177e012daaad58d72e4bdbdbc2730b1df76941ba03f06367545b213ba82a33bab46deba31570973deb1802a3d459704c3a963c38eec69ef82f228d5 dont-strip.patch"
diff --git a/user/trigger-rally/dont-strip.patch b/user/trigger-rally/dont-strip.patch
new file mode 100644
index 000000000..e6a01b335
--- /dev/null
+++ b/user/trigger-rally/dont-strip.patch
@@ -0,0 +1,20 @@
+--- trigger-rally-0.6.5/src/GNUmakefile.old 2016-11-05 17:27:10.000000000 +0000
++++ trigger-rally-0.6.5/src/GNUmakefile 2018-08-07 02:37:36.010000000 +0000
+@@ -118,7 +118,7 @@
+ @cd ../..; \
+ md5sum "$(DISTARC)" > "$(DISTARC).md5"
+
+-# links the object files into the executable, which it then strips
++# links the object files into the executable
+ $(TR_EXEFILE): $(OBJFILES)
+ @printf "%s" $(CXX)
+ @for file in $(OBJFILES); do \
+@@ -126,8 +126,6 @@
+ done;
+ @printf "\t-> %s\n" $@
+ @$(CXX) -o $@ $(OBJFILES) $(LDFLAGS)
+- @printf "strip\t%s\n" $@
+- @strip $@
+
+ #
+ # removes object files, dependency files, executable and