summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/libtap/APKBUILD12
1 files changed, 3 insertions, 9 deletions
diff --git a/user/libtap/APKBUILD b/user/libtap/APKBUILD
index 0c47e0468..b8a992768 100644
--- a/user/libtap/APKBUILD
+++ b/user/libtap/APKBUILD
@@ -1,27 +1,23 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libtap
-pkgver=1.12.0
+pkgver=1.14.0
pkgrel=0
pkgdesc="C library implementing the Test Anything Protocol (TAP)"
url="https://www.shlomifish.org/open-source/projects/libtap/"
arch="all"
license="BSD-3-Clause"
depends=""
-depends_dev=""
makedepends="cmake perl"
subpackages="$pkgname-dev $pkgname-doc"
-source="http://web-cpan.shlomifish.org/downloads/libtap-$pkgver.tar.bz2"
-builddir="$srcdir/libtap-$pkgver"
+source="http://web-cpan.shlomifish.org/downloads/libtap-$pkgver.tar.xz"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
@@ -31,13 +27,11 @@ build() {
}
check() {
- cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="510f85a5b10525cf8b67a0bcc67213e43a9e752def5293fecbc97f7058d24256a85cd8ce8c0b408186ca676f3ca700ddbeea4c8c7558352665956b4233258d31 libtap-1.12.0.tar.bz2"
+sha512sums="1d78f9ed5b554a7a9f8a2a6e3dcb30e09ba5bd4b98c77499e57599be615413f6c6dddb3dd498b6ac49a5449e54e1134a6a4816adaab5b993e3c0027edc2a2404 libtap-1.14.0.tar.xz"