summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/iproute2/APKBUILD1
-rw-r--r--system/iproute2/iproute2.post-install6
-rw-r--r--system/lvm2/APKBUILD4
-rw-r--r--system/zsh/APKBUILD5
-rw-r--r--system/zsh/skel4
-rw-r--r--user/eudev/APKBUILD8
-rw-r--r--user/gamin/APKBUILD15
-rw-r--r--user/gamin/deadlock.patch65
8 files changed, 88 insertions, 20 deletions
diff --git a/system/iproute2/APKBUILD b/system/iproute2/APKBUILD
index 4b4b6060c..b4e32f6a8 100644
--- a/system/iproute2/APKBUILD
+++ b/system/iproute2/APKBUILD
@@ -11,7 +11,6 @@ options="!check"
license="GPL-2.0-only"
depends=""
makedepends="bison flex bash libelf-dev libmnl-dev libcap-dev bsd-compat-headers"
-install="$pkgname.post-install"
subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp:noarch"
source="https://kernel.org/pub/linux/utils/net/iproute2/iproute2-$pkgver.tar.xz
devlink-sysinfo.patch"
diff --git a/system/iproute2/iproute2.post-install b/system/iproute2/iproute2.post-install
deleted file mode 100644
index 36d567ea2..000000000
--- a/system/iproute2/iproute2.post-install
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-if [ "$(readlink /bin/ip)" = "/bin/busybox" ]; then
- rm -f /bin/ip
-fi
-exit 0
diff --git a/system/lvm2/APKBUILD b/system/lvm2/APKBUILD
index 842dee2fa..fc491a70a 100644
--- a/system/lvm2/APKBUILD
+++ b/system/lvm2/APKBUILD
@@ -51,6 +51,10 @@ build () {
--with-thin=internal \
--enable-dmeventd \
--enable-cmdlib \
+ --with-default-dm-run-dir=/run \
+ --with-default-locking-dir=/run/lock/lvm \
+ --with-default-pid-dir=/run \
+ --with-default-run-dir=/run/lvm \
--with-thin-check=/sbin/thin_check \
--with-thin-dump=/sbin/thin_dump \
--with-thin-repair=/sbin/thin_repair \
diff --git a/system/zsh/APKBUILD b/system/zsh/APKBUILD
index 5c80e950b..695a26a1d 100644
--- a/system/zsh/APKBUILD
+++ b/system/zsh/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=zsh
pkgver=5.7.1
-pkgrel=0
+pkgrel=1
pkgdesc="A very advanced and programmable command interpreter (shell)"
url="https://www.zsh.org/"
arch="all"
@@ -14,6 +14,7 @@ makedepends_host="ncurses-dev pcre-dev utmps-dev"
install="zsh.post-install zsh.post-upgrade zsh.pre-deinstall"
# Note the custom fetch() function
source="https://www.zsh.org/pub/$pkgname-$pkgver.tar.xz
+ skel
zprofile
zshrc
"
@@ -118,6 +119,7 @@ package() {
make DESTDIR="$pkgdir" install
install -Dm644 "$srcdir"/zprofile "$pkgdir"/etc/zsh/zprofile
install -Dm644 "$srcdir"/zshrc "$pkgdir"/etc/zsh/zshrc
+ install -Dm755 "$srcdir"/skel "$pkgdir"/etc/skel/.zshrc
}
doc() {
@@ -176,5 +178,6 @@ _submv() {
}
sha512sums="a6aa88e1955a80229a4784a128866e325f79a8b5f73c922ab480048411036f1835cbb31daa30ab38bd16ab2a50040eda8f4f1f64704b21b6acc3051b1dbf18d0 zsh-5.7.1.tar.xz
+7d46b958a3402214a1982a4fbb71b9916b385e295593202e2cc4893f278b4faec6950c02b9924551687e3f6e53c727d5b6f2a8d39bc0e7abe33bedc0110f96ac skel
e90723eb790581419498f3ab86fb5d6cab4aaede8c87eb79ead7047d259b643cfb47f4d1beb06d03e038cfda3a20ef9dd4c1b417270ab55c688e166fe30ef4f6 zprofile
1675e016f97333cad89b587f4292d81b6bc10e27b75482e3e0c3808539c95bd49b907b6579fb98d817f77f2f2384c0df5afa3e2b6f43b6ae9b466925cd9ccffc zshrc"
diff --git a/system/zsh/skel b/system/zsh/skel
new file mode 100644
index 000000000..e3ddddf99
--- /dev/null
+++ b/system/zsh/skel
@@ -0,0 +1,4 @@
+# Lines configured by zsh-newuser-install
+HISTFILE=~/.histfile
+setopt appendhistory extendedglob
+# End of lines configured by zsh-newuser-install
diff --git a/user/eudev/APKBUILD b/user/eudev/APKBUILD
index f2ed0a333..9e28545fe 100644
--- a/user/eudev/APKBUILD
+++ b/user/eudev/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=eudev
pkgver=3.2.8
-pkgrel=0
+pkgrel=1
pkgdesc="OpenRC compatible fork of systemd-udev"
url="https://wiki.gentoo.org/wiki/Project:Eudev"
arch="all"
@@ -90,13 +90,13 @@ netifnames() {
openrc() {
replaces="udev-init-scripts-openrc"
default_openrc
- install -d "$subpkgdir"/usr/share/runlevels/openrc/sysinit
+ install -d "$subpkgdir"/usr/share/openrc/runlevels/sysinit
# https://bts.adelielinux.org/show_bug.cgi?id=51
# if eudev is installed, it should be running in the sysinit runlevel
ln -s /etc/init.d/udev \
- "$subpkgdir"/usr/share/runlevels/openrc/sysinit/udev
+ "$subpkgdir"/usr/share/openrc/runlevels/sysinit/udev
ln -s /etc/init.d/udev-trigger \
- "$subpkgdir"/usr/share/runlevels/openrc/sysinit/udev-trigger
+ "$subpkgdir"/usr/share/openrc/runlevels/sysinit/udev-trigger
}
sha512sums="13221e6f9696a8630d867eb7d73f3bf5dd1bc2dfd80d62af00342be4cbf39a862e644ea3776fa4d91463e594ca50c5deecbeb7e05d161097e889ea58a66ccc42 eudev-3.2.8.tar.gz
diff --git a/user/gamin/APKBUILD b/user/gamin/APKBUILD
index a53174220..b7d0461fc 100644
--- a/user/gamin/APKBUILD
+++ b/user/gamin/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer:
pkgname=gamin
pkgver=0.1.10
-pkgrel=12
+pkgrel=13
pkgdesc="Library for file and directory monitoring"
url="http://www.gnome.org/~veillard/gamin"
arch="all"
@@ -9,18 +9,18 @@ license="LGPL-2.0+"
subpackages="$pkgname-dev"
depends=""
makedepends="glib-dev"
-source="http://www.gnome.org/~veillard/$pkgname/sources/$pkgname-$pkgver.tar.gz
+source="https://www.gnome.org/~veillard/$pkgname/sources/$pkgname-$pkgver.tar.gz
fix-deprecated-const.patch
- fix-pthread-mutex.patch"
+ fix-pthread-mutex.patch
+ deadlock.patch
+ "
prepare() {
- cd "$builddir"
update_config_sub
default_prepare
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -35,16 +35,15 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
export MKDIRPROG="mkdir -p"
make DESTDIR="$pkgdir" install
}
sha512sums="21bfe6fcf8fb3117cd5a08c8ce3b8d0d1dd23e478e60a95b76c20d02cc29b050dde086578d81037990484ff891c3e104d2cbbf3d294b4a79346b14a0cae075bb gamin-0.1.10.tar.gz
c4c10bee70c7231db395cbfe5bdf513ade6be599a11a9d35888ddfaca42d619fe2b5e87c2b2bab469ea98ba718bc01711252313ba5f53c392379b669f5b2902b fix-deprecated-const.patch
-70628fc39521ea8bc4a40b009d0881f6ee540334a31b2f0cb67dde0f75808c69feb78088ad24c3c4a0dec9fa59e87960fd81d1a2e56963ce9268d0a5e14f88e8 fix-pthread-mutex.patch"
+70628fc39521ea8bc4a40b009d0881f6ee540334a31b2f0cb67dde0f75808c69feb78088ad24c3c4a0dec9fa59e87960fd81d1a2e56963ce9268d0a5e14f88e8 fix-pthread-mutex.patch
+183bb2188fadc32c47ceab8c7fe339e7485c9a57f892b011179ae2be64a16f92e031fcdf2a55959a08c482a82adbad0f3270d1df7441532d0bdffa786ba1de94 deadlock.patch"
diff --git a/user/gamin/deadlock.patch b/user/gamin/deadlock.patch
new file mode 100644
index 000000000..8bc6e40bf
--- /dev/null
+++ b/user/gamin/deadlock.patch
@@ -0,0 +1,65 @@
+From f9c67a13af33f389429e4e760f2023a23a9ac19f Mon Sep 17 00:00:00 2001
+From: Anssi Hannula <anssi@mageia.org>
+Date: Wed, 4 Jan 2012 00:23:55 +0200
+Subject: [PATCH 4/4] fix possible server deadlock in ih_sub_cancel
+
+ih_sub_foreach() calls ih_sub_cancel() while inotify_lock is locked.
+However, ih_sub_cancel() locks it again, and locking GMutex recursively
+causes undefined behaviour.
+
+Fix that by removing locking from ih_sub_cancel() as ih_sub_foreach()
+is its only user. Also make the function static so that it won't
+accidentally get used by other files without locking (inotify-helper.h
+is an internal server header).
+
+This should fix the intermittent deadlocks I've been experiencing
+causing KDE applications to no longer start, and probably also
+http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=542361
+---
+ server/inotify-helper.c | 7 ++-----
+ server/inotify-helper.h | 1 -
+ 2 files changed, 2 insertions(+), 6 deletions(-)
+
+diff --git a/server/inotify-helper.c b/server/inotify-helper.c
+index d77203e..0789fa4 100644
+--- a/server/inotify-helper.c
++++ b/server/inotify-helper.c
+@@ -123,13 +123,11 @@ ih_sub_add (ih_sub_t * sub)
+
+ /**
+ * Cancels a subscription which was being monitored.
++ * inotify_lock must be held when calling.
+ */
+-gboolean
++static gboolean
+ ih_sub_cancel (ih_sub_t * sub)
+ {
+- G_LOCK(inotify_lock);
+-
+-
+ if (!sub->cancelled)
+ {
+ IH_W("cancelling %s\n", sub->pathname);
+@@ -140,7 +138,6 @@ ih_sub_cancel (ih_sub_t * sub)
+ sub_list = g_list_remove (sub_list, sub);
+ }
+
+- G_UNLOCK(inotify_lock);
+ return TRUE;
+ }
+
+diff --git a/server/inotify-helper.h b/server/inotify-helper.h
+index 5d3b6d0..d36b5fd 100644
+--- a/server/inotify-helper.h
++++ b/server/inotify-helper.h
+@@ -34,7 +34,6 @@ gboolean ih_startup (event_callback_t ecb,
+ found_callback_t fcb);
+ gboolean ih_running (void);
+ gboolean ih_sub_add (ih_sub_t *sub);
+-gboolean ih_sub_cancel (ih_sub_t *sub);
+
+ /* Return FALSE from 'f' if the subscription should be cancelled */
+ void ih_sub_foreach (void *callerdata, gboolean (*f)(ih_sub_t *sub, void *callerdata));
+--
+2.5.0
+