summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/man-db/APKBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/user/man-db/APKBUILD b/user/man-db/APKBUILD
index 466e5be58..32e688455 100644
--- a/user/man-db/APKBUILD
+++ b/user/man-db/APKBUILD
@@ -10,6 +10,7 @@ license="GPL-2+"
depends="groff less"
makedepends="db-dev gettext-dev libpipeline-dev zlib-dev"
subpackages="$pkgname-lang $pkgname-doc"
+options="!check" # requires //IGNORE in iconv
source="http://download.savannah.nongnu.org/releases/man-db/man-db-$pkgver.tar.xz
man-db.trigger"
triggers="man-db.trigger=/usr/share/man"
@@ -30,6 +31,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install