summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/s6-linux-init/APKBUILD7
-rw-r--r--system/skalibs/APKBUILD4
-rw-r--r--user/btrfs-progs/APKBUILD4
-rw-r--r--user/horizon/APKBUILD11
-rw-r--r--user/horizon/bootloader.patch94
-rw-r--r--user/mbuffer/APKBUILD36
-rw-r--r--user/mbuffer/test-static-file-instead.patch11
7 files changed, 58 insertions, 109 deletions
diff --git a/system/s6-linux-init/APKBUILD b/system/s6-linux-init/APKBUILD
index 49a69ddad..742ed3ff6 100644
--- a/system/s6-linux-init/APKBUILD
+++ b/system/s6-linux-init/APKBUILD
@@ -1,14 +1,14 @@
# Contributor: Laurent Bercot <ska-adelie@skarnet.org>
# Maintainer: Laurent Bercot <ska-adelie@skarnet.org>
pkgname=s6-linux-init
-pkgver=1.0.4.2
+pkgver=1.0.5.1
pkgrel=0
pkgdesc="A s6-based init system"
url="https://skarnet.org/software/$pkgname/"
arch="all"
options="!check" # No test suite.
license="ISC"
-_skalibs_version=2.9.2.1
+_skalibs_version=2.9.3.0
_s6_version=2.9.2.0
depends="execline s6>=$_s6_version s6-linux-init-common"
makedepends="skalibs-dev>=$_skalibs_version execline-dev s6-dev utmps-dev"
@@ -119,8 +119,7 @@ doc() {
mkdir -p "$subpkgdir/usr/share/doc"
cp -a "$builddir/doc" "$subpkgdir/usr/share/doc/$pkgname"
}
-
-sha512sums="31dfe6911f6de527c43120097bd711cfb84cdec6f056ccaa03d48a1bcecb852caacdbaabddf0188ea30c4827abe3293acb8ebff8dfe80ea8665934802fac0e53 s6-linux-init-1.0.4.2.tar.gz
+sha512sums="c23fff1f5f2433119cbcfceb8e69c2f5542c8377079010891f4147a056d66c23fc08e08ca20ce0236d40386aac187cefd7b38bccb1bd5395d01ef4716c7a7432 s6-linux-init-1.0.5.1.tar.gz
756b0cbbe5dabb4631380c3c7ea199cc213224b2e36e50a2d012a61948170078b78bf49b85d886319fecf59843087f937d3d804723b2553ac9f94d088a2f0fd8 rc.init
e73c3c32b118831074288d23fadace2158a2b15d5a13ffa73290b92a9e39c2a21c73d3b0eabea29bcbaa5f6381611fd8d0aaa6aa691ec7de91b8ef6ae404b6da runlevel
7bb050248a5c2ab6a56c50c35f87cde724f97ff9882f5e60b0f0f2f14bd93c1df7d99fedc3d81c8519cf1a1ed90e03f1cbb9bf891c7b3618aa9a5f5738d262f4 rc.shutdown
diff --git a/system/skalibs/APKBUILD b/system/skalibs/APKBUILD
index 129fa7e79..ed0414589 100644
--- a/system/skalibs/APKBUILD
+++ b/system/skalibs/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Laurent Bercot <ska-adelie@skarnet.org>
# Maintainer: Laurent Bercot <ska-adelie@skarnet.org>
pkgname=skalibs
-pkgver=2.9.2.1
+pkgver=2.9.3.0
pkgrel=0
pkgdesc="A set of general-purpose C programming libraries for skarnet.org software"
url="https://skarnet.org/software/skalibs/"
@@ -57,4 +57,4 @@ doc() {
cp -a "$builddir/doc" "$subpkgdir/usr/share/doc/$pkgname"
}
-sha512sums="bd507faf30f0564fb8d3e5f86de04ab4b39961dab2497ba9f4a81980a57f7ff68cad366b9847b25d555b5b9263460d13f096e1774d080d1d286979f2e7324c54 skalibs-2.9.2.1.tar.gz"
+sha512sums="41e867fcaf16da437840b796a41b2d34ea53aafedde8b4fc86d712934ec533e9f7f2a8b7902542570ea6b5bcba772569fc4f47bccef770b5dee4f9d113b3df11 skalibs-2.9.3.0.tar.gz"
diff --git a/user/btrfs-progs/APKBUILD b/user/btrfs-progs/APKBUILD
index e8412ef96..c2c423ff8 100644
--- a/user/btrfs-progs/APKBUILD
+++ b/user/btrfs-progs/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=btrfs-progs
-pkgver=5.7
+pkgver=5.9
pkgrel=0
pkgdesc="File system utilities for Btrfs"
url="https://btrfs.wiki.kernel.org/index.php/Main_Page"
@@ -31,4 +31,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="72c3af13ca589f2e0b96cb7602319035ef8aab6ee224fff3544a5d0bfc013a66552dde4533ec5e64696d404b8905431cd0f25367c40fd34ea39be7c0ed8c2d16 btrfs-progs-v5.7.tar.xz"
+sha512sums="38db047198ab0467d3fe235f7e8e1fd14ade00dd0b182588220c5f5e4b598efbdcd30a3d5d56cf0a0ed8a902d2374af0927eb7f3720cd761172c7291a2a65c94 btrfs-progs-v5.9.tar.xz"
diff --git a/user/horizon/APKBUILD b/user/horizon/APKBUILD
index b49640561..8d2e480c2 100644
--- a/user/horizon/APKBUILD
+++ b/user/horizon/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=horizon
-pkgver=0.9.5
-pkgrel=1
+pkgver=0.9.6
+pkgrel=0
pkgdesc="Installation tools for Adélie Linux"
url="https://horizon.adelielinux.org/"
arch="all"
@@ -17,9 +17,7 @@ makedepends="bcnm-dev boost-dev cmake curl-dev eudev-dev libarchive-dev
libcap-dev libx11-dev libxkbfile-dev qt5-qtbase-dev"
subpackages="$pkgname-image $pkgname-dbg $pkgname-dev $pkgname-doc $pkgname-qt5
$pkgname-tools $pkgname-wizard $pkgname-boot"
-source="https://distfiles.adelielinux.org/source/horizon-$pkgver.tar.xz
- bootloader.patch
- "
+source="https://distfiles.adelielinux.org/source/horizon-$pkgver.tar.xz"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -158,5 +156,4 @@ GLOBALS
"$subpkgdir"/usr/share/xsessions/horizon.desktop
}
-sha512sums="373cbf87aa468d0ea41abad07f61cdaa6088cfdcba13c0beff245dbd8e270aa42c3e301a22913299d148e829114bd0b5aa746541c4b4b0c7286da35015c54d88 horizon-0.9.5.tar.xz
-88e7c6df4dc2c8c7f6befd5f96f82267fefccb98d0c5e6c26c611323e505f7ee964dcfd2128dbe165c064d953e7afef2787ab49a6c4a834ffe8fd50c00eb26ae bootloader.patch"
+sha512sums="d5ffe9bd423e98272ca780c59e6e32c42b284c68f3a0bace07bd693d457e2edcd68d7fc03f638b545960154ea26b7c09feee083dbffa986da2a7cd418be9500f horizon-0.9.6.tar.xz"
diff --git a/user/horizon/bootloader.patch b/user/horizon/bootloader.patch
deleted file mode 100644
index a09b4a603..000000000
--- a/user/horizon/bootloader.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-From 3658104dcc622e69a64cf97fbc9ed477f3faed6c Mon Sep 17 00:00:00 2001
-From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
-Date: Wed, 30 Sep 2020 19:19:59 -0500
-Subject: [PATCH] meta: Run update-boot when bootloader requested
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-If the user chooses no-boot or isn't installing Adélie, this will fail
-quietly. But if the user is installing Adélie, this is necessary to
-generate bootloader configuration.
----
- hscript/meta.cc | 26 ++++++++++++++++++++------
- 1 file changed, 20 insertions(+), 6 deletions(-)
-
-diff --git a/hscript/meta.cc b/hscript/meta.cc
-index 4efdc80..84e851a 100644
---- a/hscript/meta.cc
-+++ b/hscript/meta.cc
-@@ -823,7 +823,7 @@ bool Bootloader::execute() const {
- << std::endl
- << "chroot " << script->targetDirectory()
- << " grub-install " << _device << std::endl;
-- return true;
-+ goto updateboot;
- }
- #ifdef HAS_INSTALL_ENV
- if(run_command("/sbin/apk",
-@@ -851,8 +851,8 @@ bool Bootloader::execute() const {
- mount(nullptr, efipath.c_str(), nullptr,
- MS_REMOUNT | MS_BIND | MS_RDONLY | MS_NOEXEC | MS_NODEV |
- MS_NOSUID | MS_RELATIME, nullptr);
-+ goto updateboot;
- #endif /* HAS_INSTALL_ENV */
-- return true; /* LCOV_EXCL_LINE */
- }
- else if(method == "grub-bios") {
- if(script->options().test(Simulate)) {
-@@ -861,7 +861,7 @@ bool Bootloader::execute() const {
- << std::endl
- << "chroot " << script->targetDirectory()
- << " grub-install " << _device << std::endl;
-- return true;
-+ goto updateboot;
- }
- #ifdef HAS_INSTALL_ENV
- if(run_command("/sbin/apk",
-@@ -876,8 +876,8 @@ bool Bootloader::execute() const {
- output_error(pos, "bootloader: failed to install GRUB");
- return false;
- }
-+ goto updateboot;
- #endif /* HAS_INSTALL_ENV */
-- return true; /* LCOV_EXCL_LINE */
- }
- else if(method == "iquik") {
- output_error(pos, "bootloader: iQUIK is not yet supported");
-@@ -891,7 +891,7 @@ bool Bootloader::execute() const {
- << "chroot " << script->targetDirectory()
- << " grub-install --macppc-directory=/boot/grub "
- << _device << std::endl;
-- return true;
-+ goto updateboot;
- }
- #ifdef HAS_INSTALL_ENV
- if(run_command("/sbin/apk",
-@@ -907,9 +907,23 @@ bool Bootloader::execute() const {
- output_error(pos, "bootloader: failed to install GRUB");
- return false;
- }
-+ goto updateboot;
- #endif /* HAS_INSTALL_ENV */
-- return true; /* LCOV_EXCL_LINE */
- }
-
- return false; /* LCOV_EXCL_LINE */
-+
-+updateboot:
-+ /* We ignore if update-boot fails, in case the user has chosen no-boot. */
-+ if(script->options().test(Simulate)) {
-+ std::cout << "chroot " << script->targetDirectory()
-+ << " /usr/sbin/update-boot || true" << std::endl;
-+ }
-+#ifdef HAS_INSTALL_ENV
-+ else {
-+ run_command("chroot",
-+ {script->targetDirectory(), "/usr/sbin/update-boot"});
-+ }
-+#endif /* HAS_INSTALL_ENV */
-+ return true;
- }
---
-2.25.4
-
diff --git a/user/mbuffer/APKBUILD b/user/mbuffer/APKBUILD
new file mode 100644
index 000000000..fbcaeaeb9
--- /dev/null
+++ b/user/mbuffer/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: CyberLeo <cyberleo@cyberleo.net>
+# Maintainer: CyberLeo <cyberleo@cyberleo.net>
+pkgname=mbuffer
+pkgver=20200929
+pkgrel=0
+pkgdesc="mbuffer is a tool for buffering data streams."
+url="http://www.maier-komor.de/mbuffer.html"
+arch="all"
+license="GPL-3.0-only"
+depends=""
+makedepends=""
+subpackages="$pkgname-doc"
+source="http://www.maier-komor.de/software/mbuffer/mbuffer-$pkgver.tgz
+ test-static-file-instead.patch"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="332106205ea8743c9cf47529106c04ac15801a02b116d8e0c0fd3baadad51331c9f4ba1c8fa125edb42940cf401048a45ba23e2dac0e5189671bcf0ecee36996 mbuffer-20200929.tgz
+28b7c7c7ee2b2130315cd6c4765d492e9d29376670a03ab0a1ab862a1ec5dea93e91e9de5e08604db69fe4139370eedb2a0754f16e5ebec3de9b48dc2a1dbea7 test-static-file-instead.patch"
diff --git a/user/mbuffer/test-static-file-instead.patch b/user/mbuffer/test-static-file-instead.patch
new file mode 100644
index 000000000..9c549bfaa
--- /dev/null
+++ b/user/mbuffer/test-static-file-instead.patch
@@ -0,0 +1,11 @@
+--- mbuffer-20200929/Makefile.in.orig 2020-11-08 07:47:44.512670020 +0000
++++ mbuffer-20200929/Makefile.in 2020-11-08 07:48:33.032115323 +0000
+@@ -101,7 +101,7 @@
+ test.tar test.md5 mbuffer.md5 idev.so tapetest.so have-af
+
+ test.tar:
+- $(TAR) cf test.tar --ignore-failed-read $(TESTTREE)
++ truncate -s 10M test.tar
+
+ test.md5: test.tar
+ openssl md5 < test.tar > test.md5