summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README.rst7
-rw-r--r--legacy/java-gcj-compat/APKBUILD (renamed from user/java-gcj-compat/APKBUILD)0
-rw-r--r--system/curl/APKBUILD17
-rw-r--r--user/chrony/APKBUILD6
-rw-r--r--user/distcc/APKBUILD3
-rw-r--r--user/fts/APKBUILD2
-rw-r--r--user/gtkspell/APKBUILD15
-rw-r--r--user/gtkspell/enchant-2.patch89
-rw-r--r--user/konsole/APKBUILD7
-rw-r--r--user/konsole/cursor.patch87
-rw-r--r--user/libbsd/APKBUILD2
-rw-r--r--user/libcanberra/APKBUILD2
-rw-r--r--user/libical/APKBUILD5
-rw-r--r--user/libidl/APKBUILD5
-rw-r--r--user/libnih/APKBUILD2
-rw-r--r--user/libqrencode/APKBUILD2
-rw-r--r--user/makedepend/APKBUILD8
-rw-r--r--user/opencv/APKBUILD1
-rw-r--r--user/py3-six/APKBUILD2
-rw-r--r--user/sane/APKBUILD7
20 files changed, 226 insertions, 43 deletions
diff --git a/README.rst b/README.rst
index ee78b6bb1..f5677945c 100644
--- a/README.rst
+++ b/README.rst
@@ -5,12 +5,12 @@
* **A. Wilcox**, Distro Lead
* **Elizabeth Myers**, Platform Group
* **Horst Burkhardt**, Platform Group
- * **William Pitcock**, Platform Group
+ * **Kiyoshi Aman**, Platform Group
* **Adélie Linux Developers and Users**, contributions
:Status:
Production
:Copyright:
- © 2017-2018 Adélie Linux Team. NCSA open source licence.
+ © 2017-2019 Adélie Linux Team. NCSA open source licence.
@@ -53,7 +53,8 @@ find what you need.
``system``: System-level packages
`````````````````````````````````
The ``system`` directory contains packages used by Adélie for core system
-functionality. Special care should be taken before bumping these packages.
+functionality, or for building of the system itself. Special care should be
+taken before bumping these packages.
``user``: User packages
diff --git a/user/java-gcj-compat/APKBUILD b/legacy/java-gcj-compat/APKBUILD
index a75f1e6b1..a75f1e6b1 100644
--- a/user/java-gcj-compat/APKBUILD
+++ b/legacy/java-gcj-compat/APKBUILD
diff --git a/system/curl/APKBUILD b/system/curl/APKBUILD
index 7ed8be239..229275904 100644
--- a/system/curl/APKBUILD
+++ b/system/curl/APKBUILD
@@ -3,7 +3,7 @@
# Contributor: Łukasz Jendrysik <scadu@yandex.com>
# Maintainer:
pkgname=curl
-pkgver=7.61.1
+pkgver=7.64.0
pkgrel=0
pkgdesc="An URL retrival utility and library"
url="https://curl.haxx.se"
@@ -13,11 +13,17 @@ depends="ca-certificates"
makedepends_build="groff perl"
makedepends_host="zlib-dev openssl-dev libssh2-dev"
makedepends="$makedepends_build $makedepends_host"
-source="https://curl.haxx.se/download/$pkgname-$pkgver.tar.bz2
- "
+source="https://curl.haxx.se/download/$pkgname-$pkgver.tar.xz"
subpackages="$pkgname-dbg $pkgname-doc $pkgname-dev libcurl"
# secfixes:
+# 7.64.0-r0:
+# - CVE-2019-3823
+# - CVE-2019-3822
+# - CVE-2018-16890
+# - CVE-2018-16842
+# - CVE-2018-16840
+# - CVE-2018-16839
# 7.60.0-r0:
# - CVE-2017-8816
# - CVE-2017-8817
@@ -68,7 +74,6 @@ subpackages="$pkgname-dbg $pkgname-doc $pkgname-dev libcurl"
# - CVE-2014-0139
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -83,12 +88,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
@@ -98,4 +101,4 @@ libcurl() {
mv "$pkgdir"/usr/lib "$subpkgdir"/usr
}
-sha512sums="484d33c0d32109539a95309cdb4404c03c0e7164fdbf7a4724a5b01aa20e2d48fbe6363c7cc53060d4d28050cfa6b43f9ed220ab65d4d389eb00efff5db1bfb5 curl-7.61.1.tar.bz2"
+sha512sums="953f1f5336ce5dfd1b9f933624432d401552d91ee02d39ecde6f023c956f99ec6aae8d7746d7c34b6eb2d6452f114e67da4e64d9c8dd90b7644b7844e7b9b423 curl-7.64.0.tar.xz"
diff --git a/user/chrony/APKBUILD b/user/chrony/APKBUILD
index 54cf3023f..dc2fe5d4f 100644
--- a/user/chrony/APKBUILD
+++ b/user/chrony/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=chrony
pkgver=3.4
-pkgrel=0
+pkgrel=1
_ver=${pkgver/_/-}
pkgdesc="NTP client and server programs"
url="https://chrony.tuxfamily.org"
@@ -14,7 +14,7 @@ arch="all"
license="GPL-2.0-only"
install="$pkgname.pre-install $pkgname.pre-upgrade"
depends=""
-makedepends="asciidoctor libcap-dev texinfo"
+makedepends="asciidoctor libcap-dev libedit-dev texinfo"
checkdepends="bash"
subpackages="$pkgname-doc $pkgname-openrc"
source="https://download.tuxfamily.org/$pkgname/$pkgname-$_ver.tar.gz
@@ -50,7 +50,7 @@ build() {
--infodir=/usr/share/info \
--mandir=/usr/share/man \
--sysconfdir=/etc/$pkgname \
- --disable-readline \
+ --without-readline \
--with-user=$pkgname \
--with-sendmail=/usr/sbin/sendmail \
--enable-ntp-signd
diff --git a/user/distcc/APKBUILD b/user/distcc/APKBUILD
index c81035ef7..9584cab67 100644
--- a/user/distcc/APKBUILD
+++ b/user/distcc/APKBUILD
@@ -34,7 +34,8 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --without-avahi
+ --without-avahi \
+ --disable-Werror
make
}
diff --git a/user/fts/APKBUILD b/user/fts/APKBUILD
index 0e7d81cf1..2864ee250 100644
--- a/user/fts/APKBUILD
+++ b/user/fts/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=fts
pkgver=1.2.7
pkgrel=1
diff --git a/user/gtkspell/APKBUILD b/user/gtkspell/APKBUILD
index 6ed3ffdcc..cd7b8f100 100644
--- a/user/gtkspell/APKBUILD
+++ b/user/gtkspell/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer:
pkgname=gtkspell
pkgver=2.0.16
-pkgrel=9
+pkgrel=10
pkgdesc="Highlighting and replacement of misspelled words in Gtk software"
url="http://gtkspell.sourceforge.net/"
arch="all"
@@ -9,16 +9,16 @@ license="GPL-2.0-only"
makedepends="gtk+2.0-dev enchant-dev intltool"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
langdir="/usr/lib/locale"
-source="http://$pkgname.sourceforge.net/download/$pkgname-$pkgver.tar.gz"
+source="http://$pkgname.sourceforge.net/download/$pkgname-$pkgver.tar.gz
+ enchant-2.patch
+ "
prepare() {
- cd "$builddir"
- update_config_sub
default_prepare
+ update_config_sub
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,13 +27,12 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="7d3afb327c2e15608194e6ee6110107a0ce082e483788d831d636b2e579472304137373c09a966d8e5c0cd2f830bf2e0ee477c9b5fca7da6ee27fd1498915b9d gtkspell-2.0.16.tar.gz"
+sha512sums="7d3afb327c2e15608194e6ee6110107a0ce082e483788d831d636b2e579472304137373c09a966d8e5c0cd2f830bf2e0ee477c9b5fca7da6ee27fd1498915b9d gtkspell-2.0.16.tar.gz
+0071d81b7dabcf1bb4be76c13c453724606a3d030ea13a7bb87fe4e96b1dc40118110e470f5f4044c55e49c49ff0d6761ef3db7091228ef52225ac35fba42f6d enchant-2.patch"
diff --git a/user/gtkspell/enchant-2.patch b/user/gtkspell/enchant-2.patch
new file mode 100644
index 000000000..e6dd3298b
--- /dev/null
+++ b/user/gtkspell/enchant-2.patch
@@ -0,0 +1,89 @@
+--- gtkspell-2.0.16/configure.ac.old 2009-10-23 02:52:31.000000000 +0000
++++ gtkspell-2.0.16/configure.ac 2019-03-18 16:16:30.890000000 +0000
+@@ -12,12 +12,12 @@
+ AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
+ AC_CONFIG_HEADERS([config.h])
+
+-SPELLER_LIB=-lenchant
++SPELLER_LIB=
+
+ AC_SUBST(SPELLER_LIB)
+ GTKSPELL_PACKAGES=gtk+-2.0
+ AC_SUBST(GTKSPELL_PACKAGES)
+-PKG_CHECK_MODULES(GTKSPELL, $GTKSPELL_PACKAGES enchant >= 0.4.0 )
++PKG_CHECK_MODULES(GTKSPELL, $GTKSPELL_PACKAGES enchant-2 )
+ AC_SUBST(GTKSPELL_CFLAGS)
+ AC_SUBST(GTKSPELL_LIBS)
+
+--- gtkspell-2.0.16/gtkspell/gtkspell.c.old 2009-10-09 19:01:47.000000000 +0000
++++ gtkspell-2.0.16/gtkspell/gtkspell.c 2019-03-18 16:17:15.140000000 +0000
+@@ -277,7 +277,7 @@
+ get_word_extents_from_mark(spell->buffer, &start, &end, spell->mark_click);
+ word = gtk_text_buffer_get_text(spell->buffer, &start, &end, FALSE);
+
+- enchant_dict_add_to_pwl( spell->speller, word, strlen(word));
++ enchant_dict_add( spell->speller, word, strlen(word));
+
+ gtkspell_recheck_all(spell);
+
+--- gtkspell-2.0.16/configure.old 2009-10-23 02:57:15.000000000 +0000
++++ gtkspell-2.0.16/configure 2019-03-18 16:20:29.900000000 +0000
+@@ -2715,12 +2715,12 @@
+ pkg_cv_GTKSPELL_CFLAGS="$GTKSPELL_CFLAGS"
+ else
+ if test -n "$PKG_CONFIG" && \
+- { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"\$GTKSPELL_PACKAGES enchant >= 0.4.0 \"") >&5
+- ($PKG_CONFIG --exists --print-errors "$GTKSPELL_PACKAGES enchant >= 0.4.0 ") 2>&5
++ { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"\$GTKSPELL_PACKAGES enchant-2 \"") >&5
++ ($PKG_CONFIG --exists --print-errors "$GTKSPELL_PACKAGES enchant-2 ") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_GTKSPELL_CFLAGS=`$PKG_CONFIG --cflags "$GTKSPELL_PACKAGES enchant >= 0.4.0 " 2>/dev/null`
++ pkg_cv_GTKSPELL_CFLAGS=`$PKG_CONFIG --cflags "$GTKSPELL_PACKAGES enchant-2 " 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -2733,12 +2733,12 @@
+ pkg_cv_GTKSPELL_LIBS="$GTKSPELL_LIBS"
+ else
+ if test -n "$PKG_CONFIG" && \
+- { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"\$GTKSPELL_PACKAGES enchant >= 0.4.0 \"") >&5
+- ($PKG_CONFIG --exists --print-errors "$GTKSPELL_PACKAGES enchant >= 0.4.0 ") 2>&5
++ { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"\$GTKSPELL_PACKAGES enchant-2 \"") >&5
++ ($PKG_CONFIG --exists --print-errors "$GTKSPELL_PACKAGES enchant-2 ") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_GTKSPELL_LIBS=`$PKG_CONFIG --libs "$GTKSPELL_PACKAGES enchant >= 0.4.0 " 2>/dev/null`
++ pkg_cv_GTKSPELL_LIBS=`$PKG_CONFIG --libs "$GTKSPELL_PACKAGES enchant-2 " 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -2757,14 +2757,14 @@
+ _pkg_short_errors_supported=no
+ fi
+ if test $_pkg_short_errors_supported = yes; then
+- GTKSPELL_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "$GTKSPELL_PACKAGES enchant >= 0.4.0 "`
++ GTKSPELL_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "$GTKSPELL_PACKAGES enchant-2 "`
+ else
+- GTKSPELL_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "$GTKSPELL_PACKAGES enchant >= 0.4.0 "`
++ GTKSPELL_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "$GTKSPELL_PACKAGES enchant-2 "`
+ fi
+ # Put the nasty error message in config.log where it belongs
+ echo "$GTKSPELL_PKG_ERRORS" >&5
+
+- { { $as_echo "$as_me:$LINENO: error: Package requirements ($GTKSPELL_PACKAGES enchant >= 0.4.0 ) were not met:
++ { { $as_echo "$as_me:$LINENO: error: Package requirements ($GTKSPELL_PACKAGES enchant-2 ) were not met:
+
+ $GTKSPELL_PKG_ERRORS
+
+@@ -2775,7 +2775,7 @@
+ and GTKSPELL_LIBS to avoid the need to call pkg-config.
+ See the pkg-config man page for more details.
+ " >&5
+-$as_echo "$as_me: error: Package requirements ($GTKSPELL_PACKAGES enchant >= 0.4.0 ) were not met:
++$as_echo "$as_me: error: Package requirements ($GTKSPELL_PACKAGES enchant-2 ) were not met:
+
+ $GTKSPELL_PKG_ERRORS
+
diff --git a/user/konsole/APKBUILD b/user/konsole/APKBUILD
index 827af3d24..551c18148 100644
--- a/user/konsole/APKBUILD
+++ b/user/konsole/APKBUILD
@@ -16,7 +16,9 @@ makedepends="cmake extra-cmake-modules qt5-qtbase-dev kbookmarks-dev
kpty-dev kservice-dev ktextwidgets-dev kwidgetsaddons-dev python3
kwindowsystem-dev kxmlgui-dev kdbusaddons-dev knewstuff-dev"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://download.kde.org/stable/applications/$pkgver/src/konsole-$pkgver.tar.xz"
+source="https://download.kde.org/stable/applications/$pkgver/src/konsole-$pkgver.tar.xz
+ cursor.patch
+ "
build() {
cd "$builddir"
@@ -44,4 +46,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="9fecd316a9bc7adaca9a3fac38a57d293286b6328e88d96ac1cf8967fcb67ef8e9a5b085e185c4373599eafd0eaa18f0d73df70df16b98a1badd9efb689e1f7c konsole-18.12.3.tar.xz"
+sha512sums="9fecd316a9bc7adaca9a3fac38a57d293286b6328e88d96ac1cf8967fcb67ef8e9a5b085e185c4373599eafd0eaa18f0d73df70df16b98a1badd9efb689e1f7c konsole-18.12.3.tar.xz
+66dcb31dd63f7a300b64058e8f9e56aa122c407d3a4a85c2323e7abf2e8eb4a3e1dd83de9445dac4938f9395b612eac5ceb9626bf895b532cfd19f63e0fbb2d7 cursor.patch"
diff --git a/user/konsole/cursor.patch b/user/konsole/cursor.patch
new file mode 100644
index 000000000..621a4f36b
--- /dev/null
+++ b/user/konsole/cursor.patch
@@ -0,0 +1,87 @@
+From 9af659c73e3203e1d5ef3873fa6c0144258b9673 Mon Sep 17 00:00:00 2001
+From: Wolfgang Bauer <wbauer@tmo.at>
+Date: Mon, 4 Mar 2019 09:59:45 -0500
+Subject: Fix ibeam and underline cursor rendering
+
+Summary:
+Since anti-aliasing was enabled in the painter, coordinates need to
+be shifted half a pixel so that they align with the pixel grid,
+otherwise the result gets "blurred" due to the anti-aliasing.
+And as parts of the blurred shape leak outside the cursor rectangle,
+this also leaves artifacts when the cursor moves or blinks as these
+parts are not cleared.
+
+This is basically the same as commit
+e7085310d6d594823d0ed491fa8bdbd99dec4932 for the
+standard block cursor.
+
+BUG: 402589
+
+Test Plan:
+- Switch cursor shape to "I-Beam" or "Underline" in the "Advanced"
+profile settings
+
+The cursors are a single line again now, before they were blurred by
+anti-aliasing.
+
+Screenshots:
+Before:
+{F6656366}
+{F6656370}
+
+After:
+{F6656371}
+{F6656373}
+
+Also, there are no more artifacts when the cursor is moved or
+cursor blinking is enabled.
+
+Reviewers: #konsole, hindenburg
+
+Reviewed By: #konsole, hindenburg
+
+Subscribers: hindenburg, konsole-devel
+
+Tags: #konsole
+
+Differential Revision: https://phabricator.kde.org/D19513
+
+(cherry picked from commit eccfb1f62bbf67ebffee11e241bd05757b826ff1)
+---
+ src/TerminalDisplay.cpp | 18 ++++++++++--------
+ 1 file changed, 10 insertions(+), 8 deletions(-)
+
+diff --git a/src/TerminalDisplay.cpp b/src/TerminalDisplay.cpp
+index 64c831c..7c8137d 100644
+--- a/src/TerminalDisplay.cpp
++++ b/src/TerminalDisplay.cpp
+@@ -958,16 +958,18 @@ void TerminalDisplay::drawCursor(QPainter& painter,
+ }
+ }
+ } else if (_cursorShape == Enum::UnderlineCursor) {
+- painter.drawLine(cursorRect.left(),
+- cursorRect.bottom(),
+- cursorRect.right(),
+- cursorRect.bottom());
++ QLineF line(cursorRect.left() + 0.5,
++ cursorRect.bottom() - 0.5,
++ cursorRect.right() - 0.5,
++ cursorRect.bottom() - 0.5);
++ painter.drawLine(line);
+
+ } else if (_cursorShape == Enum::IBeamCursor) {
+- painter.drawLine(cursorRect.left(),
+- cursorRect.top(),
+- cursorRect.left(),
+- cursorRect.bottom());
++ QLineF line(cursorRect.left() + 0.5,
++ cursorRect.top() + 0.5,
++ cursorRect.left() + 0.5,
++ cursorRect.bottom() - 0.5);
++ painter.drawLine(line);
+ }
+ }
+
+--
+cgit v1.1
+
diff --git a/user/libbsd/APKBUILD b/user/libbsd/APKBUILD
index 015d71295..3c5cb2cf1 100644
--- a/user/libbsd/APKBUILD
+++ b/user/libbsd/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libbsd
pkgver=0.9.1
pkgrel=0
diff --git a/user/libcanberra/APKBUILD b/user/libcanberra/APKBUILD
index bd41ad019..756f8e3f7 100644
--- a/user/libcanberra/APKBUILD
+++ b/user/libcanberra/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libcanberra
pkgver=0.30
pkgrel=4
diff --git a/user/libical/APKBUILD b/user/libical/APKBUILD
index 513674394..7a27c56d4 100644
--- a/user/libical/APKBUILD
+++ b/user/libical/APKBUILD
@@ -1,14 +1,15 @@
# Maintainer:
pkgname=libical
pkgver=3.0.4
-pkgrel=1
+pkgrel=2
pkgdesc="Reference implementation of the iCalendar format"
url="https://libical.github.io/libical/"
arch="all"
#options="!check" # Test suite is very broken.
license="MPL-2.0 OR LGPL-2.1-only"
depends=""
-makedepends="cmake glib-dev icu-dev libxml2-dev perl"
+depends_dev="db-dev"
+makedepends="$depends_dev cmake glib-dev icu-dev libxml2-dev perl"
subpackages="$pkgname-dev"
source="https://github.com/libical/libical/releases/download/v$pkgver/libical-$pkgver.tar.gz"
diff --git a/user/libidl/APKBUILD b/user/libidl/APKBUILD
index e3a95ff98..b3143333c 100644
--- a/user/libidl/APKBUILD
+++ b/user/libidl/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
pkgname=libidl
pkgver=0.8.14
pkgrel=3
@@ -8,9 +8,8 @@ url="https://www.gnome.org/"
arch="all"
options="!check" # No test suite.
license="LGPL-2.0-only"
-depends=
+depends=""
makedepends="bison flex glib-dev"
-install=
subpackages="$pkgname-dev $pkgname-doc"
source="https://download.gnome.org/sources/libIDL/${pkgver%.*}/libIDL-$pkgver.tar.bz2"
builddir="$srcdir"/libIDL-$pkgver
diff --git a/user/libnih/APKBUILD b/user/libnih/APKBUILD
index 5a1e91495..9636f2a1a 100644
--- a/user/libnih/APKBUILD
+++ b/user/libnih/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libnih
pkgver=1.0.3
pkgrel=6
diff --git a/user/libqrencode/APKBUILD b/user/libqrencode/APKBUILD
index dc3f6eee7..12690b8d7 100644
--- a/user/libqrencode/APKBUILD
+++ b/user/libqrencode/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libqrencode
pkgver=4.0.2
pkgrel=0
diff --git a/user/makedepend/APKBUILD b/user/makedepend/APKBUILD
index 280e7b41b..da9da0ee9 100644
--- a/user/makedepend/APKBUILD
+++ b/user/makedepend/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=makedepend
pkgver=1.0.5
pkgrel=1
@@ -7,10 +7,8 @@ pkgdesc="Utility for making makefile dependencies"
url="https://www.freedesktop.org/"
arch="all"
license="MIT"
-depends=
-depends_dev=
-makedepends="$depends_dev util-macros xorgproto-dev"
-install=""
+depends=""
+makedepends="util-macros xorgproto-dev"
subpackages="$pkgname-doc"
source="https://www.X.Org/releases/individual/util/${pkgname}-${pkgver}.tar.bz2"
diff --git a/user/opencv/APKBUILD b/user/opencv/APKBUILD
index d899f30f1..0745f8a6a 100644
--- a/user/opencv/APKBUILD
+++ b/user/opencv/APKBUILD
@@ -23,6 +23,7 @@ prepare() {
*/carotene*) continue;;
*/protobuf*) continue;;
*/ittnotify) continue;; # Else FTBFS on x86_64
+ */quirc) continue;;
esac
rm -rf "$i"
done
diff --git a/user/py3-six/APKBUILD b/user/py3-six/APKBUILD
index 3b5c00d34..b1c4ffadd 100644
--- a/user/py3-six/APKBUILD
+++ b/user/py3-six/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
pkgname=py3-six
_pkgname=six
pkgver=1.11.0
diff --git a/user/sane/APKBUILD b/user/sane/APKBUILD
index 87ad4deb5..1d7322866 100644
--- a/user/sane/APKBUILD
+++ b/user/sane/APKBUILD
@@ -4,14 +4,15 @@
pkgname=sane
_pkgname=sane-backends
pkgver=1.0.27
-pkgrel=3
+pkgrel=4
pkgdesc="Scanner access library"
url="http://www.sane-project.org/"
arch="all"
license="GPL-2.0+ AND GPL-2.0+-with-sane-exception AND Public-Domain"
depends=""
-makedepends="diffutils file libtool libusb-dev v4l-utils-dev net-snmp-dev libpng-dev
- libjpeg-turbo-dev tiff-dev libgphoto2-dev libieee1284-dev linux-headers"
+makedepends="diffutils file libtool libusb-dev v4l-utils-dev net-snmp-dev
+ libpng-dev libjpeg-turbo-dev tiff-dev libgphoto2-dev libieee1284-dev
+ linux-headers ncurses-dev"
install="saned.pre-install $pkgname.pre-install"
pkgusers="saned"
pkggroups="scanner"