summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/firefox-esr/APKBUILD7
-rw-r--r--user/thunderbird/APKBUILD7
2 files changed, 14 insertions, 0 deletions
diff --git a/user/firefox-esr/APKBUILD b/user/firefox-esr/APKBUILD
index b4e4f2303..fa19cb879 100644
--- a/user/firefox-esr/APKBUILD
+++ b/user/firefox-esr/APKBUILD
@@ -90,6 +90,13 @@ build() {
# gcc 6
export CXXFLAGS="-fno-delete-null-pointer-checks -fno-schedule-insns2"
+ case "${CARCH}" in
+ armv7)
+ # 32-bit memory ceiling, #1012
+ LDFLAGS="${LDFLAGS} -Wl,--strip-debug";
+ ;;
+ esac
+
# set rpath so linker finds the libs
export LDFLAGS="$LDFLAGS -Wl,-rpath,${_mozappdir}"
diff --git a/user/thunderbird/APKBUILD b/user/thunderbird/APKBUILD
index 02693efca..b115202f3 100644
--- a/user/thunderbird/APKBUILD
+++ b/user/thunderbird/APKBUILD
@@ -104,6 +104,13 @@ build() {
# gcc 6
export CXXFLAGS="-fno-delete-null-pointer-checks -fno-schedule-insns2"
+ case "${CARCH}" in
+ armv7)
+ # 32-bit memory ceiling, #1012
+ LDFLAGS="${LDFLAGS} -Wl,--strip-debug";
+ ;;
+ esac
+
# set rpath so linker finds the libs
export LDFLAGS="$LDFLAGS -Wl,-rpath,${_mozappdir}"