summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/ed/APKBUILD4
-rw-r--r--system/kbd/APKBUILD18
-rw-r--r--system/kbd/consolefont.confd4
-rw-r--r--system/kbd/keymaps.confd3
-rw-r--r--user/checkbashisms/APKBUILD4
-rw-r--r--user/feh/APKBUILD14
-rw-r--r--user/feh/getopt.patch100
-rw-r--r--user/fuse3/APKBUILD4
-rw-r--r--user/jansson/APKBUILD4
-rw-r--r--user/keepassxc/APKBUILD4
-rw-r--r--user/llvm8/APKBUILD6
-rw-r--r--user/llvm8/scc-insertion.patch33
-rw-r--r--user/mosquitto/APKBUILD7
-rw-r--r--user/mosquitto/disable-flaky-test.patch14
-rw-r--r--user/mutt/APKBUILD9
-rw-r--r--user/netqmail/APKBUILD2
-rw-r--r--user/nextcloud-client/APKBUILD4
-rw-r--r--user/twm/APKBUILD8
-rw-r--r--user/xmlsec/APKBUILD4
-rw-r--r--user/youtube-dl/APKBUILD4
20 files changed, 201 insertions, 49 deletions
diff --git a/system/ed/APKBUILD b/system/ed/APKBUILD
index d13ab5a2b..f57513f33 100644
--- a/system/ed/APKBUILD
+++ b/system/ed/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer:
pkgname=ed
-pkgver=1.15
+pkgver=1.16
pkgrel=0
pkgdesc="GNU version of standard text editor"
url="https://www.gnu.org/software/ed/"
@@ -30,4 +30,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="27a16db41e88626b9718b1868f2fc629b609e436aca2450846f87492c61bf60cec3db0c54ff9a421d9bcbf59fe91a8c672aee5772e1b1eec8a365f227c30ecba ed-1.15.tar.lz"
+sha512sums="1ca999edd7007c56bf9aa91436997a813e665910dda19a3307fa5b85adc05667eb120cb54cb6544b919f1c7f631baf3ee03079abe1171b875fb9653f535fa7bd ed-1.16.tar.lz"
diff --git a/system/kbd/APKBUILD b/system/kbd/APKBUILD
index deb7fb205..144ddcefc 100644
--- a/system/kbd/APKBUILD
+++ b/system/kbd/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kbd
pkgver=2.2.0_git20190823
-pkgrel=1
+pkgrel=2
pkgdesc="Console keyboard and font management utilities"
url="https://kbd-project.org/"
arch="all"
@@ -11,7 +11,9 @@ license="GPL-2.0+"
depends=""
checkdepends="check-dev"
makedepends="linux-headers linux-pam-dev autoconf automake libtool"
-subpackages="$pkgname-doc $pkgname-fonts::noarch $pkgname-keymaps::noarch
+provides="$pkgname-keymaps"
+replaces="$pkgname-keymaps"
+subpackages="$pkgname-doc $pkgname-fonts::noarch
$pkgname-lang $pkgname-openrc"
source="https://dev.sick.bike/dist/$pkgname-$pkgver.tar.xz
consolefont.confd
@@ -62,16 +64,8 @@ fonts() {
mkdir -p "$subpkgdir"/usr/share
mv "$pkgdir"/usr/share/consolefonts "$subpkgdir"/usr/share/
}
-
-keymaps() {
- pkgdesc="Legacy keymaps shipped with Linux kbd tools"
- mkdir -p "$subpkgdir"/usr/share
- mv "$pkgdir"/usr/share/keymaps "$subpkgdir"/usr/share/
- mv "$pkgdir"/usr/share/unimaps "$subpkgdir"/usr/share/
-}
-
sha512sums="7f6202aeb17d6224095447a92d999478220457e1e7cadb90a7c40ca7f3b0c5b1f672db1995fb69652ca37558a75df582bfb5fea5772f3b1e040fe39f8f54504e kbd-2.2.0_git20190823.tar.xz
-19761fdd2b32c1bbcc9254b89b7893741e144b917a75410af3f274553fe61e2f56cbbd17ff77ac929e9377604663cbbfd9e53c73e7d41e71de6de573730950c7 consolefont.confd
+837054b29050b955b4c3f1ddd6481c79792a66e2415bafbcfbf3e12a27066ddd3ce35e069448dfb1b2a00e843cec180dd6940edbd9014cd2a0c2aaa1b76c9fb0 consolefont.confd
1e67f75f27ec5de8f71489c83f78e53e8fd0925ae2d82dabf516f98905c5aff206a8e943e92b6af413eae5f0ecb9c2240526dfc3c56811a8dc1d19ced561bba3 consolefont.initd
-af7d37fc6be1382414ca8245ca6f8d2ee8b82650b8a08eebbd980cf6dd2b92524fce2851ce0b2cd67e915488c12044ab50c5ab1f01c3072af87eed3e058ac268 keymaps.confd
+9391671bbe8b3b7b4eba63ff4e4b7f17297712393abca69f0e24e3a5304a545faa213de8bc799de922b69ee52048d6e6cf352d7213b459991286ef6dea77e8c3 keymaps.confd
510d7eb582a914fa7cfb868d0c3d55a21ee1519033117d0943a153528b5810d09f6421ddc02d93906c1a66fb7e07e86240f38dad0d38cfb5a8c7e9a6335a937f keymaps.initd"
diff --git a/system/kbd/consolefont.confd b/system/kbd/consolefont.confd
index 4c41d0633..9e8a30505 100644
--- a/system/kbd/consolefont.confd
+++ b/system/kbd/consolefont.confd
@@ -15,6 +15,6 @@
#consoletranslation="8859-1_to_uni"
# unicodemap is the unicode map file to use. Leave commented to use the
-# default one. Have a look in /usr/share/unimaps (from the kbd-keymaps
-# package) for a selection of map files you can use.
+# default one. Have a look in /usr/share/unimaps for a selection of map
+# files you can use.
#unicodemap="iso01"
diff --git a/system/kbd/keymaps.confd b/system/kbd/keymaps.confd
index 9a2863413..30e65188a 100644
--- a/system/kbd/keymaps.confd
+++ b/system/kbd/keymaps.confd
@@ -1,6 +1,5 @@
# Use keymap to specify the default console keymap. There is a complete tree
-# of keymaps in /usr/share/keymaps to choose from (from the kbd-keymaps
-# package).
+# of keymaps in /usr/share/keymaps to choose from.
keymap="us"
# Should we first load the 'windowkeys' console keymap? Most x86 users will
diff --git a/user/checkbashisms/APKBUILD b/user/checkbashisms/APKBUILD
index b616e4fab..96961ecb3 100644
--- a/user/checkbashisms/APKBUILD
+++ b/user/checkbashisms/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=checkbashisms
-pkgver=2.20.2
+pkgver=2.20.3
pkgrel=0
pkgdesc="Check shell scripts for POSIX compliance"
url="https://salsa.debian.org/debian/devscripts"
@@ -37,4 +37,4 @@ bashcomp() {
"$subpkgdir/usr/share/bash-completion/completions/$pkgname"
}
-sha512sums="d9147604a718582a19c036a040c62612427163146048dbf9e3665545072e8132d08f51dccfd3f0a01453c0405a0326dad8f83afd10270eec5c69fa0612cb8510 devscripts_2.20.2.tar.xz"
+sha512sums="6d86deeecff82fc16df7d978678f5b88293164688078bf0732a7e6b844cf8845868be31c107518cf43b8dbcbadcd12a9691585f5725abd397f63ff9456fbdd8f devscripts_2.20.3.tar.xz"
diff --git a/user/feh/APKBUILD b/user/feh/APKBUILD
index 899461202..b95aaf01d 100644
--- a/user/feh/APKBUILD
+++ b/user/feh/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Max Rees <maxcrees@me.com>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=feh
-pkgver=3.3
+pkgver=3.4.1
pkgrel=0
pkgdesc="feh is a fast, lightweight image viewer which uses imlib2"
url="https://feh.finalrewind.org/"
@@ -12,7 +12,14 @@ checkdepends="perl-test-command"
makedepends="curl-dev imlib2-dev libexif-dev libjpeg-turbo-dev libpng-dev
libxinerama-dev libxt-dev"
subpackages="$pkgname-doc"
-source="https://feh.finalrewind.org/$pkgname-$pkgver.tar.bz2"
+source="https://feh.finalrewind.org/$pkgname-$pkgver.tar.bz2
+ getopt.patch
+ "
+
+prepare() {
+ default_prepare
+ rm src/getopt.c src/getopt1.c src/getopt.h
+}
build() {
make PREFIX=/usr curl=1 exif=1 xinerama=1
@@ -31,4 +38,5 @@ package() {
install
}
-sha512sums="0372115a8f2df77cdfc0fc1b24479e72d9be1f24127c787909ef671075b199b8d5f873200ce202f51705991cf3c5f5cc71ef8f47294fe520e3a9acc5cb7582a9 feh-3.3.tar.bz2"
+sha512sums="d674d3134819cf6731aebf8af87a2f890d54dd7f8c64071e8816a032aeeb95c31f56752bb3477be0dfb653f813872b32dc2daf4e0514fed03e3f6bba36896c66 feh-3.4.1.tar.bz2
+cf02fbfcb1fd4f4e5cf899f7f94fd42521dbe8f1b805268eae5ae6222b85884c31abc3346a95ed46dfece7b89b445018e159ff8a42b799b3db18275e29eba1e3 getopt.patch"
diff --git a/user/feh/getopt.patch b/user/feh/getopt.patch
new file mode 100644
index 000000000..be7616fa9
--- /dev/null
+++ b/user/feh/getopt.patch
@@ -0,0 +1,100 @@
+--- feh-3.4.1/src/feh.h 2020-05-29 21:55:03.000000000 +0000
++++ feh-3.4.1/src/feh.h 2020-06-20 02:22:16.040051483 +0000
+@@ -74,7 +74,7 @@ CONNECTION WITH THE SOFTWARE OR THE USE
+ #include "menu.h"
+
+ #include "utils.h"
+-#include "getopt.h"
++#include <getopt.h>
+
+ #include "debug.h"
+
+--- feh-3.4.1/src/Makefile 2020-05-29 21:55:03.000000000 +0000
++++ feh-3.4.1/src/Makefile 2020-06-20 02:22:43.660051920 +0000
+@@ -4,8 +4,6 @@ TARGETS = \
+ events.c \
+ feh_png.c \
+ filelist.c \
+- getopt.c \
+- getopt1.c \
+ gib_hash.c \
+ gib_imlib.c \
+ gib_list.c \
+--- feh-3.4.1/src/deps.mk 2020-05-29 21:55:03.000000000 +0000
++++ feh-3.4.1/src/deps.mk 2020-06-20 02:23:33.810052712 +0000
+@@ -1,57 +1,55 @@
+ events.o: events.c feh.h gib_hash.h gib_list.h gib_imlib.h gib_style.h \
+- structs.h menu.h utils.h getopt.h debug.h filelist.h winwidget.h \
++ structs.h menu.h utils.h debug.h filelist.h winwidget.h \
+ timers.h options.h events.h thumbnail.h
+ feh_png.o: feh_png.c feh_png.h feh.h gib_hash.h gib_list.h gib_imlib.h \
+- gib_style.h structs.h menu.h utils.h getopt.h debug.h
++ gib_style.h structs.h menu.h utils.h debug.h
+ filelist.o: filelist.c feh.h gib_hash.h gib_list.h gib_imlib.h \
+- gib_style.h structs.h menu.h utils.h getopt.h debug.h filelist.h \
++ gib_style.h structs.h menu.h utils.h debug.h filelist.h \
+ signals.h options.h
+-getopt.o: getopt.c
+-getopt1.o: getopt1.c getopt.h
+ gib_hash.o: gib_hash.c gib_hash.h gib_list.h utils.h debug.h
+ gib_imlib.o: gib_imlib.c gib_imlib.h gib_style.h gib_list.h utils.h \
+ debug.h
+ gib_list.o: gib_list.c gib_list.h utils.h debug.h
+ gib_style.o: gib_style.c gib_style.h gib_list.h utils.h debug.h
+ imlib.o: imlib.c feh.h gib_hash.h gib_list.h gib_imlib.h gib_style.h \
+- structs.h menu.h utils.h getopt.h debug.h filelist.h signals.h \
++ structs.h menu.h utils.h debug.h filelist.h signals.h \
+ winwidget.h options.h
+ index.o: index.c feh.h gib_hash.h gib_list.h gib_imlib.h gib_style.h \
+- structs.h menu.h utils.h getopt.h debug.h filelist.h winwidget.h \
++ structs.h menu.h utils.h debug.h filelist.h winwidget.h \
+ options.h index.h
+ keyevents.o: keyevents.c feh.h gib_hash.h gib_list.h gib_imlib.h \
+- gib_style.h structs.h menu.h utils.h getopt.h debug.h thumbnail.h \
++ gib_style.h structs.h menu.h utils.h debug.h thumbnail.h \
+ filelist.h winwidget.h options.h
+ list.o: list.c feh.h gib_hash.h gib_list.h gib_imlib.h gib_style.h \
+- structs.h menu.h utils.h getopt.h debug.h filelist.h options.h
++ structs.h menu.h utils.h debug.h filelist.h options.h
+ main.o: main.c feh.h gib_hash.h gib_list.h gib_imlib.h gib_style.h \
+- structs.h menu.h utils.h getopt.h debug.h filelist.h winwidget.h \
++ structs.h menu.h utils.h debug.h filelist.h winwidget.h \
+ timers.h options.h events.h signals.h wallpaper.h
+ md5.o: md5.c md5.h
+ menu.o: menu.c feh.h gib_hash.h gib_list.h gib_imlib.h gib_style.h \
+- structs.h menu.h utils.h getopt.h debug.h thumbnail.h filelist.h \
++ structs.h menu.h utils.h debug.h thumbnail.h filelist.h \
+ winwidget.h wallpaper.h options.h
+ multiwindow.o: multiwindow.c feh.h gib_hash.h gib_list.h gib_imlib.h \
+- gib_style.h structs.h menu.h utils.h getopt.h debug.h winwidget.h \
++ gib_style.h structs.h menu.h utils.h debug.h winwidget.h \
+ timers.h filelist.h options.h signals.h
+ options.o: options.c feh.h gib_hash.h gib_list.h gib_imlib.h gib_style.h \
+- structs.h menu.h utils.h getopt.h debug.h filelist.h options.h
++ structs.h menu.h utils.h debug.h filelist.h options.h
+ signals.o: signals.c feh.h gib_hash.h gib_list.h gib_imlib.h gib_style.h \
+- structs.h menu.h utils.h getopt.h debug.h filelist.h winwidget.h \
++ structs.h menu.h utils.h debug.h filelist.h winwidget.h \
+ options.h
+ slideshow.o: slideshow.c feh.h gib_hash.h gib_list.h gib_imlib.h \
+- gib_style.h structs.h menu.h utils.h getopt.h debug.h filelist.h \
++ gib_style.h structs.h menu.h utils.h debug.h filelist.h \
+ timers.h winwidget.h options.h signals.h
+ thumbnail.o: thumbnail.c feh.h gib_hash.h gib_list.h gib_imlib.h \
+- gib_style.h structs.h menu.h utils.h getopt.h debug.h filelist.h \
++ gib_style.h structs.h menu.h utils.h debug.h filelist.h \
+ winwidget.h options.h thumbnail.h md5.h feh_png.h index.h signals.h
+ timers.o: timers.c feh.h gib_hash.h gib_list.h gib_imlib.h gib_style.h \
+- structs.h menu.h utils.h getopt.h debug.h options.h timers.h
++ structs.h menu.h utils.h debug.h options.h timers.h
+ utils.o: utils.c feh.h gib_hash.h gib_list.h gib_imlib.h gib_style.h \
+- structs.h menu.h utils.h getopt.h debug.h options.h
++ structs.h menu.h utils.h debug.h options.h
+ wallpaper.o: wallpaper.c feh.h gib_hash.h gib_list.h gib_imlib.h \
+- gib_style.h structs.h menu.h utils.h getopt.h debug.h filelist.h \
++ gib_style.h structs.h menu.h utils.h debug.h filelist.h \
+ options.h wallpaper.h
+ winwidget.o: winwidget.c feh.h gib_hash.h gib_list.h gib_imlib.h \
+- gib_style.h structs.h menu.h utils.h getopt.h debug.h filelist.h \
++ gib_style.h structs.h menu.h utils.h debug.h filelist.h \
+ winwidget.h options.h events.h
diff --git a/user/fuse3/APKBUILD b/user/fuse3/APKBUILD
index 14cafec71..5d8d8f7bd 100644
--- a/user/fuse3/APKBUILD
+++ b/user/fuse3/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=fuse3
_pkgname=fuse
-pkgver=3.9.1
+pkgver=3.9.2
pkgrel=0
pkgdesc="The reference implementation of the Linux FUSE (Filesystem in Userspace) interface"
url="https://github.com/libfuse/libfuse"
@@ -80,6 +80,6 @@ openrc() {
install_if="openrc fuse-common=$pkgver-r$pkgrel"
}
-sha512sums="295bb62274264789c977a1fee78c6c122a2f227ae85d750b8519cafbdcf6551499b77cf021d83cc8261831e29761c166d84a4e50bdebb4191c76bcad1d15d329 fuse-3.9.1.tar.xz
+sha512sums="47795d2e0431c93ff36609247016a5ddfa631e4dcdc56cb579030bdb78497e3fa2db28b0cbadd0848024be39381c54f8441de28b0af51f8b800519e76c7af9ed fuse-3.9.2.tar.xz
1a9e1d1e8a7b0778ffde328e4322c73b5d57ec98d52767c846d755cce861ab27989823a75b6c5f994432ddb77fa351dfa4a8f948c9467c5f7d5f471e4608358b fix-realpath.patch
7f6a503ef23cfa8b809c544375c2d83ad56525269b48ad1a7dff0ce36f4bf2f2a3fafed9dc70a71ff6281b261db5f01829e16c06f041921a5d8c8d715a04a8c1 fuse.initd"
diff --git a/user/jansson/APKBUILD b/user/jansson/APKBUILD
index b6f332c62..0d583f27f 100644
--- a/user/jansson/APKBUILD
+++ b/user/jansson/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Max Rees <maxcrees@me.com>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=jansson
-pkgver=2.12
+pkgver=2.13.1
pkgrel=0
pkgdesc="C library for encoding, decoding and manipulating JSON data"
url="http://www.digip.org/jansson/" # No HTTPS
@@ -31,4 +31,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="e40bdafdfa1fa663f71e00c06d7bfc98cff4ed3581a147894e5272e50fa5f9b9a7af6aaca41ff423a2ddd2554a192b36efcc32f6a3c98c727e9f819b955357cb jansson-2.12.tar.gz"
+sha512sums="e32be6665e41cf1763608c2f1ac4ce0824d4d7ffa5f4a5824cefde279250fdd399d49ba93d8894e16a473731f629b846554654347f027ca9a0a96ed047f10192 jansson-2.13.1.tar.gz"
diff --git a/user/keepassxc/APKBUILD b/user/keepassxc/APKBUILD
index 4aa4ecff3..9d09215f9 100644
--- a/user/keepassxc/APKBUILD
+++ b/user/keepassxc/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Max Rees <maxcrees@me.com>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=keepassxc
-pkgver=2.5.3
+pkgver=2.5.4
pkgrel=0
pkgdesc="A community revival of the KeePassX password manager"
url="https://keepassxc.org"
@@ -34,4 +34,4 @@ package() {
make DESTDIR="$pkgdir" -C build install
}
-sha512sums="8b1e3360b4ae5de170be6936291f7b309de09b2462fcd5a48f239c22f1c8b6ffe721aca8d1e9b6ae3881f7b16374850d7f4b809733244fd16d45eed6ad4f60c6 keepassxc-2.5.3-src.tar.xz"
+sha512sums="8a70363dd579b95ccb05cb846aa34a5ed89de4305f3bef9e518e5986fe7f0313cb1daaa347f5b2267002f3fff4b71c87f5bb9073f6e6879d2556a2f0e4791dd3 keepassxc-2.5.4-src.tar.xz"
diff --git a/user/llvm8/APKBUILD b/user/llvm8/APKBUILD
index 0e09db7af..065576966 100644
--- a/user/llvm8/APKBUILD
+++ b/user/llvm8/APKBUILD
@@ -6,7 +6,7 @@ _pkgname=llvm
pkgver=8.0.1
_majorver=${pkgver%%.*}
pkgname=$_pkgname$_majorver
-pkgrel=0
+pkgrel=1
pkgdesc="Low Level Virtual Machine compiler system, version $_majorver"
arch="all"
options="!checkroot !dbg"
@@ -25,6 +25,7 @@ source="https://github.com/llvm/llvm-project/releases/download/llvmorg-$pkgver/l
more-secure-plt.patch
even-more-secure-plt.patch
python3-test.patch
+ scc-insertion.patch
"
builddir="$srcdir/$_pkgname-$pkgver.src"
@@ -233,4 +234,5 @@ caeec8e4dbd92f5f74940780b69075f3879a267a8623822cbdc193fd14706eb089071e3a5a20d60c
e5ddbc4b6c4928e79846dc3c022eb7928aaa8fed40515c78f5f03b8ab8264f34f1eb8aa8bfc0f436450932f4917e54ad261603032092ea271d9590f11a37cf1e musl-ppc64-elfv2.patch
7ba7f5b396e1afb49ea53fdc16729f0709fbba88de433cc8a8e2f751d13733011d4121318f68d7f8a16a6c57c3a1bee727cc3e0da0f5c6cae38eff70d3a539cf more-secure-plt.patch
deb71762721ebc73bfdf23143b582f40c70eddcef3e337ed14499e8e336bee2906292d38d64fe98fa633430c1bcb66cf6a2e067258c8fbe6e931f99f6d10a6f7 even-more-secure-plt.patch
-53cc0d13dd871e9b775bb4e7567de4f9a97d91b8246cd7ce74607fd88d6e3e2ab9455f5b4195bc7f9dbdedbc77d659d43e98ec0b7cd78cd395aaea6919510287 python3-test.patch"
+53cc0d13dd871e9b775bb4e7567de4f9a97d91b8246cd7ce74607fd88d6e3e2ab9455f5b4195bc7f9dbdedbc77d659d43e98ec0b7cd78cd395aaea6919510287 python3-test.patch
+4422a83ea953a6b30cb447a448d246956abd6b0cbd2451247e5f2c41318b2c0d18c7b6781155ea40a5558bbd66e9e1482cec0875d95776545fd0d87356b5e4bd scc-insertion.patch"
diff --git a/user/llvm8/scc-insertion.patch b/user/llvm8/scc-insertion.patch
new file mode 100644
index 000000000..b2d7d511a
--- /dev/null
+++ b/user/llvm8/scc-insertion.patch
@@ -0,0 +1,33 @@
+From f7e9f4f4c50245d10ca9869a9f8f3d431dfb6948 Mon Sep 17 00:00:00 2001
+From: Warren Ristow <warren_ristow@playstation.sony.com>
+Date: Tue, 14 Jan 2020 10:30:24 -0800
+Subject: [PATCH] SCC: Allow ReplaceNode to safely support insertion
+
+If scc_iterator::ReplaceNode is inserting a new entry in the map,
+rather than replacing an existing entry, the possibility of growing
+the map could cause a failure. This change safely implements the
+insertion.
+
+Reviewed By: probinson
+
+Differential Revision: https://reviews.llvm.org/D72469
+---
+ include/llvm/ADT/SCCIterator.h | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/include/llvm/ADT/SCCIterator.h b/include/llvm/ADT/SCCIterator.h
+index eb1a5d0938cf..1e642b9f75d3 100644
+--- a/include/llvm/ADT/SCCIterator.h
++++ b/include/llvm/ADT/SCCIterator.h
+@@ -134,7 +134,10 @@ class scc_iterator : public iterator_facade_base<
+ /// has been deleted, and \c New is to be used in its place.
+ void ReplaceNode(NodeRef Old, NodeRef New) {
+ assert(nodeVisitNumbers.count(Old) && "Old not in scc_iterator?");
+- nodeVisitNumbers[New] = nodeVisitNumbers[Old];
++ // Do the assignment in two steps, in case 'New' is not yet in the map, and
++ // inserting it causes the map to grow.
++ auto tempVal = nodeVisitNumbers[Old];
++ nodeVisitNumbers[New] = tempVal;
+ nodeVisitNumbers.erase(Old);
+ }
+ };
diff --git a/user/mosquitto/APKBUILD b/user/mosquitto/APKBUILD
index 67ec942a1..71e1fb99c 100644
--- a/user/mosquitto/APKBUILD
+++ b/user/mosquitto/APKBUILD
@@ -2,12 +2,11 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=mosquitto
-pkgver=1.6.9
+pkgver=1.6.10
pkgrel=0
pkgdesc="An Open Source MQTT Broker"
url="https://mosquitto.org/"
arch="all"
-options="!check" # "Connection refused" during testing.
license="EPL-1.0 AND EDL-1.0 AND MIT AND BSD-3-Clause"
depends=""
checkdepends="python3"
@@ -74,7 +73,7 @@ clients() {
mv "$pkgdir"/usr/bin/mosquitto_[ps]ub "$subpkgdir"/usr/bin/
}
-sha512sums="f78228a1e8305e4d89b34250981ed2c5fe5317636003636dc90f6fa2b1e3ca3c8fadb705ee7301f5252456cb093a6547bd46a255ca3d9fb5cdced697738d6eb7 mosquitto-1.6.9.tar.gz
+sha512sums="2050a7a7af864057a177728f1cab9f6db70d6d1ea609d90c637723c2c9cfc9716429739302abd6742bde932716fae340854fff35956693dfee4ef31ce7b04a25 mosquitto-1.6.10.tar.gz
681fddc737b3ef3e6c052f0c854a730df290352640a18a63e23ef83d14c425558aff87805d1eb95e44de101b5df48872173af9f5414464ffa8cf727ea2c0491e mosquitto.initd
-3886171e36f759a717aa6626d5b8dbd392963c737d5de28b4d52b81359008927b99ff7a0ca82f56a0e5deaed4585571759ba9216336a664fd346845837c2bc18 disable-flaky-test.patch
+daaae48d49e49a9911f152dfc80f67f2371ad62647d3324b360eb83f816c0898469c135209ddb69e80a29b313bbe3b6ee11463955c97a44584921c13832a07be disable-flaky-test.patch
b07f9bec2751ab32c43f53e74d8fca18dbf2d7ce7f8fab562dbcf75de19609ba6219d735ac504697404e0ed36613a14074e3a19e735297195877798f778d337a openrc-conf.patch"
diff --git a/user/mosquitto/disable-flaky-test.patch b/user/mosquitto/disable-flaky-test.patch
index 8fd51c403..1dade3cd4 100644
--- a/user/mosquitto/disable-flaky-test.patch
+++ b/user/mosquitto/disable-flaky-test.patch
@@ -9,3 +9,17 @@
./11-persistent-subscription.py
./11-persistent-subscription-v5.py
./11-persistent-subscription-no-local.py
+
+Upstream issue: https://github.com/eclipse/mosquitto/issues/1659
+
+--- mosquitto-1.6.10/test/lib/Makefile 2020-05-25 22:49:59.000000000 +0000
++++ mosquitto-1.6.10/test/lib/Makefile 2020-06-20 01:41:00.350012338 +0000
+@@ -33,7 +33,7 @@ c : test-compile
+ ./02-subscribe-qos0.py $@/02-subscribe-qos0.test
+ ./02-subscribe-qos1.py $@/02-subscribe-qos1.test
+ ./02-subscribe-qos1.py $@/02-subscribe-qos1-async1.test
+- ./02-subscribe-qos1.py $@/02-subscribe-qos1-async2.test
++ #./02-subscribe-qos1.py $@/02-subscribe-qos1-async2.test
+ ./02-subscribe-qos2.py $@/02-subscribe-qos2.test
+ ./02-unsubscribe-multiple-v5.py $@/02-unsubscribe-multiple-v5.test
+ ./02-unsubscribe-v5.py $@/02-unsubscribe-v5.test
diff --git a/user/mutt/APKBUILD b/user/mutt/APKBUILD
index 09b0f49d3..04d3efb64 100644
--- a/user/mutt/APKBUILD
+++ b/user/mutt/APKBUILD
@@ -3,7 +3,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=mutt
-pkgver=1.13.4
+pkgver=1.14.4
pkgrel=0
pkgdesc="Small but very powerful text-mode email client"
url="http://www.mutt.org" # No HTTPS
@@ -16,6 +16,10 @@ makedepends="cyrus-sasl-dev gdbm-dev gettext-tiny gpgme-dev
subpackages="$pkgname-doc $pkgname-lang"
source="https://bitbucket.org/$pkgname/$pkgname/downloads/$pkgname-$pkgver.tar.gz"
+# secfixes:
+# 1.14.4-r0:
+# - CVE-2020-14093
+
build() {
ISPELL=/usr/bin/hunspell \
./configure \
@@ -35,7 +39,6 @@ build() {
--with-curses \
--with-mailpath=/var/spool/mail \
--with-docdir=/usr/share/doc/$pkgname \
- --without-included-gettext \
--with-ssl \
--with-sasl
make
@@ -57,4 +60,4 @@ package() {
"$pkgdir"/etc/Muttrc.gpg.dist
}
-sha512sums="59ae13d7cef052818f38f6d52e2cb42251f393ecf622eae113bfa29218b541195471de822efbdb072c6f74a4dc385bb94fe27c37b44c62eac7e2a0a4e0c6adc3 mutt-1.13.4.tar.gz"
+sha512sums="86484f009ca8bd1e26206694e03609a16f8a4e8c83620a07a4376fe160535a838e8c918a8a30799fb3d9cf46c059d67124f7425c42093fb5e5bf8ea4ac310daa mutt-1.14.4.tar.gz"
diff --git a/user/netqmail/APKBUILD b/user/netqmail/APKBUILD
index 45b92dbc8..9be7d7c68 100644
--- a/user/netqmail/APKBUILD
+++ b/user/netqmail/APKBUILD
@@ -9,7 +9,7 @@ arch="all"
license="Public-Domain"
options="suid !check" # suid programs (qmail-queue); no test suite
depends="execline s6 s6-networking"
-makedepends="utmps-dev"
+makedepends="groff utmps-dev"
subpackages="$pkgname-doc $pkgname-openrc"
provider_priority=1
provides="sendmail"
diff --git a/user/nextcloud-client/APKBUILD b/user/nextcloud-client/APKBUILD
index b9b3064d6..b4d265440 100644
--- a/user/nextcloud-client/APKBUILD
+++ b/user/nextcloud-client/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=nextcloud-client
-pkgver=2.6.3
+pkgver=2.6.4
pkgrel=0
pkgdesc="Nextcloud desktop client"
url="https://github.com/nextcloud/desktop"
@@ -42,6 +42,6 @@ package() {
EOF
}
-sha512sums="ddeb8a32e0208bc415bf421cb3ce05713adb617fa78c0b5cb4d894c9e8d3499dcc495c115de3ea7abb0c402eef4bc64ede8c59a7f056acda47779096fedc8025 nextcloud-client-2.6.3.tar.gz
+sha512sums="849bf9bfa6a50342f6b58e805dc72ef342cb5f3e2e27d8f45d6a48759b1956dec194fb376b9a6b760df724f01eec3a22aadaa439f03e5166b1b2afb5454e40f1 nextcloud-client-2.6.4.tar.gz
38dd89ca2bf67294187bb4d5c59cdf725ec3b502f23bf4a60210e85c66f6a7e00da0e0b41775bc138159bed300dc60a1f179d1d6ad3b7a27e1aadf4f0576f348 no-webengine.patch
c14054e6dc228ca77a659371b3c151e0551477fce3a2678a54da4ba73adbcf972a78114c5649adc3dc813fb01b55bbb812620caac0bc0460519424c2caa6c81f test-fix-include.patch"
diff --git a/user/twm/APKBUILD b/user/twm/APKBUILD
index de08c9b46..ec7ea903c 100644
--- a/user/twm/APKBUILD
+++ b/user/twm/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=twm
-pkgver=1.0.10
+pkgver=1.0.11
pkgrel=0
pkgdesc="Tom's/Tab Window Manager for the X Window System"
url="https://www.X.Org"
@@ -11,9 +11,9 @@ options="!check" # No test suite.
license="MIT AND X11"
depends=""
makedepends="bison util-macros libxext-dev libx11-dev libxt-dev
- libice-dev libxmu-dev"
+ libice-dev libxmu-dev libxrandr-dev"
subpackages="$pkgname-doc"
-source="https://www.X.Org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
+source="https://www.X.Org/releases/individual/app/$pkgname-$pkgver.tar.xz"
build() {
./configure \
@@ -28,4 +28,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="1280683fce7ebbf5670239cb1f3cee2b40612bd9850d98827e793cf8bf298bdb58e48387cab943ea6befc6f7b34da2567353c22b8eaeb8bcf1b9e303cd7e6a9e twm-1.0.10.tar.bz2"
+sha512sums="948034bba23e6b6c4412fcd2e46bb11a9980297601218a54a5055165ab0229a44dde0d50f338b24e82d76f390597e2fa09d11ff7f3fe1b1d736b10083c7da20d twm-1.0.11.tar.xz"
diff --git a/user/xmlsec/APKBUILD b/user/xmlsec/APKBUILD
index 5c71b8f19..1bbd3abb7 100644
--- a/user/xmlsec/APKBUILD
+++ b/user/xmlsec/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=xmlsec
-pkgver=1.2.29
+pkgver=1.2.30
_pkgname="$pkgname${pkgver%%.*}"
pkgrel=0
pkgdesc="C-based XML signature and encryption syntax and processing library"
@@ -68,4 +68,4 @@ nss() {
mv "$pkgdir"/usr/lib/libxmlsec1-nss.so* "$subpkgdir"/usr/lib/
}
-sha512sums="07c3012179da4392f0a9d41a51ed51d692ca8b491310488b955d5fef0637f104d3f82374754b0ef175fadc663a8ca8c996178198c5dd77b3a8b34393d1482e4d xmlsec1-1.2.29.tar.gz"
+sha512sums="07152470a9fe5d077f8a358608ca1d8a79ee0d2777660f61ed5717dc640714a3adfe66843e6a4023898eb0f5ed79771d70c41132571f3a1aeda82c1894b69c98 xmlsec1-1.2.30.tar.gz"
diff --git a/user/youtube-dl/APKBUILD b/user/youtube-dl/APKBUILD
index 424f883b1..aee2f895a 100644
--- a/user/youtube-dl/APKBUILD
+++ b/user/youtube-dl/APKBUILD
@@ -3,7 +3,7 @@
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=youtube-dl
-pkgver=2020.03.24
+pkgver=2020.06.16.1
pkgrel=0
pkgdesc="Command-line program to download videos from YouTube and many other sites"
url="https://youtube-dl.org"
@@ -66,5 +66,5 @@ fishcomp() {
"$subpkgdir/usr/share/fish/completions/"
}
-sha512sums="421c0ae412977cdf94d079aa7982360ffdfc4271bb7af27a598adbdb8454c2044e5c44ff3a9f339e9b0989c1264223ca83bba6a9151d01052f8f72c076d9e369 youtube-dl-2020.03.24.tar.gz
+sha512sums="2f0c01cd1a52293afd8c4fddc20b6f7baca94903fbe852769ad1d25740bd87e38d42ee4a275c2e3d611c639c432f6245d27f361471c6b566da03677384a04e54 youtube-dl-2020.06.16.1.tar.gz
5760d06e6bbc1eee2c6be2d1f580f86b3cfa5f4bc44a62fb8145ce1cd41352ecf2f65d65d79a2d7f1ec129a34c28a7ec3d0d328c907e743bfcea54c65c71285d tumblr.patch"