summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/ncftp/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/user/ncftp/APKBUILD b/user/ncftp/APKBUILD
new file mode 100644
index 000000000..1a9b5fce4
--- /dev/null
+++ b/user/ncftp/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Dan Theisen <djt@hxx.in>
+pkgname=ncftp
+pkgver=3.2.6
+pkgrel=0
+pkgdesc="A set of free application programs implementing FTP"
+url="http://www.ncftp.com/"
+arch="all"
+options="!check" # No test suite.
+license="ClArtistic"
+makedepends="ncurses-dev"
+source="ftp://ftp.ncftp.com/ncftp/$pkgname-$pkgver-src.tar.gz"
+subpackages="$pkgname-doc $pkgname-bookmarks"
+
+build () {
+ cd "$builddir"
+
+ LIBS="-ltinfo" ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man
+
+ cd "$builddir"/libncftp
+ make shared
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"/libncftp
+ make PREFIX="${pkgdir}"/usr soinstall
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ install -D doc/LICENSE.txt \
+ "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+}
+
+bookmarks () {
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/ncftpbookmarks \
+ "$subpkgdir"/usr/bin/
+}
+
+sha512sums="a2f8ac555bee8af4be1aa745ce5838beee99cd2253c1fe701b710ec135d7c47e2bf8b22ec928975ec2460919977d45a07fb12185ab58a2e96e3092039ffd3303 ncftp-3.2.6-src.tar.gz"