summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/libsodium/APKBUILD33
-rw-r--r--user/nacl/APKBUILD33
2 files changed, 33 insertions, 33 deletions
diff --git a/user/libsodium/APKBUILD b/user/libsodium/APKBUILD
new file mode 100644
index 000000000..a63992976
--- /dev/null
+++ b/user/libsodium/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Laurent Bercot <ska-adelie@skarnet.org>
+# Maintainer: Laurent Bercot <ska-adelie@skarnet.org>
+pkgname=libsodium
+pkgver=1.0.17
+pkgrel=0
+pkgdesc="Networking and Cryptography library: sodium fork"
+url="https://libsodium.org/"
+arch="all"
+license="ISC"
+subpackages="$pkgname-dev"
+source="https://download.libsodium.org/libsodium/releases/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --enable-retpoline \
+ --with-pthreads \
+ --with-gnu-ld
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make install "DESTDIR=$pkgdir"
+}
+
+sha512sums="7cc9e4f11e656008ce9dff735acea95acbcb91ae4936de4d26f7798093766a77c373e9bd4a7b45b60ef8a11de6c55bc8dcac13bebf8c23c671d0536430501da1 libsodium-1.0.17.tar.gz"
diff --git a/user/nacl/APKBUILD b/user/nacl/APKBUILD
deleted file mode 100644
index 63abcb0a2..000000000
--- a/user/nacl/APKBUILD
+++ /dev/null
@@ -1,33 +0,0 @@
-# Contributor: Laurent Bercot <ska-adelie@skarnet.org>
-# Maintainer: Laurent Bercot <ska-adelie@skarnet.org>
-pkgname=nacl
-pkgver=20110221
-pkgrel=0
-pkgdesc="Networking and Cryptography library"
-url="https://nacl.cr.yp.to/"
-arch="all"
-options="!check" # No test suite.
-license="Public-Domain"
-subpackages="$pkgname-dev"
-source="https://hyperelliptic.org/$pkgname/$pkgname-$pkgver.tar.bz2"
-_bins="curvecpclient curvecpmakekey curvecpmessage curvecpprintkey curvecpserver nacl-sha256 nacl-sha512"
-
-build() {
- cd "$builddir"
- echo "$CC $CFLAGS" > okcompilers/c
- echo "g++ $CXXFLAGS" > okcompilers/cpp
- ./do done # 'done' is only there to work around buggy syntax highlighting >.>
-}
-
-package() {
- mkdir -p "$pkgdir/usr/bin" "$pkgdir/usr/include/$pkgname" "$pkgdir/usr/lib/$pkgname"
- _shorthostname=`hostname | sed 's/\..*//' | tr -cd '[a-z][A-Z][0-9]'`
- cd "$builddir/build/$_shorthostname"
- _okabi=`bin/okabi | head -n 1`
- for i in $_bins ; do cp "bin/$i" "$pkgdir/usr/bin/" ; done
- cp include/cpuid.h include/"$_okabi"/*.h "$pkgdir/usr/include/$pkgname/"
- ln -s . "$pkgdir/usr/include/$pkgname/$_okabi"
- cp lib/"$_okabi"/*.o lib/"$_okabi"/*.a "$pkgdir/usr/lib/$pkgname"
-}
-
-sha512sums="4c031ceffe6a28dc74b46ac003d485531f78de467c802df73c8b22ca53644dabb7d2e3080b7bdd6583f0d07ad76b6d95bc0ffdce319ca2f80ee041e6fe618656 nacl-20110221.tar.bz2"