summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--experimental/horizon/APKBUILD100
-rw-r--r--experimental/horizon/noninstall-mount.patch61
-rw-r--r--system/execline/APKBUILD4
-rw-r--r--system/openrc/APKBUILD2
-rw-r--r--system/openrc/openrc.post-install2
-rw-r--r--system/skalibs/APKBUILD4
-rw-r--r--user/mtools/APKBUILD32
-rw-r--r--user/netqmail/0005-CVE-2005-1513.patch19
-rw-r--r--user/netqmail/APKBUILD4
9 files changed, 221 insertions, 7 deletions
diff --git a/experimental/horizon/APKBUILD b/experimental/horizon/APKBUILD
new file mode 100644
index 000000000..9c1d39ee7
--- /dev/null
+++ b/experimental/horizon/APKBUILD
@@ -0,0 +1,100 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=horizon
+pkgver=0.9.0
+pkgrel=0
+pkgdesc="Installation tools for Adélie Linux"
+url="https://horizon.adelielinux.org/"
+arch="all"
+options="!check" # Unpackaged dependency ruby-aruba.
+license="AGPL-3.0+"
+depends=""
+checkdepends="ruby-aruba ruby-rspec valgrind"
+# Second group is the Qt5 UI deps.
+makedepends="bcnm-dev boost-dev cmake curl-dev eudev-dev libarchive-dev
+ linux-headers parted-dev skalibs-dev util-linux-dev
+
+ libcap-dev libx11-dev libxkbfile-dev qt5-qtbase-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-image $pkgname-qt5
+ $pkgname-tools $pkgname-wizard"
+source="https://distfiles.adelielinux.org/source/horizon-$pkgver.tar.xz
+ noninstall-mount.patch
+ "
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=True \
+ -DBUILD_TOOLS=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS -Wno-format-truncation" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ -DINSTALL=ON \
+ ${CMAKE_CROSSOPTS} \
+ -Bbuild
+ make -C build
+
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=False \
+ -DBUILD_TOOLS=OFF \
+ -DBUILD_UI=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS -Wno-format-truncation" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ -DINSTALL=OFF \
+ ${CMAKE_CROSSOPTS} \
+ -Bbuild-wizard
+ make -C build-wizard
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE make -C build test
+}
+
+package() {
+ make DESTDIR="$pkgdir" -C build install
+}
+
+image() {
+ pkgdesc="Tools for generating images using HorizonScript"
+ mkdir -p "$subpkgdir"/usr/bin
+ mkdir -p "$subpkgdir"/usr/lib
+
+ mv "$pkgdir"/usr/bin/hscript-image "$subpkgdir"/usr/bin/
+ mv "$pkgdir"/usr/lib/libhi-backends.so "$subpkgdir"/usr/lib/
+}
+
+qt5() {
+ pkgdesc="Qt 5 installation wizard for Adélie Linux"
+ mkdir -p "$subpkgdir"/usr/bin
+
+ for _bin in horizon-ppc64-detect horizon-qt5 horizon-run-qt5; do
+ mv "$pkgdir"/usr/bin/$_bin "$subpkgdir"/usr/bin/
+ done
+}
+
+tools() {
+ pkgdesc="Tools for authoring HorizonScript files"
+ mkdir -p "$subpkgdir"/usr/bin
+
+ for _bin in hscript-fromjson hscript-simulate hscript-validate; do
+ mv "$pkgdir"/usr/bin/$_bin "$subpkgdir"/usr/bin/
+ done
+}
+
+wizard() {
+ pkgdesc="Wizard to generate a HorizonScript for another computer"
+
+ make DESTDIR="$subpkgdir" -C "$builddir"/build-wizard install
+ rm "$subpkgdir"/usr/bin/hscript-printowner
+ rm -r "$subpkgdir"/usr/include
+ rm -r "$subpkgdir"/usr/lib
+ rm -r "$subpkgdir"/usr/share
+}
+
+sha512sums="a2185744b611154f41ba433399f621c8114147bc981dad03fac581bf7ddd67c46042bc230fd68d4c89188cefa281022d101d7394cf1a0554729da540706e6216 horizon-0.9.0.tar.xz
+44a4f022df03a3ac3ec9fe3aea9faa8d98ed6c9b61ff50e3c363f5691a2ed428d328f6d5aa019f25be67811dede8da7195eaf354f1cd3a4a56c77f698d53e7fb noninstall-mount.patch"
diff --git a/experimental/horizon/noninstall-mount.patch b/experimental/horizon/noninstall-mount.patch
new file mode 100644
index 000000000..2b0e7152a
--- /dev/null
+++ b/experimental/horizon/noninstall-mount.patch
@@ -0,0 +1,61 @@
+diff --git a/ui/qt5/horizonwizard.cc b/ui/qt5/horizonwizard.cc
+index 143ae43..556a6f3 100644
+--- a/ui/qt5/horizonwizard.cc
++++ b/ui/qt5/horizonwizard.cc
+@@ -542,7 +542,9 @@ QString HorizonWizard::toHScript() {
+ break;
+ }
+
++#ifdef HAS_INSTALL_ENV
+ part_lines << (dynamic_cast<PartitionMountPage *>(page(Page_PartitionMount)))->mountLines();
++#endif /* HAS_INSTALL_ENV */
+
+ if(chosen_disk.empty()) {
+ lines << part_lines;
+diff --git a/ui/qt5/mountdialog.cc b/ui/qt5/mountdialog.cc
+index f986423..103e442 100644
+--- a/ui/qt5/mountdialog.cc
++++ b/ui/qt5/mountdialog.cc
+@@ -16,6 +16,7 @@
+ #include <QLabel>
+ #include <QLineEdit>
+ #include <QPushButton>
++#include <QSet>
+ #include <QVBoxLayout>
+
+ MountDialog::MountDialog(QStringList skipParts, QStringList skipMounts,
+@@ -75,7 +76,11 @@ MountDialog::MountDialog(QStringList skipParts, QStringList skipMounts,
+
+ QVBoxLayout *controlLayout = new QVBoxLayout;
+ controlLayout->addWidget(new QLabel(tr("Partition")));
++#ifdef HAS_INSTALL_ENV
+ controlLayout->addWidget(partList);
++#else /* !HAS_INSTALL_ENV */
++ controlLayout->addWidget(partInput);
++#endif /* HAS_INSTALL_ENV */
+ controlLayout->addWidget(new QLabel(tr("will be mounted on")));
+ controlLayout->addWidget(pathInput);
+
+@@ -87,14 +92,22 @@ MountDialog::MountDialog(QStringList skipParts, QStringList skipMounts,
+ }
+
+ QString MountDialog::partition() const {
++#ifdef HAS_INSTALL_ENV
+ assert(partList->currentItem() != nullptr);
+ return partList->currentItem()->text();
++#else /* !HAS_INSTALL_ENV */
++ return partInput->text();
++#endif /* HAS_INSTALL_ENV */
+ }
+
+ void MountDialog::setPartition(const QString &part) {
++#ifdef HAS_INSTALL_ENV
+ QList<QListWidgetItem *> candidate = partList->findItems(part, Qt::MatchExactly);
+ if(candidate.empty()) return;
+ partList->setCurrentItem(candidate.at(0));
++#else /* !HAS_INSTALL_ENV */
++ partInput->setText(part);
++#endif /* HAS_INSTALL_ENV */
+ }
+
+ QString MountDialog::mountPoint() const {
diff --git a/system/execline/APKBUILD b/system/execline/APKBUILD
index 252daeb63..bc7328ea3 100644
--- a/system/execline/APKBUILD
+++ b/system/execline/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Laurent Bercot <ska-adelie@skarnet.org>
# Maintainer: Laurent Bercot <ska-adelie@skarnet.org>
pkgname=execline
-pkgver=2.6.0.0
+pkgver=2.6.0.2
pkgrel=0
pkgdesc="A small scripting language for non-interactive scripts"
url="https://skarnet.org/software/$pkgname/"
@@ -62,4 +62,4 @@ doc() {
cp -a "$builddir/doc" "$subpkgdir/usr/share/doc/$pkgname"
}
-sha512sums="890a533a6ffad98b066adda34ae4a7e69daa98950974fcdb4635cff4c8957851b7fc6beaf25802c7ed5085285fc9b2aa9d9806afdb1aaa6884745a978b969f7a execline-2.6.0.0.tar.gz"
+sha512sums="915823af0d557fc7a181e088ce319568e62ea4bf743704e498786422c97b991e6b09447c7cff7d7dda520d391773ef4b2fea68e44479c02766966256719bb4c0 execline-2.6.0.2.tar.gz"
diff --git a/system/openrc/APKBUILD b/system/openrc/APKBUILD
index 2b1c5f520..ac9d8b184 100644
--- a/system/openrc/APKBUILD
+++ b/system/openrc/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer:
pkgname=openrc
pkgver=0.24.1
-pkgrel=8
+pkgrel=9
pkgdesc="OpenRC manages the services, startup and shutdown of a host"
url="https://github.com/OpenRC/openrc"
arch="all"
diff --git a/system/openrc/openrc.post-install b/system/openrc/openrc.post-install
index 0f6572ef7..9632de2ee 100644
--- a/system/openrc/openrc.post-install
+++ b/system/openrc/openrc.post-install
@@ -1,6 +1,6 @@
#!/bin/sh
-if [ -d /etc/runlevels ]; then
+if [ -d /etc/runlevels/sysinit ]; then
exit 0
fi
diff --git a/system/skalibs/APKBUILD b/system/skalibs/APKBUILD
index ada2b303c..129fa7e79 100644
--- a/system/skalibs/APKBUILD
+++ b/system/skalibs/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Laurent Bercot <ska-adelie@skarnet.org>
# Maintainer: Laurent Bercot <ska-adelie@skarnet.org>
pkgname=skalibs
-pkgver=2.9.2.0
+pkgver=2.9.2.1
pkgrel=0
pkgdesc="A set of general-purpose C programming libraries for skarnet.org software"
url="https://skarnet.org/software/skalibs/"
@@ -57,4 +57,4 @@ doc() {
cp -a "$builddir/doc" "$subpkgdir/usr/share/doc/$pkgname"
}
-sha512sums="a351cb8d048cefa495cc35fd2758579879d5ac11d2a1fc00c694d5655aa9e430228517c01fc91bdbc70c3992f73429a68a5365cb46039a7b7bb11358f0f4506d skalibs-2.9.2.0.tar.gz"
+sha512sums="bd507faf30f0564fb8d3e5f86de04ab4b39961dab2497ba9f4a81980a57f7ff68cad366b9847b25d555b5b9263460d13f096e1774d080d1d286979f2e7324c54 skalibs-2.9.2.1.tar.gz"
diff --git a/user/mtools/APKBUILD b/user/mtools/APKBUILD
new file mode 100644
index 000000000..34b0b8730
--- /dev/null
+++ b/user/mtools/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=mtools
+pkgver=4.0.24
+pkgrel=0
+pkgdesc="Utilities to access MS-DOS disks without mounting them"
+url="https://www.gnu.org/software/mtools/"
+arch="all"
+options="!check" # No test suite.
+license="GPL-3.0+"
+depends=""
+makedepends=""
+subpackages="$pkgname-doc"
+source="https://ftp.gnu.org/gnu/mtools/mtools-$pkgver.tar.bz2"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ install -Dm644 -t "$pkgdir"/etc mtools.conf
+ sed -i -e 's/^SAMPLE FILE$/#&/' "$pkgdir"/etc/mtools.conf
+}
+
+sha512sums="b74becc4f696315cfabc016d1746e744b43e366de73bf1bffeec4fbab1e4815967594de8acb4af01f89d36a925f93672efbac205b89540161bd53ab7edebcf04 mtools-4.0.24.tar.bz2"
diff --git a/user/netqmail/0005-CVE-2005-1513.patch b/user/netqmail/0005-CVE-2005-1513.patch
new file mode 100644
index 000000000..3b3876cb3
--- /dev/null
+++ b/user/netqmail/0005-CVE-2005-1513.patch
@@ -0,0 +1,19 @@
+diff -rNU3 netqmail-1.06.old/alloc.c netqmail-1.06/alloc.c
+--- netqmail-1.06.old/alloc.c 1998-06-15 10:53:16.000000000 +0000
++++ netqmail-1.06/alloc.c 2020-05-21 11:33:24.689739728 +0000
+@@ -1,3 +1,4 @@
++#include <limits.h>
+ #include "alloc.h"
+ #include "error.h"
+ extern char *malloc();
+@@ -15,6 +16,10 @@
+ unsigned int n;
+ {
+ char *x;
++ if (n >= (INT_MAX >> 3)) {
++ errno = error_nomem;
++ return 0;
++ }
+ n = ALIGNMENT + n - (n & (ALIGNMENT - 1)); /* XXX: could overflow */
+ if (n <= avail) { avail -= n; return space + avail; }
+ x = malloc(n);
diff --git a/user/netqmail/APKBUILD b/user/netqmail/APKBUILD
index 551895f83..45b92dbc8 100644
--- a/user/netqmail/APKBUILD
+++ b/user/netqmail/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Laurent Bercot <ska-adelie@skarnet.org>
pkgname=netqmail
pkgver=1.06
-pkgrel=6
+pkgrel=7
pkgdesc="The qmail mail transfer agent (community version)"
url="http://www.netqmail.org/"
arch="all"
@@ -19,6 +19,7 @@ source="http://www.netqmail.org/$pkgname-$pkgver.tar.gz
0002-qbiffutmpx-20170820.patch
0003-qmailremote-20170716.patch
0004-notifyfd.patch
+ 0005-CVE-2005-1513.patch
qmail.run
smtpd.run
smtpsd.run
@@ -106,6 +107,7 @@ ad126cad5c0d35351919ad87022fd94b910519d91cf82f38c158f423bbfc1b82455844a791ba0c69
b3af9c29e6d46daa2a1b9f677c6f32892d5f8c9b8d5c2bdd6f34b106dd5ad41394c05a5ebe145c6e29b4ced4482f08b2d09e7818fd309123c0d087600500e336 0002-qbiffutmpx-20170820.patch
cbebdc72c7cc5c437531c9277534ae552c6d044a83b36e3f3ce60ab5563c55eb814d6c543cc0997abab73075d1b517cc0929dd65674d468d517b0ca38196e2b4 0003-qmailremote-20170716.patch
b32a8a36c8ab8872abd4f1a117482f064a6d631a6bb2ba75cafe61743bef09f923d26935d9514eec33a7dec5aeb3d0b517d677e55924859d2db5233bc11f9f11 0004-notifyfd.patch
+ac8406c1d16ce2e55e47bc83ca6e095833a54de73cecee222cad3fcececa518386b95a11cb0c9c2dcc6851bae28aa539b11069305aa887a291177bf177ee7b01 0005-CVE-2005-1513.patch
954a905bac5e3bc49f180dc0de7f6ee4c4ae8f94dd400ee4b06d3c944f1ff1cfc44bddccb07ae439f2523ad06fcb89023e57d091737da88f836013757794e931 qmail.run
c0cd244af4d8186305c51b0e93960bdb1ea6ce40f1adf20c4f72419aa7498e35649590919ebd16547a0313676bf9171c9efea2ff8ac3a5c773b18473a972a977 smtpd.run
719c4ce5ad93cddeafbb734cffeec3fd959d3f374e44e1f34e9a25d638303dd97df41642d3df5c7a069a8db47d1e31c32a16ecd2d04b72860c4e00bbba0c9fcf smtpsd.run