summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/sysvinit/APKBUILD8
-rw-r--r--system/sysvinit/utmpx.patch19
2 files changed, 14 insertions, 13 deletions
diff --git a/system/sysvinit/APKBUILD b/system/sysvinit/APKBUILD
index 1168141a4..1532dfd35 100644
--- a/system/sysvinit/APKBUILD
+++ b/system/sysvinit/APKBUILD
@@ -1,16 +1,16 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=sysvinit
-pkgver=3.06
+pkgver=3.11
pkgrel=0
pkgdesc="System V-style init programs"
url="https://savannah.nongnu.org/projects/sysvinit"
arch="all"
license="GPL-2.0+"
+options="!check"
depends="s6-linux-init-common"
makedepends="linux-headers utmps-dev"
install="sysvinit.post-upgrade sysvinit.post-install"
-options="!check"
provides="/sbin/init=0"
subpackages="$pkgname-doc"
source="https://github.com/slicer69/sysvinit/releases/download/$pkgver/$pkgname-$pkgver.tar.xz
@@ -71,7 +71,7 @@ package() {
_install_s6_stuff
}
-sha512sums="dc56ce12f18f7ecde6c9828e72dd8ab7afccd0f88ad4438d6a5b356a30b21e9ba9c796a4b2520a20a0c384f058be6bdb7b9b0df9786bbf65a80dff97c2be733b sysvinit-3.06.tar.xz
+sha512sums="12e2d11b76702b493e8f083e5409b98a1daf41a8d9fb7ef8a36416bb0310d5a26b92eaee0c9396c03cf08842258b953f79541ae147ef730f3bc54530da4d1029 sysvinit-3.11.tar.xz
87668b49690091a227c0384fd2400f1006d24c27cc27a25efa7eba56839ccb1eead00b58ce4b654eab9c0208d68aa2cbb888fd5f2990905845aa9688442a69a0 inittab-2.88
-187dbef4452624ac9035994edbbefa9efd8847ff307002703ca35cfa149780c7e1addb38859dbfdb5dd1e046510418ee493fa3dfdfcc5706c262b1238c7cc39e utmpx.patch
+78d04e33099de13b40243ac0be3e93bf4f2addcee3155c799e711ffec0dc003bf416d956d302aba92ec3e80d2dc6b2d73da0133e3466fce49531f672190ca2d9 utmpx.patch
e52fd49daa5abfc583f1973f3428b1e00a71e7136a8bc6418e94b345d53ef250b3b3c3bee389fe37872b26a78d0957ae852e221428f33b2c728dfd3d50b59634 s6-svscanboot"
diff --git a/system/sysvinit/utmpx.patch b/system/sysvinit/utmpx.patch
index d874f2e7c..e839a0834 100644
--- a/system/sysvinit/utmpx.patch
+++ b/system/sysvinit/utmpx.patch
@@ -43,7 +43,7 @@ diff -ur a/src/dowall.c b/src/dowall.c
diff -ur a/src/halt.c b/src/halt.c
--- a/src/halt.c 2022-05-04 08:18:19.100000000 +0000
+++ b/src/halt.c 2022-05-04 08:18:29.030000000 +0000
-@@ -47,7 +47,7 @@
+@@ -49,7 +49,7 @@
#include <sys/stat.h>
#include <sys/param.h>
#include <stdlib.h>
@@ -52,7 +52,7 @@ diff -ur a/src/halt.c b/src/halt.c
#include <fcntl.h>
#include <string.h>
#include <unistd.h>
-@@ -95,7 +95,7 @@
+@@ -106,7 +106,7 @@
*/
int get_runlevel(void)
{
@@ -61,7 +61,7 @@ diff -ur a/src/halt.c b/src/halt.c
char *r;
int runlevel, status;
-@@ -123,8 +123,8 @@
+@@ -134,8 +134,8 @@
/*
* Find runlevel in utmp.
*/
@@ -72,7 +72,7 @@ diff -ur a/src/halt.c b/src/halt.c
#if RUNLVL_PICKY
/*
* Only accept value if it's from after boottime.
-@@ -136,7 +136,7 @@
+@@ -147,7 +147,7 @@
return (ut->ut_pid & 255);
#endif
}
@@ -96,7 +96,7 @@ diff -ur a/src/init.c b/src/init.c
#include <ctype.h>
#include <stdarg.h>
#include <sys/ttydefaults.h>
-@@ -149,7 +145,7 @@
+@@ -156,7 +152,7 @@
int sleep_time = WAIT_BETWEEN_SIGNALS; /* Sleep time between TERM and KILL */
char *argv0; /* First arguments; show up in ps listing */
int maxproclen; /* Maximal length of argv[0] with \0 */
@@ -105,7 +105,7 @@ diff -ur a/src/init.c b/src/init.c
char *console_dev; /* Console device. */
int pipe_fd = -1; /* /run/initctl */
int did_boot = 0; /* Did we already do BOOT* stuff? */
-@@ -2322,12 +2318,6 @@
+@@ -2332,12 +2328,6 @@
static
void redo_utmp_wtmp(void)
{
@@ -118,7 +118,7 @@ diff -ur a/src/init.c b/src/init.c
if ((wrote_wtmp_reboot == 0) || (wrote_utmp_reboot == 0))
write_utmp_wtmp("reboot", "~~", 0, BOOT_TIME, "~");
-@@ -2862,8 +2852,6 @@
+@@ -2879,8 +2869,6 @@
console_init();
if (!reload) {
@@ -127,7 +127,7 @@ diff -ur a/src/init.c b/src/init.c
/* Close whatever files are open, and reset the console. */
close(0);
close(1);
-@@ -2877,13 +2865,6 @@
+@@ -2894,13 +2882,6 @@
setenv("PATH", PATH_DEFAULT, 1 /* Overwrite */);
/*
@@ -162,7 +162,8 @@ diff -ur a/src/runlevel.c b/src/runlevel.c
char prev;
int status, runlevel;
- if (argc > 1) utmpname(argv[1]);
+- if (argc > 1) utmpname(argv[1]);
++ if (argc > 1) utmpxname(argv[1]);
- setutent();
- while ((ut = getutent()) != NULL) {