summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/utmps/APKBUILD4
-rw-r--r--user/abiword/APKBUILD50
-rw-r--r--user/abiword/fix-black-drawing-regression.patch54
-rw-r--r--user/adwaita-icon-theme/APKBUILD37
-rw-r--r--user/doxygen/APKBUILD10
-rw-r--r--user/gnutls/APKBUILD4
-rw-r--r--user/gobject-introspection/APKBUILD6
-rw-r--r--user/goffice/APKBUILD39
-rw-r--r--user/graphite2/APKBUILD4
-rw-r--r--user/imagemagick/APKBUILD4
-rw-r--r--user/libev/APKBUILD4
-rw-r--r--user/libgphoto2/APKBUILD4
-rw-r--r--user/libqtxdg/APKBUILD4
-rw-r--r--user/lmdb/APKBUILD4
-rw-r--r--user/nasm/APKBUILD4
-rw-r--r--user/php7-apcu/APKBUILD4
-rw-r--r--user/uptimed/APKBUILD39
-rw-r--r--user/uptimed/uptimed.init12
-rw-r--r--user/valgrind/APKBUILD14
-rw-r--r--user/valgrind/realloc.patch24
-rw-r--r--user/wv/APKBUILD36
-rw-r--r--user/xf86-video-r128/APKBUILD7
-rw-r--r--user/xf86-video-r128/xaa.patch21
23 files changed, 354 insertions, 35 deletions
diff --git a/system/utmps/APKBUILD b/system/utmps/APKBUILD
index 2306b8be3..91bb18b19 100644
--- a/system/utmps/APKBUILD
+++ b/system/utmps/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Laurent Bercot <ska-adelie@skarnet.org>
# Maintainer: Laurent Bercot <ska-adelie@skarnet.org>
pkgname=utmps
-pkgver=0.0.1.3
+pkgver=0.0.2.0
pkgrel=2
pkgdesc="A secure utmp/wtmp implementation"
url="https://skarnet.org/software/$pkgname/"
@@ -46,6 +46,6 @@ doc() {
cp -a "$builddir/doc" "$subpkgdir/usr/share/doc/$pkgname"
}
-sha512sums="ec6135e56858f4bb81ca8c5015e605bc1ecc809ef10565207335a86ccee250683fde7c1df999649b6055ef2df900a70cd3d2f9f1066e066c6871a0cfe2785824 utmps-0.0.1.3.tar.gz
+sha512sums="5fffb86f68475f3eadf8da53e3ae40284040cceb644f453218a5fd9e1be081920b5c787283e2578a60922e2feb75c94a7430034a658f7399645fc3bcc9afa28f utmps-0.0.2.0.tar.gz
525d43e3eced30c564e5390fc715b6caa1ae2b6515a9e3bf01263ff3fb9379bd6908ed302d0d50b6568ac36ed44d272dcc44a683f9ae34d586d8ad17023ed6b1 utmpd.run
93e4fae527ada9381e0b0a7ad5de9079e8d88959abd74fa5c0710c30c6153832abb010b57ddf83055ca34c032e7e5c9c1eedceb2f122a11ab20837ab66dcf5e2 wtmpd.run"
diff --git a/user/abiword/APKBUILD b/user/abiword/APKBUILD
new file mode 100644
index 000000000..351961055
--- /dev/null
+++ b/user/abiword/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: multiplexd <multi@in-addr.xyz>
+pkgname=abiword
+pkgver=3.0.2
+pkgrel=0
+pkgdesc="A fully-featured word processor"
+url="https://www.abisource.com"
+arch="all"
+options="!check" # Test suite requires valgrind, etc
+license="GPL-2.0+"
+makedepends="bzip2-dev enchant-dev fribidi-dev goffice-dev gtk+3.0-dev
+ libgsf-dev libjpeg-turbo-dev librsvg-dev libxslt-dev pcre-dev
+ popt-dev wv-dev"
+
+# openxml plugin
+makedepends="$makedepends boost-dev"
+
+# collab plugin
+makedepends="$makedepends gnutls-dev libsoup-dev dbus-glib-dev"
+
+subpackages="$pkgname-dev $pkgname-doc"
+
+_plugins="applix babelfish bmp clarisworks collab docbook eml epub \
+ freetranslation garble gdict gimp google hancom hrtext iscii kword \
+ latex loadbindings mht mif mswrite openwriter openxml opml paint \
+ passepartout pdb pdf presentation s5 sdw t602 urldict wikipedia wml \
+ xslfo"
+
+source="https://www.abisource.com/downloads/$pkgname/$pkgver/source/$pkgname-$pkgver.tar.gz
+ fix-black-drawing-regression.patch"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --enable-shared \
+ --disable-static \
+ --enable-plugins="$_plugins"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="29ce9e80b3b85ab2933e7d39216771d8c4e05db5255eaed0cf8e1d032ffaac2cb1880bf24e754196ad5dae4969a1c2101ce4dc9c1db14604adc2f852b6a17fe3 abiword-3.0.2.tar.gz
+cae9a08047cd97d11acea25a2f0b0ca4e8e4556b462eb476507fa178a7412221839febfeb36bebf491bb94d53525c4584d86230f96c403a7ceb2dec4223be8fe fix-black-drawing-regression.patch"
diff --git a/user/abiword/fix-black-drawing-regression.patch b/user/abiword/fix-black-drawing-regression.patch
new file mode 100644
index 000000000..dbce8c696
--- /dev/null
+++ b/user/abiword/fix-black-drawing-regression.patch
@@ -0,0 +1,54 @@
+From cec2fda355b67b5b814a803c5ed128c425cbb030 Mon Sep 17 00:00:00 2001
+From: Hubert Figuiere <hub@figuiere.net>
+Date: Thu, 8 Dec 2016 02:03:10 +0000
+Subject: [PATCH] Bug 13815 - draw event should return TRUE
+
+This fix the black drawing regression with Gtk3.22
+
+git-svn-id: svn+ssh://svn.abisource.com/svnroot/abiword/branches/ABI-3-0-0-STABLE@35394 bcba8976-2d24-0410-9c9c-aab3bd5fdfd6
+---
+ src/af/xap/gtk/xap_UnixFrameImpl.cpp | 6 +++---
+ src/af/xap/gtk/xap_UnixFrameImpl.h | 4 ++--
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/src/af/xap/gtk/xap_UnixFrameImpl.cpp b/src/af/xap/gtk/xap_UnixFrameImpl.cpp
+index 780000e..10f8e00 100644
+--- a/src/af/xap/gtk/xap_UnixFrameImpl.cpp
++++ b/src/af/xap/gtk/xap_UnixFrameImpl.cpp
+@@ -1208,9 +1208,9 @@ gint XAP_UnixFrameImpl::_fe::delete_event(GtkWidget * w, GdkEvent * /*event*/, g
+ }
+
+ #if GTK_CHECK_VERSION(3,0,0)
+-gint XAP_UnixFrameImpl::_fe::draw(GtkWidget * w, cairo_t * cr)
++gboolean XAP_UnixFrameImpl::_fe::draw(GtkWidget * w, cairo_t * cr)
+ #else
+-gint XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
++gboolean XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
+ #endif
+ {
+ XAP_UnixFrameImpl * pUnixFrameImpl = static_cast<XAP_UnixFrameImpl *>(g_object_get_data(G_OBJECT(w), "user_data"));
+@@ -1243,7 +1243,7 @@ gint XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
+ pView->draw(&rClip);
+ #endif
+ }
+- return FALSE;
++ return TRUE;
+ }
+
+ static bool bScrollWait = false;
+diff --git a/src/af/xap/gtk/xap_UnixFrameImpl.h b/src/af/xap/gtk/xap_UnixFrameImpl.h
+index 30ee5d8..a0ff57f 100644
+--- a/src/af/xap/gtk/xap_UnixFrameImpl.h
++++ b/src/af/xap/gtk/xap_UnixFrameImpl.h
+@@ -152,9 +152,9 @@ class XAP_UnixFrameImpl : public XAP_FrameImpl
+ static gint key_release_event(GtkWidget* w, GdkEventKey* e);
+ static gint delete_event(GtkWidget * w, GdkEvent * /*event*/, gpointer /*data*/);
+ #if GTK_CHECK_VERSION(3,0,0)
+- static gint draw(GtkWidget * w, cairo_t * cr);
++ static gboolean draw(GtkWidget * w, cairo_t * cr);
+ #else
+- static gint expose(GtkWidget * w, GdkEventExpose* pExposeEvent);
++ static gboolean expose(GtkWidget * w, GdkEventExpose* pExposeEvent);
+ #endif
+ static gint do_ZoomUpdate( gpointer /* xap_UnixFrame * */ p);
+ static void vScrollChanged(GtkAdjustment * w, gpointer /*data*/);
diff --git a/user/adwaita-icon-theme/APKBUILD b/user/adwaita-icon-theme/APKBUILD
new file mode 100644
index 000000000..ae769910e
--- /dev/null
+++ b/user/adwaita-icon-theme/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=adwaita-icon-theme
+pkgver=3.31.1
+pkgrel=0
+pkgdesc="GNOME system icon set"
+url="https://www.gnome.org/"
+arch="noarch"
+license="CC-BY-SA-3.0 OR LGPL-3.0-only"
+depends=""
+makedepends=""
+subpackages=""
+source="https://ftp.gnome.org/pub/gnome/sources/adwaita-icon-theme/3.31/adwaita-icon-theme-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="aa73637cca8189e7141c0554ba7bda1234cbe192710463c9ad1c81b46a410b21e5fb48a090917324163ee4c0301fb1380d18ef5f9bb8faf1b401a52af18c60b1 adwaita-icon-theme-3.31.1.tar.xz"
diff --git a/user/doxygen/APKBUILD b/user/doxygen/APKBUILD
index 382530d4c..b1f5414e2 100644
--- a/user/doxygen/APKBUILD
+++ b/user/doxygen/APKBUILD
@@ -1,6 +1,8 @@
# Maintainer:
pkgname=doxygen
-pkgver=1.8.14
+pkgver=1.8.15
+_pkgver=${pkgver%.*.*}_${pkgver#*.}
+_pkgver=${_pkgver%.*}_${pkgver#*.*.}
pkgrel=0
pkgdesc="A documentation system for C++, C, Java, IDL, and PHP"
url="http://www.doxygen.org/"
@@ -9,10 +11,10 @@ license="GPL-2.0-only"
depends=""
makedepends="bison cmake coreutils flex perl python3"
checkdepends="libxml2-utils"
-subpackages=""
-source="http://ftp.stack.nl/pub/users/dimitri/doxygen-$pkgver.src.tar.gz
+source="https://github.com/doxygen/doxygen/archive/Release_$_pkgver.tar.gz
doxygen-1.8.14-install.patch
"
+builddir="$srcdir/doxygen-Release_$_pkgver"
build() {
cd "$builddir"
@@ -38,5 +40,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="5fac7e457a51b1f8e39fb65de5e0c07633e573f74e876580e7bcad5693540d6970fde1b2cb799a4df6ab9dfca951ece15b76b3010134d7658db3500183bea85c doxygen-1.8.14.src.tar.gz
+sha512sums="bc3ea295b894a73324bf41408d05332bc480638840b62fac6f12493be15de29eedd4e7f2d7ad61e0db36623887ca364eda5eb5e46d9b91a4241240cb380b07d5 Release_1_8_15.tar.gz
725a29a6f21ffc8ec6ca8ed6d746a69cc78060e97704c7fe909abee603ba0a99f27dc3b80c414afd886d0ee81d9948b13f29c43f7db2e00aae8c0c3a32aa9ec1 doxygen-1.8.14-install.patch"
diff --git a/user/gnutls/APKBUILD b/user/gnutls/APKBUILD
index 233bbcb52..de26ee5e5 100644
--- a/user/gnutls/APKBUILD
+++ b/user/gnutls/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer:
pkgname=gnutls
-pkgver=3.6.4
+pkgver=3.6.5
pkgrel=0
pkgdesc="A TLS protocol implementation"
url="http://www.gnutls.org/"
@@ -72,5 +72,5 @@ xx() {
mv "$pkgdir"/usr/lib/lib*xx.so.* "$subpkgdir"/usr/lib/
}
-sha512sums="f39ac09b48ebf230653cbf82b29ded39a1403313067135495b23f428b35783f9ef073993157d1f284678abedd19e2cf1fd01af843001b88320ca17b346b219ab gnutls-3.6.4.tar.xz
+sha512sums="127f053ce45c63cd745fa5a654a2d8e4fbc322f5e17dcc3740fb2e7b376dd18dad59318d66e6e93e37d6a179fca4b35cf2ae62d13be5645cd2d06badd79d4dce gnutls-3.6.5.tar.xz
abc24ee59cc67805fe953535b0bae33080fc8b0bf788304377f6d10ec8c162c4cf203a69c98a4ba3483b4c60ed7a204433cc7db9b8190eddb0d68f6fb6dad52d gnulib-tests-dont-require-gpg-passphrase.patch"
diff --git a/user/gobject-introspection/APKBUILD b/user/gobject-introspection/APKBUILD
index 85345d331..c8f5fc03a 100644
--- a/user/gobject-introspection/APKBUILD
+++ b/user/gobject-introspection/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer:
pkgname=gobject-introspection
-pkgver=1.58.2
-pkgrel=1
+pkgver=1.58.3
+pkgrel=0
pkgdesc="Introspection system for GObject-based libraries"
url="https://wiki.gnome.org/action/show/Projects/GObjectIntrospection"
arch="all"
@@ -48,5 +48,5 @@ dev() {
replaces="gobject-introspection"
}
-sha512sums="b516527a910702b26f8034ded463bdd28bb9db782ac77947ac2178ae3a41bd9e0390fff6155aca6e9ec92c6cf051314134322efae6937bd9cbcb4033df65c677 gobject-introspection-1.58.2.tar.xz
+sha512sums="0811cd08e224975b3aa55ae89d648fc65f3105cae8a077a5671593d84743b1db28e9fbffe53fc86a2b3e82ea98c35f3daae033d3df07c7020cc3bf8b5d94f796 gobject-introspection-1.58.3.tar.xz
106e36c04ab9035b92d7f34251c3af2c37fbbc538d2b96027735565df74314eb90a93288f1bc62c08742ff6ba525d72ea03306e3b32f48724a09548788466d3d we-are-in-a-pickle.patch"
diff --git a/user/goffice/APKBUILD b/user/goffice/APKBUILD
new file mode 100644
index 000000000..0b5fc833b
--- /dev/null
+++ b/user/goffice/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: multiplexd <multi@in-addr.xyz>
+pkgname=goffice
+pkgver=0.10.44
+pkgrel=0
+pkgdesc="Library of document-centric objects and utilities built on top of GLib and Gtk+"
+url="https://www.gnome.org"
+arch="all"
+license="(GPL-2.0-only OR GPL-3.0-only) AND GPL-2.0+ AND MIT"
+makedepends="librsvg-dev intltool gtk+2.0-dev libtool gtk-doc
+ libxslt-dev gobject-introspection-dev glib-dev libgsf-dev cairo-dev
+ libxml2-dev gtk+3.0-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-introspection
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="9e86440afaee4d6eadd31c328a13dc54fb4056dfc70ef0196d83bada5f05eb4fc12daf35fc4e79ea6ebfe8a97dc6ed74b50e514f9d27f08bff776ab898f1c71d goffice-0.10.44.tar.xz"
diff --git a/user/graphite2/APKBUILD b/user/graphite2/APKBUILD
index 403b60522..33ff919e7 100644
--- a/user/graphite2/APKBUILD
+++ b/user/graphite2/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=graphite2
_realname=${pkgname/2/}
-pkgver=1.3.12
+pkgver=1.3.13
pkgrel=0
pkgdesc="Text processing engine for complex languages"
url="http://graphite.sil.org/"
@@ -44,5 +44,5 @@ package() {
make DESTDIR="$pkgdir/" install
}
-sha512sums="d0aed05b54445a9664435d5aef9d78fc07a89be23d18b7b1339d37412b09faca6da3dc1e72524e4b114724b76aa6f36934e8ab1a01bd0752e353efa075c9e643 graphite2-1.3.12.tar.gz
+sha512sums="8e2c6047a66b4d8873842de6b9b1909d326512b47a04f483b3a6113b97fd0d47e0da7cf9ecf96e060ca06e5288b49f1300e2fd7165d2d82d6a8eb8cb7d53d33f graphite2-1.3.13.tar.gz
4ef5414e6d554bb8d6ead435e38d061a073f350c313b7141158bb68332f5f57ca5250385875a387b828bb657964588e974143b96b5e11c2cd314871e7baddb88 graphite2-1.2.0-cmakepath.patch"
diff --git a/user/imagemagick/APKBUILD b/user/imagemagick/APKBUILD
index 9f8cdbae9..111b178df 100644
--- a/user/imagemagick/APKBUILD
+++ b/user/imagemagick/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname=imagemagick
-pkgver=7.0.8.17
+pkgver=7.0.8.23
_abiver=7
_pkgver=${pkgver%.*}-${pkgver##*.}
pkgrel=0
@@ -81,4 +81,4 @@ _cxx() {
mv "$pkgdir"/usr/lib/libMagick++*.so.* "$subpkgdir"/usr/lib/
}
-sha512sums="b55408059f85b6fcecae40ccb0a924d73936f6877454cd5ed03e9e0b338ddc9954e0b4c089a2c7545d444deaba24fe90c69a3bb218a6d6165ebe782f6e9413e1 ImageMagick-7.0.8-17.tar.xz"
+sha512sums="8063903d9992d89db302f9f95acdf112d3d38609289af5fcef66acf7f684b3223fea64829a0f6dd15f71f6b6b52f74d3c716c2217ffd83558c5b8a4b7a4aec3f ImageMagick-7.0.8-23.tar.xz"
diff --git a/user/libev/APKBUILD b/user/libev/APKBUILD
index d1b32c7da..e13d861ef 100644
--- a/user/libev/APKBUILD
+++ b/user/libev/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer:
pkgname=libev
-pkgver=4.24
+pkgver=4.25
pkgrel=0
pkgdesc="Event dispatch library"
url="http://software.schmorp.de/pkg/libev.html"
@@ -36,5 +36,5 @@ package() {
rm "$pkgdir"/usr/include/event.h
}
-sha512sums="e4cb3b5dd4b9828d5b8da840c73ae4604258a8c4330aafa5472298b83bf944628f36918f0ddd47d9069d255639f0b24a2cf8d349f0644ffd50de823bcb54a31a libev-4.24.tar.gz
+sha512sums="83455d4dcb626a28d8477aaea27cdee6bc88b273fae926a57eed9f6a59d4b0ea2eef0f41ad09ff711aea2956ed83a591aa53cfe8aa242f7d0a4da19180d764c4 libev-4.25.tar.gz
b5bc1b5ed1e605cd45a01adce70c1a97188c0b46a36333f12eccd4407c95d96f18adff90ee8c5733c1783a36b4adc5ef67d6b470104339a1ac5c4539a2a4599e libev-4.11-Add-pkgconfig-support.patch"
diff --git a/user/libgphoto2/APKBUILD b/user/libgphoto2/APKBUILD
index 76e277987..7bd75969d 100644
--- a/user/libgphoto2/APKBUILD
+++ b/user/libgphoto2/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer:
pkgname=libgphoto2
-pkgver=2.5.21
+pkgver=2.5.22
pkgrel=0
pkgdesc="Digital camera library"
url="http://www.gphoto.org"
@@ -46,4 +46,4 @@ package() {
"$pkgdir/lib/udev/rules.d/54-gphoto.rules"
}
-sha512sums="08e5d6a7b7603b92d3e24d3ee7843aa980525f25b7315e7ca6f17a6a1e059748471d9cf0b19392ea965cf0eb094386be275fcb5b97de1d9e7df6c66fe92a81c6 libgphoto2-2.5.21.tar.bz2"
+sha512sums="8f02c460324c115810f56a9408ecba7aabb801947249c1ee79f0f0a1db1d785d34992508232bad7af112aed2dfc6b213365cee694dd0e7d5edf4072c63fa01cb libgphoto2-2.5.22.tar.bz2"
diff --git a/user/libqtxdg/APKBUILD b/user/libqtxdg/APKBUILD
index e49fb0742..4c1c24f96 100644
--- a/user/libqtxdg/APKBUILD
+++ b/user/libqtxdg/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=libqtxdg
pkgver=3.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Qt5-based library implementing the XDG spec"
url="https://lxqt.org"
arch="all"
@@ -23,7 +23,7 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
- -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
-DBUILD_TESTS=True \
diff --git a/user/lmdb/APKBUILD b/user/lmdb/APKBUILD
index 149173dca..d59738f6e 100644
--- a/user/lmdb/APKBUILD
+++ b/user/lmdb/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Olivier Mauras <olivier@mauras.ch>
# Maintainer:
pkgname=lmdb
-pkgver=0.9.22
+pkgver=0.9.23
pkgrel=0
pkgdesc="Lightning Memory-Mapped Database"
url="http://symas.com/mdb/"
@@ -32,5 +32,5 @@ tools() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
-sha512sums="49afca13b9683ed571c274380bb5e111236903b12d19bcb8781d6bbc00f711766b0d62de0b36536c85309cc9ff9e9d0aaa708e27bae9be6cfcaed8ba91e5545d LMDB_0.9.22.tar.gz
+sha512sums="47466a96ce288d18d489acf1abf811aa973649848a4cac31f71e1f25ea781a055ebd6616d2d630214b2df2f146f12609c82d65be0196f49d6b46a6c96464e120 LMDB_0.9.23.tar.gz
151022cad94d2138146e3cd36622171f07fb03cc66d116ac9ce766c61a8b1aa65b521bfda88b27456204f53ecd430bdeddb4d7786956a12ed0cd53f8323ffd03 lmdb_make.patch"
diff --git a/user/nasm/APKBUILD b/user/nasm/APKBUILD
index 2c6f00c52..81aa6a996 100644
--- a/user/nasm/APKBUILD
+++ b/user/nasm/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer:
pkgname=nasm
-pkgver=2.14
+pkgver=2.14.02
pkgrel=0
pkgdesc="80x86 assembler designed for portability and modularity"
url="https://www.nasm.us/"
@@ -31,4 +31,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="9a87935b90a8eaa5adcad7efc058e429483d451c8acb8fd051f0dca760eb649839f40e45f91a551ecf89da4320a32299daa21f8ecb9384a18a5359ccb0e74894 nasm-2.14.tar.bz2"
+sha512sums="71e3d44736493b1a56d4230bc2e5519e858aaadde5d89a692f1472fad6755084460e36b42852707f4c862eff75d3f2c232aedcc4e61e9d9ffcc8c9ca6498292b nasm-2.14.02.tar.bz2"
diff --git a/user/php7-apcu/APKBUILD b/user/php7-apcu/APKBUILD
index aa487a4e6..4398a424d 100644
--- a/user/php7-apcu/APKBUILD
+++ b/user/php7-apcu/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=php7-apcu
_pkgname=${pkgname#php7-}
-pkgver=5.1.14
+pkgver=5.1.15
pkgrel=0
pkgdesc="Userland cache for PHP"
url="https://github.com/krakjoe/apcu"
@@ -39,4 +39,4 @@ package() {
make INSTALL_ROOT="$pkgdir" install
}
-sha512sums="fe39d46d2905732296a70b79ab0977909c9ff7cb571118f35831e75a9a018edf909992954e39f79cc4710f9fdec93e6067068afea02304345e4ff6babc65a7d0 php7-apcu-5.1.14.tar.gz"
+sha512sums="d95ab6a8a073acfc6af2f83b038f68e4150a1eb518369c163f4d1bc0c8b006c84754759fa9b72ac6f7ca008c27802a3a2aca14ae9d7ca23c02078d720a530b1c php7-apcu-5.1.15.tar.gz"
diff --git a/user/uptimed/APKBUILD b/user/uptimed/APKBUILD
new file mode 100644
index 000000000..ace7b6884
--- /dev/null
+++ b/user/uptimed/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=uptimed
+pkgver=0.4.1
+pkgrel=0
+pkgdesc='System uptime record daemon'
+arch="all"
+options="!check" # No tests
+url="https://github.com/rpodgorny/uptimed"
+license="GPL-2.0-only"
+subpackages="$pkgname-doc $pkgname-openrc"
+makedepends="autoconf automake libtool"
+source="$pkgname-$pkgver.tar.gz::https://github.com/rpodgorny/uptimed/archive/v$pkgver.tar.gz
+ uptimed.init"
+
+build() {
+ cd "$builddir"
+ autoreconf -vif
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
+ mv "$pkgdir"/etc/uptimed.conf-dist \
+ "$pkgdir"/etc/uptimed.conf
+ install -Dm755 "$srcdir"/uptimed.init \
+ "$pkgdir"/etc/init.d/uptimed
+}
+
+sha512sums="5dfe79aebab8c8daca3a3ec88d54e312446fc7cf8b54ef1414cbfcb3fb25053ef31235de4b42cb14fc7352965b77ca2875c753b97b4d61178792a5484715e23a uptimed-0.4.1.tar.gz
+0884e9f5ace5a69b8eea4401c7f3b84f0a434f0ceb2b920919e83f318eb9e54182932de174cf1666ddddbab84c146781f3dd78571e80cc274963a72bf4f53a6b uptimed.init"
diff --git a/user/uptimed/uptimed.init b/user/uptimed/uptimed.init
new file mode 100644
index 000000000..deba54128
--- /dev/null
+++ b/user/uptimed/uptimed.init
@@ -0,0 +1,12 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+description="uptimed - a daemon to record uptime records"
+pidfile="/var/run/uptimed/uptimed.pid"
+command="/usr/sbin/uptimed"
+command_args="-p ${pidfile}"
+
+start_pre() {
+ uptimed -b
+}
diff --git a/user/valgrind/APKBUILD b/user/valgrind/APKBUILD
index d79ba75c4..fc710b4b2 100644
--- a/user/valgrind/APKBUILD
+++ b/user/valgrind/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=valgrind
pkgver=3.13.0
-pkgrel=4
+pkgrel=5
pkgdesc="A tool to help find memory-management problems in programs"
url="http://valgrind.org/"
arch="all"
@@ -15,10 +15,11 @@ makedepends="autoconf automake libtool bash perl cmd:which"
options="!strip !check"
subpackages="$pkgname-dev $pkgname-doc"
source="ftp://sourceware.org/pub/$pkgname/$pkgname-$pkgver.tar.bz2
- uclibc.patch
- arm.patch
0001-Ensure-ELFv2-is-supported-on-PPC64.patch
+ arm.patch
+ realloc.patch
suppressions.patch
+ uclibc.patch
"
prepare() {
@@ -65,7 +66,8 @@ package() {
}
sha512sums="34e1013cd3815d30a459b86220e871bb0a6209cc9e87af968f347083693779f022e986f211bdf1a5184ad7370cde12ff2cfca8099967ff94732970bd04a97009 valgrind-3.13.0.tar.bz2
-d59a10db9037e120df2ee94a103402ca95a79abee9d8be63e4e1bca29c82dca775cc402a79b854ec11a2160a4d2da202c237369418e221d1925267ea2613fd5d uclibc.patch
-9ee297d1b2b86891584443ad0caadc4977e1447979611ccf1cc55dbee61911b0b063bc4ad936d86c451cedae410cb3219b5a088b2ad0aa17df182d564fe36cfe arm.patch
71afb12748f69f0976a299c65572818b70cbce5d04f230a49a50f114351d8083c59a9e197cefbcb9145806797ff4d1d54488f50342b680c9a2b76e4a7f7cf305 0001-Ensure-ELFv2-is-supported-on-PPC64.patch
-d011b2769d35ca3206967e6dac9f3fb24a6496e5bbfdc73342382245c89375b09d6948b10ba3cf8aa0050c79c0dd13b75764aec0ec5c6ac479fa930941067747 suppressions.patch"
+9ee297d1b2b86891584443ad0caadc4977e1447979611ccf1cc55dbee61911b0b063bc4ad936d86c451cedae410cb3219b5a088b2ad0aa17df182d564fe36cfe arm.patch
+57086a768f3876b26b0e507bc159a73f0955f03d5af8cc30e21103e348ca67f2e58b5555a5a97f299751c6602692ad43d8346bb68a80917d740fb4d65bba9665 realloc.patch
+d011b2769d35ca3206967e6dac9f3fb24a6496e5bbfdc73342382245c89375b09d6948b10ba3cf8aa0050c79c0dd13b75764aec0ec5c6ac479fa930941067747 suppressions.patch
+d59a10db9037e120df2ee94a103402ca95a79abee9d8be63e4e1bca29c82dca775cc402a79b854ec11a2160a4d2da202c237369418e221d1925267ea2613fd5d uclibc.patch"
diff --git a/user/valgrind/realloc.patch b/user/valgrind/realloc.patch
new file mode 100644
index 000000000..d0eb795b8
--- /dev/null
+++ b/user/valgrind/realloc.patch
@@ -0,0 +1,24 @@
+--- valgrind-3.13.0/coregrind/m_replacemalloc/vg_replace_malloc.c
++++ valgrind-3.13.0/coregrind/m_replacemalloc/vg_replace_malloc.c
+@@ -765,13 +765,15 @@ static void init(void);
+ DO_INIT; \
+ MALLOC_TRACE("realloc(%p,%llu)", ptrV, (ULong)new_size ); \
+ \
+- if (ptrV == NULL) \
+- /* We need to call a malloc-like function; so let's use \
+- one which we know exists. */ \
+- return VG_REPLACE_FUNCTION_EZU(10010,VG_Z_LIBC_SONAME,malloc) \
+- (new_size); \
++ if (ptrV == NULL) { \
++ TRIGGER_MEMCHECK_ERROR_IF_UNDEFINED(new_size); \
++ v = (void*)VALGRIND_NON_SIMD_CALL1( info.tl_malloc, new_size ); \
++ MALLOC_TRACE(" = %p\n", v ); \
++ return v; \
++ } \
+ if (new_size <= 0) { \
+- VG_REPLACE_FUNCTION_EZU(10050,VG_Z_LIBC_SONAME,free)(ptrV); \
++ if (ptrV != NULL) \
++ VALGRIND_NON_SIMD_CALL1( info.tl_free, ptrV ); \
+ MALLOC_TRACE(" = 0\n"); \
+ return NULL; \
+ } \
diff --git a/user/wv/APKBUILD b/user/wv/APKBUILD
new file mode 100644
index 000000000..ec9a0a081
--- /dev/null
+++ b/user/wv/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: multiplexd <multi@in-addr.xyz>
+pkgname=wv
+pkgver=1.2.9
+pkgrel=0
+pkgdesc="A library that can load and parse Word 2000, 97, 95 and 6 file formats"
+url="https://sourceforge.net/projects/wvware"
+arch="all"
+options="!check" # No test suite.
+license="GPL-2.0+ AND RSA-MD5"
+subpackages="$pkgname-dev $pkgname-doc"
+depends=""
+makedepends="libgsf-dev libpng-dev bzip2-dev"
+source="https://www.abisource.com/downloads/wv/$pkgver/wv-$pkgver.tar.gz"
+
+prepare() {
+ update_config_sub
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="ae5c762012595ce8922bfda8749ad3e9cb055edab30152c3a5feaaf3ca6601f357d1e301b179e9a5860cd99452dd6e63e5f44f5bcc12f8db148bdd334e0200a5 wv-1.2.9.tar.gz"
diff --git a/user/xf86-video-r128/APKBUILD b/user/xf86-video-r128/APKBUILD
index 0dd94af4e..094b11633 100644
--- a/user/xf86-video-r128/APKBUILD
+++ b/user/xf86-video-r128/APKBUILD
@@ -10,7 +10,9 @@ license="X11 AND MIT"
depends=""
makedepends="util-macros xorgproto-dev xorg-server-dev"
subpackages="$pkgname-doc"
-source="https://www.x.org/releases/individual/driver/xf86-video-r128-$pkgver.tar.bz2"
+source="https://www.x.org/releases/individual/driver/xf86-video-r128-$pkgver.tar.bz2
+ xaa.patch
+ "
build() {
cd "$builddir"
@@ -34,4 +36,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="0e667e2cfa8a87a00846361d86528c93754c403c812b66798953fa4c857b2143b2c4c44885da467e7f910d8cb910b69492cdcb6f25e2197bae6617364d152e38 xf86-video-r128-6.12.0.tar.bz2"
+sha512sums="0e667e2cfa8a87a00846361d86528c93754c403c812b66798953fa4c857b2143b2c4c44885da467e7f910d8cb910b69492cdcb6f25e2197bae6617364d152e38 xf86-video-r128-6.12.0.tar.bz2
+45104ea2da49933f6d40834badb58c4db8706a9bf3080df7b2538f4cb1e7964b900c10b47386b9502bb4abee796b5f40f30252d1526e26d860b833c4dabca8ba xaa.patch"
diff --git a/user/xf86-video-r128/xaa.patch b/user/xf86-video-r128/xaa.patch
new file mode 100644
index 000000000..3ede81203
--- /dev/null
+++ b/user/xf86-video-r128/xaa.patch
@@ -0,0 +1,21 @@
+--- xf86-video-r128-6.12.0/src/r128_driver.c.old 2019-01-05 15:59:11.340000000 +0000
++++ xf86-video-r128-6.12.0/src/r128_driver.c 2019-01-05 16:16:10.810000000 +0000
+@@ -1887,14 +1887,16 @@
+ }
+
+ if (!info->noAccel) {
++#ifdef HAVE_XAA_H
+ if (R128XAAAccelInit(pScreen)) {
+ info->accelOn = TRUE;
+ xf86DrvMsg(pScrn->scrnIndex, X_INFO,
+ "XAA acceleration enabled.\n");
+- } else {
++ } else
++#endif
+ xf86DrvMsg(pScrn->scrnIndex, X_INFO,
+ "Acceleration disabled.\n");
+- }
++
+ }
+ }
+ }