summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--bootstrap/classpath-0.99-r1/APKBUILD50
-rw-r--r--bootstrap/classpath-0.99-r1/add-aarch64-endianness.patch29
-rw-r--r--bootstrap/ecj-3.2/APKBUILD42
3 files changed, 121 insertions, 0 deletions
diff --git a/bootstrap/classpath-0.99-r1/APKBUILD b/bootstrap/classpath-0.99-r1/APKBUILD
new file mode 100644
index 000000000..3b2402d54
--- /dev/null
+++ b/bootstrap/classpath-0.99-r1/APKBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Horst Burkhardt <horst@adelielinux.org>
+pkgname=classpath
+pkgver=0.99
+pkgrel=2
+pkgdesc="GNU Classpath Java Class Library"
+url="https://www.gnu.org/software/classpath/"
+arch="all"
+options="!check" #No test suite provided.
+license="GPL-2.0-with-classpath-exception"
+depends=""
+makedepends="zlib-dev fastjar zip jikes libltdl"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz
+ add-aarch64-endianness.patch"
+
+build() {
+ export JAVAC="/usr/bin/ecj-3.2"
+ export JAVACFLAGS="-nowarn"
+ export gjl_java_args="-Xmx768M"
+ export CLASSPATH="/usr/share/classpath/glibj.zip"
+ ./configure \
+ --disable-Werror \
+ --disable-gmp \
+ --disable-gtk-peer \
+ --disable-gconf-peer \
+ --disable-plugin \
+ --disable-dssi \
+ --enable-jni \
+ --disable-alsa \
+ --disable-dependency-tracking \
+ --disable-gjdoc \
+ --disable-examples \
+ --with-glibj-dir=/usr/lib/classpath-0.99/share/classpath \
+ --prefix=/usr/lib/classpath-0.99 \
+ --datadir=/usr/lib/classpath-0.99 \
+ --datarootdir=/usr/lib/classpath-0.99/share \
+ --mandir=/usr/lib/classpath-0.99/share/man \
+ --infodir=/usr/lib/classpath-0.99/share/info
+ make DESTDIR="$pkgdir"
+ }
+
+package() {
+ make DESTDIR="$pkgdir" install
+ mv "$pkgdir"/usr/lib/classpath-0.99/share/info "$pkgdir"/usr/lib/classpath-0.99/share
+ mv "$pkgdir"/usr/lib/classpath-0.99/share/man "$pkgdir"/usr/lib/classpath-0.99/share
+ ln -s "$pkgdir"/usr/lib/classpath-0.99/bin/gjavah "$pkgdir"/usr/bin/gjavah
+ }
+
+sha512sums="d8f38677ecc6a0f4b26197ab16e9888c51043364141675ad69684828e2d0ecb93122249672e2e7997aea817cc4aac68c17ccf59bf8913afe81e9536bee6b73ac classpath-0.99.tar.gz
+d3aeabaa4e7adcacc15d0122a0bd27621e89e2ec58d1af3ace620f7d923676e9d323c27f387790a66fec68db91174f9b14df4697f04ad270820259f749a1ae51 add-aarch64-endianness.patch"
diff --git a/bootstrap/classpath-0.99-r1/add-aarch64-endianness.patch b/bootstrap/classpath-0.99-r1/add-aarch64-endianness.patch
new file mode 100644
index 000000000..6fdac0c4f
--- /dev/null
+++ b/bootstrap/classpath-0.99-r1/add-aarch64-endianness.patch
@@ -0,0 +1,29 @@
+This is modeled after the ia64 support. Aarch64 can be either big endian
+or little endian, so we add the case for both.
+
+---
+ native/fdlibm/ieeefp.h | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/native/fdlibm/ieeefp.h b/native/fdlibm/ieeefp.h
+index 1a9740f..73455c0 100644
+--- a/native/fdlibm/ieeefp.h
++++ b/native/fdlibm/ieeefp.h
+@@ -27,6 +27,14 @@
+ #endif
+ #endif
+
++#ifdef __aarch64__
++#ifdef __BIG_ENDIAN__
++#define __IEEE_BIG_ENDIAN
++#else
++#define __IEEE_LITTLE_ENDIAN
++#endif
++#endif
++
+ #ifdef __hppa__
+ #define __IEEE_BIG_ENDIAN
+ #endif
+--
+2.16.3
+
diff --git a/bootstrap/ecj-3.2/APKBUILD b/bootstrap/ecj-3.2/APKBUILD
new file mode 100644
index 000000000..e0c57ff39
--- /dev/null
+++ b/bootstrap/ecj-3.2/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Horst Burkhardt <horst@adelielinux.org>
+pkgname=ecj
+pkgver=3.2.2
+pkgrel=0
+pkgdesc="A Java compiler implemented in Java, for the Eclipse IDE"
+url="https://www.eclipse.org/"
+arch="all"
+options="!check" #No test suite provided.
+license="GPL-2.0+"
+depends="jamvm=1.5.1-r0"
+makedepends="ant=1.8.4-r0 zip"
+subpackages="$pkgname-dev"
+source="https://archive.eclipse.org/eclipse/downloads/drops/R-$pkgver-200702121330/eclipse-sourceBuild-srcIncluded-$pkgver.zip
+ "
+
+prepare() {
+ rm -v lib/classes.zip
+ default_prepare
+ autoreconf -vif
+ }
+
+build() {
+ export JAVAC="/usr/bin/jikes"
+ ./configure \
+ --enable-ffi \
+ --disable-int-caching \
+ --enable-runtime-reloc-checks \
+ --prefix=/usr/$pkgname \
+ --datadir=/usr/share \
+ --bindir=/usr/bin \
+ --with-classpath-install-dir=/usr
+ make
+ }
+
+package() {
+ make DESTDIR="$pkgdir" install
+ ln -s jamvm "$pkgdir"/usr/bin/java
+ ln -s jikes "$pkgdir"/usr/bin/javac
+ ln -s fastjar "$pkgdir"/usr/bin/jar
+ }
+
+sha512sums="74a7e66f4411e1856d35c396ffb12124ac5ad622e5cb401558b24aa675d158efbc1522534e962786adf6ae8ff328d394f25f8f28d6b6a9e5531bc4abf241c8f3 eclipse-sourceBuild-srcIncluded-3.2.2.zip"