summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/apk-tools/0001-solver-allow-names-with-only-one-provider-to-be-auto.patch57
-rw-r--r--system/apk-tools/APKBUILD4
-rw-r--r--system/apk-tools/list.patch22
-rw-r--r--system/apk-tools/openssl-compat.patch11
-rw-r--r--system/psmisc/APKBUILD5
-rw-r--r--system/psmisc/musl_ptregs.patch6
-rw-r--r--user/enchant/APKBUILD1
-rw-r--r--user/gpgme/APKBUILD9
-rw-r--r--user/gpgme/test32bit.patch93
-rw-r--r--user/libreoffice/APKBUILD4
-rw-r--r--user/libreoffice/boost.patch17
-rw-r--r--user/libsass/APKBUILD2
-rw-r--r--user/pulseaudio/APKBUILD2
-rw-r--r--user/qt5-qtscript/APKBUILD9
-rw-r--r--user/qt5-qtscript/gcc8.patch238
-rw-r--r--user/sassc/APKBUILD2
16 files changed, 399 insertions, 83 deletions
diff --git a/system/apk-tools/0001-solver-allow-names-with-only-one-provider-to-be-auto.patch b/system/apk-tools/0001-solver-allow-names-with-only-one-provider-to-be-auto.patch
deleted file mode 100644
index 107676e93..000000000
--- a/system/apk-tools/0001-solver-allow-names-with-only-one-provider-to-be-auto.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From 0dcbd933c8d3d305395a99b7b1690a187ce5ec8c Mon Sep 17 00:00:00 2001
-From: William Pitcock <nenolod@dereferenced.org>
-Date: Wed, 21 Feb 2018 15:35:53 +0000
-Subject: [PATCH] solver: allow names with only one provider to be autoselected
- regardless of priority
-
----
- src/solver.c | 5 +++--
- test/provides.repo | 9 ++++++++-
- 2 files changed, 11 insertions(+), 3 deletions(-)
-
-diff --git a/src/solver.c b/src/solver.c
-index 91e5958..d27a7a3 100644
---- a/src/solver.c
-+++ b/src/solver.c
-@@ -671,11 +671,12 @@ static void select_package(struct apk_solver_state *ss, struct apk_name *name)
- (!p->pkg->ss.iif_triggered ||
- !p->pkg->ss.tag_ok))
- continue;
-- /* Virtual packages without provider_priority cannot be autoselected */
-+ /* Virtual packages without provider_priority cannot be autoselected,
-+ * unless there is only one provider */
- if (p->version == &apk_null_blob &&
- p->pkg->name->auto_select_virtual == 0 &&
- p->pkg->name->ss.requirers == 0 &&
-- p->pkg->provider_priority == 0)
-+ (p->pkg->provider_priority == 0 && name->providers->num > 1))
- continue;
- if (compare_providers(ss, p, &chosen) > 0)
- chosen = *p;
-diff --git a/test/provides.repo b/test/provides.repo
-index 58bd416..358151e 100644
---- a/test/provides.repo
-+++ b/test/provides.repo
-@@ -82,7 +82,7 @@ P:conflicted-provider-b
- V:0.1
- S:1
- I:1
--p:conflicted-provider
-+p:conflicted-provider conflicted-provider-2
-
- C:Q1EyN5AdpAOBJWKMR89ppC66ccccj=
- P:conflicted-dep
-@@ -104,3 +104,10 @@ V:0.1
- S:1
- I:1
- p:self-provide
-+
-+C:Q1EyN5AdpAOBJWKMR89ppC66eeeej=
-+P:conflicted-dep-2
-+V:0.1
-+S:1
-+I:1
-+D:conflicted-provider-2
---
-2.16.1
-
diff --git a/system/apk-tools/APKBUILD b/system/apk-tools/APKBUILD
index c6b0b479a..d35a6b2f1 100644
--- a/system/apk-tools/APKBUILD
+++ b/system/apk-tools/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Adelie Platform Group <adelie-devel@lists.adelielinux.org>
pkgname=apk-tools
pkgver=2.10.3
-pkgrel=0
+pkgrel=1
pkgdesc="Alpine Package Keeper - package manager"
url="https://git.alpinelinux.org/cgit/apk-tools/"
arch="all"
@@ -13,6 +13,7 @@ makedepends_host="zlib-dev openssl openssl-dev linux-headers"
makedepends="$makedepends_build $makedepends_host"
subpackages="$pkgname-static"
source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz
+ list.patch
pmmx.patch
"
@@ -68,4 +69,5 @@ static() {
}
sha512sums="1b190cfd04c69369bd4f2b708d4df0f8cf2937e1580c95138fd2c2257e7604d015deaca10a9fe0da6742981caadb6b067c15e417a1951866f781b8a5c71c98ee apk-tools-2.10.3.tar.xz
+1c1bd86c47273f23c9c12639fbfa2978c3a1104cb8b30be7e92d1b1d0f863c28efe9153612d62402616dabc3e713877125f56798c908470937d0fa567db948db list.patch
746d00ce2af554a25db7ecea2b0a4d8f7399d2560efb6bf59ea144012d0163d3e0bad84c799bd706e8be6c0a543d4e35728d6beb269fddbbea626384009129cb pmmx.patch"
diff --git a/system/apk-tools/list.patch b/system/apk-tools/list.patch
new file mode 100644
index 000000000..ea264e0fa
--- /dev/null
+++ b/system/apk-tools/list.patch
@@ -0,0 +1,22 @@
+diff --git a/src/list.c b/src/list.c
+index e285e3f..dcbaeea 100644
+--- a/src/list.c
++++ b/src/list.c
+@@ -61,7 +61,7 @@ static int is_orphaned(const struct apk_name *name)
+ /* repo 1 is always installed-db, so if other bits are set it means the package is available somewhere
+ * (either cache or in a proper repo)
+ */
+- return (repos & ~BIT(1)) == 0;
++ return (repos & ~BIT(0)) == 0;
+ }
+
+ /* returns the currently installed package if there is a newer package that satisfies `name` */
+@@ -144,7 +144,7 @@ static void filter_package(const struct apk_package *pkg, const struct list_ctx
+ if (ctx->orphaned && !is_orphaned(pkg->name))
+ return;
+
+- if (ctx->available && pkg->repos == BIT(1))
++ if (ctx->available && pkg->repos == BIT(0))
+ return;
+
+ if (ctx->upgradable && !is_upgradable(pkg->name, pkg))
diff --git a/system/apk-tools/openssl-compat.patch b/system/apk-tools/openssl-compat.patch
deleted file mode 100644
index cdafefd05..000000000
--- a/system/apk-tools/openssl-compat.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- apk-tools-2.8.1/libfetch/common.c.old 2017-10-27 08:12:05.000000000 -0500
-+++ apk-tools-2.8.1/libfetch/common.c 2017-11-11 22:37:18.661697875 -0600
-@@ -504,7 +504,7 @@
-
- SSL_load_error_strings();
-
-- conn->ssl_meth = TLS_client_method();
-+ conn->ssl_meth = SSLv23_client_method();
- conn->ssl_ctx = SSL_CTX_new(conn->ssl_meth);
- SSL_CTX_set_mode(conn->ssl_ctx, SSL_MODE_AUTO_RETRY);
-
diff --git a/system/psmisc/APKBUILD b/system/psmisc/APKBUILD
index 461b6bc6d..8eb5be7d5 100644
--- a/system/psmisc/APKBUILD
+++ b/system/psmisc/APKBUILD
@@ -1,9 +1,8 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
-
pkgname=psmisc
pkgver=23.1
-pkgrel=0
+pkgrel=1
pkgdesc="Miscellaneous utilities that use the proc filesystem"
url="https://gitlab.com/psmisc/psmisc"
arch="all"
@@ -58,4 +57,4 @@ package() {
sha512sums="636f33b628f07599c7a08d0fe0e084469647e2b03046f9c220f6a24475ab1d5dd07db2501bc1a581ca68c72c212367b5dab8b44edfe477a70bfc8740af2b1365 psmisc-23.1.tar.bz2
a68c75eb3c66a9df0d4e574a9439eeed0cd2dc97b3cad3fcd8b945619c2ec238b73bf479d1b55ddd4821471cd8934ee1fbc7871c92de7ef72c3d3f989ab62c9f dont-underlink-peekfd.patch
b16139606e1ccaebd94b7b7a14f49f530b180f1fd24338008e4c4d48761b57953458c46e57b0f7ec191353514f68126f79c281875c4cd56ed2f1220ace131ce1 fix-peekfd-on-ppc.patch
-73dec9791e8cdb85cd3d9ef9be4d16e0fef481c6edc334ed9e954829444b1a92b87f7a3a2e6c1d09ac207bed828f214f5f2a95caa66540a7f2a6c58a6b8f6f2c musl_ptregs.patch"
+57e3ebf427bae9d3ef5b40be1cbc29743009720a75369c91d338f7634fea5bf522f20ec54404b99f3a39e2c4c146c40baee2b22f68e5ede76678d488fde00db5 musl_ptregs.patch"
diff --git a/system/psmisc/musl_ptregs.patch b/system/psmisc/musl_ptregs.patch
index 29fee6a2a..280181a58 100644
--- a/system/psmisc/musl_ptregs.patch
+++ b/system/psmisc/musl_ptregs.patch
@@ -7,13 +7,17 @@ Index: psmisc-22.21/src/peekfd.c
===================================================================
--- a/src/peekfd.c.old
+++ b/src/peekfd.c
-@@ -27,7 +27,9 @@
+@@ -27,7 +27,13 @@
#include <sys/types.h>
#include <sys/wait.h>
#include <sys/syscall.h>
++#ifdef __PPC__
+#define pt_regs uapi_pt_regs
++#endif
#include <asm/ptrace.h>
++#ifdef __PPC__
+#undef pt_regs
++#endif
#include <byteswap.h>
#include <endian.h>
#include <sys/user.h>
diff --git a/user/enchant/APKBUILD b/user/enchant/APKBUILD
index f2ddc1c65..57b0bf6c1 100644
--- a/user/enchant/APKBUILD
+++ b/user/enchant/APKBUILD
@@ -5,6 +5,7 @@ pkgrel=0
pkgdesc="A wrapper library for generic spell checking"
url="https://abiword.github.io/enchant/"
arch="all"
+options="!check" # Requires dictionary that it can't find
license="LGPL-2.0+"
subpackages="$pkgname-dev $pkgname-doc"
depends=""
diff --git a/user/gpgme/APKBUILD b/user/gpgme/APKBUILD
index bb97598e4..c541b7af7 100644
--- a/user/gpgme/APKBUILD
+++ b/user/gpgme/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=gpgme
pkgver=1.12.0
-pkgrel=1
+pkgrel=2
pkgdesc="GnuPG Made Easy"
url="https://www.gnupg.org/related_software/gpgme/"
arch="all"
@@ -13,7 +13,9 @@ depends_dev="libgpg-error-dev libassuan-dev qt5-qtbase-dev"
makedepends="$depends_dev doxygen python3-dev swig cmd:which"
subpackages="$pkgname-dev $pkgname-doc gpgmepp qgpgme py3-gpg:_py"
source="https://gnupg.org/ftp/gcrypt/$pkgname/$pkgname-$pkgver.tar.bz2
- 1.12.0-fix-t-tofuinfo.patch"
+ 1.12.0-fix-t-tofuinfo.patch
+ test32bit.patch
+ "
build() {
cd "$builddir"
@@ -60,4 +62,5 @@ _py() {
}
sha512sums="c228b3df28377df882be536ada56dc9c73150048a58e591aa4495f89c854af95820152cd60139840f994c249e9c7df50d8b89eb9d6dc4ce02aa80bbfebcdd014 gpgme-1.12.0.tar.bz2
-c8748651021a6ea670329cffb9565b905272b092315e77dc6fa9fa23890f8a55c2159edbfa026e8af961f2ff0c0d524dc8332a2e9a24fce2b37ac7cc4bb88cb3 1.12.0-fix-t-tofuinfo.patch"
+c8748651021a6ea670329cffb9565b905272b092315e77dc6fa9fa23890f8a55c2159edbfa026e8af961f2ff0c0d524dc8332a2e9a24fce2b37ac7cc4bb88cb3 1.12.0-fix-t-tofuinfo.patch
+26bb302f462d7164842acea38080b3937b0b7b11d12fcfe1a61d656a41c993474dc7d9ca2298f936b030874a2f59f85b2189b11087f8b39d4c685a9a4e5d9450 test32bit.patch"
diff --git a/user/gpgme/test32bit.patch b/user/gpgme/test32bit.patch
new file mode 100644
index 000000000..49dafdddb
--- /dev/null
+++ b/user/gpgme/test32bit.patch
@@ -0,0 +1,93 @@
+From 651a1afe80bcc421da26f38015e8a322e140f130 Mon Sep 17 00:00:00 2001
+From: Ben McGinnes <ben@adversary.org>
+Date: Sat, 20 Oct 2018 11:07:55 +1100
+Subject: [PATCH] python bindings: callback test
+
+* lang/python/tests/t-callbacks.py: Updated test logic to try
+ generating a key which expires in 2099 and if that fails then
+ fallback to an expiration in 2037 in an attempt to catch the 32-bit
+ systems.
+---
+ lang/python/tests/t-callbacks.py | 32 ++++++++++++++++++++++++++++++--
+ 1 file changed, 30 insertions(+), 2 deletions(-)
+
+diff --git a/lang/python/tests/t-callbacks.py b/lang/python/tests/t-callbacks.py
+index 5bcac237..3a210dd0 100755
+--- a/lang/python/tests/t-callbacks.py
++++ b/lang/python/tests/t-callbacks.py
+@@ -20,12 +20,14 @@
+ from __future__ import absolute_import, print_function, unicode_literals
+
+ import os
++import platform
+ import gpg
+ import support
+ _ = support # to appease pyflakes.
+
+ del absolute_import, print_function, unicode_literals
+
++oops = None
+ c = gpg.Context()
+ c.set_pinentry_mode(gpg.constants.PINENTRY_MODE_LOOPBACK)
+
+@@ -99,6 +101,17 @@ Expire-Date: 2099-12-31
+ </GnupgKeyParms>
+ """
+
++prams = """<GnupgKeyParms format="internal">
++Key-Type: RSA
++Key-Length: 1024
++Name-Real: Joe Tester
++Name-Comment: with stupid passphrase
++Name-Email: joe+gpg@example.org
++Passphrase: Crypt0R0cks
++Expire-Date: 2037-12-31
++</GnupgKeyParms>
++"""
++
+ messages = []
+
+
+@@ -111,7 +124,10 @@ def progress_cb(what, typ, current, total, hook=None):
+
+ c = gpg.Context()
+ c.set_progress_cb(progress_cb, messages)
+-c.op_genkey(parms, None, None)
++try:
++ c.op_genkey(parms, None, None)
++except Exception as oops:
++ c.op_genkey(prams, None, None)
+ assert len(messages) > 0
+
+
+@@ -123,7 +139,10 @@ def progress_cb(what, typ, current, total, hook=None):
+ c = gpg.Context()
+ c.set_progress_cb(progress_cb, None)
+ try:
+- c.op_genkey(parms, None, None)
++ try:
++ c.op_genkey(parms, None, None)
++ except Exception as oops:
++ c.op_genkey(prams, None, None)
+ except Exception as e:
+ assert e == myException
+ else:
+@@ -139,6 +158,15 @@ alpha = c.get_key("A0FF4590BB6122EDEF6E3C542D727CC768697734", False)
+ cookie = object()
+ edit_cb_called = False
+
++def oops_check():
++ if oops is not None and platform.architecture()[0] != "64bit":
++ y2k38_msg = "System appears to be 32-bit and vulnerable to EOL in 2038."
++ elif oops is not None and platform.architecture()[0] == "64bit":
++ y2k38_msg = "System appears to be 64-bit, but may use 32-bit time."
++ else:
++ y2k38_msg = "System is 64-bit and/or not susceptible to 2038 EOL."
++ return y2k38_msg
++
+
+ def edit_cb(status, args, hook):
+ global edit_cb_called
+--
+2.11.0
+
diff --git a/user/libreoffice/APKBUILD b/user/libreoffice/APKBUILD
index a9e18b5f3..b6968e4ab 100644
--- a/user/libreoffice/APKBUILD
+++ b/user/libreoffice/APKBUILD
@@ -94,6 +94,7 @@ source="https://download.documentfoundation.org/$pkgname/src/$_ver/$pkgname-$pkg
disable-outdated-font-test.patch
disable-mariadbc.patch
disable-mysqlc.patch
+ boost.patch
"
ldpath="/usr/lib/$pkgname/program"
@@ -483,4 +484,5 @@ bac06a1f0f6ef3e5860ec340470583b2a7ff079efa9efee9119ae1ac320b97ecbfdb7eba63975d4f
6a039ba592a23b8db1dd5c8d5dffbc9562270de691d2eb1e1c420f8632532c0fce14a0f3844dc2e6f6b6b04655c40230bd69fd81d1ae6f0bd16f0e88ce0a2783 disable-crc-test.patch
4ffc389a3c545d37d152bb52390c3abd06a32eb9fee03110c07e8b57f9b9d1be68fdc5092ad0be76f6540367a1f1d2e9e32d519021d8205847594edb811da428 disable-outdated-font-test.patch
c1925fe5833410c6a4b47a1723e67ce3898fc01ebded766023855cd93f290a6788638a86a8595e112ab788628c0ea7642c41d7ff987ba9117c2e079a99a3b29f disable-mariadbc.patch
-01ef207d0b3ab1ded5edadd2d05cefe65d7c2dc4285abee12d7fbb61c92b2a3e37d5cfe5bb8f5ea9a40fd2918396ec25b473a916012e04732ebbe79ee6768a21 disable-mysqlc.patch"
+01ef207d0b3ab1ded5edadd2d05cefe65d7c2dc4285abee12d7fbb61c92b2a3e37d5cfe5bb8f5ea9a40fd2918396ec25b473a916012e04732ebbe79ee6768a21 disable-mysqlc.patch
+431f55b4ec96caa94b0f55d3691931ad65320ecacbd8f9c9f477107136866ba614683eb77458006960240918392e995a567f5b5436d75003ac036f6d24a77e0a boost.patch"
diff --git a/user/libreoffice/boost.patch b/user/libreoffice/boost.patch
new file mode 100644
index 000000000..cd8ef9dba
--- /dev/null
+++ b/user/libreoffice/boost.patch
@@ -0,0 +1,17 @@
+After https://github.com/boostorg/logic/commit/23cd89d4c80f build fails:
+
+sfx2/source/appl/shutdownicon.cxx:170:12: error: no viable conversion from returned value of type 'boost::logic::tribool' to function return type 'bool'
+ return loaded;
+ ^~~~~~
+
+--- lo/sfx2/source/appl/shutdownicon.cxx.orig 2018-06-19 22:27:30 UTC
++++ lo/sfx2/source/appl/shutdownicon.cxx
+@@ -167,7 +167,7 @@ bool LoadModule()
+ #endif // ENABLE_QUICKSTART_APPLET
+ }
+ assert(!boost::logic::indeterminate(loaded));
+- return loaded;
++ return bool{loaded};
+ }
+
+ }
diff --git a/user/libsass/APKBUILD b/user/libsass/APKBUILD
index b96567340..5d560aa6e 100644
--- a/user/libsass/APKBUILD
+++ b/user/libsass/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libsass
pkgver=3.5.5
pkgrel=0
pkgdesc="Library for preprocessing CSS"
-url="http://sass-lang.com/libsass"
+url="https://sass-lang.com/libsass"
arch="all"
options="!check" # Tests require sassc, which requires this library.
license="MIT"
diff --git a/user/pulseaudio/APKBUILD b/user/pulseaudio/APKBUILD
index 9e3f7a565..bacaab731 100644
--- a/user/pulseaudio/APKBUILD
+++ b/user/pulseaudio/APKBUILD
@@ -9,7 +9,7 @@ url="https://www.freedesktop.org/wiki/Software/PulseAudio"
pkgusers="pulse"
pkggroups="pulse pulse-access"
arch="all"
-options="!checkroot"
+options="!check" # Complains about permissions in /var/tmp.
license="LGPL-2.1+"
makedepends="alsa-lib-dev bash bluez-dev check-dev dbus-dev eudev-dev fftw-dev
gconf-dev gtk+3.0-dev intltool libcap-dev libsndfile-dev m4 openssl-dev
diff --git a/user/qt5-qtscript/APKBUILD b/user/qt5-qtscript/APKBUILD
index 16237b5c6..4f56a9e7d 100644
--- a/user/qt5-qtscript/APKBUILD
+++ b/user/qt5-qtscript/APKBUILD
@@ -2,14 +2,16 @@
pkgname=qt5-qtscript
_pkgname=qtscript-opensource-src
pkgver=5.9.7
-pkgrel=0
+pkgrel=1
pkgdesc="Qt 5 - Deprecated scripting framework for Qt applications"
url="https://www.qt.io/"
arch="all"
license="LGPL-2.0 with exceptions OR GPL-3.0 with exceptions"
makedepends="qt5-qtbase-dev"
subpackages="$pkgname-dev"
-source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz"
+source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz
+ gcc8.patch
+ "
builddir="$srcdir"/$_pkgname-$pkgver
build() {
@@ -28,4 +30,5 @@ package() {
make INSTALL_ROOT="$pkgdir" install
}
-sha512sums="e019d2e7aa29e1183636503822db960d97f1787fa7517f286acbe42645f2c5daa099cc251ac6640e3243dedb4ef64e509f2e22bca798a7e583063e0ac7635662 qtscript-opensource-src-5.9.7.tar.xz"
+sha512sums="e019d2e7aa29e1183636503822db960d97f1787fa7517f286acbe42645f2c5daa099cc251ac6640e3243dedb4ef64e509f2e22bca798a7e583063e0ac7635662 qtscript-opensource-src-5.9.7.tar.xz
+426174235ab57b14edf58166327372ba215dfce092b9d4cc07686b326c999d4d6348460a75343791de96b6ad7352c393b4a748d0592865e0d78dc119c12657f2 gcc8.patch"
diff --git a/user/qt5-qtscript/gcc8.patch b/user/qt5-qtscript/gcc8.patch
new file mode 100644
index 000000000..2fb04a708
--- /dev/null
+++ b/user/qt5-qtscript/gcc8.patch
@@ -0,0 +1,238 @@
+From 97ec1d1882a83c23c91f0f7daea48e05858d8c32 Mon Sep 17 00:00:00 2001
+From: Thiago Macieira <thiago.macieira@intel.com>
+Date: Mon, 28 Jan 2019 14:33:12 -0800
+Subject: Fix build with GCC 8.3
+
+Qualifiers in the asm statement are not allowed in the global scope. I
+thought they were necessary for LTO, but I the commit to this file that
+added them predates my work on setting up LTO for GCC.
+
+Change-Id: Id98140e1c2f0426cabbefffd157e23e5ece67a49
+Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
+---
+ .../javascriptcore/JavaScriptCore/jit/JITStubs.cpp | 48 +++++++++++-----------
+ 1 file changed, 24 insertions(+), 24 deletions(-)
+
+diff --git a/src/3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp b/src/3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp
+index 1abdf8b..9f60761 100644
+--- a/src/3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp
++++ b/src/3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp
+@@ -116,7 +116,7 @@ COMPILE_ASSERT(offsetof(struct JITStackFrame, savedEBX) == 0x3c, JITStackFrame_s
+ COMPILE_ASSERT(offsetof(struct JITStackFrame, callFrame) == 0x58, JITStackFrame_callFrame_offset_matches_ctiTrampoline);
+ COMPILE_ASSERT(offsetof(struct JITStackFrame, code) == 0x50, JITStackFrame_code_offset_matches_ctiTrampoline);
+
+-asm volatile (
++asm (
+ ".text\n"
+ ".globl " SYMBOL_STRING(ctiTrampoline) "\n"
+ HIDE_SYMBOL(ctiTrampoline) "\n"
+@@ -138,7 +138,7 @@ SYMBOL_STRING(ctiTrampoline) ":" "\n"
+ "ret" "\n"
+ );
+
+-asm volatile (
++asm (
+ ".globl " SYMBOL_STRING(ctiVMThrowTrampoline) "\n"
+ HIDE_SYMBOL(ctiVMThrowTrampoline) "\n"
+ SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n"
+@@ -154,7 +154,7 @@ SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n"
+ "ret" "\n"
+ );
+
+-asm volatile (
++asm (
+ ".globl " SYMBOL_STRING(ctiOpThrowNotCaught) "\n"
+ HIDE_SYMBOL(ctiOpThrowNotCaught) "\n"
+ SYMBOL_STRING(ctiOpThrowNotCaught) ":" "\n"
+@@ -179,7 +179,7 @@ COMPILE_ASSERT(offsetof(struct JITStackFrame, savedRBX) == 0x48, JITStackFrame_s
+ COMPILE_ASSERT(offsetof(struct JITStackFrame, callFrame) == 0x90, JITStackFrame_callFrame_offset_matches_ctiTrampoline);
+ COMPILE_ASSERT(offsetof(struct JITStackFrame, code) == 0x80, JITStackFrame_code_offset_matches_ctiTrampoline);
+
+-asm volatile (
++asm (
+ ".globl " SYMBOL_STRING(ctiTrampoline) "\n"
+ HIDE_SYMBOL(ctiTrampoline) "\n"
+ SYMBOL_STRING(ctiTrampoline) ":" "\n"
+@@ -206,7 +206,7 @@ SYMBOL_STRING(ctiTrampoline) ":" "\n"
+ "ret" "\n"
+ );
+
+-asm volatile (
++asm (
+ ".globl " SYMBOL_STRING(ctiVMThrowTrampoline) "\n"
+ HIDE_SYMBOL(ctiVMThrowTrampoline) "\n"
+ SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n"
+@@ -222,7 +222,7 @@ SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n"
+ "ret" "\n"
+ );
+
+-asm volatile (
++asm (
+ ".globl " SYMBOL_STRING(ctiOpThrowNotCaught) "\n"
+ HIDE_SYMBOL(ctiOpThrowNotCaught) "\n"
+ SYMBOL_STRING(ctiOpThrowNotCaught) ":" "\n"
+@@ -242,7 +242,7 @@ SYMBOL_STRING(ctiOpThrowNotCaught) ":" "\n"
+ #error "JIT_STUB_ARGUMENT_VA_LIST not supported on ARMv7."
+ #endif
+
+-asm volatile (
++asm (
+ ".text" "\n"
+ ".align 2" "\n"
+ ".globl " SYMBOL_STRING(ctiTrampoline) "\n"
+@@ -269,7 +269,7 @@ SYMBOL_STRING(ctiTrampoline) ":" "\n"
+ "bx lr" "\n"
+ );
+
+-asm volatile (
++asm (
+ ".text" "\n"
+ ".align 2" "\n"
+ ".globl " SYMBOL_STRING(ctiVMThrowTrampoline) "\n"
+@@ -287,7 +287,7 @@ SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n"
+ "bx lr" "\n"
+ );
+
+-asm volatile (
++asm (
+ ".text" "\n"
+ ".align 2" "\n"
+ ".globl " SYMBOL_STRING(ctiOpThrowNotCaught) "\n"
+@@ -305,7 +305,7 @@ SYMBOL_STRING(ctiOpThrowNotCaught) ":" "\n"
+
+ #elif COMPILER(GCC) && CPU(ARM_TRADITIONAL)
+
+-asm volatile (
++asm (
+ ".globl " SYMBOL_STRING(ctiTrampoline) "\n"
+ HIDE_SYMBOL(ctiTrampoline) "\n"
+ SYMBOL_STRING(ctiTrampoline) ":" "\n"
+@@ -323,7 +323,7 @@ SYMBOL_STRING(ctiTrampoline) ":" "\n"
+ "mov pc, lr" "\n"
+ );
+
+-asm volatile (
++asm (
+ ".globl " SYMBOL_STRING(ctiVMThrowTrampoline) "\n"
+ HIDE_SYMBOL(ctiVMThrowTrampoline) "\n"
+ SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n"
+@@ -418,7 +418,7 @@ COMPILE_ASSERT(offsetof(struct JITStackFrame, callFrame) == 0x38, JITStackFrame_
+ COMPILE_ASSERT(offsetof(struct JITStackFrame, code) == 0x30, JITStackFrame_code_offset_matches_ctiTrampoline);
+ COMPILE_ASSERT(offsetof(struct JITStackFrame, savedEBX) == 0x1c, JITStackFrame_stub_argument_space_matches_ctiTrampoline);
+
+-asm volatile (
++asm (
+ ".text\n"
+ ".globl " SYMBOL_STRING(ctiTrampoline) "\n"
+ HIDE_SYMBOL(ctiTrampoline) "\n"
+@@ -440,7 +440,7 @@ SYMBOL_STRING(ctiTrampoline) ":" "\n"
+ "ret" "\n"
+ );
+
+-asm volatile (
++asm (
+ ".globl " SYMBOL_STRING(ctiVMThrowTrampoline) "\n"
+ HIDE_SYMBOL(ctiVMThrowTrampoline) "\n"
+ SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n"
+@@ -456,7 +456,7 @@ SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n"
+ "ret" "\n"
+ );
+
+-asm volatile (
++asm (
+ ".globl " SYMBOL_STRING(ctiOpThrowNotCaught) "\n"
+ HIDE_SYMBOL(ctiOpThrowNotCaught) "\n"
+ SYMBOL_STRING(ctiOpThrowNotCaught) ":" "\n"
+@@ -480,7 +480,7 @@ COMPILE_ASSERT(offsetof(struct JITStackFrame, callFrame) == 0x58, JITStackFrame_
+ COMPILE_ASSERT(offsetof(struct JITStackFrame, code) == 0x48, JITStackFrame_code_offset_matches_ctiTrampoline);
+ COMPILE_ASSERT(offsetof(struct JITStackFrame, savedRBX) == 0x78, JITStackFrame_stub_argument_space_matches_ctiTrampoline);
+
+-asm volatile (
++asm (
+ ".text\n"
+ ".globl " SYMBOL_STRING(ctiTrampoline) "\n"
+ HIDE_SYMBOL(ctiTrampoline) "\n"
+@@ -515,7 +515,7 @@ SYMBOL_STRING(ctiTrampoline) ":" "\n"
+ "ret" "\n"
+ );
+
+-asm volatile (
++asm (
+ ".globl " SYMBOL_STRING(ctiVMThrowTrampoline) "\n"
+ HIDE_SYMBOL(ctiVMThrowTrampoline) "\n"
+ SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n"
+@@ -531,7 +531,7 @@ SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n"
+ "ret" "\n"
+ );
+
+-asm volatile (
++asm (
+ ".globl " SYMBOL_STRING(ctiOpThrowNotCaught) "\n"
+ HIDE_SYMBOL(ctiOpThrowNotCaught) "\n"
+ SYMBOL_STRING(ctiOpThrowNotCaught) ":" "\n"
+@@ -551,7 +551,7 @@ SYMBOL_STRING(ctiOpThrowNotCaught) ":" "\n"
+ #error "JIT_STUB_ARGUMENT_VA_LIST not supported on ARMv7."
+ #endif
+
+-asm volatile (
++asm (
+ ".text" "\n"
+ ".align 2" "\n"
+ ".globl " SYMBOL_STRING(ctiTrampoline) "\n"
+@@ -578,7 +578,7 @@ SYMBOL_STRING(ctiTrampoline) ":" "\n"
+ "bx lr" "\n"
+ );
+
+-asm volatile (
++asm (
+ ".text" "\n"
+ ".align 2" "\n"
+ ".globl " SYMBOL_STRING(ctiVMThrowTrampoline) "\n"
+@@ -596,7 +596,7 @@ SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n"
+ "bx lr" "\n"
+ );
+
+-asm volatile (
++asm (
+ ".text" "\n"
+ ".align 2" "\n"
+ ".globl " SYMBOL_STRING(ctiOpThrowNotCaught) "\n"
+@@ -614,7 +614,7 @@ SYMBOL_STRING(ctiOpThrowNotCaught) ":" "\n"
+
+ #elif COMPILER(GCC) && CPU(ARM_TRADITIONAL)
+
+-asm volatile (
++asm (
+ ".text\n"
+ ".globl " SYMBOL_STRING(ctiTrampoline) "\n"
+ HIDE_SYMBOL(ctiTrampoline) "\n"
+@@ -632,7 +632,7 @@ SYMBOL_STRING(ctiTrampoline) ":" "\n"
+ "mov pc, lr" "\n"
+ );
+
+-asm volatile (
++asm (
+ ".globl " SYMBOL_STRING(ctiVMThrowTrampoline) "\n"
+ HIDE_SYMBOL(ctiVMThrowTrampoline) "\n"
+ SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n"
+@@ -1024,7 +1024,7 @@ static NEVER_INLINE void throwStackOverflowError(CallFrame* callFrame, JSGlobalD
+ extern "C" { \
+ rtype JITStubThunked_##op(STUB_ARGS_DECLARATION); \
+ }; \
+- asm volatile ( \
++ asm ( \
+ ".text" "\n" \
+ ".align 2" "\n" \
+ ".globl " SYMBOL_STRING(cti_##op) "\n" \
+@@ -1053,7 +1053,7 @@ COMPILE_ASSERT(offsetof(struct JITStackFrame, thunkReturnAddress) == THUNK_RETUR
+ extern "C" { \
+ rtype JITStubThunked_##op(STUB_ARGS_DECLARATION); \
+ }; \
+- asm volatile ( \
++ asm ( \
+ ".globl " SYMBOL_STRING(cti_##op) "\n" \
+ HIDE_SYMBOL(cti_##op) "\n" \
+ SYMBOL_STRING(cti_##op) ":" "\n" \
+--
+cgit v1.2.1
+
diff --git a/user/sassc/APKBUILD b/user/sassc/APKBUILD
index dcda892bb..ee082659f 100644
--- a/user/sassc/APKBUILD
+++ b/user/sassc/APKBUILD
@@ -4,7 +4,7 @@ pkgname=sassc
pkgver=3.5.0
pkgrel=0
pkgdesc="CSS preprocessor and extension language compiler"
-url="http://sass-lang.com/"
+url="https://sass-lang.com/"
arch="all"
license="MIT"
depends=""