summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/chelf/APKBUILD9
-rw-r--r--user/chelf/fix-uninitialised-read.patch11
2 files changed, 3 insertions, 17 deletions
diff --git a/user/chelf/APKBUILD b/user/chelf/APKBUILD
index 83b9c1402..6e7aff4c0 100644
--- a/user/chelf/APKBUILD
+++ b/user/chelf/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=chelf
-pkgver=0.1_git20190110
+pkgver=0.2.2
pkgrel=0
pkgdesc="Display or change the stack size of an ELF binary"
url=" "
@@ -11,9 +11,7 @@ license="BSD-2-Clause"
depends=""
makedepends=""
subpackages=""
-source="$pkgname-$pkgver.tar.xz::https://distfiles.adelielinux.org/source/$pkgname-$pkgver.txz
- fix-uninitialised-read.patch
- "
+source="$pkgname-$pkgver.tar.xz::https://distfiles.adelielinux.org/source/$pkgname-$pkgver.txz"
build() {
cd "$builddir"
@@ -25,5 +23,4 @@ package() {
install -D -m755 chelf "$pkgdir"/usr/bin/chelf
}
-sha512sums="6154e1580f4ea355aaa5017cced37d278d7e864d2c924e521aadc79d839ce79d1a94a9f8ebef1274f92748058278b628ec384f5d5e4572fe56d7745208146dbe chelf-0.1_git20190110.tar.xz
-435610112eec83b27c922b5f84ca1e9abfa8c1834f5fafea0deb6911532fd7c0924da002a0c5523d6cd013c8d56e02cc6ae30321fdf4955399b7fcabe5c64e35 fix-uninitialised-read.patch"
+sha512sums="bf29f0f526ca1977e0d0743901f6afeb23b2dd78b60618ea65201ea95000832854250f44de6e7625b6d546cace4638be094989cdb96b4e842285ef85718c0082 chelf-0.2.2.tar.xz"
diff --git a/user/chelf/fix-uninitialised-read.patch b/user/chelf/fix-uninitialised-read.patch
deleted file mode 100644
index 0623647fe..000000000
--- a/user/chelf/fix-uninitialised-read.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- chelf-0.1_git20190110/main.c.old 2018-10-29 10:37:25.000000000 +0000
-+++ chelf-0.1_git20190110/main.c 2019-01-10 18:44:45.320000000 +0000
-@@ -32,7 +32,7 @@
- {
- int fd, rv = -1;
- struct stat st;
-- void *elf;
-+ void *elf = NULL;
- const int open_flags = (mode == MODE_WRITE) ? O_RDWR : O_RDONLY;
- const int mmap_flags = (mode == MODE_WRITE) ?
- (PROT_WRITE|PROT_READ) : PROT_READ;