summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/musl/APKBUILD4
-rw-r--r--system/musl/ldconfig4
-rw-r--r--system/openrc/APKBUILD6
-rw-r--r--system/openrc/modloop.initd7
-rw-r--r--system/openrc/sysfsconf.initd6
-rw-r--r--system/paxmark/APKBUILD6
-rw-r--r--system/paxmark/paxmark2
-rw-r--r--user/acpid/APKBUILD4
-rw-r--r--user/acpid/handler.sh2
-rw-r--r--user/alsa-utils/APKBUILD4
-rw-r--r--user/alsa-utils/alsa.initd4
-rw-r--r--user/apache-httpd/APKBUILD4
-rwxr-xr-xuser/apache-httpd/apache-httpd.initd4
-rw-r--r--user/iptables/APKBUILD4
-rw-r--r--user/iptables/iptables.initd2
-rw-r--r--user/php7/APKBUILD4
-rw-r--r--user/php7/php-fpm.initd7
-rw-r--r--user/postgresql/APKBUILD4
-rw-r--r--user/postgresql/postgresql.initd6
-rw-r--r--user/strongswan/APKBUILD4
-rw-r--r--user/strongswan/charon.initd2
21 files changed, 46 insertions, 44 deletions
diff --git a/system/musl/APKBUILD b/system/musl/APKBUILD
index 73bfea8b5..336d81458 100644
--- a/system/musl/APKBUILD
+++ b/system/musl/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=musl
pkgver=1.1.23
-pkgrel=0
+pkgrel=1
pkgdesc="System library (libc) implementation"
url="https://www.musl-libc.org/"
arch="all"
@@ -123,6 +123,6 @@ ef532aebeaa89b3274f7f75f1adaa4d1eea60f4e2822a6711c748768cc3a65a77ebd218d7a8ab411
ded41235148930f8cf781538f7d63ecb0c65ea4e8ce792565f3649ee2523592a76b2a166785f0b145fc79f5852fd1fb1729a7a09110b3b8f85cba3912e790807 fgetspent_r.patch
fda015fad0d0a65efb192c08d201b2f5b2bfff18c43b551855b119a1d63213bd417a93a6b2965e68243884c5b17b34a585795cc4cace603788d37149e933cfb1 powerpc-wchar_t.patch
7ed6c620a5ea5585c323936b1ff01eb7f01a1192240706a0d0470b661a7a03ea10ed17507c59678aaedce51b7a5ea839c2f528f19f12de02119bf4e47f7c3998 strftime-add-l-support.patch
-cce2f1eeb61e55674469c26871a573cce61d739c3defe9c8f56f2b774f6ba5435849ad542a6714120efddc98c297098e9c98a1a424ac593df2243d4aa479f9a9 ldconfig
+cb71d29a87f334c75ecbc911becde7be825ab30d8f39fa6d64cb53812a7c9abaf91d9804c72540e5be3ddd3c84cfe7fd9632274309005cb8bcdf9a9b09b4b923 ldconfig
378d70e65bcc65bb4e1415354cecfa54b0c1146dfb24474b69e418cdbf7ad730472cd09f6f103e1c99ba6c324c9560bccdf287f5889bbc3ef0bdf0e08da47413 getent.c
9d42d66fb1facce2b85dad919be5be819ee290bd26ca2db00982b2f8e055a0196290a008711cbe2b18ec9eee8d2270e3b3a4692c5a1b807013baa5c2b70a2bbf iconv.c"
diff --git a/system/musl/ldconfig b/system/musl/ldconfig
index 7699c6722..991927bae 100644
--- a/system/musl/ldconfig
+++ b/system/musl/ldconfig
@@ -18,11 +18,11 @@ msg() {
}
musl_arch() {
- $ROOT/usr/lib/libc.so |& sed -n 's/^musl libc (\(.*\))$/\1/p'
+ $ROOT/usr/lib/libc.so 2>&1 | sed -n 's/^musl libc (\(.*\))$/\1/p'
}
musl_version() {
- $ROOT/usr/lib/libc.so |& sed -n 's/^Version //p'
+ $ROOT/usr/lib/libc.so 2>&1 | sed -n 's/^Version //p'
}
read_ldso_conf() {
diff --git a/system/openrc/APKBUILD b/system/openrc/APKBUILD
index c59c0b642..6c41d9f99 100644
--- a/system/openrc/APKBUILD
+++ b/system/openrc/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer:
pkgname=openrc
pkgver=0.24.1
-pkgrel=7
+pkgrel=8
pkgdesc="OpenRC manages the services, startup and shutdown of a host"
url="https://github.com/OpenRC/openrc"
arch="all"
@@ -95,6 +95,6 @@ d54630d40a2d6b10a325cb012d4efcda997a60c008ca953ce5d60059d3f267308a59dabddf93a5fc
99b542c0903ad6874b8c308b2e0660a4fe2ff9db962dfec65325cd12c368873a2ae800d5e6d42dc4deff775e1d5c0068869eb72581f7ab16e88d5738afe1d3dd hostname.initd
c06eac7264f6cc6888563feeae5ca745aae538323077903de1b19102e4f16baa34c18b8c27af5dd5423e7670834e2261e9aa55f2b1ec8d8fdc2be105fe894d55 hwdrivers.initd
b04058ec630e19de0bafefe06198dc1bff8c8d5d2c89e4660dd83dda8bb82a76cdb1d8661cce88e4a406aa6b4152e17efff52d3eb18ffaec0751d0b6cdbcc48a modules.initd
-92c0245ba4d7cc6828a9b68510fb541cf3b21b9b844a858336af60e84d1db62ddb4471aad0d82ef05d639335a81014f8350a71a746c2bcd90697daa6a8c03408 modloop.initd
+328e1f4cf3d9542ae47a517b900b57f383e0c0e24e24c52437667b72fa11d7986329dac176168ca9b6729cb412286f1ad8327771c85aa821c8b534b1bd860712 modloop.initd
aa702a7da8e6c0e5d8738febaf6b4e4cb021b30ce5c1809b530abf2b36739079446b16fc054740da8d86ed099942cf5deed6597cedb64c058f3def587a8b4689 modloop.confd
-d76c75c58e6f4b0801edac4e081b725ef3d50a9a8c9bbb5692bf4d0f804af7d383bf71a73d5d03ed348a89741ef0b2427eb6a7cbf5a9b9ff60a240639fa6ec88 sysfsconf.initd"
+02eb7a0b430f0dd985dc1a6cdcca41b1f0dca1a2c164364713ff6706511884295a1ccbd51c87686ffc197ca5cd093be5404fba98d21cf4e4076535706a67f106 sysfsconf.initd"
diff --git a/system/openrc/modloop.initd b/system/openrc/modloop.initd
index 9d664dd40..85ad2b165 100644
--- a/system/openrc/modloop.initd
+++ b/system/openrc/modloop.initd
@@ -24,9 +24,10 @@ mountdirs() {
find_modloop() {
local dir="$1"
- local kver=$(uname -r)
+ local kver="$(uname -r)"
local oifs="$IFS"
- IFS=$'\n'
+ IFS="
+"
set -- $(blkid "$dir"/boot/* "$dir"/*)
IFS="$oifs"
for line; do
@@ -42,7 +43,7 @@ find_modloop() {
find_backing_file() {
local dir="$1"
- local dev=$(df -P "$dir" | tail -1 | awk '{print $1}')
+ local dev="$(df -P "$dir" | tail -1 | awk '{print $1}')"
cat /sys/block/${dev#/dev/}/loop/backing_file 2>/dev/null
}
diff --git a/system/openrc/sysfsconf.initd b/system/openrc/sysfsconf.initd
index 433e51d63..5d4f9aeab 100644
--- a/system/openrc/sysfsconf.initd
+++ b/system/openrc/sysfsconf.initd
@@ -12,14 +12,14 @@ setval() {
local value="$1" attrib="$2"
# Some fields need a terminating newline, others
# need the terminating newline to be absent :-(
- echo -n "$value" > "$attrib" 2>/dev/null \
- || echo "$value" > "$attrib"
+ printf '%s' "$value" > "$attrib" 2>/dev/null \
+ || printf '%s\n' "$value" > "$attrib"
}
load_conffile() {
local file="$1"
while read line; do
- local line=${line%%#*}
+ local line="${line%%#*}"
local cmd= attrib= value=
set -- $line
if [ $# -eq 0 ]; then
diff --git a/system/paxmark/APKBUILD b/system/paxmark/APKBUILD
index 767803915..3c9c69400 100644
--- a/system/paxmark/APKBUILD
+++ b/system/paxmark/APKBUILD
@@ -2,13 +2,13 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=paxmark
pkgver=0.11
-pkgrel=0
+pkgrel=1
pkgdesc="Manage PaX marking of executables"
url="https://alpinelinux.org"
arch="noarch"
options="!check"
license="GPL-2.0-only"
-depends="attr"
+depends="attr bash"
makedepends=""
install=""
subpackages=""
@@ -20,4 +20,4 @@ package() {
ln -s paxmark "$pkgdir"/usr/sbin/paxmark.sh
}
-sha512sums="c43b5a48a8ac14b027114f712820b1fb8b0e209fcfe1a69eb64b4c68289a3bb3f26c3ea40350cbfdaa97329b4a8e1de2582025e5221c3016aff85bb75118e665 paxmark"
+sha512sums="ed904790bfa6c86e216e2c8c1ed8fb1f997b7d1a55f997459655e402d8eec6447095709e38472cf909ea4d03e623e3e0eeddc0da57378901fe9d18d8c14b68d8 paxmark"
diff --git a/system/paxmark/paxmark b/system/paxmark/paxmark
index f80eb69ff..87a84f4f7 100644
--- a/system/paxmark/paxmark
+++ b/system/paxmark/paxmark
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
ret=0
flags="${1//[!zPpEeMmRrSs]}"
diff --git a/user/acpid/APKBUILD b/user/acpid/APKBUILD
index c9ad2e28e..a806b93de 100644
--- a/user/acpid/APKBUILD
+++ b/user/acpid/APKBUILD
@@ -8,7 +8,7 @@
pkgname=acpid
pkgver=2.0.31
-pkgrel=0
+pkgrel=1
pkgdesc="Daemon for handling ACPI power management events"
url="https://sourceforge.net/projects/acpid2/"
arch="all"
@@ -51,7 +51,7 @@ package() {
}
sha512sums="05eb96cdae698731b14caa89aa01239a0f16ce732f897d295447753aab7c8d49227c9b9ce901c6fd3bfdb117688e6ed80ec61aea0f64d75c9c0afe2aea2aa91a acpid-2.0.31.tar.xz
-f5935340391a927b2c0b8d36f6b9579d740299a46c210f762483336f2685e80bdfc237dd5ac5eeed5e458eff2fa436cd36e3277c4ee2085e05662e1525c56edd handler.sh
+42e8a66c4fd4de3bf0b6adc359c5d5a08e45bf38fc2945c75ab0bf38058c10906e2c84f50895bb85b38e1a19646d91e40a875f2b45f67e07a9336d27bfa2dcd8 handler.sh
2ca236168ce6aaa56c980568c781d6e51590870b7a7936c74bf72532ef3f6c60a369f37597202f3a236d60637fd0daa6611d4ae0348484011ff71871a9914246 default
7381d30b5c6478cdbf5dff93ae95baa0b3b1fe0a04b02cf491831f1657d6f71b8eef121b7e78f3201d11a5856bfb30df0a57437c76e6fbe05ad88cd45e86ae64 acpid.initd
518cb397b2aa63b893ead1be08f32fe436d19b72663dee66834cfbc112b003333f0df8b9e4f1ffe64b813783f657d3fe8b9a0c5e992d5665583357e68b266705 acpid.confd"
diff --git a/user/acpid/handler.sh b/user/acpid/handler.sh
index 8e291bc2b..298ac1b81 100644
--- a/user/acpid/handler.sh
+++ b/user/acpid/handler.sh
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/bin/sh
logger "Received ACPI event: ${@}"
diff --git a/user/alsa-utils/APKBUILD b/user/alsa-utils/APKBUILD
index 835c37b43..057e77cc1 100644
--- a/user/alsa-utils/APKBUILD
+++ b/user/alsa-utils/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=alsa-utils
pkgver=1.1.9
-pkgrel=0
+pkgrel=1
pkgdesc="Advanced Linux Sound Architecture (ALSA) utilities"
url="https://www.alsa-project.org/wiki/Main_Page"
arch="all"
@@ -38,5 +38,5 @@ package() {
sha512sums="92fa689ea5897150972d5376e7999ff060cad09cb0b06991d81c87b61a243ecec944e2a4c7ad38878596cd8b4246e44c5a3a35e5bc6452c02ebf35c9bed91970 alsa-utils-1.1.9.tar.bz2
817215be6e9f103a8a187df5b1142c4d2e952f547a64579a9b8cfa58bd762d6a55bde75c0f66f018c0597744d07ccdb08216f7b368db464e36667cecedcc00f3 alsaconf.patch
-8a52e6363d5dcfb16e1e607e1af3e46a2148989689e5ab04caf05f84dc68b34cc003b1cf0945ce2c3670cc7f3ef0e40824f689f1efa2d09177c82b13571a7168 alsa.initd
+7bf743024d7c5caed2fbf8af5cee73bcc569a7bab0bd6459541d3704cc6a7456d588b600b690e7406e122deaf0316dd1f67219a267bec4dff3f6c0f120edaae4 alsa.initd
6e716e6230fd3d2c33e3cb2dbf572d632c9ac6452c1768388bea7d3ca22f7c72cf6bcd702580f45cb9089983582011c8b04cbdb4420d14fb988167b1391ea547 alsa.confd"
diff --git a/user/alsa-utils/alsa.initd b/user/alsa-utils/alsa.initd
index e0a1215cf..1266b6624 100644
--- a/user/alsa-utils/alsa.initd
+++ b/user/alsa-utils/alsa.initd
@@ -39,7 +39,7 @@ restore() {
for ossfile in "${alsastatedir}"/oss/card*_pcm* ; do
[ -e "${ossfile}" ] || continue
# We use cat because I'm not sure if cp works properly on /proc
- local procfile=${ossfile##${alsastatedir}/oss}
+ local procfile="${ossfile##${alsastatedir}/oss}"
procfile="$(echo "${procfile}" | sed -e 's,_,/,g')"
if [ -e /proc/asound/"${procfile}"/oss ] ; then
cat "${ossfile}" > /proc/asound/"${procfile}"/oss
@@ -63,7 +63,7 @@ save() {
for ossfile in /proc/asound/card*/pcm*/oss; do
[ -e "${ossfile}" ] || continue
- local device=${ossfile##/proc/asound/} ; device=${device%%/oss}
+ local device="${ossfile##/proc/asound/}" ; device="${device%%/oss}"
device="$(echo "${device}" | sed -e 's,/,_,g')"
mkdir -p "${alsastatedir}/oss/"
cp "${ossfile}" "${alsastatedir}/oss/${device}"
diff --git a/user/apache-httpd/APKBUILD b/user/apache-httpd/APKBUILD
index 90a098922..fe6dd6672 100644
--- a/user/apache-httpd/APKBUILD
+++ b/user/apache-httpd/APKBUILD
@@ -3,7 +3,7 @@
pkgname=apache-httpd
_pkgreal=httpd
pkgver=2.4.39
-pkgrel=1
+pkgrel=2
pkgdesc="Open-source HTTP server"
url="https://httpd.apache.org"
arch="all"
@@ -138,7 +138,7 @@ ldap() {
sha512sums="9742202040b3dc6344b301540f54b2d3f8e36898410d24206a7f8dcecb1bea7d7230fabc7256752724558af249facf64bffe2cf678b8f7cccb64076737abfda7 httpd-2.4.39.tar.bz2
c8bc2bb06ae51b0956e0ee673e80c444551c9b33dfcbb845106477c46d9e52786a8896022e1f00102264fecdf66e35e47fc6cf0abe9836fa536735cff4e6adf4 adelie.layout
336e81fa0d08f8fbe6243d52bd59b12cf2e925deb49b29d7a22953c5d40a951b6b753f51e5a396752cb0bbaf1cf25b1358902f375fb65639d00e62db7ae55ff2 apache-httpd.confd
-9893248f1724748c9ef91171728b4c557ced7de543e23ed72cb75c02728048b2813ac99015a4a28e7984daa51faa6e42403c17b875539fe71c33424865eccecf apache-httpd.initd
+5762d53f39ce7ecd730e05ddf6c063ede65cd75b9e7d67217784c80366646491ef9474306e8eb119c8fb5b4358407b07636a4e9cd82325d8df4e3e00dabc3459 apache-httpd.initd
18e8859c7d99c4483792a5fd20127873aad8fa396cafbdb6f2c4253451ffe7a1093a3859ce719375e0769739c93704c88897bd087c63e1ef585e26dcc1f5dd9b apache-httpd.logrotate
cba279f31c12c3516bacf74856493c5a62a94017b3911d457b33e350af646b3e97632b15e396992e5115532c88c81fdd680a951ca0c71eb8a207f39d6c027c41 httpd.conf
83d57c57b809340bb07291c340ded5903ae55c0bba7c48e4eb0d27529ce4ecb6e235378ad770c69c8be2762b5346fa5bec94b6c585510719c37fe6addb33f998 alias.conf
diff --git a/user/apache-httpd/apache-httpd.initd b/user/apache-httpd/apache-httpd.initd
index c18643735..24be3e172 100755
--- a/user/apache-httpd/apache-httpd.initd
+++ b/user/apache-httpd/apache-httpd.initd
@@ -114,7 +114,7 @@ fullstatus() {
if ! service_started "${SVCNAME}"; then
eerror "${SVCNAME} not started"
- elif ! type -p $(set -- ${LYNX}; echo $1) 2>&1 >/dev/null; then
+ elif ! command -v "$(set -- ${LYNX}; printf '%s' "$1")" 2>&1 >/dev/null; then
eerror "lynx not installed!"
else
${LYNX} ${STATUSURL}
@@ -134,7 +134,7 @@ configdump() {
if ! service_started "${SVCNAME}"; then
eerror "${SVCNAME} not started"
- elif ! type -p $(set -- ${LYNX}; echo $1) 2>&1 >/dev/null; then
+ elif ! command -v "$(set -- ${LYNX}; printf '%s' "$1")" 2>&1 >/dev/null; then
eerror "lynx not installed!"
else
echo "${HTTPD} started with '${HTTPD_OPTS}'"
diff --git a/user/iptables/APKBUILD b/user/iptables/APKBUILD
index c9b8f4715..1d34a1ce3 100644
--- a/user/iptables/APKBUILD
+++ b/user/iptables/APKBUILD
@@ -3,7 +3,7 @@
pkgname=iptables
pkgver=1.8.3
-pkgrel=0
+pkgrel=1
pkgdesc="Linux kernel firewall, NAT and packet mangling tools"
url="https://www.netfilter.org/projects/iptables/index.html"
arch="all"
@@ -61,6 +61,6 @@ package() {
}
sha512sums="84b10080646077cbea78b7f3fcc58c6c6e1898213341c69862e1b48179f37a6820c3d84437c896071f966b61aa6d16b132d91948a85fd8c05740f29be3a0986d iptables-1.8.3.tar.bz2
-059b3bd8dd7dec60060ec5eb1e639fe8203207629f3a7dd4fdbe5ebca3f7e9b80df5592ebb27542e31830fd15a53cffac5772567053c104dfccf9b78613a31a1 iptables.initd
+726dfa1aa598d9dff802b99347138c861703b3dd28b2721a6b79b12f87d988369d3b4b9daee7cb2f9a930daac8921600de1e5342a347b3eae3791f0b9f0acbeb iptables.initd
cb7fecd5cab2c78bd3f215a41f39ec11c37eb360efbe83982378a0e647e0aa9dc0b7ec915a5b5081aa2f7747464787e69404aa15ba15a063c32cb8fb7dd13d1e iptables.confd
0897a7a22f8b700f7f1f5c355ad6cbf39740e44d6c962af99e479978d8a2d556ca7fe4e31f238829046b4a871ce0b5fd52e2544f1361d15dd1ea3e33992646c4 ip6tables.confd"
diff --git a/user/iptables/iptables.initd b/user/iptables/iptables.initd
index 98b52d0cd..63b2f06a4 100644
--- a/user/iptables/iptables.initd
+++ b/user/iptables/iptables.initd
@@ -34,7 +34,7 @@ depend() {
}
set_table_policy() {
- local chains table=$1 policy=$2
+ local chains table="$1" policy="$2"
case ${table} in
nat) chains="PREROUTING POSTROUTING OUTPUT";;
mangle) chains="PREROUTING INPUT FORWARD OUTPUT POSTROUTING";;
diff --git a/user/php7/APKBUILD b/user/php7/APKBUILD
index 6c6b08849..25b5af5ae 100644
--- a/user/php7/APKBUILD
+++ b/user/php7/APKBUILD
@@ -42,7 +42,7 @@
pkgname=php7
_pkgname=php
pkgver=7.2.20
-pkgrel=0
+pkgrel=1
_apiver=20170718
pkgdesc="The PHP7 language runtime engine"
url="https://php.net/"
@@ -532,7 +532,7 @@ _mv() {
}
sha512sums="8c32cb46e34440f3af905e9fc73d327e28c62b5b1b4b7f7221b192364b409172a88ae9f35aef40b796a81fbe87b8b64dec214cbf54011f5af53d9e8eddc9b3fa php-7.2.20.tar.bz2
-23df4e779c809db3e3b8e5b0353b1aafaad2f3dc56f2d1cd45f9b0e3ad71b32e40700d6ebfe914b3c87e8e0b670d0dc862ded1e5c898adf160e33dea372e044f php-fpm.initd
+cb3ba48fbd412f12d98ef1f88b509b40bc4ca44a16779a06d43e4db3cb8d24d54404b9e11ca941b5339af8d3281ca9c8ea3ba5ced4339f91fb40608b5ce9a647 php-fpm.initd
01d4ba3ef104ea378eb0e8cbb7bdee3fdf65e4bd6865eb3bc6c0dc4af31c2d52887abdf0150b5ef984b877860285a3b1af84b11ffebb5b8b722ea9faf83edfeb php-fpm.logrotate
a7f9ba5e11652fd1cb9e756c3269269a95de083ecb5be936a85c7a09c1396db9088e0251c6a643c40235c0e776fce2a471e5c7f5a033b85c7d3b3110c2b39e48 php-module.conf
b1008eabc86fcff88336fe2961e3229c159c930a05d97359136c381c5c1cc572a33110308a3e5ef5e31c60327f76c9ef02b375cd2ea8ff9caa7deeddc216f4ce disabled-tests.list
diff --git a/user/php7/php-fpm.initd b/user/php7/php-fpm.initd
index 46c65ec2e..88a87d458 100644
--- a/user/php7/php-fpm.initd
+++ b/user/php7/php-fpm.initd
@@ -51,9 +51,10 @@ start_pre() {
# If unix socket is used (instead of TCP/IP), then ensure that the
# directory exists and has correct privileges.
local listen="$(conf_get listen)"
- if [ "${listen:0:1}" = "/" ]; then
- checkpath -d -o $user:$group "$(dirname "$listen")"
- fi
+ case "$listen" in
+ /*)
+ checkpath -d -o $user:$group "$(dirname "$listen")";;
+ esac
checkpath -d "$(dirname "$pidfile")"
}
diff --git a/user/postgresql/APKBUILD b/user/postgresql/APKBUILD
index 97300d986..87a397f3d 100644
--- a/user/postgresql/APKBUILD
+++ b/user/postgresql/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=postgresql
pkgver=10.9
-pkgrel=0
+pkgrel=1
pkgdesc="Featureful object-relational database system (RDBMS)"
url="https://www.postgresql.org/"
arch="all"
@@ -259,7 +259,7 @@ sha512sums="4e2f30a0fd262f2e3ce5fc836425be635326600cd6cd4e117c57f59ea7ab2e9ea463
5f9d8bb4957194069d01af8ab3abc6d4d83a7e7f8bd7ebe1caae5361d621a3e58f91b14b952958138a794e0a80bc154fbb7e3e78d211e2a95b9b7901335de854 perl-rpath.patch
8439a6fdfdea0a4867daeb8bc23d6c825f30c00d91d4c39f48653f5ee77341f23282ce03a77aad94b5369700f11d2cb28d5aee360e59138352a9ab331a9f9d0f conf-unix_socket_directories.patch
1966b2a3971f56fbecd8daa45965236d487683e13300e5c000e595bbadbbe9d0e1301fbbfa034f452abe8a4e4a427781f772370b9ff392bb03fc11ee43c9dee7 disable-broken-tests.patch
-224e80f9e62843fd248e625abdd0d9fe477729ff3f9a64fc5c86dd37bb7176d3504107fbed7ce578e3a1db7f60b8cf2abf5fe4862c81f76b6d026e29ca495cfc postgresql.initd
+2c3aab4b24e0e1f60c3bd5aa2e24d93d3480711389e48454ed7cd7713eb27df7e1b29970ba1931ad0ae810458fae9e5cc7b6b6e2a24924eb4c493c6e7088ae75 postgresql.initd
a6d9cba5c7270484b3a22083b2b37742faefb01b6643040050c92235840c601b2e206ebda32804937b729c6cf42c79a558b921900e52fc420df2a03b5f29e1f7 postgresql.confd
f5a1cba051e7d846c2d16703514601cb25729ed96b677c9bd0c199d64552120a8b14b238af01917fdb87106681e12dee6fff7447558155ba273e4f96be5e2892 pg-restore.initd
c14a5684e914abb3b0ee71bbf15eed71a9264deacaa404a6e3af6bfc330d93e7598624d0ed11a94263106cc660f7f54c8ff57e759033cf606a795f69ff6c1c7c pg-restore.confd
diff --git a/user/postgresql/postgresql.initd b/user/postgresql/postgresql.initd
index 846229a40..1c1a5dcf9 100644
--- a/user/postgresql/postgresql.initd
+++ b/user/postgresql/postgresql.initd
@@ -63,8 +63,8 @@ start_pre() {
fi
fi
- local socket_dirs=$(get_config "unix_socket_directories" "/run/postgresql")
- local port=$(get_config "port" "$port")
+ local socket_dirs="$(get_config "unix_socket_directories" "/run/postgresql")"
+ local port="$(get_config "port" "$port")"
start_stop_daemon_args="$start_stop_daemon_args --env PGPORT=$port"
@@ -124,7 +124,7 @@ stop() {
&& retry="$retry/SIGQUIT/$force_timeout" \
|| force_timeout=0
- local seconds=$(( $nice_timeout + $rude_timeout + $force_timeout ))
+ local seconds="$(( $nice_timeout + $rude_timeout + $force_timeout ))"
ebegin "Stopping PostgreSQL (this can take up to $seconds seconds)"
diff --git a/user/strongswan/APKBUILD b/user/strongswan/APKBUILD
index e81d0be7c..6c895911a 100644
--- a/user/strongswan/APKBUILD
+++ b/user/strongswan/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Lee Starnes <lee@canned-death.us>
pkgname=strongswan
pkgver=5.7.1
-pkgrel=1
+pkgrel=2
pkgdesc="IPsec-based VPN solution focused on security and ease of use, supporting IKEv1/IKEv2 and MOBIKE"
url="https://www.strongswan.org/"
arch="all"
@@ -103,4 +103,4 @@ sha512sums="43102814434bee7c27a5956be59099cc4ffb9bb5b0d6382ce4c6a80d1d82ed6639f6
f7d98fb99b4855e8bfbb7369292c170536b1987e717feeda71f64ab71b35538e7d462609a773c6a6ed08c8e6ee7a186df12e1ea7d64b9dac0b17d4c7af17dab3 1002-vici-send-certificates-for-ike-sa-events.patch
a4235cd07e17ad3441dc391ded11ee9f4debdffa1e8218809731e73a545ca6fcdc0bb87239d41b1102b0b6719a4d31d43758972d2193ebe298b275285de2ce54 1003-vici-add-support-for-individual-sa-state-changes.patch
8b61e3ffbb39b837733e602ec329e626dc519bf7308d3d4192b497d18f38176789d23ef5afec51f8463ee1ddaf4d74546b965c03184132e217cbc27017e886c9 strongswan.initd
-1c44c801f66305c0331f76e580c0d60f1b7d5cd3cc371be55826b06c3899f542664628a912a7fb48626e34d864f72ca5dcd34b2f0d507c4f19c510d0047054c1 charon.initd"
+7182bed917585bce9749b4495ad64d3052d2999dbb505c34d568acd6df7b151232ec10c8efe12f0a07d0555ddfe01aad4e3b767b08f17a55ffcbedc57dc9d934 charon.initd"
diff --git a/user/strongswan/charon.initd b/user/strongswan/charon.initd
index 6f79679c0..7fda8d775 100644
--- a/user/strongswan/charon.initd
+++ b/user/strongswan/charon.initd
@@ -15,7 +15,7 @@ depend() {
start_post() {
ebegin "Loading ${name:-$RC_SVCNAME} configuration"
sleep 0.2
- swanctl --load-all &>/dev/null
+ swanctl --load-all >/dev/null 2>&1
eend $?
}