summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/m4/APKBUILD7
-rw-r--r--system/mailx/APKBUILD9
-rw-r--r--system/make/APKBUILD1
-rw-r--r--system/mdevd/APKBUILD2
-rw-r--r--system/mpc1/APKBUILD7
-rw-r--r--system/mpfr3/APKBUILD5
6 files changed, 10 insertions, 21 deletions
diff --git a/system/m4/APKBUILD b/system/m4/APKBUILD
index 861b1671f..a673c7277 100644
--- a/system/m4/APKBUILD
+++ b/system/m4/APKBUILD
@@ -6,9 +6,9 @@ pkgdesc="GNU macro processor"
url="https://www.gnu.org/software/m4"
arch="all"
license="GPL-3.0+"
-depends=
-makedepends="texinfo"
+depends=""
checkdepends="diffutils"
+makedepends="texinfo"
subpackages="m4-doc"
source="https://ftp.gnu.org/gnu/m4/$pkgname-$pkgver.tar.gz
disable-mbrtowc-test.patch
@@ -17,7 +17,6 @@ source="https://ftp.gnu.org/gnu/m4/$pkgname-$pkgver.tar.gz
"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -26,12 +25,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make install DESTDIR="$pkgdir"
rm -rf "$pkgdir"/usr/lib/charset.alias
rmdir -p "$pkgdir"/usr/lib 2>/dev/null || true
diff --git a/system/mailx/APKBUILD b/system/mailx/APKBUILD
index 4e9f0f221..846c4a08b 100644
--- a/system/mailx/APKBUILD
+++ b/system/mailx/APKBUILD
@@ -17,13 +17,14 @@ source="https://downloads.sourceforge.net/heirloom/$pkgname-$pkgver.tar.bz2
mailx-12.4-cve.patch"
build() {
- cd "$builddir"
- make PREFIX="/usr" SYSCONFDIR="/etc" STRIP=":" SENDMAIL="/usr/sbin/sendmail" MAILSPOOL="/var/spool/mail"
+ make PREFIX="/usr" SYSCONFDIR="/etc" STRIP=":" SENDMAIL="/usr/sbin/sendmail" \
+ MAILSPOOL="/var/spool/mail"
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" PREFIX="/usr" SYSCONFDIR="/etc" STRIP=":" UCBINSTALL="`command -v install`" SENDMAIL="/usr/sbin/sendmail" MAILSPOOL="/var/spool/mail" install
+ make DESTDIR="$pkgdir" PREFIX="/usr" SYSCONFDIR="/etc" STRIP=":" \
+ UCBINSTALL="`command -v install`" SENDMAIL="/usr/sbin/sendmail" \
+ MAILSPOOL="/var/spool/mail" install
install -m 755 "$srcdir"/Mail "$pkgdir"/usr/bin/Mail
}
diff --git a/system/make/APKBUILD b/system/make/APKBUILD
index 944f1c8b3..7f8639199 100644
--- a/system/make/APKBUILD
+++ b/system/make/APKBUILD
@@ -8,6 +8,7 @@ arch="all"
license="GPL-3.0+"
depends=""
checkdepends="perl"
+makedepends=""
subpackages="$pkgname-doc $pkgname-lang"
source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.bz2
fix-atexit-exit.patch
diff --git a/system/mdevd/APKBUILD b/system/mdevd/APKBUILD
index 5617909f0..4368a8aab 100644
--- a/system/mdevd/APKBUILD
+++ b/system/mdevd/APKBUILD
@@ -14,13 +14,11 @@ subpackages="$pkgname-doc $pkgname-openrc"
source="https://skarnet.org/software/$pkgname/$pkgname-$pkgver.tar.gz mdev.conf mdevd.run mdevd.initd"
build() {
- cd "$builddir"
./configure --enable-allstatic --enable-static-libc
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
mkdir -p -m 0755 "$pkgdir/etc"
cp -f "$srcdir/mdev.conf" "$pkgdir/etc/"
diff --git a/system/mpc1/APKBUILD b/system/mpc1/APKBUILD
index a0c516857..f90ee06ed 100644
--- a/system/mpc1/APKBUILD
+++ b/system/mpc1/APKBUILD
@@ -6,17 +6,14 @@ pkgdesc="Multiprecision C library"
url="http://www.multiprecision.org/"
arch="all"
license="LGPL-3.0+"
-depends=
+depends=""
makedepends_host="gmp-dev mpfr-dev"
makedepends="$makedepends_host"
-install=
subpackages="$pkgname-dev $pkgname-doc"
source="https://ftp.gnu.org/gnu/mpc/mpc-$pkgver.tar.gz"
-
builddir="$srcdir"/mpc-$pkgver
build() {
- cd "$builddir"
# workaround for a bug in configure script
EGREP=egrep \
./configure \
@@ -32,12 +29,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/system/mpfr3/APKBUILD b/system/mpfr3/APKBUILD
index 0e490bcd2..394e1480f 100644
--- a/system/mpfr3/APKBUILD
+++ b/system/mpfr3/APKBUILD
@@ -11,12 +11,11 @@ depends_dev="gmp-dev"
makedepends_build="texinfo"
makedepends_host="gmp-dev"
makedepends="$makedepends_build $makedepends_host"
-source="https://www.mpfr.org/mpfr-$pkgver/mpfr-$pkgver.tar.xz"
subpackages="$pkgname-doc mpfr-dev"
+source="https://www.mpfr.org/mpfr-$pkgver/mpfr-$pkgver.tar.xz"
builddir="$srcdir/mpfr-$pkgver"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,12 +26,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}