summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/py3-pyyaml/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/py3-pyyaml/APKBUILD b/user/py3-pyyaml/APKBUILD
new file mode 100644
index 000000000..92f26040a
--- /dev/null
+++ b/user/py3-pyyaml/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: zlg <zlg+adelie@zlg.space>
+# Maintainer: zlg <zlg+adelie@zlg.space>
+pkgname=py3-pyyaml
+_pkgname=PyYAML
+pkgver=3.13
+pkgrel=0
+pkgdesc="YAML parser and emitter for Python"
+url="https://pyyaml.org/wiki/PyYAML https://pypi.org/project/PyYAML/"
+arch="all"
+license="MIT"
+depends="python3 yaml"
+makedepends="python3-dev yaml yaml-dev"
+install=""
+subpackages=""
+source="http://pyyaml.org/download/pyyaml/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="93642286d0317e2fe970632c36d38ce6030f7cabcf971f28e3a1054f07390fcee5baaf7f167e7c9690dbd7b2adc61f5b7d75a218ace0abca34ff8815486cfdd7 PyYAML-3.13.tar.gz"