summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/perl-path-tiny/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/user/perl-path-tiny/APKBUILD b/user/perl-path-tiny/APKBUILD
new file mode 100644
index 000000000..0f32e49eb
--- /dev/null
+++ b/user/perl-path-tiny/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Dan Theisen <djt@hxx.in>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-path-tiny
+pkgver=0.108
+pkgrel=0
+pkgdesc="File path utility"
+url="https://metacpan.org/pod/Path::Tiny"
+arch="noarch"
+license="Apache-2.0"
+depends="perl"
+makedepends="perl-dev"
+checkdepends="perl-test-mockrandom"
+install=""
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/D/DA/DAGOLDEN/Path-Tiny-$pkgver.tar.gz"
+builddir="$srcdir/Path-Tiny-$pkgver"
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="21cbc8ec84474a2fc14b77a2c8b659676d4842a87a7572497c0dd6ba1c2e5f91cdefa30fc9578fdc416d8c8ee4155ff302833925c1fdf9242c898ba6a0ebee13 Path-Tiny-0.108.tar.gz"