summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/dotconf/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/user/dotconf/APKBUILD b/user/dotconf/APKBUILD
new file mode 100644
index 000000000..54f08fa92
--- /dev/null
+++ b/user/dotconf/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=dotconf
+pkgver=1.3
+pkgrel=0
+pkgdesc="Configuration file parsing library"
+url=" "
+arch="all"
+license="LGPL-2.1-only"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://distfiles.gentoo.org/distfiles/dotconf-$pkgver.tar.gz"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="ced0e66f70d11a309e77add1bfac1da8e85dcbe193633bd4bd1ae4bfd043b66880406e93ec18327b8c5d3de8d4bfc5278db6e5cb39b030ee1dabfa1ce267a98e dotconf-1.3.tar.gz"