summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/byacc/APKBUILD2
-rw-r--r--system/musl/APKBUILD4
-rw-r--r--system/musl/gettext-preserve-errno.patch28
-rw-r--r--system/openrc/APKBUILD2
-rw-r--r--system/zip/APKBUILD2
-rw-r--r--user/boost/APKBUILD2
-rw-r--r--user/cdrtools/APKBUILD2
-rw-r--r--user/comic-neue/APKBUILD22
-rw-r--r--user/courier-prime/APKBUILD21
-rw-r--r--user/dialog/APKBUILD2
-rw-r--r--user/faad2/APKBUILD2
-rw-r--r--user/fltk/APKBUILD4
-rw-r--r--user/freecell-solver/APKBUILD4
-rw-r--r--user/hyphen/APKBUILD2
-rw-r--r--user/i3wm/APKBUILD4
-rw-r--r--user/ido/APKBUILD2
-rw-r--r--user/imake/APKBUILD2
-rw-r--r--user/kolourpaint/APKBUILD2
-rw-r--r--user/libart-lgpl/APKBUILD2
-rw-r--r--user/libtirpc/APKBUILD2
-rw-r--r--user/lynx/APKBUILD2
-rw-r--r--user/nmap/APKBUILD87
-rw-r--r--user/ode/APKBUILD2
-rw-r--r--user/openal-soft/APKBUILD4
-rw-r--r--user/perl-extutils-depends/APKBUILD4
-rw-r--r--user/plasma-desktop/APKBUILD2
-rw-r--r--user/qps/APKBUILD2
-rw-r--r--user/trojita/APKBUILD2
28 files changed, 189 insertions, 29 deletions
diff --git a/system/byacc/APKBUILD b/system/byacc/APKBUILD
index 42affc3bd..ff756eb4a 100644
--- a/system/byacc/APKBUILD
+++ b/system/byacc/APKBUILD
@@ -4,7 +4,7 @@ pkgname=byacc
pkgver=20180609
pkgrel=2
pkgdesc="The Berkeley Yacc general-purpose parser generator"
-url="http://invisible-island.net/byacc/byacc.html"
+url="https://invisible-island.net/byacc/byacc.html"
arch="all"
options="!checkroot"
license="Public-Domain"
diff --git a/system/musl/APKBUILD b/system/musl/APKBUILD
index 368ba8766..1ab117c16 100644
--- a/system/musl/APKBUILD
+++ b/system/musl/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=musl
pkgver=1.1.21
-pkgrel=0
+pkgrel=1
pkgdesc="System library (libc) implementation"
url="http://www.musl-libc.org/"
arch="all"
@@ -26,6 +26,7 @@ source="http://www.musl-libc.org/releases/musl-$pkgver.tar.gz
3001-make-real-lastlog-h.patch
handle-aux-at_base.patch
fgetspent_r.patch
+ gettext-preserve-errno.patch
ldconfig
getent.c
@@ -123,6 +124,7 @@ sha512sums="fa6c4cc012626c5e517e0e10926fc845e3aa5f863ffaceeb38ac5b9ce0af631a37f6
88ae443dbb8e0a4368235bdc3a1c5c7b718495afa75e06deb8e01becc76cb1f0d6964589e2204fc749c9c1b3190b8b9ac1ae2c0099cab8e2ce3ec877103d4332 3001-make-real-lastlog-h.patch
6a7ff16d95b5d1be77e0a0fbb245491817db192176496a57b22ab037637d97a185ea0b0d19da687da66c2a2f5578e4343d230f399d49fe377d8f008410974238 handle-aux-at_base.patch
ded41235148930f8cf781538f7d63ecb0c65ea4e8ce792565f3649ee2523592a76b2a166785f0b145fc79f5852fd1fb1729a7a09110b3b8f85cba3912e790807 fgetspent_r.patch
+db180e437b8b7582e4d2baf06b592b88a9f6e5a8f18b7afa81d7a707240a774273778f8fec1c5cbea2a137e00cca49ff08fe762c871be20c70b50104b7e8e1e1 gettext-preserve-errno.patch
cce2f1eeb61e55674469c26871a573cce61d739c3defe9c8f56f2b774f6ba5435849ad542a6714120efddc98c297098e9c98a1a424ac593df2243d4aa479f9a9 ldconfig
378d70e65bcc65bb4e1415354cecfa54b0c1146dfb24474b69e418cdbf7ad730472cd09f6f103e1c99ba6c324c9560bccdf287f5889bbc3ef0bdf0e08da47413 getent.c
9d42d66fb1facce2b85dad919be5be819ee290bd26ca2db00982b2f8e055a0196290a008711cbe2b18ec9eee8d2270e3b3a4692c5a1b807013baa5c2b70a2bbf iconv.c"
diff --git a/system/musl/gettext-preserve-errno.patch b/system/musl/gettext-preserve-errno.patch
new file mode 100644
index 000000000..c55df3e21
--- /dev/null
+++ b/system/musl/gettext-preserve-errno.patch
@@ -0,0 +1,28 @@
+diff --git a/src/locale/dcngettext.c b/src/locale/dcngettext.c
+index 8b891d00..4c304393 100644
+--- a/src/locale/dcngettext.c
++++ b/src/locale/dcngettext.c
+@@ -122,6 +122,7 @@ char *dcngettext(const char *domainname, const char *msgid1, const char *msgid2,
+ const struct __locale_map *lm;
+ size_t domlen;
+ struct binding *q;
++ int old_errno = errno;
+
+ if ((unsigned)category >= LC_ALL) goto notrans;
+
+@@ -138,6 +139,7 @@ char *dcngettext(const char *domainname, const char *msgid1, const char *msgid2,
+ lm = loc->cat[category];
+ if (!lm) {
+ notrans:
++ errno = old_errno;
+ return (char *) ((n == 1) ? msgid1 : msgid2);
+ }
+
+@@ -250,6 +252,7 @@ notrans:
+ trans += l+1;
+ }
+ }
++ errno = old_errno;
+ return (char *)trans;
+ }
+
diff --git a/system/openrc/APKBUILD b/system/openrc/APKBUILD
index a252385b5..dac0cec8d 100644
--- a/system/openrc/APKBUILD
+++ b/system/openrc/APKBUILD
@@ -4,7 +4,7 @@ pkgver=0.24.1
_ver=${pkgver/_git*/}
pkgrel=6
pkgdesc="OpenRC manages the services, startup and shutdown of a host"
-url="http://git.overlays.gentoo.org/gitweb/?p=proj/openrc.git"
+url="https://github.com/OpenRC/openrc"
arch="all"
license="BSD-2-Clause"
depends="psmisc /sbin/init"
diff --git a/system/zip/APKBUILD b/system/zip/APKBUILD
index 401ce74e3..98e60671b 100644
--- a/system/zip/APKBUILD
+++ b/system/zip/APKBUILD
@@ -4,7 +4,7 @@ pkgname=zip
pkgver=3.0
pkgrel=5
pkgdesc="Creates PKZIP-compatible .zip files"
-url="http://www.info-zip.org/pub/infozip/Zip.html"
+url="http://infozip.sourceforge.net/"
arch="all"
options="!check" # No test suite.
license="Info-ZIP"
diff --git a/user/boost/APKBUILD b/user/boost/APKBUILD
index e526129df..87bbc0827 100644
--- a/user/boost/APKBUILD
+++ b/user/boost/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.62.0
_pkgver="${pkgver//./_}"
pkgrel=7
pkgdesc="Free peer-reviewed portable C++ source libraries"
-url="http://www.boost.org/"
+url="https://www.boost.org/"
arch="all"
license="BSL-1.0"
options="!check" # No test suite.
diff --git a/user/cdrtools/APKBUILD b/user/cdrtools/APKBUILD
index 0145aa351..39a3021c8 100644
--- a/user/cdrtools/APKBUILD
+++ b/user/cdrtools/APKBUILD
@@ -4,7 +4,7 @@ pkgname=cdrtools
pkgver=3.01
pkgrel=1
pkgdesc="Highly portable CD/DVD/Blu-Ray command line recording software"
-url="http://cdrecord.sourceforge.net/private/cdrecord.html"
+url="http://schilytools.sourceforge.net/"
arch="all"
options="suid"
license="CDDL-1.0"
diff --git a/user/comic-neue/APKBUILD b/user/comic-neue/APKBUILD
new file mode 100644
index 000000000..8b731ab10
--- /dev/null
+++ b/user/comic-neue/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=comic-neue
+pkgver=2.3
+pkgrel=0
+pkgdesc="Casual typeface"
+url="http://comicneue.com/"
+arch="noarch"
+options="!check" # No test suite.
+license="OFL-1.1"
+depends="fontconfig"
+makedepends=""
+subpackages=""
+source="http://comicneue.com/comic-neue-$pkgver.zip"
+builddir="$srcdir"
+
+package() {
+ cd "$builddir"
+ install -m644 -Dt "$pkgdir"/usr/share/fonts/X11/OTF/ OTF/*.otf
+}
+
+sha512sums="37adcc314f6d4bdc888e056488b209c4a8f3ee5f51618960a733e9d88ee513bafb2abf2b3d9d5bc4d2106297cf38645a8ab56c0fe79974b2ee6e0528aebaf4f5 comic-neue-2.3.zip"
diff --git a/user/courier-prime/APKBUILD b/user/courier-prime/APKBUILD
new file mode 100644
index 000000000..94cdce083
--- /dev/null
+++ b/user/courier-prime/APKBUILD
@@ -0,0 +1,21 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=courier-prime
+pkgver=1.203
+pkgrel=0
+pkgdesc="Redesigned Courier typeface made for screenwriters"
+url="https://www.quoteunquoteapps.com/courierprime/"
+arch="noarch"
+options="!check" # No test suite.
+license="OFL-1.1"
+depends="fontconfig"
+makedepends=""
+subpackages=""
+source="https://dev.gentoo.org/~jstein/dist/courier-prime-$pkgver.tar.xz"
+
+package() {
+ cd "$builddir"
+ install -m644 -Dt "$pkgdir"/usr/share/fonts/X11/TTF/ *.ttf
+}
+
+sha512sums="fef9d7f09dafbdb9d8626cb06cac617319d5ec43aef29fe7f6ee25156b380f9ec9684715d6012f05cb40d9511d44cf36a9ed1951281218b2c545e6ce4e7cdbda courier-prime-1.203.tar.xz"
diff --git a/user/dialog/APKBUILD b/user/dialog/APKBUILD
index a7dc72010..cc5e3e668 100644
--- a/user/dialog/APKBUILD
+++ b/user/dialog/APKBUILD
@@ -5,7 +5,7 @@ _realver=1.3-20181107
pkgver=${_realver/-/.}
pkgrel=0
pkgdesc="Script interpreter providing curses widgets"
-url="http://invisible-island.net/dialog/dialog.html"
+url="https://invisible-island.net/dialog/dialog.html"
arch="all"
options="!check" # No test suite.
license="LGPL-2.1-only"
diff --git a/user/faad2/APKBUILD b/user/faad2/APKBUILD
index 061255a83..c76894b27 100644
--- a/user/faad2/APKBUILD
+++ b/user/faad2/APKBUILD
@@ -3,7 +3,7 @@ pkgname=faad2
pkgver=2.8.8
pkgrel=0
pkgdesc="ISO AAC audio decoder"
-url="http://www.audiocoding.com/"
+url="https://www.audiocoding.com/"
arch="all"
options="!check" # No test suite.
license="GPL-2.0+"
diff --git a/user/fltk/APKBUILD b/user/fltk/APKBUILD
index fa5f5702c..fe5c3d55f 100644
--- a/user/fltk/APKBUILD
+++ b/user/fltk/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.3.4.2
_realver=1.3.4-2
pkgrel=0
pkgdesc="Cross-platform C++ GUI toolkit"
-url="http://www.fltk.org/"
+url="https://www.fltk.org/"
arch="all"
options="!check" # No test suite.
license="LGPL-2.0-only WITH FLTK-exception"
@@ -13,7 +13,7 @@ depends=""
depends_dev="libx11-dev libxext-dev libxft-dev mesa-dev"
makedepends="$depends_dev libjpeg-turbo-dev libpng-dev libxinerama-dev"
subpackages="$pkgname-doc $pkgname-dev $pkgname-fluid"
-source="http://fltk.org/pub/fltk/1.3.4/$pkgname-$_realver-source.tar.gz"
+source="https://fltk.org/pub/fltk/1.3.4/$pkgname-$_realver-source.tar.gz"
builddir="$srcdir"/$pkgname-$_realver
build() {
diff --git a/user/freecell-solver/APKBUILD b/user/freecell-solver/APKBUILD
index abf6ae301..78c1eadb5 100644
--- a/user/freecell-solver/APKBUILD
+++ b/user/freecell-solver/APKBUILD
@@ -4,7 +4,7 @@ pkgname=freecell-solver
pkgver=4.20.0
pkgrel=0
pkgdesc="Library for solving card games"
-url="http://fc-solve.shlomifish.org/"
+url="https://fc-solve.shlomifish.org/"
arch="all"
license="MIT"
depends="python3"
@@ -13,7 +13,7 @@ makedepends="gperf perl perl-task-freecellsolver-testing python3 py3-random2
checkdepends="gmp-dev libtap-dev perl-dev py3-cffi py3-pycotap the_silver_searcher
valgrind"
subpackages="$pkgname-dev $pkgname-doc"
-source="http://fc-solve.shlomifish.org/downloads/fc-solve/freecell-solver-$pkgver.tar.xz"
+source="https://fc-solve.shlomifish.org/downloads/fc-solve/freecell-solver-$pkgver.tar.xz"
build() {
cd "$builddir"
diff --git a/user/hyphen/APKBUILD b/user/hyphen/APKBUILD
index eb37c9a1b..a4d891e72 100644
--- a/user/hyphen/APKBUILD
+++ b/user/hyphen/APKBUILD
@@ -4,7 +4,7 @@ pkgname=hyphen
pkgver=2.8.8
pkgrel=1
pkgdesc="Library for high quality word hyphenation and justification"
-url="https://hunspell.sourceforge.net/"
+url="https://hunspell.github.io/"
arch="all"
license="LGPL-2.1+ OR LGPL-2.0+ OR MPL-1.0 or GPL-2.0+"
subpackages="$pkgname-dev"
diff --git a/user/i3wm/APKBUILD b/user/i3wm/APKBUILD
index 197cbd45f..59c94e802 100644
--- a/user/i3wm/APKBUILD
+++ b/user/i3wm/APKBUILD
@@ -5,7 +5,7 @@ pkgname=i3wm
pkgver=4.15
pkgrel=0
pkgdesc="Improved dynamic tiling window manager"
-url="http://i3wm.org"
+url="https://i3wm.org"
arch="all"
license="BSD-3-Clause"
options="!check" # The test suite requires X
@@ -15,7 +15,7 @@ makedepends="bison flex libxcb-dev xcb-util-cursor-dev xcb-util-keysyms-dev
checkdepends="perl-x11-xcb perl-anyevent perl-json-xs perl-ipc-run
perl-inline-c perl-dev libxcb-dev xcb-util-dev xorg-server-xephyr"
subpackages="$pkgname-doc"
-source="http://i3wm.org/downloads/i3-$pkgver.tar.bz2
+source="https://i3wm.org/downloads/i3-$pkgver.tar.bz2
i3wm-musl-glob-tilde.patch
i3wm-test-fix-off_t.patch
i3wm-test-disable-branch-check.patch"
diff --git a/user/ido/APKBUILD b/user/ido/APKBUILD
index a2714b183..9f858605e 100644
--- a/user/ido/APKBUILD
+++ b/user/ido/APKBUILD
@@ -4,7 +4,7 @@ pkgname=ido
pkgver=12.10.2
pkgrel=0
pkgdesc="Library for indicator display objects"
-url="https://launchpad.net/libido"
+url="https://launchpad.net/ido"
arch="all"
options="!check" # broken testsuite
license="(LGPL-2.1-only OR LGPL-3.0-only) AND GPL-3.0-only AND LGPL-2.0+"
diff --git a/user/imake/APKBUILD b/user/imake/APKBUILD
index ba5585c32..b2eb2284b 100644
--- a/user/imake/APKBUILD
+++ b/user/imake/APKBUILD
@@ -4,7 +4,7 @@ pkgname=imake
pkgver=1.0.7
pkgrel=0
pkgdesc="X Windows make utility"
-url="http://www.x.org"
+url="https://www.x.org"
arch="all"
license="X11"
options="!check" # No testsuite
diff --git a/user/kolourpaint/APKBUILD b/user/kolourpaint/APKBUILD
index 086b99da6..2cfeb26e9 100644
--- a/user/kolourpaint/APKBUILD
+++ b/user/kolourpaint/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kolourpaint
pkgver=18.08.3
pkgrel=0
pkgdesc="Simple painting program for KDE"
-url="https://www.kolourpaint.org/"
+url="https://kolourpaint.org/"
arch="all"
# yes, there is 2 only *and* 2+ code here.
license="BSD-2-Clause AND LGPL-2.0-only AND LGPL-2.0+"
diff --git a/user/libart-lgpl/APKBUILD b/user/libart-lgpl/APKBUILD
index e234aeced..8eb73fdb3 100644
--- a/user/libart-lgpl/APKBUILD
+++ b/user/libart-lgpl/APKBUILD
@@ -3,7 +3,7 @@ pkgname=libart-lgpl
pkgver=2.3.21
pkgrel=6
pkgdesc="Library for high-performance 2D graphics"
-url="http://www.levien.com/libart/"
+url="https://www.levien.com/libart/"
arch="all"
options="!check" # No test suite.
license="LGPL-2.0+"
diff --git a/user/libtirpc/APKBUILD b/user/libtirpc/APKBUILD
index 64124563a..5231ff63d 100644
--- a/user/libtirpc/APKBUILD
+++ b/user/libtirpc/APKBUILD
@@ -3,7 +3,7 @@ pkgname=libtirpc
pkgver=1.1.4
pkgrel=1
pkgdesc="Transport Independent RPC library (SunRPC replacement)"
-url="http://libtirpc.sourceforge.net/"
+url="https://sourceforge.net/projects/libtirpc/"
arch="all"
options="!check" # No test suite.
license="BSD-3-Clause"
diff --git a/user/lynx/APKBUILD b/user/lynx/APKBUILD
index 14d35db09..d19215e41 100644
--- a/user/lynx/APKBUILD
+++ b/user/lynx/APKBUILD
@@ -7,7 +7,7 @@ _relver=${pkgver/_p/rel.}
_v=${_relver%rel.*}
pkgrel=0
pkgdesc="Cross-platform text-based browser"
-url="http://lynx.invisible-island.net/"
+url="https://lynx.invisible-island.net/"
arch="all"
license="GPL-2.0-only"
depends="gzip"
diff --git a/user/nmap/APKBUILD b/user/nmap/APKBUILD
new file mode 100644
index 000000000..9be34874f
--- /dev/null
+++ b/user/nmap/APKBUILD
@@ -0,0 +1,87 @@
+# Maintainer: Dan Theisen <djt@hxx.in>
+pkgname=nmap
+pkgver=7.70
+pkgrel=0
+pkgdesc="A network exploration tool and security/port scanner"
+url="http://nmap.org"
+arch="all"
+license="GPL-2.0-only"
+depends=""
+makedepends="linux-headers openssl-dev libpcap-dev pcre-dev zlib-dev libssh2-dev lua5.3-dev"
+options="!checkroot"
+subpackages="
+ $pkgname-doc
+ $pkgname-scripts::noarch
+ $pkgname-nselibs::noarch
+ $pkgname-nping
+ $pkgname-ncat"
+source="https://nmap.org/dist/$pkgname-$pkgver.tar.bz2"
+
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ # zenmap and ndiff require python 2
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --without-zenmap \
+ --without-ndiff \
+ --with-openssl=yes \
+ --with-libpcap=yes \
+ --with-libpcre=yes \
+ --with-libz=yes \
+ --with-libssh2=yes \
+ --with-liblua=/usr/lua5.3
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
+scripts() {
+ depends="$pkgname-nselibs"
+ pkgdesc="$pkgdesc (scripts)"
+
+ mkdir -p "$subpkgdir"/usr/share/nmap/
+ mv "$pkgdir"/usr/share/nmap/scripts \
+ "$subpkgdir"/usr/share/nmap/
+}
+
+nselibs() {
+ pkgdesc="$pkgdesc (nselibs)"
+
+ mkdir -p "$subpkgdir"/usr/share/nmap/
+ mv "$pkgdir"/usr/share/nmap/nse_main.lua \
+ "$pkgdir"/usr/share/nmap/nselib \
+ "$subpkgdir"/usr/share/nmap/
+}
+
+ncat() {
+ pkgdesc="$pkgdesc (ncat tool)"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/ncat "$subpkgdir"/usr/bin
+}
+
+nping() {
+ pkgdesc="$pkgdesc (nping tool)"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/nping "$subpkgdir"/usr/bin
+}
+
+sha512sums="084c148b022ff6550e269d976d0077f7932a10e2ef218236fe13aa3a70b4eb6506df03329868fc68cb3ce78e4360b200f5a7a491d3145028fed679ef1c9ecae5 nmap-7.70.tar.bz2"
diff --git a/user/ode/APKBUILD b/user/ode/APKBUILD
index f21ef2b42..7a55d53cb 100644
--- a/user/ode/APKBUILD
+++ b/user/ode/APKBUILD
@@ -4,7 +4,7 @@ pkgname=ode
pkgver=0.14
pkgrel=0
pkgdesc="High performance library for simulating rigid body dynamics"
-url="https://www.ode-wiki.org/wiki/index.php?title=Main_Page"
+url="https://ode.org/"
arch="all"
options="!check" # Fails 48/52 tests
license="LGPL-2.1+ OR BSD-3-Clause"
diff --git a/user/openal-soft/APKBUILD b/user/openal-soft/APKBUILD
index fe3cbda8b..d5d32afe3 100644
--- a/user/openal-soft/APKBUILD
+++ b/user/openal-soft/APKBUILD
@@ -4,14 +4,14 @@ pkgname=openal-soft
pkgver=1.19.1
pkgrel=0
pkgdesc="Software implementation of OpenAL API"
-url="http://kcat.strangesoft.net/openal.html"
+url="https://kcat.strangesoft.net/openal.html"
arch="all"
license="LGPL-2.0+"
depends=""
depends_dev="alsa-lib-dev"
makedepends="$depends_dev cmake linux-headers pulseaudio-dev"
subpackages="$pkgname-dev"
-source="http://kcat.strangesoft.net/openal-releases/${pkgname}-${pkgver}.tar.bz2"
+source="https://kcat.strangesoft.net/openal-releases/${pkgname}-${pkgver}.tar.bz2"
prepare() {
default_prepare
diff --git a/user/perl-extutils-depends/APKBUILD b/user/perl-extutils-depends/APKBUILD
index 3947f7667..2d62635f2 100644
--- a/user/perl-extutils-depends/APKBUILD
+++ b/user/perl-extutils-depends/APKBUILD
@@ -4,7 +4,7 @@ pkgname=perl-extutils-depends
pkgver=0.405
pkgrel=0
pkgdesc="Easily build XS extensions that depend on XS extensions"
-url="https://metacpan.org/release/ExtUtils::Depends"
+url="https://metacpan.org/release/ExtUtils-Depends"
arch="noarch"
license="Artistic-1.0-Perl AND GPL-2.0"
depends="perl"
@@ -12,7 +12,6 @@ makedepends="perl-dev"
install=""
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/X/XA/XAOC/ExtUtils-Depends-$pkgver.tar.gz"
-sha512sums="b9983ad763ff0cb81c899bc24f3152f13c69e608304b6e4446bd07b9b13d039650f3f87544c0bdd29c67246ea2973f04a1ce0fccbffb566fe89fdbe0bb03f11b ExtUtils-Depends-0.405.tar.gz"
builddir="$srcdir/ExtUtils-Depends-$pkgver"
build() {
@@ -32,3 +31,4 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
+sha512sums="b9983ad763ff0cb81c899bc24f3152f13c69e608304b6e4446bd07b9b13d039650f3f87544c0bdd29c67246ea2973f04a1ce0fccbffb566fe89fdbe0bb03f11b ExtUtils-Depends-0.405.tar.gz"
diff --git a/user/plasma-desktop/APKBUILD b/user/plasma-desktop/APKBUILD
index 4b06e92d6..963cfc1dd 100644
--- a/user/plasma-desktop/APKBUILD
+++ b/user/plasma-desktop/APKBUILD
@@ -4,7 +4,7 @@ pkgname=plasma-desktop
pkgver=5.12.7
pkgrel=0
pkgdesc="Modern, functional, integrated libre desktop environment"
-url="https://www.kde.org/info/plasma-desktop"
+url="https://www.kde.org/plasma-desktop"
arch="all"
options="!check" # Test suite fails due to keyboard layouts
license="GPL-2.0 LGPL-2.1"
diff --git a/user/qps/APKBUILD b/user/qps/APKBUILD
index 814b96ed7..cdcc140e8 100644
--- a/user/qps/APKBUILD
+++ b/user/qps/APKBUILD
@@ -4,7 +4,7 @@ pkgname=qps
pkgver=1.10.19
pkgrel=0
pkgdesc="Qt-based task manager"
-url="https://github.com/QtDesktop"
+url="https://lxqt.org"
arch="all"
options="!check" # No test suite.
license="GPL-2.0+"
diff --git a/user/trojita/APKBUILD b/user/trojita/APKBUILD
index 2c92fc0fd..429226f42 100644
--- a/user/trojita/APKBUILD
+++ b/user/trojita/APKBUILD
@@ -4,7 +4,7 @@ pkgname=trojita
pkgver=0.7
pkgrel=0
pkgdesc="Qt-based IMAP email client"
-url="https://trojita.flaska.net/"
+url="http://trojita.flaska.net/"
arch="all"
options="!check"
license="(GPL-2.0-only OR GPL-3.0-only) AND (LGPL-2.1 WITH Nokia-Qt-exception-1.1 OR GPL-3.0-only) AND BSD-3-Clause AND GPL-2.0-only AND GPL-2.0+ AND LGPL-2.0-only AND LGPL-2.0+ AND LGPL-2.1+"