summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--experimental/kpartx/APKBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/experimental/kpartx/APKBUILD b/experimental/kpartx/APKBUILD
index 00a4c909c..881c34ae7 100644
--- a/experimental/kpartx/APKBUILD
+++ b/experimental/kpartx/APKBUILD
@@ -3,29 +3,28 @@
pkgname=kpartx
pkgver=0.8.4
pkgrel=0
-pkgdesc="Manipulates device mappings for the partitions of any block device; part of linux multipath-tools."
+pkgdesc="Manipulates device mappings for the partitions of any block device."
url="http://christophe.varoqui.free.fr/"
arch="all"
-options="!check" # Requires root and loopback kernel module.
-license="LGPL-2.0"
+options="checkroot" # Requires root and loopback kernel module.
+license="LGPL-2.0-only"
depends=""
makedepends="lvm2-dev"
+checkdepends="debianutils-which"
subpackages="$pkgname-doc"
source="https://git.opensvc.com/?p=multipath-tools/.git;a=snapshot;h=refs/tags/$pkgver;sf=tgz;/multipath-tools-$pkgver.tar.gz"
-builddir="$srcdir/multipath-tools-$pkgver"
+builddir="$srcdir/multipath-tools-$pkgver/kpartx"
build() {
- cd kpartx
make kpartx
}
check() {
- cd kpartx
- ./test-kpartx
+ echo 'exec sleep "$(echo ${1} / 1000000.0 | bc)"' > usleep && chmod 755 usleep
+ PATH=$PATH:/sbin:/usr/sbin:$builddir ./test-kpartx
}
package() {
- cd kpartx
make DESTDIR="$pkgdir" install
}