summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/libinput/APKBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/user/libinput/APKBUILD b/user/libinput/APKBUILD
index 284bfeae2..1220bb1cd 100644
--- a/user/libinput/APKBUILD
+++ b/user/libinput/APKBUILD
@@ -1,22 +1,22 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libinput
-pkgver=1.11.1
+pkgver=1.12.1
pkgrel=0
pkgdesc="Library for handling input devices"
url="https://www.freedesktop.org/wiki/Software/libinput/"
arch="all"
license="MIT"
-makedepends="doxygen eudev-dev graphviz libevdev-dev libwacom-dev meson
- mtdev-dev"
+makedepends="eudev-dev libevdev-dev libwacom-dev meson mtdev-dev"
checkdepends="check-dev valgrind"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
source="https://freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz"
build() {
cd "$builddir"
+ # Docs disabled: requires sphinx now
meson --prefix=/usr \
- -Ddocumentation=true \
+ -Ddocumentation=false \
-Dlibwacom=true \
-Ddebug-gui=false \
-Dtests=true builddir/
@@ -34,4 +34,4 @@ package() {
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-sha512sums="3dd1a318c89d66f5a66016c6dbfa5277b61a8cb5337d99f85b1eeef40ed894bdc04fd4588a97383988daea0f034df5a72bff318325320a01b857db9deb94a2b0 libinput-1.11.1.tar.xz"
+sha512sums="de1714526ee1244e3086729efa5b72724b2b989fa8d04418e633d1ef5a8ea777ae3cd4b8c5b015ca0da2b8cf5b07111bff2283c7d6068abcdfa81c3f71b81d68 libinput-1.12.1.tar.xz"