summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/apk-tools/APKBUILD16
-rw-r--r--system/apk-tools/deep.patch50
-rw-r--r--system/apk-tools/list.patch24
-rw-r--r--system/apk-tools/pmmx.patch2
-rw-r--r--system/apk-tools/search.patch29
-rw-r--r--system/apk-tools/virtual.patch109
-rw-r--r--system/coreutils/APKBUILD14
-rw-r--r--system/nss/APKBUILD4
-rw-r--r--system/s6-linux-init/APKBUILD4
-rw-r--r--user/abiword/APKBUILD12
-rw-r--r--user/acpid/APKBUILD2
-rw-r--r--user/goffice/APKBUILD5
-rw-r--r--user/haveged/APKBUILD2
-rw-r--r--user/i3status/APKBUILD31
-rw-r--r--user/i3status/asciidoctor.patch50
-rw-r--r--user/i3status/glob_tilde.patch38
-rw-r--r--user/libnftnl/APKBUILD7
-rw-r--r--user/nftables/APKBUILD6
-rw-r--r--user/wv/APKBUILD4
19 files changed, 260 insertions, 149 deletions
diff --git a/system/apk-tools/APKBUILD b/system/apk-tools/APKBUILD
index 78478e51e..86a15d28a 100644
--- a/system/apk-tools/APKBUILD
+++ b/system/apk-tools/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Adelie Platform Group <adelie-devel@lists.adelielinux.org>
pkgname=apk-tools
-pkgver=2.10.3
-pkgrel=2
+pkgver=2.10.4
+pkgrel=0
pkgdesc="Alpine Package Keeper - package manager"
url="https://git.alpinelinux.org/cgit/apk-tools/"
arch="all"
@@ -13,9 +13,9 @@ makedepends_host="zlib-dev openssl openssl-dev linux-headers"
makedepends="$makedepends_build $makedepends_host"
subpackages="$pkgname-static"
source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz
- deep.patch
- list.patch
pmmx.patch
+ search.patch
+ virtual.patch
"
prepare() {
@@ -69,7 +69,7 @@ static() {
"$subpkgdir"/sbin/apk.static
}
-sha512sums="1b190cfd04c69369bd4f2b708d4df0f8cf2937e1580c95138fd2c2257e7604d015deaca10a9fe0da6742981caadb6b067c15e417a1951866f781b8a5c71c98ee apk-tools-2.10.3.tar.xz
-059f0368b096c53357db567bf720f049cf19a88dbf10dc2496a739dfe332a6487b87f07056d7cf6f0c8a385782821547d4aba8c393591c4070838f1c98819dda deep.patch
-53d446734d32341cbd9ca00aedcd65d4d99220da354a9339837a6c79609a321f61ae917fb3cd9d4bffebcfc171d06c0f0d315e29a2d16285545c4fa085a75639 list.patch
-746d00ce2af554a25db7ecea2b0a4d8f7399d2560efb6bf59ea144012d0163d3e0bad84c799bd706e8be6c0a543d4e35728d6beb269fddbbea626384009129cb pmmx.patch"
+sha512sums="d2d9fde0aae9059236f68a3fc2f2186104bb9a099b15d296a6202a20ab2912638f10bb3b9edb70f359d060c5839573c3d50ef37d13095fa01c66dc3219ab6e39 apk-tools-2.10.4.tar.xz
+78f863c83af8b245aa38416c47016bcbe95ea8e33802123f6ea54b3752eb3c1ee79e5d6fc76ddedd2fba522b82a7367837f4596321085d54397b27fd5edf3b2f pmmx.patch
+5ac09eadabe44fe05c952c25df8f6daca292c63e6e5e3481d57603b8b3f1980385ccd87ad4a87b617353d1f936591afb9ee8815e4d8ec3e33913be2b3e3a3f84 search.patch
+4e2a8db82e6e40ae4863d12ee55151468d6e8c383e2e2001015f469e07f47057bc9055ab52a4a04f2bffa41ec225f77a9bd6042d5e1fcbd2908d7393e3aed2a1 virtual.patch"
diff --git a/system/apk-tools/deep.patch b/system/apk-tools/deep.patch
deleted file mode 100644
index b9e361717..000000000
--- a/system/apk-tools/deep.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From b0be9f610c02bb2d5e681a3904940d311e9de298 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
-Date: Mon, 3 Jun 2019 14:53:46 +0300
-Subject: solver: fix common dependency merging to inherit pinning and flags
-
-Notably this fixes occasional issues when doing upgrade with multiple
-versions of same packages. Without this the upgrade flag is not always
-propagated properly down the dependency chain.
----
- src/solver.c | 10 +++++++---
- 1 file changed, 7 insertions(+), 3 deletions(-)
-
-diff --git a/src/solver.c b/src/solver.c
-index e10cf8b..2121dd9 100644
---- a/src/solver.c
-+++ b/src/solver.c
-@@ -462,6 +462,8 @@ static void reconsider_name(struct apk_solver_state *ss, struct apk_name *name)
- name->name, name0->name);
- name0->ss.requirers++;
- name_requirers_changed(ss, name0);
-+ foreach_array_item(p, name0->providers)
-+ inherit_pinning_and_flags(ss, p->pkg, pkg);
- }
- }
- }
-@@ -510,7 +512,6 @@ static int compare_providers(struct apk_solver_state *ss,
- unsigned int solver_flags;
- int r;
-
--
- /* Prefer existing package */
- if (pkgA == NULL || pkgB == NULL)
- return (pkgA != NULL) - (pkgB != NULL);
-@@ -675,8 +676,11 @@ static void select_package(struct apk_solver_state *ss, struct apk_name *name)
-
- if (name->ss.requirers || name->ss.has_iif) {
- foreach_array_item(p, name->providers) {
-- dbg_printf(" consider "PKG_VER_FMT" iif_triggered=%d, tag_ok=%d, selectable=%d, provider_priority=%d, installed=%d\n",
-- PKG_VER_PRINTF(p->pkg), p->pkg->ss.iif_triggered, p->pkg->ss.tag_ok, p->pkg->ss.pkg_selectable,
-+ dbg_printf(" consider "PKG_VER_FMT" iif_triggered=%d, tag_ok=%d, selectable=%d, available=%d, flags=0x%x, provider_priority=%d, installed=%d\n",
-+ PKG_VER_PRINTF(p->pkg),
-+ p->pkg->ss.iif_triggered, p->pkg->ss.tag_ok,
-+ p->pkg->ss.pkg_selectable, p->pkg->ss.pkg_available,
-+ p->pkg->ss.solver_flags,
- p->pkg->provider_priority, p->pkg->ipkg != NULL);
- /* Ensure valid pinning and install-if trigger */
- if (name->ss.requirers == 0 &&
---
-cgit v1.2.1
-
diff --git a/system/apk-tools/list.patch b/system/apk-tools/list.patch
deleted file mode 100644
index 9692c0c8c..000000000
--- a/system/apk-tools/list.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/src/list.c b/src/list.c
-index e285e3f..dcbaeea 100644
---- a/src/list.c
-+++ b/src/list.c
-@@ -61,7 +61,7 @@ static int is_orphaned(const struct apk_name *name)
- /* repo 1 is always installed-db, so if other bits are set it means the package is available somewhere
- * (either cache or in a proper repo)
- */
-- return (repos & ~BIT(1)) == 0;
-+ return (repos & ~BIT(0)) == 0;
- }
-
- /* returns the currently installed package if there is a newer package that satisfies `name` */
-@@ -144,7 +144,7 @@ static void filter_package(const struct apk_package *pkg, const struct list_ctx
- if (ctx->orphaned && !is_orphaned(pkg->name))
- return;
-
-- if (ctx->available && pkg->repos == BIT(1))
-+ if (ctx->available && pkg->repos == BIT(0))
- return;
-
- if (ctx->upgradable && !is_upgradable(pkg->name, pkg))
-0001-list-Detect-orphaned-packages-correctly.patch
-0001-list-Detect-orphaned-packages-correctly.patch
diff --git a/system/apk-tools/pmmx.patch b/system/apk-tools/pmmx.patch
index 1b19edc94..e64ad6c0d 100644
--- a/system/apk-tools/pmmx.patch
+++ b/system/apk-tools/pmmx.patch
@@ -1,6 +1,6 @@
--- apk-tools-2.10.1/src/apk_defines.h.old 2018-09-10 08:04:03.000000000 +0000
+++ apk-tools-2.10.1/src/apk_defines.h 2019-01-04 03:31:41.900000000 +0000
-@@ -88,7 +88,7 @@
+@@ -89,7 +89,7 @@
#if defined(__x86_64__)
#define APK_DEFAULT_ARCH "x86_64"
#elif defined(__i386__)
diff --git a/system/apk-tools/search.patch b/system/apk-tools/search.patch
new file mode 100644
index 000000000..1c652356f
--- /dev/null
+++ b/system/apk-tools/search.patch
@@ -0,0 +1,29 @@
+From 530a6e6847657aa9187acd187269ac25f7cdd932 Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Tue, 9 Jul 2019 00:40:15 -0500
+Subject: [PATCH] search: Show in "simple" help output
+
+Most users probably want to know about the 'search' applet.
+
+Omission from 'apk --help' output reported by fungalnet[1].
+
+[1]: https://www.reddit.com/r/AdelieLinux/comments/c8mtk9/apk_search/
+---
+ src/search.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/search.c b/src/search.c
+index 9a71747..0b00a3b 100644
+--- a/src/search.c
++++ b/src/search.c
+@@ -209,6 +209,7 @@ static struct apk_applet apk_search = {
+ .help = "Search package by PATTERNs or by indexed dependencies",
+ .arguments = "PATTERN",
+ .open_flags = APK_OPENF_READ | APK_OPENF_NO_STATE,
++ .command_groups = APK_COMMAND_GROUP_QUERY,
+ .context_size = sizeof(struct search_ctx),
+ .optgroups = { &optgroup_global, &optgroup_applet },
+ .main = search_main,
+--
+2.22.0
+
diff --git a/system/apk-tools/virtual.patch b/system/apk-tools/virtual.patch
new file mode 100644
index 000000000..31e6d6807
--- /dev/null
+++ b/system/apk-tools/virtual.patch
@@ -0,0 +1,109 @@
+From b45415b1096e76f40b32326d2798123f81fe5976 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Tue, 2 Jul 2019 15:27:57 +0300
+Subject: [PATCH 1/2] add: fix virtual package id generation
+
+Fixes 37fbafcd by adding more input to the hash than just second
+grained time stamp - collisions would happen when running apk
+scripted.
+
+For virtual package the hash works only as unique identifier, so
+try to add elements that should make it unique in most cases.
+
+Fixes #10648
+---
+ src/add.c | 51 +++++++++++++++++++++++++++++++++++----------------
+ 1 file changed, 35 insertions(+), 16 deletions(-)
+
+diff --git a/src/add.c b/src/add.c
+index 2d342ab..e028736 100644
+--- a/src/add.c
++++ b/src/add.c
+@@ -11,6 +11,7 @@
+
+ #include <errno.h>
+ #include <stdio.h>
++#include <unistd.h>
+ #include "apk_applet.h"
+ #include "apk_database.h"
+ #include "apk_print.h"
+@@ -80,6 +81,38 @@ static int non_repository_check(struct apk_database *db)
+ return 1;
+ }
+
++static struct apk_package *create_virtual_package(struct apk_database *db, struct apk_name *name)
++{
++ char ver[32];
++ struct apk_package *virtpkg;
++ struct tm tm;
++ EVP_MD_CTX *mdctx;
++ time_t now = apk_time();
++ pid_t pid = getpid();
++
++ localtime_r(&now, &tm);
++ strftime(ver, sizeof ver, "%Y%m%d.%H%M%S", &tm);
++
++ virtpkg = apk_pkg_new();
++ if (virtpkg == NULL) return 0;
++
++ virtpkg->name = name;
++ virtpkg->version = apk_blob_atomize(APK_BLOB_STR(ver));
++ virtpkg->description = strdup("virtual meta package");
++ virtpkg->arch = apk_blob_atomize(APK_BLOB_STR("noarch"));
++
++ mdctx = EVP_MD_CTX_new();
++ EVP_DigestInit_ex(mdctx, apk_checksum_default(), NULL);
++ EVP_DigestUpdate(mdctx, &tm, sizeof tm);
++ EVP_DigestUpdate(mdctx, &pid, sizeof pid);
++ EVP_DigestUpdate(mdctx, virtpkg->name->name, strlen(virtpkg->name->name) + 1);
++ virtpkg->csum.type = EVP_MD_CTX_size(mdctx);
++ EVP_DigestFinal_ex(mdctx, virtpkg->csum.data, NULL);
++ EVP_MD_CTX_free(mdctx);
++
++ return virtpkg;
++}
++
+ static int add_main(void *ctx, struct apk_database *db, struct apk_string_array *args)
+ {
+ struct add_ctx *actx = (struct add_ctx *) ctx;
+@@ -93,10 +126,6 @@ static int add_main(void *ctx, struct apk_database *db, struct apk_string_array
+
+ if (actx->virtpkg) {
+ apk_blob_t b = APK_BLOB_STR(actx->virtpkg);
+- struct tm tm;
+- time_t now;
+- char ver[32];
+-
+ apk_blob_pull_dep(&b, db, &virtdep);
+ if (APK_BLOB_IS_NULL(b) || virtdep.conflict ||
+ virtdep.result_mask != APK_DEPMASK_ANY ||
+@@ -104,24 +133,14 @@ static int add_main(void *ctx, struct apk_database *db, struct apk_string_array
+ apk_error("%s: bad package specifier");
+ return -1;
+ }
+-
+ if (virtdep.name->name[0] != '.' && non_repository_check(db))
+ return -1;
+
+- now = apk_time();
+- localtime_r(&now, &tm);
+- strftime(ver, sizeof ver, "%Y%m%d.%H%M%S", &tm);
+-
+- virtpkg = apk_pkg_new();
+- if (virtpkg == NULL) {
++ virtpkg = create_virtual_package(db, virtdep.name);
++ if (!virtpkg) {
+ apk_error("Failed to allocate virtual meta package");
+ return -1;
+ }
+- virtpkg->name = virtdep.name;
+- apk_blob_checksum(APK_BLOB_STR(ver), apk_checksum_default(), &virtpkg->csum);
+- virtpkg->version = apk_blob_atomize(APK_BLOB_STR(ver));
+- virtpkg->description = strdup("virtual meta package");
+- virtpkg->arch = apk_blob_atomize(APK_BLOB_STR("noarch"));
+
+ virtdep.result_mask = APK_VERSION_EQUAL;
+ virtdep.version = virtpkg->version;
+--
+2.22.0
+
diff --git a/system/coreutils/APKBUILD b/system/coreutils/APKBUILD
index 4f9c1ddea..e5461c7d2 100644
--- a/system/coreutils/APKBUILD
+++ b/system/coreutils/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=coreutils
pkgver=8.31
-pkgrel=2
+pkgrel=3
pkgdesc="Basic file, shell, and text manipulation utilities"
url="https://www.gnu.org/software/coreutils/"
arch="all"
@@ -30,13 +30,15 @@ build() {
LIBS="-lutmps -lskarnet" ./configure \
--build=$CBUILD \
--host=$CHOST \
- --prefix=/usr \
+ --prefix=/ \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
+ --datarootdir=/usr/share \
+ --libexecdir=/usr/libexec \
--enable-nls \
--without-gmp \
- --enable-no-install-program=hostname,su,kill,uptime \
+ --enable-no-install-program=groups,hostname,su,kill,uptime \
--enable-install-program=arch \
--with-packager="Adélie" \
--with-packager-bug-reports="https://bts.adelielinux.org/"
@@ -55,8 +57,10 @@ check() {
package() {
make DESTDIR="$pkgdir" install
- rm -rf "$pkgdir"/usr/lib/charset.alias
- rmdir -p "$pkgdir"/usr/lib 2>/dev/null || true
+ # stdbuf(1) requires a /usr/libexec/ .so
+ # env(1) needs to be in /usr/bin/ for compatibility with the rest of the world
+ mkdir -p "$pkgdir"/usr/bin
+ mv "$pkgdir"/bin/stdbuf "$pkgdir"/bin/env "$pkgdir"/usr/bin/
}
sha512sums="ef8941dae845bbf5ae5838bc49e44554a766302930601aada6fa594e8088f0fbad74e481ee392ff89633e68b99e4da3f761fcb5d31ee3b233d540fe2a2d4e1af coreutils-8.31.tar.xz
diff --git a/system/nss/APKBUILD b/system/nss/APKBUILD
index 2699bd658..9c41ced39 100644
--- a/system/nss/APKBUILD
+++ b/system/nss/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Łukasz Jendrysik <scadu@yandex.com>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=nss
-pkgver=3.44
+pkgver=3.44.1
_ver=${pkgver//./_}
pkgrel=0
pkgdesc="Mozilla Network Security Services"
@@ -141,7 +141,7 @@ tools() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
-sha512sums="c4d7343a66f91c5888a121e266d1f1471da798a21d608a29caf598a828725e4bf9ea7411a105b23335f20bd7c12788dad567922ceeaebeb0c98fbf9bbe4006f7 nss-3.44.tar.gz
+sha512sums="eb8777701a25b54377026633b6bf284e4c62308012058355f348a7c57525afe96db74a07de41ba01754e316a7dff06689de527359a5474ed7ab606779c4cf169 nss-3.44.1.tar.gz
75dbd648a461940647ff373389cc73bc8ec609139cd46c91bcce866af02be6bcbb0524eb3dfb721fbd5b0bc68c20081ed6f7debf6b24317f2a7ba823e8d3c531 nss.pc.in
0f2efa8563b11da68669d281b4459289a56f5a3a906eb60382126f3adcfe47420cdcedc6ab57727a3afeeffa2bbb4c750b43bef8b5f343a75c968411dfa30e09 nss-util.pc.in
09c69d4cc39ec9deebc88696a80d0f15eb2d8c94d9daa234a2adfec941b63805eb4ce7f2e1943857b938bddcaee1beac246a0ec627b71563d9f846e6119a4a15 nss-softokn.pc.in
diff --git a/system/s6-linux-init/APKBUILD b/system/s6-linux-init/APKBUILD
index 70f8bbefa..aed46e575 100644
--- a/system/s6-linux-init/APKBUILD
+++ b/system/s6-linux-init/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Laurent Bercot <ska-adelie@skarnet.org>
# Maintainer: Laurent Bercot <ska-adelie@skarnet.org>
pkgname=s6-linux-init
-pkgver=1.0.1.0
+pkgver=1.0.2.0
pkgrel=0
pkgdesc="A s6-based init system"
url="https://skarnet.org/software/$pkgname/"
@@ -109,7 +109,7 @@ doc() {
cp -a "$builddir/doc" "$subpkgdir/usr/share/doc/$pkgname"
}
-sha512sums="0b40601b25f88464b5ff63b7eddf6ffa30eb868d2d9652f3d6a608b8f508e46712214d6e674f74136e57dd4504eb71ef585c725ba1a6566cfc0a025e70cfadc9 s6-linux-init-1.0.1.0.tar.gz
+sha512sums="1140434b07bf85956382a43bc8f58fa32cbefc43e40a48825b9e938d7950d988585e872667b79ba1bd44f0befb69202bcb7347c0e722ab5d20dc9304cd1be843 s6-linux-init-1.0.2.0.tar.gz
756b0cbbe5dabb4631380c3c7ea199cc213224b2e36e50a2d012a61948170078b78bf49b85d886319fecf59843087f937d3d804723b2553ac9f94d088a2f0fd8 rc.init
e73c3c32b118831074288d23fadace2158a2b15d5a13ffa73290b92a9e39c2a21c73d3b0eabea29bcbaa5f6381611fd8d0aaa6aa691ec7de91b8ef6ae404b6da runlevel
7bb050248a5c2ab6a56c50c35f87cde724f97ff9882f5e60b0f0f2f14bd93c1df7d99fedc3d81c8519cf1a1ed90e03f1cbb9bf891c7b3618aa9a5f5738d262f4 rc.shutdown
diff --git a/user/abiword/APKBUILD b/user/abiword/APKBUILD
index 351961055..76ae5ea08 100644
--- a/user/abiword/APKBUILD
+++ b/user/abiword/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: multiplexd <multi@in-addr.xyz>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=abiword
pkgver=3.0.2
pkgrel=0
@@ -11,26 +11,21 @@ license="GPL-2.0+"
makedepends="bzip2-dev enchant-dev fribidi-dev goffice-dev gtk+3.0-dev
libgsf-dev libjpeg-turbo-dev librsvg-dev libxslt-dev pcre-dev
popt-dev wv-dev"
-
# openxml plugin
makedepends="$makedepends boost-dev"
-
# collab plugin
makedepends="$makedepends gnutls-dev libsoup-dev dbus-glib-dev"
-
subpackages="$pkgname-dev $pkgname-doc"
-
_plugins="applix babelfish bmp clarisworks collab docbook eml epub \
freetranslation garble gdict gimp google hancom hrtext iscii kword \
latex loadbindings mht mif mswrite openwriter openxml opml paint \
passepartout pdb pdf presentation s5 sdw t602 urldict wikipedia wml \
xslfo"
-
source="https://www.abisource.com/downloads/$pkgname/$pkgver/source/$pkgname-$pkgver.tar.gz
- fix-black-drawing-regression.patch"
+ fix-black-drawing-regression.patch
+ "
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -42,7 +37,6 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/acpid/APKBUILD b/user/acpid/APKBUILD
index aa674dfbb..c9ad2e28e 100644
--- a/user/acpid/APKBUILD
+++ b/user/acpid/APKBUILD
@@ -1,4 +1,4 @@
-# Maintainer: multiplexd <multi@in-addr.xyz>
+# Maintainer:
# Contributor: Morten Linderud <foxboron@archlinux.org>
# Contributor: Sébastien Luttringer
# Contributor: xduugu
diff --git a/user/goffice/APKBUILD b/user/goffice/APKBUILD
index 0b5fc833b..91f8ef190 100644
--- a/user/goffice/APKBUILD
+++ b/user/goffice/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: multiplexd <multi@in-addr.xyz>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=goffice
pkgver=0.10.44
pkgrel=0
@@ -14,7 +14,6 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,12 +26,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/haveged/APKBUILD b/user/haveged/APKBUILD
index 83dc7d866..98fd59e1c 100644
--- a/user/haveged/APKBUILD
+++ b/user/haveged/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
# Contributor: Danilo Godec <danilo.godec@agenda.si>
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
-# Maintainer: multiplexd <multi@in-addr.xyz>
+# Maintainer:
pkgname=haveged
pkgver=1.9.4
pkgrel=1
diff --git a/user/i3status/APKBUILD b/user/i3status/APKBUILD
index 554916af7..b892fef2f 100644
--- a/user/i3status/APKBUILD
+++ b/user/i3status/APKBUILD
@@ -1,35 +1,40 @@
# Contributor: Luis Ressel <aranea@aixah.de>
# Maintainer: Luis Ressel <aranea@aixah.de>
pkgname=i3status
-pkgver=2.12
+pkgver=2.13
pkgrel=0
pkgdesc="Status bar generator for dzen2, xmobar or similar"
url="https://i3wm.org/i3status/"
arch="all"
-options="!check" # No test suite
+options="!check" # No test suite
license="MIT"
depends=""
-makedepends="alsa-lib-dev confuse-dev libnl3-dev pkgconf pulseaudio-dev yajl-dev"
+makedepends="alsa-lib-dev asciidoctor confuse-dev libnl3-dev pkgconf
+ pulseaudio-dev yajl-dev"
subpackages="$pkgname-doc"
source="$url/$pkgname-$pkgver.tar.bz2
+ asciidoctor.patch
glob_tilde.patch"
prepare() {
- cd "$builddir"
default_prepare
- # TODO: The setcap part can be dropped after the 2.13 release
- sed -i -e '/^CFLAGS+=-g$/d' -e '/setcap/d' Makefile
+ autoreconf -vif
}
build() {
- cd "$builddir"
- make i3status
+ mkdir build
+ cd build
+
+ PATH_ASCIIDOC=/usr/bin/asciidoctor ../configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
+ make -C build DESTDIR="$pkgdir" install
}
-
-sha512sums="687a880a65cb8df46f5e9d2256b59724ba3424c502e9a0fb3ca71b070875df5f4008ee501c554bc716f2d728a5cf813a36d22d7377d42c3c46b14381d385bab3 i3status-2.12.tar.bz2
-2a0a85dba02b9e9962f13d4bc151fd1672f215292800d9eeff5a10bd363b74f422d3b320851f31b73062ceeded974f5b105aec914c84f78ba418312bed189aa4 glob_tilde.patch"
+sha512sums="6dadff19e53499d169ba4f491e1f821014b4f92fc3c93d7947c85cbbbdeaba538d02bd8ab98fe266a8f80756a287fd5803ec77a8cd874d50082b5cad309875c2 i3status-2.13.tar.bz2
+26527b9a0053d363f2b2991f9be3a15cb5fbf5553dca9498a9cff1c1a65e887f392215b60a484e329e6ef8efd63f9b67727826fb6ccfe1033c653feef34aaab8 asciidoctor.patch
+765a5b64d79f61cd68280d77a7316e7f571a3c2e385d9a227885cde5fc057b1a892e92a65c0fc54832bfdda30743df6e9f82a847b55c9e7389575c7fbad9e0d4 glob_tilde.patch"
diff --git a/user/i3status/asciidoctor.patch b/user/i3status/asciidoctor.patch
new file mode 100644
index 000000000..575a00e1b
--- /dev/null
+++ b/user/i3status/asciidoctor.patch
@@ -0,0 +1,50 @@
+From 1821c7cd94e2424352f0fcb1f2933b368a4c381c Mon Sep 17 00:00:00 2001
+From: Luis Ressel <aranea@aixah.de>
+Date: Tue, 9 Jul 2019 13:18:43 +0200
+Subject: [PATCH] Build man pages with asciidoctor
+
+asciidoctor doesn't support the -f option. Furthermore, its docbook
+output appears to be unsuitable for xmlto, so make it generate a manpage
+directly.
+---
+ Makefile.am | 7 ++-----
+ configure.ac | 3 ---
+ 2 files changed, 2 insertions(+), 8 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index bb251f0..93ef552 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -11,13 +11,10 @@ dist_man1_MANS = \
+ asciidoc_MANS = \
+ man/i3status.1
+
+-$(asciidoc_MANS): man/%.1: man/%.xml man/$(dirstamp)
+- $(AM_V_GEN) out='$@'; @PATH_XMLTO@ man -o "$${out%/*}" $<
++$(asciidoc_MANS): man/%.1: man/%.man man/$(dirstamp)
++ $(AM_V_GEN) @PATH_ASCIIDOC@ -d manpage -b manpage -o $@ $<
+ @stamp='$@'; $(MKDIR_P) "$${stamp%/*}"
+
+-man/%.xml: man/%.man man/asciidoc.conf man/$(dirstamp)
+- $(AM_V_GEN) @PATH_ASCIIDOC@ -d manpage -b docbook -f $(top_builddir)/man/asciidoc.conf -o $@ $<
+-
+ AM_CPPFLAGS = \
+ -DSYSCONFDIR="\"$(sysconfdir)\"" \
+ -I$(top_srcdir)/include \
+diff --git a/configure.ac b/configure.ac
+index cf9e430..78c4aa5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -104,9 +104,6 @@ AC_PROG_LN_S
+ AC_PATH_PROG([PATH_ASCIIDOC], [asciidoc], [no])
+ AS_IF([test x"$PATH_ASCIIDOC" = x"no"],
+ [AC_MSG_ERROR([asciidoc is required for generating man pages])])
+-AC_PATH_PROG([PATH_XMLTO], [xmlto], [no])
+-AS_IF([test x"$PATH_XMLTO" = x"no"],
+- [AC_MSG_ERROR([xmlto is required for generating man pages])])
+
+ AM_PROG_AR
+
+--
+2.22.0
+
diff --git a/user/i3status/glob_tilde.patch b/user/i3status/glob_tilde.patch
index b1f2ba667..87177d78e 100644
--- a/user/i3status/glob_tilde.patch
+++ b/user/i3status/glob_tilde.patch
@@ -1,8 +1,14 @@
-diff --git i/i3status.c w/i3status.c
-index 5088c96..3c18214 100644
---- i/i3status.c
-+++ w/i3status.c
-@@ -210,29 +210,19 @@ static int valid_color(const char *value) {
+diff --git a/i3status.c b/i3status.c
+index 0898da3..f4b10fd 100644
+--- a/i3status.c
++++ b/i3status.c
+@@ -207,35 +207,23 @@ static int valid_color(const char *value) {
+
+ /*
+ * This function resolves ~ in pathnames.
+- * It may resolve wildcards in the first part of the path, but if no match
+- * or multiple matches are found, it just returns a copy of path as given.
++ * The syntax '~user' is not supported.
*
*/
static char *resolve_tilde(const char *path) {
@@ -22,19 +28,19 @@ index 5088c96..3c18214 100644
- } else {
- head = globbuf.gl_pathv[0];
- result = scalloc(strlen(head) + (tail ? strlen(tail) : 0) + 1);
-- strncpy(result, head, strlen(head));
-- if (tail)
-- strncat(result, tail, strlen(tail));
+- strcpy(result, head);
+- if (tail) {
+- strcat(result, tail);
+ char *home, *result = NULL;
+
-+ if (strncmp(path, "~/", 2) == 0) {
++ if (path[0] == '~' && (path[1] == '/' || path[1] == '\0')) {
+ home = getenv("HOME");
+ if (home != NULL) {
+ result = scalloc(strlen(home) + strlen(path));
+ strcpy(result, home);
-+ strcat(result, path+1);
++ strcat(result, path + 1);
+ return result;
-+ }
+ }
}
- globfree(&globbuf);
@@ -43,11 +49,11 @@ index 5088c96..3c18214 100644
}
static char *get_config_path(void) {
-diff --git i/include/i3status.h w/include/i3status.h
-index 9ac471d..27ecae4 100644
---- i/include/i3status.h
-+++ w/include/i3status.h
-@@ -236,4 +236,9 @@ extern cfg_t *cfg, *cfg_general, *cfg_section;
+diff --git a/include/i3status.h b/include/i3status.h
+index 217376a..34e44a0 100644
+--- a/include/i3status.h
++++ b/include/i3status.h
+@@ -241,4 +241,9 @@ extern cfg_t *cfg, *cfg_general, *cfg_section;
extern void **cur_instance;
extern pthread_t main_thread;
diff --git a/user/libnftnl/APKBUILD b/user/libnftnl/APKBUILD
index 432f60b07..f2796b3ea 100644
--- a/user/libnftnl/APKBUILD
+++ b/user/libnftnl/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
-# Maintainer: multiplexd <multi@in-addr.xyz>
+# Maintainer: Luis Ressel <aranea@aixah.de>
pkgname=libnftnl
pkgver=1.1.2
pkgrel=0
@@ -12,7 +12,6 @@ subpackages="$pkgname-dev"
source="https://netfilter.org/projects/libnftnl/files/$pkgname-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -24,12 +23,10 @@ build() {
}
check() {
- cd "$builddir"/tests
- make check # builds test binaries
+ make -C tests check # builds test binaries
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/nftables/APKBUILD b/user/nftables/APKBUILD
index 3ef6d52aa..13cd0a2a2 100644
--- a/user/nftables/APKBUILD
+++ b/user/nftables/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: multiplexd <multi@in-addr.xyz>
+# Maintainer: Luis Ressel <aranea@aixah.de>
pkgname=nftables
pkgver=0.9.0
pkgrel=0
@@ -17,8 +17,6 @@ source="https://netfilter.org/projects/nftables/files/$pkgname-$pkgver.tar.bz2
nftables.initd"
build() {
- cd "$builddir"
-
DB2MAN=docbook2x-man ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -32,8 +30,6 @@ build() {
}
package() {
- cd "$builddir"
-
make DESTDIR="$pkgdir" install
install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
diff --git a/user/wv/APKBUILD b/user/wv/APKBUILD
index ec9a0a081..8211b555d 100644
--- a/user/wv/APKBUILD
+++ b/user/wv/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: multiplexd <multi@in-addr.xyz>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=wv
pkgver=1.2.9
pkgrel=0
@@ -19,7 +19,6 @@ prepare() {
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -29,7 +28,6 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}