summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/lighttpd/APKBUILD7
-rw-r--r--user/lighttpd/lighttpd.pre-install6
2 files changed, 4 insertions, 9 deletions
diff --git a/user/lighttpd/APKBUILD b/user/lighttpd/APKBUILD
index 6a6420b06..5f768bbdd 100644
--- a/user/lighttpd/APKBUILD
+++ b/user/lighttpd/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=lighttpd
pkgver=1.4.54
-pkgrel=1
+pkgrel=2
pkgdesc="A secure, fast, compliant and very flexible web-server"
url="http://www.lighttpd.net/"
arch="all"
@@ -26,8 +26,6 @@ source="http://download.lighttpd.net/lighttpd/releases-1.4.x/$pkgname-$pkgver.ta
"
build() {
- cd "$builddir"
-
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -49,13 +47,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
-
make DESTDIR="$pkgdir" install
# create dirs
diff --git a/user/lighttpd/lighttpd.pre-install b/user/lighttpd/lighttpd.pre-install
index bdc9b91b6..3d6124de0 100644
--- a/user/lighttpd/lighttpd.pre-install
+++ b/user/lighttpd/lighttpd.pre-install
@@ -1,8 +1,8 @@
#!/bin/sh
groupadd -r -g 82 www-data 2>/dev/null
-groupadd -S lighttpd 2>/dev/null
-useradd -c lighttpd -s /sbin/nologin -g -G www-data \
- lighttpd -m -d /var/www/localhost/htdocs -k /etc/skel -r lighttpd 2>/dev/null
+groupadd -r lighttpd 2>/dev/null
+useradd -c lighttpd -s /sbin/nologin -G www-data \
+ -d /var/www/localhost/htdocs -r lighttpd 2>/dev/null
exit 0