summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/rfkill/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/user/rfkill/APKBUILD b/user/rfkill/APKBUILD
new file mode 100644
index 000000000..3e2cad165
--- /dev/null
+++ b/user/rfkill/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=rfkill
+pkgver=0.5
+pkgrel=0
+pkgdesc="Tool to query the state of the rfkill switches and buttons"
+url="https://wireless.wiki.kernel.org/en/users/Documentation/rfkill"
+arch="all"
+license="GPL"
+depends=""
+makedepends=""
+install=""
+options="!check"
+subpackages="$pkgname-doc"
+source="https://www.kernel.org/pub/software/network/rfkill/rfkill-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="6ad4d28e7bf7ec69ec6a600cd774b7b3c60e85849ae3fca0f5509ed6a283ed5656d37cfd770df45ff1ceca59edd814807d116b30e199fca303baf496441419d7 rfkill-0.5.tar.xz"