summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/gdb/APKBUILD6
-rw-r--r--system/gdb/stopcode-lock.patch75
-rw-r--r--system/musl/APKBUILD4
-rw-r--r--system/musl/ppc64-regs.patch45
-rw-r--r--system/nspr/APKBUILD6
-rw-r--r--system/nspr/stacksize.patch22
-rw-r--r--user/autoconf2.13/APKBUILD7
-rw-r--r--user/dotconf/APKBUILD43
-rw-r--r--user/flite/APKBUILD39
-rw-r--r--user/kde-utilities/APKBUILD2
-rw-r--r--user/kleopatra/APKBUILD4
-rw-r--r--user/kpimtextedit/APKBUILD7
-rw-r--r--user/libkleo/APKBUILD4
-rw-r--r--user/qt5-qtspeech/APKBUILD32
-rw-r--r--user/qt5-qtspeech/fix-linking-order.patch6
-rw-r--r--user/speech-dispatcher/APKBUILD38
-rw-r--r--user/unbound/APKBUILD4
17 files changed, 281 insertions, 63 deletions
diff --git a/system/gdb/APKBUILD b/system/gdb/APKBUILD
index b038ca23f..021848629 100644
--- a/system/gdb/APKBUILD
+++ b/system/gdb/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=gdb
pkgver=8.2
-pkgrel=0
+pkgrel=1
pkgdesc="The GNU Debugger"
url="https://www.sourceware.org/gdb/"
arch="all"
@@ -17,6 +17,7 @@ source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
ppc-musl.patch
ppc-ptregs.patch
remove-extraneous-include.patch
+ stopcode-lock.patch
"
build() {
@@ -60,4 +61,5 @@ sha512sums="11cc481bebc51eb6db73249ecb62b8c07455cf3db169f4860b3a83114849fbd2b586
986e68275f7692f39b5d8aedeb9f9e88f0e5bebb3f8c7f104933c525d35ca54fc90e18698c1e3e1009e8a188e5e70d6f252cb39e4c75e37db7bf479017e0da32 s390x-use-elf-gdb_fpregset_t.patch
04911f87904b62dd7662435f9182b20485afb29ddb3d6398a9d31fef13495f7b70639c77fdae3a40e2775e270d7cd40d0cfd7ddf832372b506808d33c8301e01 ppc-musl.patch
b75e1c1ee503a1948a7d5b8d90427b5c7d38ded69978056cee0adca222771a5c95ed1ac73127fcae7b795ea94296344eee5fca47e4cd04b418c164a756fb0933 ppc-ptregs.patch
-3ff31774ba78c1208415289566b901debd815da8b53acefe4a0785e7b2bbcff39585a556d44ff2f7d8d639ebc047620b96e72573acae376d8f23aa98dd1fe286 remove-extraneous-include.patch"
+3ff31774ba78c1208415289566b901debd815da8b53acefe4a0785e7b2bbcff39585a556d44ff2f7d8d639ebc047620b96e72573acae376d8f23aa98dd1fe286 remove-extraneous-include.patch
+720d6cbc71d5d4f5cc8955b18a76661688534d409e2beb53e9e2d2322a303fa622e622b583e1f6c50cf3f32b8abe4f5320a6885e7680769c92ef5bb09ef59d1d stopcode-lock.patch"
diff --git a/system/gdb/stopcode-lock.patch b/system/gdb/stopcode-lock.patch
new file mode 100644
index 000000000..6a4e3d855
--- /dev/null
+++ b/system/gdb/stopcode-lock.patch
@@ -0,0 +1,75 @@
+From: Andrew Burgess <andrew.burgess@embecosm.com>
+Date: Tue, 3 Jul 2018 18:02:48 +0000 (+0100)
+Subject: gdb: Avoid using W_STOPCODE(0) as this is ambiguous on MIPS
+X-Git-Tag: users/ARM/embedded-binutils-master-2018q4~1172
+X-Git-Url: https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=commitdiff_plain;h=953473375500a809fbb3eca3efa4dbb670c3a32f
+
+gdb: Avoid using W_STOPCODE(0) as this is ambiguous on MIPS
+
+The MIPS target supports 127 signals, and this can create an ambiguity
+in process wait statuses. A status value of 0x007f could potentially
+indicate a process that has exited with signal 127, or a process that
+has stopped with signal 0.
+
+In uClibc-ng the interpretation of 0x007f is that the process has
+exited with signal 127 rather than stopped with signal 0, and so,
+WIFSTOPPED (W_STOPCODE (0)) will be false rather than true as it would
+be on most other platforms.
+
+Given that it's pretty easy to avoid using W_STOPCODE (0), lets do that.
+
+gdb/ChangeLog:
+
+ * linux-nat.c (linux_nat_target::follow_fork): Avoid using
+ 'W_STOPCODE (0)' as this could be ambiguous.
+---
+
+diff --git a/gdb/linux-nat.c b/gdb/linux-nat.c
+index 86d3dfd..d2c88ad 100644
+--- a/gdb/linux-nat.c
++++ b/gdb/linux-nat.c
+@@ -445,7 +445,6 @@ linux_nat_target::follow_fork (int follow_child, int detach_fork)
+ if (!follow_child)
+ {
+ struct lwp_info *child_lp = NULL;
+- int status = W_STOPCODE (0);
+ int has_vforked;
+ ptid_t parent_ptid, child_ptid;
+ int parent_pid, child_pid;
+@@ -465,6 +464,8 @@ linux_nat_target::follow_fork (int follow_child, int detach_fork)
+ /* Detach new forked process? */
+ if (detach_fork)
+ {
++ int child_stop_signal = 0;
++ bool detach_child = true;
+ struct cleanup *old_chain = make_cleanup (delete_lwp_cleanup,
+ child_lp);
+
+@@ -484,18 +485,24 @@ linux_nat_target::follow_fork (int follow_child, int detach_fork)
+ if (!gdbarch_software_single_step_p (target_thread_architecture
+ (parent_ptid)))
+ {
++ int status;
++
+ linux_disable_event_reporting (child_pid);
+ if (ptrace (PTRACE_SINGLESTEP, child_pid, 0, 0) < 0)
+ perror_with_name (_("Couldn't do single step"));
+ if (my_waitpid (child_pid, &status, 0) < 0)
+ perror_with_name (_("Couldn't wait vfork process"));
++ else
++ {
++ detach_child = WIFSTOPPED (status);
++ child_stop_signal = WSTOPSIG (status);
++ }
+ }
+
+- if (WIFSTOPPED (status))
++ if (detach_child)
+ {
+- int signo;
++ int signo = child_stop_signal;
+
+- signo = WSTOPSIG (status);
+ if (signo != 0
+ && !signal_pass_state (gdb_signal_from_host (signo)))
+ signo = 0;
diff --git a/system/musl/APKBUILD b/system/musl/APKBUILD
index d35060fb4..bffa25154 100644
--- a/system/musl/APKBUILD
+++ b/system/musl/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=musl
pkgver=1.1.21
-pkgrel=2
+pkgrel=3
pkgdesc="System library (libc) implementation"
url="http://www.musl-libc.org/"
arch="all"
@@ -27,7 +27,6 @@ source="http://www.musl-libc.org/releases/musl-$pkgver.tar.gz
handle-aux-at_base.patch
fgetspent_r.patch
gettext-preserve-errno.patch
- ppc64-regs.patch
ldconfig
getent.c
@@ -126,7 +125,6 @@ sha512sums="fa6c4cc012626c5e517e0e10926fc845e3aa5f863ffaceeb38ac5b9ce0af631a37f6
6a7ff16d95b5d1be77e0a0fbb245491817db192176496a57b22ab037637d97a185ea0b0d19da687da66c2a2f5578e4343d230f399d49fe377d8f008410974238 handle-aux-at_base.patch
ded41235148930f8cf781538f7d63ecb0c65ea4e8ce792565f3649ee2523592a76b2a166785f0b145fc79f5852fd1fb1729a7a09110b3b8f85cba3912e790807 fgetspent_r.patch
db180e437b8b7582e4d2baf06b592b88a9f6e5a8f18b7afa81d7a707240a774273778f8fec1c5cbea2a137e00cca49ff08fe762c871be20c70b50104b7e8e1e1 gettext-preserve-errno.patch
-8d90a4bbec151f696bee30ed7275d8eb88b5c5ae7027d1dac963a950b0717b1e5149d6718c441bc9ee103b57899a9835a93f8373448b5887b52a24937bfd0af9 ppc64-regs.patch
cce2f1eeb61e55674469c26871a573cce61d739c3defe9c8f56f2b774f6ba5435849ad542a6714120efddc98c297098e9c98a1a424ac593df2243d4aa479f9a9 ldconfig
378d70e65bcc65bb4e1415354cecfa54b0c1146dfb24474b69e418cdbf7ad730472cd09f6f103e1c99ba6c324c9560bccdf287f5889bbc3ef0bdf0e08da47413 getent.c
9d42d66fb1facce2b85dad919be5be819ee290bd26ca2db00982b2f8e055a0196290a008711cbe2b18ec9eee8d2270e3b3a4692c5a1b807013baa5c2b70a2bbf iconv.c"
diff --git a/system/musl/ppc64-regs.patch b/system/musl/ppc64-regs.patch
deleted file mode 100644
index 4deb979ba..000000000
--- a/system/musl/ppc64-regs.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From ea183d9b727ac7e3ccfdcb89242566857d7182c8 Mon Sep 17 00:00:00 2001
-From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
-Date: Tue, 12 Feb 2019 09:31:34 -0600
-Subject: [PATCH] powerpc64: use a type for mcontext_t regs field
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-GCC Go dereferences `regs` for `nip`. Without this change, compilation
-fails with the following message:
-
-../../../libgo/runtime/go-signal.c: In function ‘getSiginfo’:
-../../../libgo/runtime/go-signal.c:225:56: warning: dereferencing ‘void *’ pointer
- ret.sigpc = ((ucontext_t*)(context))->uc_mcontext.regs->nip;
- ^~
-../../../libgo/runtime/go-signal.c:225:56: error: request for member ‘nip’ in something not a structure or union
----
- arch/powerpc64/bits/signal.h | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/arch/powerpc64/bits/signal.h b/arch/powerpc64/bits/signal.h
-index 34693a68..6736c69a 100644
---- a/arch/powerpc64/bits/signal.h
-+++ b/arch/powerpc64/bits/signal.h
-@@ -8,6 +8,8 @@
-
- #if defined(_GNU_SOURCE) || defined(_BSD_SOURCE)
-
-+#include <bits/user.h>
-+
- typedef unsigned long greg_t, gregset_t[48];
-
- typedef struct {
-@@ -29,7 +31,7 @@ typedef struct sigcontext {
- int _pad0;
- unsigned long handler;
- unsigned long oldmask;
-- void *regs;
-+ struct pt_regs *regs;
- gregset_t gp_regs;
- fpregset_t fp_regs;
- vrregset_t *v_regs;
---
-2.19.2
-
diff --git a/system/nspr/APKBUILD b/system/nspr/APKBUILD
index a6da52de1..bf0c907e8 100644
--- a/system/nspr/APKBUILD
+++ b/system/nspr/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=nspr
pkgver=4.20
-pkgrel=0
+pkgrel=1
pkgdesc="Netscape Portable Runtime"
url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSPR"
arch="all"
@@ -14,6 +14,7 @@ makedepends="autoconf automake"
subpackages="$pkgname-dev"
source="http://ftp.mozilla.org/pub/mozilla.org/nspr/releases/v$pkgver/src/nspr-$pkgver.tar.gz
fix-getproto.patch
+ stacksize.patch
"
prepare() {
@@ -61,4 +62,5 @@ package() {
}
sha512sums="22fdf7627f450b0594ebccaee170098e1a8cd0f429fd44816f1322756002ced3d69cf686c3f69f7cb30b8132d3605a9fce5457ab99d0002e6af11a3408a5c949 nspr-4.20.tar.gz
-ee654f609a90b9a95c1901ad1d56cdef7cce8bca9efc092198607944f142f8fec924b13219ca6663facd0f0d59b671b8b3de58ab3449c4c863d42e2937f02184 fix-getproto.patch"
+ee654f609a90b9a95c1901ad1d56cdef7cce8bca9efc092198607944f142f8fec924b13219ca6663facd0f0d59b671b8b3de58ab3449c4c863d42e2937f02184 fix-getproto.patch
+1f694fc151f6578080449e3aa999c520486bbe117b8237150966ec43092db4156e81412ac889045e0c0c3bf65d459af5bdc1cf19c9fa3dab120405a60732f15a stacksize.patch"
diff --git a/system/nspr/stacksize.patch b/system/nspr/stacksize.patch
new file mode 100644
index 000000000..c2fcecd68
--- /dev/null
+++ b/system/nspr/stacksize.patch
@@ -0,0 +1,22 @@
+set a minimum stack size on ppc64 to prevent crashes
+
+Firefox, a user of nspr, attempts to set a stack size of 32k in its
+JS watchdog, which the pthreads impl doesn't like and fails.
+
+Coincidentally, nspr here is compiled with debug on, which means it has
+assertions turned on; under normal circumstances, those would be disabled,
+the stack size set call would fail and everything would fall back on the
+default 2M stacksize, but it would still be wrong - therefore, establish
+a minimum, just like for aarch64.
+
+--- nspr-4.20/nspr/pr/include/md/_linux.h.old 2018-08-28 12:42:28.000000000 +0000
++++ nspr-4.20/nspr/pr/include/md/_linux.h 2019-02-18 17:35:30.380000000 +0000
+@@ -71,7 +71,7 @@
+ #define _MD_DEFAULT_STACK_SIZE 65536L
+ #define _MD_MMAP_FLAGS MAP_PRIVATE
+
+-#if defined(__aarch64__) || defined(__mips__)
++#if defined(__aarch64__) || defined(__mips__) || defined(__powerpc64__)
+ #define _MD_MINIMUM_STACK_SIZE 0x20000
+ #endif
+
diff --git a/user/autoconf2.13/APKBUILD b/user/autoconf2.13/APKBUILD
index d3b3ca73b..bd5b533a9 100644
--- a/user/autoconf2.13/APKBUILD
+++ b/user/autoconf2.13/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer:
pkgname=autoconf2.13
pkgver=2.13
-pkgrel=1
+pkgrel=2
pkgdesc="A GNU tool for automatically configuring source code"
arch="noarch"
license="GPL-2.0"
@@ -38,5 +38,10 @@ package() {
rm -f "$pkgdir"/usr/share/info/standards.info
}
+doc() {
+ default_doc
+ mv "$subpkgdir/usr/share/info/autoconf.info" "$subpkgdir/usr/share/info/autoconf-2.13.info"
+}
+
sha512sums="602584f4c77b7a554aaa068eda5409b68eb0b3229e9c224bffb91c83c4314d25de15bd560a323626ff78f6df339c79e1ef8938c54b78ecadf4dc75c5241290ad autoconf-2.13.tar.gz
483d0ba23c90e41c746868ea57436033930906f306b86de5e23284a60da069f4203d478615d653b8acee7226d9b02427be42a9764ff82710019de485e5f26d1b getloadavg.patch"
diff --git a/user/dotconf/APKBUILD b/user/dotconf/APKBUILD
new file mode 100644
index 000000000..54f08fa92
--- /dev/null
+++ b/user/dotconf/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=dotconf
+pkgver=1.3
+pkgrel=0
+pkgdesc="Configuration file parsing library"
+url=" "
+arch="all"
+license="LGPL-2.1-only"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://distfiles.gentoo.org/distfiles/dotconf-$pkgver.tar.gz"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="ced0e66f70d11a309e77add1bfac1da8e85dcbe193633bd4bd1ae4bfd043b66880406e93ec18327b8c5d3de8d4bfc5278db6e5cb39b030ee1dabfa1ce267a98e dotconf-1.3.tar.gz"
diff --git a/user/flite/APKBUILD b/user/flite/APKBUILD
new file mode 100644
index 000000000..5ae3ea67a
--- /dev/null
+++ b/user/flite/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=flite
+pkgver=2.1
+pkgrel=0
+pkgdesc="Small, fast text-to-speech synthesizer based on Festival"
+url="http://www.festvox.org/flite/"
+arch="all"
+options="!check" # testsuite refuses to cooperate
+license="MIT AND Apache-2.0 AND BSD-3-Clause AND Public-Domain AND BSD-2-Clause"
+depends=""
+makedepends="alsa-lib-dev"
+subpackages="$pkgname-dev"
+source="http://www.festvox.org/flite/packed/flite-$pkgver/flite-$pkgver-release.tar.bz2"
+builddir="$srcdir/flite-$pkgver-release"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="e9ef9ca4b6920178634d94bbe6e21a8b0ec471b010b07e6cc961ed2d120acb944c8e1d268fe26188f7dfe43fb7bd4bdff7fa53b2d2f12029d37e08d0316620d2 flite-2.1-release.tar.bz2"
diff --git a/user/kde-utilities/APKBUILD b/user/kde-utilities/APKBUILD
index b83782a1a..8c1a45489 100644
--- a/user/kde-utilities/APKBUILD
+++ b/user/kde-utilities/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kde-utilities
-pkgver=18.08.3
+pkgver=18.12.2
pkgrel=0
pkgdesc="Desktop utiltiies from the KDE Software Collection"
url="https://www.kde.org/applications/utilities/"
diff --git a/user/kleopatra/APKBUILD b/user/kleopatra/APKBUILD
index b980e4aed..c8c89833e 100644
--- a/user/kleopatra/APKBUILD
+++ b/user/kleopatra/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kleopatra
-pkgver=18.08.3
+pkgver=18.12.2
pkgrel=0
pkgdesc="Certificate manager and cryptography GUI"
url="https://www.kde.org/applications/utilities/kleopatra/"
@@ -40,4 +40,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="3740481570653f718eb469f1cdfbfa69e7b41104b26403c3902667894d17321f6119b3dbf1487d59c7fbfd6707cd6dcca562aeba6036cdb41a9b29530bfa5a6b kleopatra-18.08.3.tar.xz"
+sha512sums="e8273c5564c2a48afbd0c9ae467092afc3fa80cd6d374da7273e110c2b1d3c2cbc093b8e7eee682dac204ceb851352f6e4ae6263d8d689d8c3e1bb93f924906d kleopatra-18.12.2.tar.xz"
diff --git a/user/kpimtextedit/APKBUILD b/user/kpimtextedit/APKBUILD
index dd58a6090..d305928a8 100644
--- a/user/kpimtextedit/APKBUILD
+++ b/user/kpimtextedit/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kpimtextedit
-pkgver=18.08.3
+pkgver=18.12.2
pkgrel=0
pkgdesc="Text editor for Personal Information Managers (PIMs)"
url="https://pim.kde.org/"
@@ -13,7 +13,8 @@ depends_dev="qt5-qtbase-dev kwidgetsaddons-dev syntax-highlighting-dev
ktextwidgets-dev sonnet-dev"
makedepends="$depends_dev cmake extra-cmake-modules qt5-qttools-dev ki18n-dev
grantlee-dev kcodecs-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev
- kdesignerplugin-dev kemoticons-dev kiconthemes-dev kio-dev kxmlgui-dev"
+ kdesignerplugin-dev kemoticons-dev kiconthemes-dev kio-dev kxmlgui-dev
+ qt5-qtspeech-dev"
subpackages="$pkgname-dev $pkgname-lang"
source="https://download.kde.org/stable/applications/$pkgver/src/kpimtextedit-$pkgver.tar.xz"
@@ -43,4 +44,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="3a5ca2c2fc30f1c961a6f8b76a01c29be4b36c4e512e3c0cfaaa36c95fa9ba548f0d56cca3b9be86f2453c5c4be990b031cb2cd52a0747e1ab8af798156a7da7 kpimtextedit-18.08.3.tar.xz"
+sha512sums="6961f0fff5343bf77518b0d7e4991375c1a4d8b909ca81019c4a9574806942a115d08a4793bb7cfd4f6aca97d4b3e0909c6475a66c25b89866f16509899a5326 kpimtextedit-18.12.2.tar.xz"
diff --git a/user/libkleo/APKBUILD b/user/libkleo/APKBUILD
index 8122014b2..658974ef1 100644
--- a/user/libkleo/APKBUILD
+++ b/user/libkleo/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libkleo
-pkgver=18.08.3
+pkgver=18.12.2
pkgrel=0
pkgdesc="KDE encryption library"
url="https://www.kde.org/"
@@ -41,4 +41,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="5bd2aac755e6dad05e05e1c49b83cccf8b349c9231533dc821b3ba1dcc4da3fb66f7e8aaaeebdd1c080a28d94b9646afb248b5bee44e3bec8447d1293dda5f10 libkleo-18.08.3.tar.xz"
+sha512sums="06dba154a77df481678208c7b687c1b7b7664fbde971ba5b4f854bdcdc6ab6e1f09864b989da7c929fa1b56bae4042d37ed2d39b6d2eacfeda726cfc82e61839 libkleo-18.12.2.tar.xz"
diff --git a/user/qt5-qtspeech/APKBUILD b/user/qt5-qtspeech/APKBUILD
new file mode 100644
index 000000000..408e95824
--- /dev/null
+++ b/user/qt5-qtspeech/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=qt5-qtspeech
+_pkgname=qtspeech-opensource-src
+pkgver=5.9.7
+pkgrel=0
+pkgdesc="Qt 5 - Library for speech processing and Text-to-Speech (TTS)"
+url="https://www.qt.io/"
+arch="all"
+options="!check"
+license="LGPLv2 with exceptions OR GPLv3 with exceptions"
+depends=""
+makedepends="qt5-qtbase-dev qt5-qtmultimedia-dev speech-dispatcher-dev"
+subpackages="$pkgname-dev"
+source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz
+ fix-linking-order.patch
+ "
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ qmake
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install INSTALL_ROOT="$pkgdir"
+}
+
+sha512sums="e2d1f2f73bc6595572d18b1c17caf27878851adf164dbca25925301b94916cce96b2ea3db4c2c7e6a23d6e79c37c35b28239aa613adaf6cb9eb340f40c396099 qtspeech-opensource-src-5.9.7.tar.xz
+7bce4bd52aa0b60fbd0ec781fc18ac518a8fe76c99e61be03170f00d27747e989b1562a45435be78d0d166ab0fdf523055620ba7c63f49e328704e1cd6aa4718 fix-linking-order.patch"
diff --git a/user/qt5-qtspeech/fix-linking-order.patch b/user/qt5-qtspeech/fix-linking-order.patch
new file mode 100644
index 000000000..b07e0536d
--- /dev/null
+++ b/user/qt5-qtspeech/fix-linking-order.patch
@@ -0,0 +1,6 @@
+--- qtspeech-opensource-src-5.9.7/config.tests/flite_alsa/flite_alsa.pro.old 2018-05-31 12:22:17.000000000 +0000
++++ qtspeech-opensource-src-5.9.7/config.tests/flite_alsa/flite_alsa.pro 2019-02-17 15:12:30.810000000 +0000
+@@ -1,2 +1,2 @@
+-LIBS += -lasound
+ include(../flite/flite.pri)
++LIBS += -lasound
diff --git a/user/speech-dispatcher/APKBUILD b/user/speech-dispatcher/APKBUILD
new file mode 100644
index 000000000..b35da35bd
--- /dev/null
+++ b/user/speech-dispatcher/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=speech-dispatcher
+pkgver=0.8.8
+pkgrel=0
+pkgdesc="High-level interface to speech synthesis libraries"
+url="https://freebsoft.org/speechd"
+arch="all"
+license="LGPL-2.1-only AND (GPL-2.0+ AND LGPL-2.1+) AND LGPL-2.1+ AND GPL-2.0+"
+depends="flite"
+makedepends="alsa-lib-dev dotconf-dev flite-dev glib-dev intltool
+ libsndfile-dev pulseaudio-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://freebsoft.org/pub/projects/speechd/speech-dispatcher-$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+ LIBS="-lasound" ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="7c7b9bf9b9ce541e790b5ae396cb614616c6b3883e75c0258603e91bf679850e3d63a6251daa3a1819b30d7518e3f552c83fe87b006274ffe1aa0f7e19c0b99b speech-dispatcher-0.8.8.tar.gz"
diff --git a/user/unbound/APKBUILD b/user/unbound/APKBUILD
index aecfea4f6..3c6810ec3 100644
--- a/user/unbound/APKBUILD
+++ b/user/unbound/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Luis Ressel <aranea@aixah.de>
# Maintainer: Luis Ressel <aranea@aixah.de>
pkgname=unbound
-pkgver=1.8.3
+pkgver=1.9.0
pkgrel=0
pkgdesc="A validating, recursive and caching DNS resolver"
url="https://unbound.net/"
@@ -71,6 +71,6 @@ python() {
mv "$pkgdir/usr/lib/python"* "$subpkgdir"
}
-sha512sums="545486ccce288a6ef1937d82653a43a11dbd3aec7b8d0036e7fd107e537cdfc935def9db9178c2eb418d6f4b0849a242a0be1dea966f3e9e0145aa7266e483ad unbound-1.8.3.tar.gz
+sha512sums="7dfa8e078507fc24a2d0938eea590389453bacfcac023f1a41af19350ea1f7b87d0c82d7eead121a11068921292a96865e177274ff27ed8b8868445f80f7baf6 unbound-1.9.0.tar.gz
de9dc269553f5449c1757690c2a8a3b9f228964f5672d721cfdbc29e6fab8954907fa4fa3761dd6f705b3ccd2f729cc6e2fe870107feb68cca611589f8306b94 unbound.confd
6627cbcbcb4e04f596e7e0ffdbf80ceb54cdb59144cb89896e53503dfb41b99fd77d8b85d05e6670f77023b6eafec8885b00c0c8e4e34e3e638c52c037a7985e unbound.initd"