summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/pantheon-code/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/user/pantheon-code/APKBUILD b/user/pantheon-code/APKBUILD
new file mode 100644
index 000000000..28e63fc14
--- /dev/null
+++ b/user/pantheon-code/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
+# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
+pkgname=pantheon-code
+pkgver=7.1.0
+pkgrel=0
+pkgdesc="Programmer-oriented text editor for the Pantheon desktop environment"
+url="https://elementary.io"
+arch="all"
+license="GPL-3.0+ AND LGPL-3.0+ AND GPL-2.0+"
+depends=""
+makedepends="meson ninja editorconfig-core-c-dev glib-dev gobject-introspection-dev granite-dev gtksourceview4-dev libgee-dev libgit2-glib-dev libhandy-dev libpeas-dev libsoup-dev vala-dev vte-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="pantheon-code-$pkgver.tar.gz::https://github.com/elementary/code/archive/refs/tags/$pkgver.tar.gz"
+builddir="$srcdir/code-$pkgver"
+
+build() {
+ meson setup \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ --wrap-mode=nofallback \
+ -Dplugins=false \
+ . output
+ meson compile -C output
+}
+
+check() {
+ meson test -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C output
+}
+
+sha512sums="dc8905f3f8affa04ac6643448f5c937160ffe31f227c29551ebeb226a71566b516d754ed2e21cbd4e669a262a1be50503ff1f47e82fa80b197f0171e33813922 pantheon-code-7.1.0.tar.gz"